The keyring shipped in the 2022.12.01 ISO is outdated. You’ll need to update it using `pacman -Sy archlinux-keyring` first before pacstrap-ping :)

Hi all,
Trying to install Arch on a new birthday/Christmas present. I'm manually copying this (abbreviated) because I can't figure out how to get the text off the new box:
# pacstrap /mnt linux linux-firmware base btrfs-progs intel-ucode nano iw
[snipped the package list and stuff]
:: Retrieving packages...
 openssl-3.0.7-4-x86_64 ...
(126/126) checking keys in keyring
(126/126) checking package integrity
error: openssl: signature from "Pierre Schmitz <>" is marginal trust
:: File /mnt/var/cache/pacman/pkg/openssl-3.0.7-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
[failure messages]

Things I've tried/checked:
* clock on the new box has correct time
* pacman -Syu from another machine. That pulled down a new archlinux-keyring and openssl-3.0.7-4 and it ran fine
* new machine has same mirrorlist that worked with the pacman -Syu
* commented out mirrorlist entries one-at-a-time to see if it was one mirror problem. 5 servers all give the same results.

The other 125 packages that were downloaded all passed the integrity check (I think).
Any suggestions?

Dave Murray