On 11/2/24 5:49 PM, Robin Candau wrote:
I haven't take a detailed look but, after a quick glance, the PKGBUILD looks generally good. Here are a few details I was able to spot:
- "Previous Maintainer" should be listed as "Contributor" (e.g. `# Contributor: name <email>`) [1]
- No reason to list the -bin variant of the `mongosh` package over the "regular" one in optional dependencies [2]. The former provides the latter already.
- The source currently have a potentially conflicting / too generic name [3]. You should rename it to avoid potential name conflicts with other (packages) sources (e.g. `$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo/ archive/refs/tags/r$pkgver.tar.gz`).
Yes, this has always been a git tag download curiosity. If you download from the desktop, it provides the mongo-... prefix, but if you pull the release from a build-script it comes in as simply ... That is a welcomed solution.
- Custom variables and functions should be prefixed with a underscore. So the `all-flag-vars()` & the `filter-flags()` functions [4][5] should be called `_all-flag-vars()` & `_filter-flags()` instead.
- No need to `cd` to "${srcdir}" in the various functions (e.g. in [6]), every functions are already executed from that directory.
- I would personally ensure installed binaries [7] are executable / have the correct permission mode by using `install -Dm 755` instead of `install -D`.
Thank you. I'll take care of all that in the -6 release. Just finished with the last redundant std::move() patch - all 1300+ lines of it... I'm pleased with the way it builds and works. -- David C. Rankin, J.D.,P.E.