I've offline for some days, but here are the reports for the RC1 images.

I've performed all of the tests as I did for the beta3 images in the same environments. Also this time I've performed installations in VMware virtual machines too, using SCSI hard drives as well as IDE ones. Both bus logic and LSI logic for the drives, and tried auto prepare too. Everything worked like a charm, I've found no problems; all installations were successful and the machines bootable.

These are the images I've tested and their SHA-1 sums:
archlinux-2009.02-RC1-core-i686.iso 2D2BD3993FD9990C173CC416F6CDA686EDC8206E
archlinux-2009.02-RC1-core-x86_64.iso DD605C5B76B28328FD47E8DCF694C324B9144B83
archlinux-2009.02-RC1-ftp-i686.iso 7892E52C9D7BCA528D54B735764C9FC48FFB5F62
archlinux-2009.02-RC1-ftp-i686-isolinux.iso 24728F5213AB4487C501D68EBEE7C6932CE1D2A0
archlinux-2009.02-RC1-ftp-x86_64.iso 80332C9FE41D3504D8939F70DDF13D3A3EFCDF65
archlinux-2009.02-RC1-ftp-x86_64-isolinux.iso C3809624DFEDEB207488877040E763222F23C4D2