On 1/28/19 10:37 PM, Allan McRae wrote:
On 26/1/19 9:40 am, Morgan Adamiec wrote:
On Fri, 25 Jan 2019 at 16:05, Dave Reisner email@example.com wrote:
Again, I'm going to harp on the fact that this feels like schema, so paint it blue:
pkgbuild_schema_arrays pkgbuild_schema_strings pkgbuild_schema_arch_overrides pkgbuild_schema_package_overrides
I still like mine more, but I think `pkgbuild_schema_arrays` is fine. I prefer it to 'variable'.
Those names are good.
BTW, I used 'variable' in my suggested naming because it is an array of variable names. So not referring to the array, but what is in the array.
Then it still makes people reading the code stop and ask what the "variable" part refers to. :)
Anyway I'll add my vote for the suggestion with "schema" in it.