Hi On Mon, Apr 13, 2020 at 7:42 PM Allan McRae <allan@archlinux.org> wrote:
Changes look good. My only remaining comment is this:
On 27/3/20 6:59 am, Anatol Pomozov wrote:
+ * Returns -1 if an error happened + */ +static int curl_multi_handle_single_done(CURLM *curlm, CURLMsg *msg, const char *localpath) I have no idea what this function does from its name. This is a callback for mCURL event CURLMSG_DONE https://curl.haxx.se/libcurl/c/curl_multi_info_read.html We receive this event when one "curl easy" (or single) transfer is finished.
To be clear, I can see what the function does from the function, but the name is very vague. If I saw "handle single done", I would not be any the wiser what is going on.
How about:
curl_multi_check_finished_download() curl_multi_download_completion_check()
The names sound good to me. Let's move forward with curl_multi_check_finished_download(). I will send updated patch in a moment.
or even:
curl_multi_handle_curlmsg_done()
Allan