21 Apr
2008
21 Apr
'08
5:46 a.m.
I noticed that alpm_list_last simply returns a pointer to the previous node. Is this expected behavior? My interpretation of "last" would be to return the absolute last node, as the comment suggests. In my opinion the function as it is now should be called alpm_list_prev. From alpm_list.c:
alpm_list_t SYMEXPORT *alpm_list_last(const alpm_list_t *list) { if(list) { return(list->prev); } else { return(NULL); } }
-- Sebastian Nowicki