This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "The official pacman repository". The branch, master has been updated via 8d88f0c897e5dd531a2c74dd2bca56db56a3c63d (commit) via a28868eeae98b28c00f8112e8d81403ad21a3117 (commit) via 08e1d4764cdc7f62b11be4b411071b6a87118c93 (commit) via f04530eb618a3f7e7ee1dd15f0b2907fc28bed98 (commit) via 68d8bfa0b5c15e1ddbc7f81cd23bf464674413f9 (commit) via 3de32a08126480f2a9cd67d09ef104accfde8992 (commit) via f27fed14b16dc85da104ae4c463ba6040d7e4d64 (commit) via 298cbf2cb152df365a593a396266636a9d34355f (commit) via 48589ccc64c5e7266f70c6294087e8b0450953e9 (commit) via d896527d21107afe69328ac465a3d2f0e318ddca (commit) via 71660f55b22050219cb582def2ee246084e55893 (commit) via 4a487346c57ca6ea2beedad5f670313670fe1971 (commit) via 0478dfa1a58ca4a127897af0b90ac3a579adb06f (commit) via ce3f4e7800f215e8a2b6e22bbd5f5ec9e0de90c2 (commit) via 281bc725342e07d314f412ba6c930c3efb8f623c (commit) via 5908992e4730263edb8255439560d5411d28c895 (commit) via c3f537538029285cca2ebb22975db60033a78c40 (commit) via b02bda75f14f35817d1757863d0b3c4cf09a0677 (commit) via 815557118318779f784e82a39497f46dde32845d (commit) via e7d5803f07c11882685e2a65b5638fd385804d22 (commit) from ddc4130c978decc5b2498b24d3b20e0c4efbc3cf (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit 8d88f0c897e5dd531a2c74dd2bca56db56a3c63d Merge: a28868e 3de32a0 Author: Dan McGee <dan@archlinux.org> Date: Mon Aug 23 21:53:06 2010 -0500 Merge branch 'maint' commit a28868eeae98b28c00f8112e8d81403ad21a3117 Author: Allan McRae <allan@archlinux.org> Date: Thu Aug 5 21:37:22 2010 +1000 makepkg: error out on empty optdepends entries If optdepends was defined with empty members, then makepkg would abort late in the package building process. Detect such cases in the check_sanity() function. Fix-provided-by: Andres P <aepd87@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org> commit 08e1d4764cdc7f62b11be4b411071b6a87118c93 Author: Allan McRae <allan@archlinux.org> Date: Thu Aug 5 21:35:54 2010 +1000 makepkg: use less local variables in check_sanity Instead of declaring a new local variable for each loop in the check_sanity() function, just reuse $i. Signed-off-by: Allan McRae <allan@archlinux.org> commit f04530eb618a3f7e7ee1dd15f0b2907fc28bed98 Author: Allan McRae <allan@archlinux.org> Date: Thu Aug 5 21:12:11 2010 +1000 makepkg: remove unnecessary variable presence check It is unnecessary to check for a variables existence before looping over it. Extracted from patch supplied by Andres P <aepd87@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org> commit 68d8bfa0b5c15e1ddbc7f81cd23bf464674413f9 Author: Allan McRae <allan@archlinux.org> Date: Thu Aug 5 21:01:32 2010 +1000 makepkg: clarify invalid backup entry errors "Invalid backup entry" was not a particular helpful error message, especially when it was due to the file not being in the final package. Clarify these two messages. Signed-off-by: Allan McRae <allan@archlinux.org> commit f27fed14b16dc85da104ae4c463ba6040d7e4d64 Author: Andres P <aepd87@gmail.com> Date: Fri Jun 25 18:46:40 2010 -0430 makepkg: less code duplication in create_package Combine changelog and install file creation in create_package(). Signed-off-by: Andres P <aepd87@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org> commit 298cbf2cb152df365a593a396266636a9d34355f Author: Allan McRae <allan@archlinux.org> Date: Thu Aug 5 20:44:34 2010 +1000 makepkg: use regex to match options for privilege escalation Eases maintanence if we need to add further options in the future. Extracted from a patch supplied by Andres P <aepd87@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org> commit 48589ccc64c5e7266f70c6294087e8b0450953e9 Author: Allan McRae <allan@archlinux.org> Date: Wed Jul 7 16:58:51 2010 +1000 Fix some whitespace issues The combination of tabs and spaces is annoying in any editor that does not use a tab width of 2 spaces. Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org> commit d896527d21107afe69328ac465a3d2f0e318ddca Author: Dan McGee <dan@archlinux.org> Date: Wed Jul 7 17:12:42 2010 -0500 fgets invocation cleanup From the fgets manpage: fgets() reads in at most one less than size characters from stream and stores them into the buffer pointed to by s. Reading stops after an EOF or a newline. If a newline is read, it is stored into the buffer. A '\0' is stored after the last character in the buffer. This means there is no need at all to do 'size - 1' math. Remove all of that and just use sizeof() for simplicity on the buffer we plan on reading into. Signed-off-by: Dan McGee <dan@archlinux.org> commit ce3f4e7800f215e8a2b6e22bbd5f5ec9e0de90c2 Author: Dan McGee <dan@archlinux.org> Date: Mon Aug 23 17:42:22 2010 -0500 Enable libfetch connection caching This will allow downloads to reuse connections if possible, which could make big differences on perceived FTP speed as the connection won't have to be reestablished each time. For the most part, HTTP requests wouldn't be using keep alive anyway so this won't have an effect there. I'm not enthused about having to do this with the library initialization, but there isn't a much better place due to the fact that the loop over databases occurs on the frontend and not the backend. Signed-off-by: Dan McGee <dan@archlinux.org> commit 815557118318779f784e82a39497f46dde32845d Author: Thomas Bächler <thomas@archlinux.org> Date: Sat Aug 7 12:47:59 2010 +0200 makepkg: Allow creation of uncompressed packages When performing local testing, it may be useful to add PKGEXT='.pkg.tar' to the PKGBUILD to save time, especially with big packages. Signed-off-by: Dan McGee <dan@archlinux.org> commit e7d5803f07c11882685e2a65b5638fd385804d22 Author: Dan McGee <dan@archlinux.org> Date: Tue Jul 27 15:50:43 2010 -0500 Use the plural features of gettext Gettext has this whole 'Plural-Form' thing that until now we haven't taken advantage of. Given that not all languages have the same plural form rules as English, take advantage of it by defining a new _n() macro which will normally define to ngettext(), and adjust a few messages as an example of how to use. There are surely other places where we do singular/plural logic without me having noticed, so further patches are welcome to fix those up too. Signed-off-by: Dan McGee <dan@archlinux.org> ----------------------------------------------------------------------- Summary of changes: NEWS | 10 + doc/PKGBUILD.5.txt | 12 +- lib/libalpm/alpm.c | 13 + lib/libalpm/be_files.c | 59 +-- lib/libalpm/be_package.c | 2 +- lib/libalpm/conflict.c | 2 +- lib/libalpm/package.h | 6 +- lib/libalpm/po/LINGUAS | 1 + lib/libalpm/po/pl.po | 99 +---- lib/libalpm/po/{en_GB.po => sk.po} | 263 +++++----- lib/libalpm/trans.c | 5 +- po/LINGUAS | 1 + po/ca.po | 13 +- po/cs.po | 12 +- po/de.po | 7 +- po/el.po | 13 +- po/en_GB.po | 7 +- po/es.po | 13 +- po/fr.po | 62 ++-- po/hu.po | 7 +- po/it.po | 7 +- po/kk.po | 13 +- po/nb.po | 13 +- po/pacman.pot | 6 +- po/pl.po | 183 +++---- po/pt_BR.po | 12 +- po/ro.po | 13 +- po/ru.po | 7 - po/{en_GB.po => sk.po} | 996 ++++++++++++++++++------------------ po/sv.po | 13 +- po/tr.po | 13 +- po/uk.po | 13 +- po/zh_CN.po | 11 +- scripts/makepkg.sh.in | 114 +++-- scripts/repo-add.sh.in | 5 +- src/pacman/callback.c | 13 +- src/pacman/query.c | 6 +- src/pacman/util.c | 5 +- src/pacman/util.h | 2 + 39 files changed, 922 insertions(+), 1130 deletions(-) copy lib/libalpm/po/{en_GB.po => sk.po} (52%) mode change 100644 => 100755 copy po/{en_GB.po => sk.po} (51%) hooks/post-receive -- The official pacman repository