On 10/26/07, Nagy Gabor <ngaba@bibl.u-szeged.hu> wrote:
+ printf(_(" -u, --unneeded remove only unneeded packages (that won't break packages)\n")); Hm. This description may not be correct ("remove unneeded packages only" sounds better for me). But I won't fix it now, because I want to motivate you to fix these "Hunglish" problems (I'm not sure on "target-list" neither...). You have probably realized already, that my English is far from perfect ;-), so I leave these works for you, sorry.
Hah. "Hunglish" Just for the record... both sound a little "forced". I think it's actually the word "only" that is making it feel funny (to me). "remove unneeded packages" sounds better, but that's just my opinion. Regarding the patch... a couple of comments:
--- a/lib/libalpm/deps.h +++ b/lib/libalpm/deps.h @@ -40,6 +40,7 @@ struct __pmdepmissing_t { char target[PKG_NAME_LEN]; pmdeptype_t type; pmdepend_t depend; + char inducer[PKG_NAME_LEN]; /* this is used in case of remove dependency error only */
Hrm. I don't know if I like the name "inducer" - could you explain what you meant with this so we could maybe use a clearer term?
+int _alpm_pkgname_pkg_cmp(const void *pkgname, const void *package)
I don't know if I'm a fan of this function here. Seems a bit excessive, BUT if it does have a lot of usages, could you submit this a separate (small) patch, just so we can push it in there? Other than that, it all looks sound. And I do like the -Ru feature, myself.