[pacman-dev] [GIT] The official pacman repository branch, master, updated. v4.0.1-182-gf55be48
This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "The official pacman repository". The branch, master has been updated via f55be4897799c5a6dcb454455ad9edcfc36f8495 (commit) via b7c06d6d678ebe6a434b2387c3bda14647113f32 (commit) via b488f229d2ec4f2e4b9e746d68422460ca664715 (commit) via f12effc6ff4605ea81b3b765ff1655107aad29d8 (commit) via d8e1c450a3fcdcbd46fd930f2804d0a61087f968 (commit) via 52afce0a106cac34b4a96cbb6adf6f6bd77b6456 (commit) via 216db87f999b244738ade141fa06e666aa38db72 (commit) via 0fdf0b19ced256d395366b24a669960416341d37 (commit) via 17e71fc908df4a5df48c9054f6c0621d3c7b80ea (commit) via 090ea289429c86e7a6f256ccb582d70d32d04013 (commit) via e01fdc3dba36336bf4acbbf5ea1e3f7ac9c6fb6a (commit) via e8db984ce5997ffabafab2584fa7f00789ff3afd (commit) via 47313acee48029bfdd1ee34bf1947b962ccff283 (commit) via fcbae69fe81d080478bbd9809af5696bbbfe9d95 (commit) from 4f54bde4390d6d4302273a835e79ab1f2827adf8 (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit f55be4897799c5a6dcb454455ad9edcfc36f8495 Merge: b488f22 b7c06d6 Author: Dan McGee <dan@archlinux.org> Date: Mon Feb 6 05:50:48 2012 -0600 Merge branch 'maint' Conflicts: lib/libalpm/alpm_list.c commit b488f229d2ec4f2e4b9e746d68422460ca664715 Author: Dan McGee <dan@archlinux.org> Date: Wed Feb 1 23:45:52 2012 -0600 ALPM API adjustments for sanity and consistency This makes several small adjustments to our exposed method names, and in one case, parameters. The justification here is to make methods less odd in their naming convention. If a method takes an alpm_db_t argument, the method should be named 'alpm_db_*', but perhaps more importantly, if it doesn't take a database as the first parameter, it should not. Summary of changes: alpm_db_register_sync -> alpm_register_syncdb alpm_db_unregister_all -> alpm_unregister_all_syncdbs alpm_option_get_localdb -> aplpm_get_localdb alpm_option_get_syncdbs -> aplpm_get_syncdbs alpm_db_readgroup -> alpm_db_get_group alpm_db_set_pkgreason -> alpm_pkg_set_reason All methods keep the same argument list except for alpm_pkg_set_reason; there we drop the 'handle' argument as it can be retrieved from the passed in package object. Signed-off-by: Dan McGee <dan@archlinux.org> commit f12effc6ff4605ea81b3b765ff1655107aad29d8 Author: Dan McGee <dan@archlinux.org> Date: Wed Feb 1 23:14:01 2012 -0600 alpm.h: enum cleanups, comment formatting cleanup Don't use trailing commas in enums if people really want to use a strict C89 compiler, and document why on earth one particular enum uses bitmask values when it doesn't seem necessary. With comments, shoot for more consistency. When something is a one-liner, keep it that way and move the whole /** sequence */ to one line. When it needs more than one line, ensure we format most of them in a similar fashion. Two minor function signature adjustments are made that don't change anything other than matching the parameter name (name -> filename) and fitting in with our coding style (type* var -> type *var). Signed-off-by: Dan McGee <dan@archlinux.org> commit d8e1c450a3fcdcbd46fd930f2804d0a61087f968 Author: Dan McGee <dan@archlinux.org> Date: Mon Feb 6 05:48:49 2012 -0600 Remove last explicit include of config.h Signed-off-by: Dan McGee <dan@archlinux.org> ----------------------------------------------------------------------- Summary of changes: lib/libalpm/alpm.c | 2 +- lib/libalpm/alpm.h | 89 +++++++++++++++++++-------------------- lib/libalpm/alpm_list.c | 5 ++- lib/libalpm/be_local.c | 24 ++++++++++ lib/libalpm/db.c | 32 +------------- lib/libalpm/diskspace.c | 2 - lib/libalpm/handle.c | 24 +++++----- lib/libalpm/po/lt.po | 41 +++++++++--------- lib/libalpm/sync.c | 2 +- scripts/makepkg.sh.in | 15 +++++- src/pacman/callback.c | 4 +- src/pacman/conf.c | 2 +- src/pacman/database.c | 4 +- src/pacman/deptest.c | 2 +- src/pacman/package.c | 4 +- src/pacman/po/ca.po | 20 ++++---- src/pacman/po/cs.po | 10 ++-- src/pacman/po/da.po | 10 ++-- src/pacman/po/de.po | 10 ++-- src/pacman/po/el.po | 10 ++-- src/pacman/po/en_GB.po | 10 ++-- src/pacman/po/es.po | 19 ++++---- src/pacman/po/fi.po | 22 +++++----- src/pacman/po/fr.po | 10 ++-- src/pacman/po/hu.po | 10 ++-- src/pacman/po/it.po | 10 ++-- src/pacman/po/kk.po | 10 ++-- src/pacman/po/lt.po | 52 +++++++++++----------- src/pacman/po/nb.po | 37 ++++++++-------- src/pacman/po/pacman.pot | 10 ++-- src/pacman/po/pl.po | 10 ++-- src/pacman/po/pt.po | 10 ++-- src/pacman/po/pt_BR.po | 10 ++-- src/pacman/po/ro.po | 10 ++-- src/pacman/po/ru.po | 10 ++-- src/pacman/po/sk.po | 10 ++-- src/pacman/po/sr.po | 10 ++-- src/pacman/po/sr@latin.po | 10 ++-- src/pacman/po/sv.po | 10 ++-- src/pacman/po/tr.po | 10 ++-- src/pacman/po/uk.po | 10 ++-- src/pacman/po/zh_CN.po | 10 ++-- src/pacman/po/zh_TW.po | 10 ++-- src/pacman/query.c | 14 +++--- src/pacman/remove.c | 6 +- src/pacman/sync.c | 22 +++++----- src/pacman/util.c | 39 +++++++++++++---- src/pacman/util.h | 3 +- src/util/cleanupdelta.c | 2 +- src/util/pactree.c | 6 +- src/util/testdb.c | 4 +- test/pacman/tests/upgrade001.py | 1 + test/pacman/tests/upgrade002.py | 1 + test/pacman/tests/upgrade003.py | 1 + test/pacman/tests/upgrade004.py | 1 + 55 files changed, 381 insertions(+), 351 deletions(-) hooks/post-receive -- The official pacman repository
participants (1)
-
dan@archlinux.org