[pacman-dev] [GIT] The official pacman repository branch, master, updated. v3.3.3-141-gbe2f431
This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "The official pacman repository". The branch, master has been updated via be2f43191d0d0cdf02d72ac72a013697b0f7e879 (commit) via 2f4ee4341d1f97d95a99147556888212d1cd4507 (commit) via 69b3a811a138a84aa09e8e81b2912f6fcd0b47b9 (commit) via d39b1dbe627af218e49be6424857089a5888903b (commit) via 67700b926a1eff745272975e7b089b80bf72cc30 (commit) via e4be3e06af7f96c279851c3f2d7f1d294b8b8e70 (commit) via e5dce888c09976f1ef4664613c742d0d015e534e (commit) from 087be2f1fbae2d7168732c7004d8963a3d9d21d8 (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit be2f43191d0d0cdf02d72ac72a013697b0f7e879 Author: Dan McGee <dan@archlinux.org> Date: Sun Mar 14 19:16:26 2010 -0500 Reduce duplicate code in DB extraction Follow-up to the previous "Only extract new DB entries" patch; move the partial extraction code inside one side of the loop so we can use the same code for actually doing file extraction. Signed-off-by: Dan McGee <dan@archlinux.org> commit 2f4ee4341d1f97d95a99147556888212d1cd4507 Author: Xavier Chantry <shiningxc@gmail.com> Date: Sat Oct 10 03:11:27 2009 +1000 Only extract new DB entries This implements FS#15198. The idea apparently came from Csaba Henk <csaba-ml <at> creo.hu> which submitted a patch to Frugalware, so thanks to him, even though I did not look at the code :) The idea is to only extract folders for new packages into the package database and clean up the old directories. This is essentially implementing Xyne's "rebase" script within pacman. If using -Syy, just remove and extract everything. If using -Sy : 1. Generate list of directories in DB 2. Generate list of directories in archive 3. Compare both 4. Clean up old directories 5. Extract new directories Original-work-by: Allan McRae <allan@archlinux.org> Signed-off-by: Xavier Chantry <shiningxc@gmail.com> [Dan: fix compile error, s/int/size_t/] Signed-off-by: Dan McGee <dan@archlinux.org> commit 69b3a811a138a84aa09e8e81b2912f6fcd0b47b9 Author: Dan McGee <dan@archlinux.org> Date: Sun Mar 14 18:47:40 2010 -0500 Mark two functions static These were just introduced in the `--print` patch, and don't need to be exposed outside of util.c. Signed-off-by: Dan McGee <dan@archlinux.org> commit d39b1dbe627af218e49be6424857089a5888903b Author: Xavier Chantry <shiningxc@gmail.com> Date: Sun Jul 19 11:15:11 2009 +0200 Add new --print operation for all operations And a new --print-format option to configure the output. This implements FS#14208 Example usage : pacman -Sp --print-format "%r/%n-%v : %l [%s]" kdelibs extra/kdelibs-4.3.2-4 : ftp://mir2.archlinuxfr.org/archlinux/extra/os/i686/kdelibs-4.3.2-4-i686.pkg.tar.gz [0,00] Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org> commit 67700b926a1eff745272975e7b089b80bf72cc30 Author: Xavier Chantry <shiningxc@gmail.com> Date: Fri Sep 4 20:18:49 2009 +0200 print installed packages Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org> commit e4be3e06af7f96c279851c3f2d7f1d294b8b8e70 Author: Xavier Chantry <shiningxc@gmail.com> Date: Wed Dec 16 02:38:32 2009 +0100 callback: use variable length for progressbar text This fixes FS#17523 We always used a fixed value of 50 for textlen, which is often not enough for download progress bar. At least we can use a bigger width on large terminal (e.g. 60% of width) and keep 50 as minimum. before: nautilus-2.28.4-1-x... 5.7M 789.2K/s 00:00:07 [####################################] 100% after: nautilus-2.28.4-1-x86_64 5.7M 770.7K/s 00:00:08 [##############################] 100% Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org> commit e5dce888c09976f1ef4664613c742d0d015e534e Author: Xavier Chantry <shiningxc@gmail.com> Date: Wed Dec 16 02:16:00 2009 +0100 callback.c : less magic progress bars 1 - Explain magic numbers 2 - There was a weird off by 1 mess in the progress bar. The code supposedly shared the width between 50 chars for text (textlen) and the rest for the progress bar (proglen = getcols() - textlen). But the code actually used textlen + 1 for the text and proglen - 1 for the progress bar (with haslen=1, the progress bar was actually empty), which was a bit confusing so I changed it. Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org> ----------------------------------------------------------------------- Summary of changes: contrib/bash_completion | 9 ++- contrib/zsh_completion | 1 + doc/pacman.8.txt | 16 +++-- lib/libalpm/be_files.c | 167 ++++++++++++++++++++++++++++++++++++++++++----- lib/libalpm/util.c | 3 +- src/pacman/callback.c | 38 +++++++---- src/pacman/conf.c | 1 + src/pacman/conf.h | 6 +- src/pacman/pacman.c | 23 +++++-- src/pacman/remove.c | 6 ++ src/pacman/sync.c | 50 +++++++------- src/pacman/upgrade.c | 8 ++- src/pacman/util.c | 120 +++++++++++++++++++++++++++++++--- src/pacman/util.h | 1 + 14 files changed, 369 insertions(+), 80 deletions(-) hooks/post-receive -- The official pacman repository
participants (1)
-
dan@archlinux.org