[pacman-dev] [GIT] The official pacman repository branch, master, updated. v4.0.0rc1-175-gdb70c9d
This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "The official pacman repository". The branch, master has been updated via db70c9da153c4767bfd96a15d40e086184bd5402 (commit) via a03313f3f66e9ac03392cb255bc6c4e1958e14c2 (commit) via 905ae640cfb0787e9bdfbcacf21c62e64cc27512 (commit) via 4ed12aec30be0a36fff2937039c904526aeb3b79 (commit) via 17c3de3e4f6b03953e22d203d5891b37ffdf941c (commit) via 3d9f961d1367bf1669332047e667f98b9d35531e (commit) via 8ffa2b24a5e3d63d6f34a1257ed67904ec051e3d (commit) via b961ebe16ffb75bb947a193daa9e9fe639b6403d (commit) via 6317db84295430c2d2d164f81ff723b379b33035 (commit) via 3e08614fda144393ab1ca23dcf08f2cd2f604cf9 (commit) from 0e79802c0ac8453376d8c0f99629f5a3b499f571 (commit) Those revisions listed above that are new to this repository have not appeared on any other notification email; so we list those revisions in full, below. - Log ----------------------------------------------------------------- commit db70c9da153c4767bfd96a15d40e086184bd5402 Author: Dave Reisner <dreisner@archlinux.org> Date: Wed Sep 7 22:22:25 2011 -0400 diskspace: fix memory leak on root mount not found Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org> commit a03313f3f66e9ac03392cb255bc6c4e1958e14c2 Author: Dan McGee <dan@archlinux.org> Date: Thu Sep 8 14:14:51 2011 -0500 Print 'loading packages' message on -U operations This will be the first thing printed when doing an upgrade. Currently there is no output at all until we start resolving dependencies, which can be a while in if specifying very large targets on the command line, in which case it is nice to let the user know we are doing something. Addresses FS#25822 in the most KISS way possible. Signed-off-by: Dan McGee <dan@archlinux.org> commit 905ae640cfb0787e9bdfbcacf21c62e64cc27512 Author: Dave Reisner <dreisner@archlinux.org> Date: Tue Sep 6 14:40:29 2011 -0400 makepkg: use more awk'ish syntax in sanity checks This simplifies the flow a bit, making the pipeline a little easier to grok. Signed-off-by: Dave Reisner <dreisner@archlinux.org> commit 4ed12aec30be0a36fff2937039c904526aeb3b79 Author: Dave Reisner <dreisner@archlinux.org> Date: Tue Sep 6 14:17:15 2011 -0400 makepkg: avoid for loop in deleting manpage hardlinks find can do this all on its own and remain portable. Signed-off-by: Dave Reisner <dreisner@archlinux.org> commit 17c3de3e4f6b03953e22d203d5891b37ffdf941c Author: Dave Reisner <dreisner@archlinux.org> Date: Tue Sep 6 14:11:15 2011 -0400 makepkg: act on function return value, not output Correcting a typo, as this function will never output anything. Signed-off-by: Dave Reisner <dreisner@archlinux.org> commit 3d9f961d1367bf1669332047e667f98b9d35531e Author: Dave Reisner <dreisner@archlinux.org> Date: Sun Sep 4 12:34:57 2011 -0400 makepkg: refactor check_pgpsigs output - display associated warnings on same line as pass/fail msg, to be more consistent with checksum verification output - properly error on a revoked key (matching pacman's behavior) Signed-off-by: Dave Reisner <dreisner@archlinux.org> commit 8ffa2b24a5e3d63d6f34a1257ed67904ec051e3d Author: Dan McGee <dan@archlinux.org> Date: Wed Sep 7 20:43:49 2011 -0500 Use more correct integer types in diskspace checks This adjusts type usage to match POSIX provided types from <sys/types.h> rather than assuming everything will fit in a long or unsigned long. Use fsblkcnt_t (unsigned) and blkcnt_t (signed) as appropriate. These are affected the same way off_t is on 32 bit platforms, where the types are extende to 64 bits if large file support is enabled. Because most numbers here are block counts, this isn't near as pressing as using a 32-bit variable for file sizes where anything over 2GiB can burn you; we likely can support files at least 512 but mainly 4096 times larger. Signed-off-by: Dan McGee <dan@archlinux.org> commit b961ebe16ffb75bb947a193daa9e9fe639b6403d Author: Dan McGee <dan@archlinux.org> Date: Wed Sep 7 20:41:09 2011 -0500 query check: use provided filelist count instead of keeping track We don't need to keep track of how many files are in a package now that said value is provided to us. It also makes more sense to use size_t here for types rather than the (hopefully never too short) int. Signed-off-by: Dan McGee <dan@archlinux.org> commit 6317db84295430c2d2d164f81ff723b379b33035 Author: Dan McGee <dan@archlinux.org> Date: Wed Sep 7 20:33:23 2011 -0500 Remove unnecessary cast Signed-off-by: Dan McGee <dan@archlinux.org> commit 3e08614fda144393ab1ca23dcf08f2cd2f604cf9 Author: Dan McGee <dan@archlinux.org> Date: Wed Sep 7 15:02:52 2011 -0500 Ensure PackageRequired works as expected Changes in commit dc3336c277 caused this to stop working as expected for sync packages, due to the way the logic is structured. Ensure we always enter the signature code if the bitflag is flipped on to check signatures for packages. Rename 'use_sig' to 'has_sig' for clarity. Signed-off-by: Dan McGee <dan@archlinux.org> ----------------------------------------------------------------------- Summary of changes: lib/libalpm/be_package.c | 13 ++++++----- lib/libalpm/diskspace.c | 33 +++++++++++++++------------ lib/libalpm/diskspace.h | 7 ++++- scripts/makepkg.sh.in | 54 +++++++++++++++++++++++----------------------- src/pacman/package.c | 2 +- src/pacman/query.c | 12 +++++----- src/pacman/upgrade.c | 1 + 7 files changed, 65 insertions(+), 57 deletions(-) hooks/post-receive -- The official pacman repository
participants (1)
-
dan@archlinux.org