[pacman-dev] [PATCH] Don't display filename on -Qip operation.
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point? The -Qip operation needs to be run like this : -Qip <filename>, so the filename is already known. There is no need to display it again. Besides, on a normal -Qi operation, the filename is not displayed either because this information is not stored in the local database. Signed-off-by: Xavier Chantry <shiningxc@gmail.com> --- src/pacman/package.c | 3 --- 1 files changed, 0 insertions(+), 3 deletions(-) diff --git a/src/pacman/package.c b/src/pacman/package.c index 21213c4..1698806 100644 --- a/src/pacman/package.c +++ b/src/pacman/package.c @@ -90,9 +90,6 @@ void dump_pkg_full(pmpkg_t *pkg, int level) } /* actual output */ - if(level == 0) { - string_display(_("Filename :"), alpm_pkg_get_filename(pkg)); - } string_display(_("Name :"), alpm_pkg_get_name(pkg)); string_display(_("Version :"), alpm_pkg_get_version(pkg)); string_display(_("URL :"), alpm_pkg_get_url(pkg)); -- 1.5.5.1
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point?
I also put this question when I reworked that part. I implemented filename printing there in order to make 'pacman -Qip *.pkg.tar.gz' and similar commands more readable. Since irl filename usually refers to the package itself, and keeping this would cause more complexity, this can be removed, indeed. Bye ---------------------------------------------------- SZTE Egyetemi Könyvtár - http://www.bibl.u-szeged.hu This mail sent through IMP: http://horde.org/imp/
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point? Because it would be correct for libalpm to fill this field- remember
On Mon, Jun 2, 2008 at 4:56 AM, Xavier <shiningxc@gmail.com> wrote: there could be other frontends. So I think we need to take the correct approach rather than the easy approach. :)
The -Qip operation needs to be run like this : -Qip <filename>, so the filename is already known. There is no need to display it again. Besides, on a normal -Qi operation, the filename is not displayed either because this information is not stored in the local database.
Signed-off-by: Xavier Chantry <shiningxc@gmail.com> --- src/pacman/package.c | 3 --- 1 files changed, 0 insertions(+), 3 deletions(-)
diff --git a/src/pacman/package.c b/src/pacman/package.c index 21213c4..1698806 100644 --- a/src/pacman/package.c +++ b/src/pacman/package.c @@ -90,9 +90,6 @@ void dump_pkg_full(pmpkg_t *pkg, int level) }
/* actual output */ - if(level == 0) { - string_display(_("Filename :"), alpm_pkg_get_filename(pkg)); - } string_display(_("Name :"), alpm_pkg_get_name(pkg)); string_display(_("Version :"), alpm_pkg_get_version(pkg)); string_display(_("URL :"), alpm_pkg_get_url(pkg)); -- 1.5.5.1
_______________________________________________ pacman-dev mailing list pacman-dev@archlinux.org http://archlinux.org/mailman/listinfo/pacman-dev
On Mon, Jun 2, 2008 at 2:10 PM, Dan McGee <dpmcgee@gmail.com> wrote:
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point? Because it would be correct for libalpm to fill this field- remember
On Mon, Jun 2, 2008 at 4:56 AM, Xavier <shiningxc@gmail.com> wrote: there could be other frontends. So I think we need to take the correct approach rather than the easy approach. :)
It is not clear to me which is the correct approach because of this : "Besides, on a normal -Qi operation, the filename is not displayed either because this information is not stored in the local database."
On Mon, Jun 2, 2008 at 7:23 AM, Xavier <shiningxc@gmail.com> wrote:
On Mon, Jun 2, 2008 at 2:10 PM, Dan McGee <dpmcgee@gmail.com> wrote:
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point? Because it would be correct for libalpm to fill this field- remember
On Mon, Jun 2, 2008 at 4:56 AM, Xavier <shiningxc@gmail.com> wrote: there could be other frontends. So I think we need to take the correct approach rather than the easy approach. :)
It is not clear to me which is the correct approach because of this :
"Besides, on a normal -Qi operation, the filename is not displayed either because this information is not stored in the local database."
Sure. But pkg_load is not technically a local or sync database, but some "on-the-fly" created database which happens to be a package file, right? I believe when we populate a pkg struct by way of a package file, we can easily populate the filename field too (which is a different debate from showing it at all on a -Qi* operation, so I apologize for the slight hijacking). -Dan
Mon, 2 Jun 2008 14:23:49 +0200 -n Xavier <shiningxc@gmail.com> írta:
On Mon, Jun 2, 2008 at 2:10 PM, Dan McGee <dpmcgee@gmail.com> wrote:
From cafa4977a0639ebb30ed20974ad86bf404ca5044 Mon Sep 17 00:00:00 2001 From: Xavier Chantry <shiningxc@gmail.com> Date: Wed, 28 May 2008 23:25:40 +0200 Subject: [PATCH] Don't display filename on -Qip operation.
Some previous commits apparently broke the get_filename function for package loaded with pkg_load (on a -Qip operation), so this field is always empty now. It would be easy to fill the pkg->filename field in pkg_load, but what is the point? Because it would be correct for libalpm to fill this field- remember
On Mon, Jun 2, 2008 at 4:56 AM, Xavier <shiningxc@gmail.com> wrote: there could be other frontends. So I think we need to take the correct approach rather than the easy approach. :)
It is not clear to me which is the correct approach because of this :
"Besides, on a normal -Qi operation, the filename is not displayed either because this information is not stored in the local database."
A bit offtopic: To be honest, I never understood the logic here. -Qip would be -Ui or something like this in my mind. Bye
On 02/06/2008, at 8:53 PM, Nagy Gabor wrote:
A bit offtopic: To be honest, I never understood the logic here. -Qip would be -Ui or something like this in my mind.
Both make sense. -U because it works with package tarballs directly, and -Q because it's querying the package tarball.
participants (4)
-
Dan McGee
-
Nagy Gabor
-
Sebastian Nowicki
-
Xavier