[arch-commits] Commit in gutenprint/trunk (PKGBUILD)

andyrtr at archlinux.org andyrtr at archlinux.org
Wed Aug 11 16:42:36 EDT 2010


    Date: Wednesday, August 11, 2010 @ 16:42:35
  Author: andyrtr
Revision: 87283

upgpkg: gutenprint 5.2.6-1
new version 5.2.6

Modified:
  gutenprint/trunk/PKGBUILD

----------+
 PKGBUILD |   16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2010-08-11 19:42:19 UTC (rev 87282)
+++ PKGBUILD	2010-08-11 20:42:35 UTC (rev 87283)
@@ -2,13 +2,13 @@
 # Maintainer: Andreas Radke <andyrtr at archlinux.org>
 
 pkgname=gutenprint
-pkgver=5.2.5
+pkgver=5.2.6
 pkgrel=1
 pkgdesc="Top quality printer drivers for POSIX systems"
 arch=('i686' 'x86_64')
 license=('GPL')
 install=gutenprint.install
-depends=('readline' 'gnutls>=2.8.5')
+depends=('readline' 'gnutls>=2.8.5') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
 makedepends=('gimp>=2.6.8' 'gtk2>=2.18.6' 'cups>=1.4.2' 'foomatic-db-engine' 'ghostscript>=8.71')
 optdepends=('cups:		to use cups printer spooler(recommended)'
             'foomatic-db-engine:	to use foomatic spooler'
@@ -18,7 +18,7 @@
 url="http://gimp-print.sourceforge.net/"
 replaces=('gimp-print')
 options=('!libtool' '!emptydirs')
-md5sums=('10a0a9fac081d8116ec5ed47fbc1591c')
+md5sums=('1f0d0cbef6c089f4f095e21869fa70db')
 
 build() {
   cd ${srcdir}/${pkgname}-${pkgver}
@@ -28,8 +28,12 @@
 	--enable-cups-ppds --enable-cups-ppds-at-top-level \
 	--with-foomatic --with-foomatic3 --with-ghostscript \
 	--disable-static --disable-static-genppd --with-ijs \
-	--disable-globalized-cups-ppds || return 1
-  make || return 1
-  make DESTDIR=${pkgdir} install || return 1
+	--disable-globalized-cups-ppds
+  make
 }
 
+package() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  make DESTDIR=${pkgdir} install
+}
+



More information about the arch-commits mailing list