[arch-commits] Commit in vdpau-video/trunk (PKGBUILD enable-glx.patch)

Ionut Biru ibiru at archlinux.org
Thu Jan 27 08:54:13 EST 2011


    Date: Thursday, January 27, 2011 @ 08:54:12
  Author: ibiru
Revision: 107917

upgpkg: vdpau-video 0.7.3pre5-1
update to 0.7.3pre5, compatible with >=1.0.8

Modified:
  vdpau-video/trunk/PKGBUILD
Deleted:
  vdpau-video/trunk/enable-glx.patch

------------------+
 PKGBUILD         |   15 ++++++---------
 enable-glx.patch |   12 ------------
 2 files changed, 6 insertions(+), 21 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2011-01-27 13:53:09 UTC (rev 107916)
+++ PKGBUILD	2011-01-27 13:54:12 UTC (rev 107917)
@@ -1,7 +1,8 @@
 # $Id$
 # Maintainer: Ionut Biru <ibiru at archlinux.org>
 pkgname=vdpau-video
-pkgver=0.7.2
+pkgver=0.7.3pre5
+_pkgverbase=0.7.3.pre5
 pkgrel=1
 pkgdesc="VDPAU backend for VA API"
 arch=('i686' 'x86_64')
@@ -10,16 +11,12 @@
 depends=('libva' 'libvdpau')
 makedepends=('mesa')
 options=('!libtool')
-source=(http://www.splitted-desktop.com/~gbeauchesne/vdpau-video/${pkgname}-${pkgver}.tar.gz
-        enable-glx.patch)
-md5sums=('6aac5517fb76a0cd539d0fb77def8b2d'
-         'e184df00b34a9334dee4b71d52067883')
+source=(http://www.splitted-desktop.com/~gbeauchesne/vdpau-video/${pkgname}-${_pkgverbase}.tar.gz)
+md5sums=('723d39320cc12eda8c9a10e952edd463')
 
 build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  patch -Np1 -i $srcdir/enable-glx.patch
-  autoreconf -fi
-  ./configure --prefix=/usr --enable-glx
+  cd "${srcdir}/${pkgname}-${_pkgverbase}"
+  ./configure --prefix=/usr
   make
   make DESTDIR="${pkgdir}" install
 }

Deleted: enable-glx.patch
===================================================================
--- enable-glx.patch	2011-01-27 13:53:09 UTC (rev 107916)
+++ enable-glx.patch	2011-01-27 13:54:12 UTC (rev 107917)
@@ -1,12 +0,0 @@
-diff -Nur vdpau-video-0.7.2.orig/configure.ac vdpau-video-0.7.2/configure.ac
---- vdpau-video-0.7.2.orig/configure.ac	2010-10-08 00:09:53.000000000 -0700
-+++ vdpau-video-0.7.2/configure.ac	2010-10-08 11:34:00.536686684 -0700
-@@ -203,7 +203,7 @@
-     #  error "VA-API version >= 0.30.0-sds$LIBVA_GLX_SDS_VERSION_0_30 is required"
-     # endif
-     #elif VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 31
--    # if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_GLX_SDS_VERSION_0_31)
-+    # if !VA_CHECK_VERSION(0,31,0)
-     #  error "VA-API version >= 0.31.0-sds$LIBVA_GLX_SDS_VERSION_0_31 is required"
-     # endif
-     #else



More information about the arch-commits mailing list