[arch-commits] Commit in gnome-vfs/trunk (PKGBUILD gcrypt-config.patch)

Ionut Biru ibiru at archlinux.org
Tue Jul 26 06:40:38 EDT 2011


    Date: Tuesday, July 26, 2011 @ 06:40:38
  Author: ibiru
Revision: 132804

fix building against libgcrypt  1.5.0

Added:
  gnome-vfs/trunk/gcrypt-config.patch
Modified:
  gnome-vfs/trunk/PKGBUILD

---------------------+
 PKGBUILD            |   12 ++++++++----
 gcrypt-config.patch |   31 +++++++++++++++++++++++++++++++
 2 files changed, 39 insertions(+), 4 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2011-07-26 10:22:21 UTC (rev 132803)
+++ PKGBUILD	2011-07-26 10:40:38 UTC (rev 132804)
@@ -3,24 +3,28 @@
 
 pkgname=gnome-vfs
 pkgver=2.24.4
-pkgrel=3
+pkgrel=4
 pkgdesc="The GNOME Virtual File System"
 arch=(i686 x86_64)
 license=('LGPL')
-depends=('fam' 'gconf' 'bzip2' 'avahi' 'smbclient' 'gnome-mime-data' 'krb5' 'gnutls')
+depends=('fam' 'gconf' 'bzip2' 'avahi' 'smbclient' 'gnome-mime-data' 'krb5' 'gnutls' 'libgcrypt')
 makedepends=('pkgconfig' 'intltool' 'gtk-doc' 'gnome-common')
 options=('!libtool' '!emptydirs')
 url="http://www.gnome.org"
 install=gnome-vfs.install
 source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.24/gnome-vfs-${pkgver}.tar.bz2
-        gnutls-config.patch)
+        gnutls-config.patch
+        gcrypt-config.patch)
 sha256sums=('62de64b5b804eb04104ff98fcd6a8b7276d510a49fbd9c0feb568f8996444faa'
-            '66c7cfb12995c0dd94a2caea95c7e3c55981993f05a79c585d60915ff131955d')
+            '66c7cfb12995c0dd94a2caea95c7e3c55981993f05a79c585d60915ff131955d'
+            'c059e218f310da683778919d36e7862f7e763384805f6453d328fbaf507a8114')
 
 build() {
   cd "${srcdir}/${pkgname}-${pkgver}"
   #Fix build with new gnutls
   patch -Np1 -i "${srcdir}/gnutls-config.patch"
+  #fix build with new libgcrypt >= 1.5.0
+  patch -Np1 -i "${srcdir}/gcrypt-config.patch"
   libtoolize --force
   gtkdocize
   aclocal

Added: gcrypt-config.patch
===================================================================
--- gcrypt-config.patch	                        (rev 0)
+++ gcrypt-config.patch	2011-07-26 10:40:38 UTC (rev 132804)
@@ -0,0 +1,31 @@
+# Allow gnome-vfs-2.24 to build with libgcrypt >= 1.5.0
+--- gnome-vfs-2.24.4/configure.in	2010-07-01 12:36:09.000000000 -0300
++++ gnome-vfs-2.24.4-libgcrypt//configure.in	2011-07-22 15:55:02.296325640 -0300
+@@ -689,6 +689,16 @@
+ AM_CONDITIONAL(HAVE_SSL, test x$have_ssl = xtrue)
+
+ dnl ****************************
++dnl LibGCrypt 1.5.0
++dnl ****************************
++
++AM_PATH_LIBGCRYPT(1.5.0)
++
++if test "x${LIBGCRYPT_LIBS}" = "x"; then
++	AC_MSG_ERROR([unable to find libgcrypt])
++fi
++
++dnl ****************************
+ dnl DNS-SD implementations
+ dnl ****************************
+ AM_CONDITIONAL(HAVE_AVAHI, false)
+@@ -1045,8 +1055,8 @@
+ dnl ==============================================================================
+
+ PKG_CHECK_MODULES(LIBGNOMEVFS, glib-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED gthread-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libxml-2.0 >= $XML_REQUIRED gnome-mime-data-2.0 $dbus_requirement)
+-LIBGNOMEVFS_CFLAGS="$LIBGNOMEVFS_CFLAGS $OPENSSL_CFLAGS $LIBGNUTLS_CFLAGS $HOWL_CFLAGS $AVAHI_CFLAGS"
+-LIBGNOMEVFS_LIBS="$LIBGNOMEVFS_LIBS $OPENSSL_LIBS $LIBGNUTLS_LIBS $HOWL_LIBS $AVAHI_LIBS $RESOLVER_LIBS"
++LIBGNOMEVFS_CFLAGS="$LIBGNOMEVFS_CFLAGS $OPENSSL_CFLAGS $LIBGNUTLS_CFLAGS $HOWL_CFLAGS $AVAHI_CFLAGS $LIBGCRYPT_CFLAGS"
++LIBGNOMEVFS_LIBS="$LIBGNOMEVFS_LIBS $OPENSSL_LIBS $LIBGNUTLS_LIBS $HOWL_LIBS $AVAHI_LIBS $RESOLVER_LIBS  $LIBGCRYPT_LIBS"
+ AC_SUBST(LIBGNOMEVFS_CFLAGS)
+ AC_SUBST(LIBGNOMEVFS_LIBS)
+



More information about the arch-commits mailing list