[arch-commits] Commit in firefox-i18n/repos (3 files)

Ionut Biru ibiru at archlinux.org
Sun Nov 6 12:58:44 EST 2011


    Date: Sunday, November 6, 2011 @ 12:58:44
  Author: ibiru
Revision: 142231

archrelease: copy trunk to testing-any

Added:
  firefox-i18n/repos/testing-any/
  firefox-i18n/repos/testing-any/PKGBUILD
    (from rev 142230, firefox-i18n/trunk/PKGBUILD)
  firefox-i18n/repos/testing-any/firefox-i18n.install
    (from rev 142230, firefox-i18n/trunk/firefox-i18n.install)

----------------------+
 PKGBUILD             |  827 +++++++++++++++++++++++++++++++++++++++++++++++++
 firefox-i18n.install |    8 
 2 files changed, 835 insertions(+)

Copied: firefox-i18n/repos/testing-any/PKGBUILD (from rev 142230, firefox-i18n/trunk/PKGBUILD)
===================================================================
--- testing-any/PKGBUILD	                        (rev 0)
+++ testing-any/PKGBUILD	2011-11-06 17:58:44 UTC (rev 142231)
@@ -0,0 +1,827 @@
+# $Id$
+# Maintainer: Thomas Baechler <thomas at archlinux.org>
+# Contributor: Jaroslaw Swierczynski <swiergot at juvepoland.com>
+# Contributor: Michal Hybner <dta081 at gmail.com>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+
+pkgbase=firefox-i18n
+pkgname=('firefox-i18n'
+    'firefox-i18n-af'
+    'firefox-i18n-ak'
+    'firefox-i18n-ar'
+    'firefox-i18n-ast'
+    'firefox-i18n-be'
+    'firefox-i18n-bg'
+    'firefox-i18n-bn-bd'
+    'firefox-i18n-bn-in'
+    'firefox-i18n-br'
+    'firefox-i18n-bs'
+    'firefox-i18n-ca'
+    'firefox-i18n-cs'
+    'firefox-i18n-cy'
+    'firefox-i18n-da'
+    'firefox-i18n-de'
+    'firefox-i18n-el'
+    'firefox-i18n-en-gb'
+    'firefox-i18n-eo'
+    'firefox-i18n-es-ar'
+    'firefox-i18n-es-cl'
+    'firefox-i18n-es-es'
+    'firefox-i18n-es-mx'
+    'firefox-i18n-et'
+    'firefox-i18n-eu'
+    'firefox-i18n-fa'
+    'firefox-i18n-fi'
+    'firefox-i18n-fr'
+    'firefox-i18n-fy-nl'
+    'firefox-i18n-ga-ie'
+    'firefox-i18n-gl'
+    'firefox-i18n-gu-in'
+    'firefox-i18n-he'
+    'firefox-i18n-hi-in'
+    'firefox-i18n-hr'
+    'firefox-i18n-hu'
+    'firefox-i18n-hy-am'
+    'firefox-i18n-id'
+    'firefox-i18n-is'
+    'firefox-i18n-it'
+    'firefox-i18n-ja'
+    'firefox-i18n-kk'
+    'firefox-i18n-kn'
+    'firefox-i18n-ko'
+    'firefox-i18n-ku'
+    'firefox-i18n-lg'
+    'firefox-i18n-lt'
+    'firefox-i18n-lv'
+    'firefox-i18n-mai'
+    'firefox-i18n-mk'
+    'firefox-i18n-ml'
+    'firefox-i18n-mr'
+    'firefox-i18n-nb-no'
+    'firefox-i18n-nl'
+    'firefox-i18n-nn-no'
+    'firefox-i18n-nso'
+    'firefox-i18n-or'
+    'firefox-i18n-pa-in'
+    'firefox-i18n-pl'
+    'firefox-i18n-pt-br'
+    'firefox-i18n-pt-pt'
+    'firefox-i18n-rm'
+    'firefox-i18n-ro'
+    'firefox-i18n-ru'
+    'firefox-i18n-si'
+    'firefox-i18n-sk'
+    'firefox-i18n-sl'
+    'firefox-i18n-son'
+    'firefox-i18n-sq'
+    'firefox-i18n-sr'
+    'firefox-i18n-sv-se'
+    'firefox-i18n-ta-lk'
+    'firefox-i18n-ta'
+    'firefox-i18n-te'
+    'firefox-i18n-th'
+    'firefox-i18n-tr'
+    'firefox-i18n-uk'
+    'firefox-i18n-vi'
+    'firefox-i18n-zh-cn'
+    'firefox-i18n-zh-tw'
+    'firefox-i18n-zu')
+pkgver=8.0
+pkgrel=1
+arch=('any')
+license=('MPL')
+url="http://www.mozilla.com/"
+depends=("firefox>=${pkgver}")
+_url=ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/linux-i686/xpi
+
+source=(firefox-i18n-$pkgver-af.xpi::$_url/af.xpi
+        firefox-i18n-$pkgver-ak.xpi::$_url/ak.xpi
+        firefox-i18n-$pkgver-ar.xpi::$_url/ar.xpi
+        firefox-i18n-$pkgver-ast.xpi::$_url/ast.xpi
+        firefox-i18n-$pkgver-be.xpi::$_url/be.xpi
+        firefox-i18n-$pkgver-bg.xpi::$_url/bg.xpi
+        firefox-i18n-$pkgver-bn-BD.xpi::$_url/bn-BD.xpi
+        firefox-i18n-$pkgver-bn-IN.xpi::$_url/bn-IN.xpi
+        firefox-i18n-$pkgver-br.xpi::$_url/br.xpi
+        firefox-i18n-$pkgver-bs.xpi::$_url/bs.xpi
+        firefox-i18n-$pkgver-ca.xpi::$_url/ca.xpi
+        firefox-i18n-$pkgver-cs.xpi::$_url/cs.xpi
+        firefox-i18n-$pkgver-cy.xpi::$_url/cy.xpi
+        firefox-i18n-$pkgver-da.xpi::$_url/da.xpi
+        firefox-i18n-$pkgver-de.xpi::$_url/de.xpi
+        firefox-i18n-$pkgver-el.xpi::$_url/el.xpi
+        firefox-i18n-$pkgver-en-GB.xpi::$_url/en-GB.xpi
+        firefox-i18n-$pkgver-eo.xpi::$_url/eo.xpi
+        firefox-i18n-$pkgver-es-AR.xpi::$_url/es-AR.xpi
+        firefox-i18n-$pkgver-es-CL.xpi::$_url/es-CL.xpi
+        firefox-i18n-$pkgver-es-ES.xpi::$_url/es-ES.xpi
+        firefox-i18n-$pkgver-es-MX.xpi::$_url/es-MX.xpi
+        firefox-i18n-$pkgver-et.xpi::$_url/et.xpi
+        firefox-i18n-$pkgver-eu.xpi::$_url/eu.xpi
+        firefox-i18n-$pkgver-fa.xpi::$_url/fa.xpi
+        firefox-i18n-$pkgver-fi.xpi::$_url/fi.xpi
+        firefox-i18n-$pkgver-fr.xpi::$_url/fr.xpi
+        firefox-i18n-$pkgver-fy-NL.xpi::$_url/fy-NL.xpi
+        firefox-i18n-$pkgver-ga-IE.xpi::$_url/ga-IE.xpi
+        firefox-i18n-$pkgver-gl.xpi::$_url/gl.xpi
+        firefox-i18n-$pkgver-gu-IN.xpi::$_url/gu-IN.xpi
+        firefox-i18n-$pkgver-he.xpi::$_url/he.xpi
+        firefox-i18n-$pkgver-hi-IN.xpi::$_url/hi-IN.xpi
+        firefox-i18n-$pkgver-hr.xpi::$_url/hr.xpi
+        firefox-i18n-$pkgver-hu.xpi::$_url/hu.xpi
+        firefox-i18n-$pkgver-hy-AM.xpi::$_url/hy-AM.xpi
+        firefox-i18n-$pkgver-id.xpi::$_url/id.xpi
+        firefox-i18n-$pkgver-is.xpi::$_url/is.xpi
+        firefox-i18n-$pkgver-it.xpi::$_url/it.xpi
+        firefox-i18n-$pkgver-ja.xpi::$_url/ja.xpi
+        firefox-i18n-$pkgver-kk.xpi::$_url/kk.xpi
+        firefox-i18n-$pkgver-kn.xpi::$_url/kn.xpi
+        firefox-i18n-$pkgver-ko.xpi::$_url/ko.xpi
+        firefox-i18n-$pkgver-ku.xpi::$_url/ku.xpi
+        firefox-i18n-$pkgver-lg.xpi::$_url/lg.xpi
+        firefox-i18n-$pkgver-lt.xpi::$_url/lt.xpi
+        firefox-i18n-$pkgver-lv.xpi::$_url/lv.xpi
+        firefox-i18n-$pkgver-mai.xpi::$_url/mai.xpi
+        firefox-i18n-$pkgver-mk.xpi::$_url/mk.xpi
+        firefox-i18n-$pkgver-ml.xpi::$_url/ml.xpi
+        firefox-i18n-$pkgver-mr.xpi::$_url/mr.xpi
+        firefox-i18n-$pkgver-nb-NO.xpi::$_url/nb-NO.xpi
+        firefox-i18n-$pkgver-nl.xpi::$_url/nl.xpi
+        firefox-i18n-$pkgver-nn-NO.xpi::$_url/nn-NO.xpi
+        firefox-i18n-$pkgver-nso.xpi::$_url/nso.xpi
+        firefox-i18n-$pkgver-or.xpi::$_url/or.xpi
+        firefox-i18n-$pkgver-pa-IN.xpi::$_url/pa-IN.xpi
+        firefox-i18n-$pkgver-pl.xpi::$_url/pl.xpi
+        firefox-i18n-$pkgver-pt-BR.xpi::$_url/pt-BR.xpi
+        firefox-i18n-$pkgver-pt-PT.xpi::$_url/pt-PT.xpi
+        firefox-i18n-$pkgver-rm.xpi::$_url/rm.xpi
+        firefox-i18n-$pkgver-ro.xpi::$_url/ro.xpi
+        firefox-i18n-$pkgver-ru.xpi::$_url/ru.xpi
+        firefox-i18n-$pkgver-si.xpi::$_url/si.xpi
+        firefox-i18n-$pkgver-sk.xpi::$_url/sk.xpi
+        firefox-i18n-$pkgver-sl.xpi::$_url/sl.xpi
+        firefox-i18n-$pkgver-son.xpi::$_url/son.xpi
+        firefox-i18n-$pkgver-sq.xpi::$_url/sq.xpi
+        firefox-i18n-$pkgver-sr.xpi::$_url/sr.xpi
+        firefox-i18n-$pkgver-sv-SE.xpi::$_url/sv-SE.xpi
+        firefox-i18n-$pkgver-ta-LK.xpi::$_url/ta-LK.xpi
+        firefox-i18n-$pkgver-ta.xpi::$_url/ta.xpi
+        firefox-i18n-$pkgver-te.xpi::$_url/te.xpi
+        firefox-i18n-$pkgver-th.xpi::$_url/th.xpi
+        firefox-i18n-$pkgver-tr.xpi::$_url/tr.xpi
+        firefox-i18n-$pkgver-uk.xpi::$_url/uk.xpi
+        firefox-i18n-$pkgver-vi.xpi::$_url/vi.xpi
+        firefox-i18n-$pkgver-zh-CN.xpi::$_url/zh-CN.xpi
+        firefox-i18n-$pkgver-zh-TW.xpi::$_url/zh-TW.xpi
+        firefox-i18n-$pkgver-zu.xpi::$_url/zu.xpi)
+
+
+# Don't extract anything
+noextract=(${source[@]##*/})
+
+_path="/usr/lib/firefox/extensions/"
+
+
+package_firefox-i18n () {
+  pkgdesc="Transition package to split build"
+  install=firefox-i18n.install
+}
+
+package_firefox-i18n-af() {
+  pkgdesc="Afrikaans (South Africa) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-af.xpi "${pkgdir}/$_path/langpack-af at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ak() {
+  pkgdesc="Akan language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ak.xpi "${pkgdir}/$_path/langpack-ak at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ar() {
+  pkgdesc="Arabic language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ar.xpi "${pkgdir}/$_path/langpack-ar at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ast() {
+  pkgdesc="Asturian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ast.xpi "${pkgdir}/$_path/langpack-ast at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-be() {
+  pkgdesc="Belarusian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-be.xpi "${pkgdir}/$_path/langpack-be at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-bg() {
+  pkgdesc="Bulgarian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-bg.xpi "${pkgdir}/$_path/langpack-bg at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-bn-bd() {
+  pkgdesc="Bengali (Bangladesh) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-bn-BD.xpi "${pkgdir}/$_path/langpack-bn-BD at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-bn-in() {
+  pkgdesc="Bengali (India) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-bn-IN.xpi "${pkgdir}/$_path/langpack-bn-IN at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-br() {
+  pkgdesc="Breton language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-br.xpi "${pkgdir}/$_path/langpack-br at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-bs() {
+  pkgdesc="Bosnian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-bs.xpi "${pkgdir}/$_path/langpack-bs at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ca() {
+  pkgdesc="Catalan language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ca.xpi "${pkgdir}/$_path/langpack-ca at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-cs() {
+  pkgdesc="Czech language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-cs.xpi "${pkgdir}/$_path/langpack-cs at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-cy() {
+  pkgdesc="Welsh language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-cy.xpi "${pkgdir}/$_path/langpack-cy at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-da() {
+  pkgdesc="Danish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-da.xpi "${pkgdir}/$_path/langpack-da at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-de() {
+  pkgdesc="German language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-de.xpi "${pkgdir}/$_path/langpack-de at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-el() {
+  pkgdesc="Greek language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-el.xpi "${pkgdir}/$_path/langpack-el at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-en-gb() {
+  pkgdesc="English (United Kingdom) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-en-GB.xpi "${pkgdir}/$_path/langpack-en-GB at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-eo() {
+  pkgdesc="Esperanto language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-eo.xpi "${pkgdir}/$_path/langpack-eo at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-es-ar() {
+  pkgdesc="Spanish (Argentina) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-es-AR.xpi "${pkgdir}/$_path/langpack-es-AR at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-es-cl() {
+  pkgdesc="Spanish (Chile) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-es-CL.xpi "${pkgdir}/$_path/langpack-es-CL at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-es-es() {
+  pkgdesc="Spanish (Spain) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-es-ES.xpi "${pkgdir}/$_path/langpack-es-ES at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-es-mx() {
+  pkgdesc="Spanish (Mexico) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-es-MX.xpi "${pkgdir}/$_path/langpack-es-MX at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-et() {
+  pkgdesc="Estonian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-et.xpi "${pkgdir}/$_path/langpack-et at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-eu() {
+  pkgdesc="Basque language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-eu.xpi "${pkgdir}/$_path/langpack-eu at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-fa() {
+  pkgdesc="Persian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-fa.xpi "${pkgdir}/$_path/langpack-fa at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-fi() {
+  pkgdesc="Finnish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-fi.xpi "${pkgdir}/$_path/langpack-fi at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-fr() {
+  pkgdesc="French language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-fr.xpi "${pkgdir}/$_path/langpack-fr at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-fy-nl() {
+  pkgdesc="Frisian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-fy-NL.xpi "${pkgdir}/$_path/langpack-fy-NL at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ga-ie() {
+  pkgdesc="Irish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ga-IE.xpi "${pkgdir}/$_path/langpack-ga-IE at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-gl() {
+  pkgdesc="Galician language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-gl.xpi "${pkgdir}/$_path/langpack-gl at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-gu-in() {
+  pkgdesc="Gujarati (India) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-gu-IN.xpi "${pkgdir}/$_path/langpack-gu-IN at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-he() {
+  pkgdesc="Hebrew language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-he.xpi "${pkgdir}/$_path/langpack-he at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-hi-in() {
+  pkgdesc="Hindi language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-hi-IN.xpi "${pkgdir}/$_path/langpack-hi-IN at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-hr() {
+  pkgdesc="Croatian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-hr.xpi "${pkgdir}/$_path/langpack-hr at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-hu() {
+  pkgdesc="Hungarian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-hu.xpi "${pkgdir}/$_path/langpack-hu at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-hy-am() {
+  pkgdesc="Armenian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-hy-AM.xpi "${pkgdir}/$_path/langpack-hy-AM at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-id() {
+  pkgdesc="Indonesian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-id.xpi "${pkgdir}/$_path/langpack-id at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-is() {
+  pkgdesc="Icelandic language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-is.xpi "${pkgdir}/$_path/langpack-is at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-it() {
+  pkgdesc="Italian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-it.xpi "${pkgdir}/$_path/langpack-it at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ja() {
+  pkgdesc="Japanese language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ja.xpi "${pkgdir}/$_path/langpack-ja at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-kk() {
+  pkgdesc="Kazakh language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-kk.xpi "${pkgdir}/$_path/langpack-kk at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-kn() {
+  pkgdesc="Kannada language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-kn.xpi "${pkgdir}/$_path/langpack-kn at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ko() {
+  pkgdesc="Korean language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ko.xpi "${pkgdir}/$_path/langpack-ko at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ku() {
+  pkgdesc="Kurdish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ku.xpi "${pkgdir}/$_path/langpack-ku at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-lg() {
+  pkgdesc="Ganda language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-lg.xpi "${pkgdir}/$_path/langpack-lg at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-lt() {
+  pkgdesc="Lithuanian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-lt.xpi "${pkgdir}/$_path/langpack-lt at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-lv() {
+  pkgdesc="Latvian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-lv.xpi "${pkgdir}/$_path/langpack-lv at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-mai() {
+  pkgdesc="Maithili language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-mai.xpi "${pkgdir}/$_path/langpack-mai at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-mk() {
+  pkgdesc="Macedonian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-mk.xpi "${pkgdir}/$_path/langpack-mk at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ml() {
+  pkgdesc="Malayalam language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ml.xpi "${pkgdir}/$_path/langpack-ml at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-mr() {
+  pkgdesc="Marathi language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-mr.xpi "${pkgdir}/$_path/langpack-mr at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-nb-no() {
+  pkgdesc="Norwegian (Bokmal) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-nb-NO.xpi "${pkgdir}/$_path/langpack-nb-NO at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-nl() {
+  pkgdesc="Dutch language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-nl.xpi "${pkgdir}/$_path/langpack-nl at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-nn-no() {
+  pkgdesc="Norwegian (Nynorsk) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-nn-NO.xpi "${pkgdir}/$_path/langpack-nn-NO at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-nso() {
+  pkgdesc="Northern Sotho (Sesotho sa lebowa) Language Pack for Firefox"
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-nso.xpi "${pkgdir}/$_path/langpack-nso at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-or() {
+  pkgdesc="Oriya language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-or.xpi "${pkgdir}/$_path/langpack-or at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-pa-in() {
+  pkgdesc="Punjabi language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-pa-IN.xpi "${pkgdir}/$_path/langpack-pa-IN at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-pl() {
+  pkgdesc="Polish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-pl.xpi "${pkgdir}/$_path/langpack-pl at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-pt-br() {
+  pkgdesc="Portuguese (Brazil) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-pt-BR.xpi "${pkgdir}/$_path/langpack-pt-BR at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-pt-pt() {
+  pkgdesc="Portuguese (Portugal) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-pt-PT.xpi "${pkgdir}/$_path/langpack-pt-PT at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-rm() {
+  pkgdesc="Romansh language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-rm.xpi "${pkgdir}/$_path/langpack-rm at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ro() {
+  pkgdesc="Romanian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ro.xpi "${pkgdir}/$_path/langpack-ro at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ru() {
+  pkgdesc="Russian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ru.xpi "${pkgdir}/$_path/langpack-ru at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-si() {
+  pkgdesc="Sinhalese language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-si.xpi "${pkgdir}/$_path/langpack-si at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-sk() {
+  pkgdesc="Slovak language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-sk.xpi "${pkgdir}/$_path/langpack-sk at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-sl() {
+  pkgdesc="Slovenian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-sl.xpi "${pkgdir}/$_path/langpack-sl at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-son() {
+  pkgdesc="Songhai language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-son.xpi "${pkgdir}/$_path/langpack-son at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-sq() {
+  pkgdesc="Albanian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-sq.xpi "${pkgdir}/$_path/langpack-sq at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-sr() {
+  pkgdesc="Serbian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-sr.xpi "${pkgdir}/$_path/langpack-sr at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-sv-se() {
+  pkgdesc="Swedish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-sv-SE.xpi "${pkgdir}/$_path/langpack-sv-SE at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ta-lk() {
+  pkgdesc="Tamil (Sri Lanka) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ta-LK.xpi "${pkgdir}/$_path/langpack-ta-LK at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-ta() {
+  pkgdesc="Tamil language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-ta.xpi "${pkgdir}/$_path/langpack-ta at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-te() {
+  pkgdesc="Telugu language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-te.xpi "${pkgdir}/$_path/langpack-te at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-th() {
+  pkgdesc="Thai language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-th.xpi "${pkgdir}/$_path/langpack-th at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-tr() {
+  pkgdesc="Turkish language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-tr.xpi "${pkgdir}/$_path/langpack-tr at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-uk() {
+  pkgdesc="Ukrainian language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-uk.xpi "${pkgdir}/$_path/langpack-uk at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-vi() {
+  pkgdesc="Vietnamese language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-vi.xpi "${pkgdir}/$_path/langpack-vi at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-zh-cn() {
+  pkgdesc="Chinese (Simplified) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-zh-CN.xpi "${pkgdir}/$_path/langpack-zh-CN at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-zh-tw() {
+  pkgdesc="Chinese (Traditional) language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-zh-TW.xpi "${pkgdir}/$_path/langpack-zh-TW at firefox.mozilla.org.xpi"
+}
+
+package_firefox-i18n-zu() {
+  pkgdesc="Zulu language pack for Firefox"
+
+  cd "${srcdir}"
+  install -Dm644 firefox-i18n-$pkgver-zu.xpi "${pkgdir}/$_path/langpack-zu at firefox.mozilla.org.xpi"
+}
+md5sums=('b31ff934c50e09d4cf482a25cfb957ac'
+         'e0eeb40d7a7adb4c47c76fec75705526'
+         '39221a74b8162bdef7103c233de282fe'
+         '1d28484b9247d156cafac7d8247759cc'
+         'c1c9f02c583b77388e5274d285090740'
+         '6300ef3e170a7175837bbda44e3a27a1'
+         'ed352ca2ae9bd7883e442efab996df8e'
+         '2713a79a26bbbe94a95aed5b56a07c9b'
+         'b06f8317315d1854d02594f2e0d062a5'
+         'e1835156fef875243893ea4889debae7'
+         '9293dbbb18bfa01f44d062adee3284a5'
+         'a88d1ff6640146d13941776651126c2f'
+         'e1847408a3b03a178422f23133d4adf8'
+         '88c8c3c558d6522175547d806e52e341'
+         '3af639e23faeb0dec06dd460f31b48c8'
+         'ff47e383b8868f15cab78a52e8296cbb'
+         '29f9b0f883ad98edf3f767697c587131'
+         '93092bdd24a9b096fe7aabaff3295ce3'
+         '256d871ddca26fe63d7a0fdb9518c8dd'
+         'd4952e0b4effdb225ecb02a75c454f91'
+         'aef606afc9fb72e463a7180496d64e67'
+         'b4ce79e8daa5b547ae546a8e64c5b0b5'
+         '34d0991436c181be4fb187cfc1e00b96'
+         'a86fbd1191d34deda1cd9a6ca9472f00'
+         '8b59a48a6976336f11e67ef612081ce9'
+         '0a05c9d64d2e5081238c9ce6225419b9'
+         '835b4fb8fc56b6b6d96c9b3e71717591'
+         '0e4ab00be8b3ed2f435a5e30ff111473'
+         '1df1ef91a31b48095dc41dba090e60d5'
+         '24efa46cc4cf78bc707a4983b57c3ebd'
+         '621fd3648ce330e87fb36eea4e2a3060'
+         'ac892b3d07465bfb25b2d052af6a729c'
+         '753c69036d3e7e5682c599bf9933cd5b'
+         '645d8a2613ca279c7031d418e82b717f'
+         'f7376118303c17be8f3708676d65e66f'
+         '3476ab7df376516fdab97dea984a3618'
+         '72f593609c39c88580cf4a797c27a131'
+         'aec8758ca5f52a0d1c2414553d3a41b4'
+         '6f32549ff70de2ff8eff3856b9587d48'
+         '9c75ba95256f2bd36d3b59b9139164bd'
+         '208a481d9d31273dbbf34aea0db81f1a'
+         '96bb9a8ec2a0508a157b41340fde9769'
+         '76ca60bf19d714203db4c60e5ed06cee'
+         '1339566e4e21baa7e268b0bd3ead6b38'
+         '0e3c6197da24fd09012c1d3cc6a2ab52'
+         'e987bd899325401b01c4446e8ebf4d1f'
+         'b9980850e5876730a70f32fbb2f1734b'
+         '7ae07e0d55ba9959223c5ea36736dfc9'
+         '7829272530b25ed9be02d54ebdb4c246'
+         '5a0d2fa58f26e2f935ece556a81138a5'
+         'ee9c31342f6d7bf8c81a378c0c3d3faa'
+         '443eb729a9c66e27cdeb6bd606653c52'
+         '665127e7a66daf656b21e6dc2415ea6e'
+         '51e6b089c3729a89607ee92e12467888'
+         '139c419b7472e97e1e13c420438e26b9'
+         'c6c76d39488d007b63edc7c268403317'
+         '2c5214d98ebce2c70d751c739115ed9e'
+         '93a6479796685f12597e084e1e42a304'
+         '5fe4927b482d351cb5e28080f14c6348'
+         '9e12e0d43bd5c726930cccc188e7c234'
+         'f64fda17a84f75496a5904cd0d118fd8'
+         '3f0f5f567cc6e3ad97faf88304d5b2c8'
+         '2bb7f1ee2430fabc1e54e8de3a76d47a'
+         '394d1790f691c8ce2f83373c0e08ad80'
+         '45dbd4e41421f4e1602cbc7e0706cdb3'
+         'e7955e1feee9049c0087308ef51432d3'
+         'fe6cc42c2e89602fc2d4d7737dc45932'
+         'dc82c2881a34c43a32ddd2ab7b68b804'
+         '49bcec84bebef5de17c26033ef4bf139'
+         'b2e2c5197874880c62e38d7af5298e45'
+         'c2fbadc32678230a193b5254f5195594'
+         'f93bd0f41693d74f7b0b5700fb956d98'
+         'a10e5fba144cb6b135a37b962ed3add6'
+         'd5f64309e4830a9539b72fb179f23e90'
+         'c7751e0e57044163d774faf4edc26823'
+         '6be1a839c1c82b90fc3da7402cfc96d5'
+         '0d7c27a5c7f8204fb0e79e985a095484'
+         '4b58923b2f3428c36657e4aabe7edb45'
+         'c6063814ad71fee272ba5d5535964279'
+         '9230565246dc8a6f0aa5a2908d1024f2')

Copied: firefox-i18n/repos/testing-any/firefox-i18n.install (from rev 142230, firefox-i18n/trunk/firefox-i18n.install)
===================================================================
--- testing-any/firefox-i18n.install	                        (rev 0)
+++ testing-any/firefox-i18n.install	2011-11-06 17:58:44 UTC (rev 142231)
@@ -0,0 +1,8 @@
+post_install() {
+    echo "This is transitional package. Please install firefox-i18n-foo, where foo is your preferred language"
+}
+post_upgrade() {
+    if  [ "$(vercmp $2 4.0-3)" -lt 0 ]; then
+        post_install
+    fi
+}



More information about the arch-commits mailing list