[arch-commits] Commit in vim/trunk (PKGBUILD)

Eric Bélanger eric at archlinux.org
Tue Nov 8 23:16:14 EST 2011


    Date: Tuesday, November 8, 2011 @ 23:16:14
  Author: eric
Revision: 142403

upgpkg: vim 7.3.353-1

Upstream update, Add lua support (close FS#26557)

Modified:
  vim/trunk/PKGBUILD

----------+
 PKGBUILD |   14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2011-11-09 01:32:02 UTC (rev 142402)
+++ PKGBUILD	2011-11-09 04:16:14 UTC (rev 142403)
@@ -6,19 +6,19 @@
 pkgbase=vim
 pkgname=('vim' 'gvim' 'vim-runtime')
 _topver=7.3
-_patchlevel=338
-__hgrev=f530aef0d959
+_patchlevel=353
+__hgrev=379a6398d462
 _versiondir="vim${_topver//./}"
 pkgver=${_topver}.${_patchlevel}
 pkgrel=1
 arch=('i686' 'x86_64')
 license=('custom:vim')
 url="http://www.vim.org"
-makedepends=('gpm' 'python2' 'python' 'ruby' 'libxt' 'desktop-file-utils' 'gtk2')
+makedepends=('gpm' 'python2' 'python' 'ruby' 'libxt' 'desktop-file-utils' 'gtk2' 'lua')
 source=(ftp://ftp.archlinux.org/other/vim/${pkgname}-${pkgver}.tar.xz
         pythoncomplete.vim::http://www.vim.org/scripts/download_script.php\?src_id=10872
         vimrc archlinux.vim gvim.desktop)
-md5sums=('fc83d6580fd8441793fccfd26487aadb'
+md5sums=('3a7fb107699b741a7a1a86ff5ec3b83e'
          '6e7adfbd5d26c1d161030ec203a7f243'
          'e57777374891063b9ca48a1fe392ac05'
          '10353a61aadc3f276692d0e17db1478e'
@@ -73,7 +73,7 @@
     --with-features=big --enable-gpm --enable-acl --with-x=no \
     --disable-gui --enable-multibyte --enable-cscope \
     --disable-netbeans --enable-perlinterp --disable-pythoninterp \
-    --disable-rubyinterp
+    --disable-rubyinterp --disable-luainterp
 
   make
 
@@ -84,7 +84,7 @@
     --with-features=big --enable-gpm --enable-acl --with-x=yes \
     --enable-gui=gtk2 --enable-multibyte --enable-cscope \
     --enable-netbeans --enable-perlinterp --enable-pythoninterp \
-    --enable-python3interp --enable-rubyinterp
+    --enable-python3interp --enable-rubyinterp --enable-luainterp
 
   make
 }
@@ -119,7 +119,7 @@
 package_gvim() {
   pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with advanced features, such as a GUI)'
   depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'libxt'
-           'desktop-file-utils' 'gtk2')
+           'desktop-file-utils' 'gtk2' 'lua')
   provides=("vim=${pkgver}-${pkgrel}")
   conflicts=('vim')
   install=gvim.install



More information about the arch-commits mailing list