[arch-commits] Commit in librpcsecgss/repos (5 files)

Tobias Powalowski tpowa at archlinux.org
Tue Nov 15 04:00:02 EST 2011


    Date: Tuesday, November 15, 2011 @ 04:00:02
  Author: tpowa
Revision: 142791

db-move: moved librpcsecgss from [testing] to [core] (i686)

Added:
  librpcsecgss/repos/core-i686/PKGBUILD
    (from rev 142790, librpcsecgss/repos/testing-i686/PKGBUILD)
  librpcsecgss/repos/core-i686/librpcsecgss-0.18-heimdal.patch
    (from rev 142790, librpcsecgss/repos/testing-i686/librpcsecgss-0.18-heimdal.patch)
Deleted:
  librpcsecgss/repos/core-i686/PKGBUILD
  librpcsecgss/repos/core-i686/librpcsecgss-0.18-heimdal.patch
  librpcsecgss/repos/testing-i686/

---------------------------------+
 PKGBUILD                        |   59 ++++++++++++++++++---------------
 librpcsecgss-0.18-heimdal.patch |   66 +++++++++++++++++++-------------------
 2 files changed, 65 insertions(+), 60 deletions(-)

Deleted: core-i686/PKGBUILD
===================================================================
--- core-i686/PKGBUILD	2011-11-15 08:59:08 UTC (rev 142790)
+++ core-i686/PKGBUILD	2011-11-15 09:00:02 UTC (rev 142791)
@@ -1,27 +0,0 @@
-# $Id$
-# Maintainer: Tobias Powalowski <tpowa at archlinux.org>
-# Contributor: Andrew Krawchyk <krawch_a at denison.edu>, Marco Lima <cipparello gmail com>
-
-pkgname=librpcsecgss
-pkgver=0.19
-pkgrel=5
-pkgdesc="Library for RPCSECGSS support"
-arch=('i686' 'x86_64')
-url="http://www.citi.umich.edu/projects/nfsv4/linux/"
-license=('GPL')
-depends=('glibc' 'krb5' 'libgssglue')
-makedepends=('pkg-config' 'autoconf')
-options=('!libtool')
-source=("http://www.citi.umich.edu/projects/nfsv4/linux/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('b45ed565bdc3099023aa35830ec92997')
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  ./configure --prefix=/usr
-  make
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  make DESTDIR="$pkgdir/" install
-}

Copied: librpcsecgss/repos/core-i686/PKGBUILD (from rev 142790, librpcsecgss/repos/testing-i686/PKGBUILD)
===================================================================
--- core-i686/PKGBUILD	                        (rev 0)
+++ core-i686/PKGBUILD	2011-11-15 09:00:02 UTC (rev 142791)
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Tobias Powalowski <tpowa at archlinux.org>
+# Contributor: Andrew Krawchyk <krawch_a at denison.edu>, Marco Lima <cipparello gmail com>
+
+pkgname=librpcsecgss
+pkgver=0.19
+pkgrel=7
+pkgdesc="Library for RPCSECGSS support"
+arch=('i686' 'x86_64')
+url="http://www.citi.umich.edu/projects/nfsv4/linux/"
+license=('GPL')
+depends=('glibc' 'krb5' 'libgssglue')
+makedepends=('pkg-config' 'autoconf')
+options=('!libtool')
+source=("http://www.citi.umich.edu/projects/nfsv4/linux/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('b45ed565bdc3099023aa35830ec92997')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr
+  make
+}
+
+check() {
+   cd "${srcdir}/${pkgname}-${pkgver}"
+   make check
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="$pkgdir/" install
+}

Deleted: core-i686/librpcsecgss-0.18-heimdal.patch
===================================================================
--- core-i686/librpcsecgss-0.18-heimdal.patch	2011-11-15 08:59:08 UTC (rev 142790)
+++ core-i686/librpcsecgss-0.18-heimdal.patch	2011-11-15 09:00:02 UTC (rev 142791)
@@ -1,33 +0,0 @@
-diff -NaurwB librpcsecgss-0.18.orig/configure.in librpcsecgss-0.18/configure.in
---- librpcsecgss-0.18.orig/configure.in	2008-04-09 00:05:40.000000000 +0200
-+++ librpcsecgss-0.18/configure.in	2008-06-12 19:05:51.000000000 +0200
-@@ -12,10 +12,15 @@
- AC_PROG_RANLIB
- 
- # Checks for libraries.
--PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1], [],
-+PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1],
-+  [echo GSSGLUE found; GSSAPI_IMPLEMENTATION=libgssglue],
-+  [PKG_CHECK_MODULES([GSSGLUE], [heimdal-gssapi],
-+    [echo HEIMDAL found; GSSAPI_IMPLEMENTATION=heimdal-gssapi],
-   [AC_MSG_ERROR([Unable to locate information required to use libgssglue.
-   If you have pkgconfig installed, you might try setting environment
--  variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])
-+    variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])])
-+
-+AC_SUBST([GSSAPI_IMPLEMENTATION])
- 
- # Checks for header files.
- AC_HEADER_STDC
-diff -NaurwB librpcsecgss-0.18.orig/librpcsecgss.pc.in librpcsecgss-0.18/librpcsecgss.pc.in
---- librpcsecgss-0.18.orig/librpcsecgss.pc.in	2007-09-06 17:39:04.000000000 +0200
-+++ librpcsecgss-0.18/librpcsecgss.pc.in	2008-06-12 19:06:40.000000000 +0200
-@@ -5,7 +5,7 @@
- 
- Name: librpcsecgss
- Description: Library that implements rpcsec_gss interface.
--Requires: libgssglue
-+Requires: @GSSAPI_IMPLEMENTATION@
- Version: @PACKAGE_VERSION@
- Libs: -L at libdir@ -lrpcsecgss
- Cflags: -I at includedir@/rpcsecgss

Copied: librpcsecgss/repos/core-i686/librpcsecgss-0.18-heimdal.patch (from rev 142790, librpcsecgss/repos/testing-i686/librpcsecgss-0.18-heimdal.patch)
===================================================================
--- core-i686/librpcsecgss-0.18-heimdal.patch	                        (rev 0)
+++ core-i686/librpcsecgss-0.18-heimdal.patch	2011-11-15 09:00:02 UTC (rev 142791)
@@ -0,0 +1,33 @@
+diff -NaurwB librpcsecgss-0.18.orig/configure.in librpcsecgss-0.18/configure.in
+--- librpcsecgss-0.18.orig/configure.in	2008-04-09 00:05:40.000000000 +0200
++++ librpcsecgss-0.18/configure.in	2008-06-12 19:05:51.000000000 +0200
+@@ -12,10 +12,15 @@
+ AC_PROG_RANLIB
+ 
+ # Checks for libraries.
+-PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1], [],
++PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1],
++  [echo GSSGLUE found; GSSAPI_IMPLEMENTATION=libgssglue],
++  [PKG_CHECK_MODULES([GSSGLUE], [heimdal-gssapi],
++    [echo HEIMDAL found; GSSAPI_IMPLEMENTATION=heimdal-gssapi],
+   [AC_MSG_ERROR([Unable to locate information required to use libgssglue.
+   If you have pkgconfig installed, you might try setting environment
+-  variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])
++    variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])])
++
++AC_SUBST([GSSAPI_IMPLEMENTATION])
+ 
+ # Checks for header files.
+ AC_HEADER_STDC
+diff -NaurwB librpcsecgss-0.18.orig/librpcsecgss.pc.in librpcsecgss-0.18/librpcsecgss.pc.in
+--- librpcsecgss-0.18.orig/librpcsecgss.pc.in	2007-09-06 17:39:04.000000000 +0200
++++ librpcsecgss-0.18/librpcsecgss.pc.in	2008-06-12 19:06:40.000000000 +0200
+@@ -5,7 +5,7 @@
+ 
+ Name: librpcsecgss
+ Description: Library that implements rpcsec_gss interface.
+-Requires: libgssglue
++Requires: @GSSAPI_IMPLEMENTATION@
+ Version: @PACKAGE_VERSION@
+ Libs: -L at libdir@ -lrpcsecgss
+ Cflags: -I at includedir@/rpcsecgss



More information about the arch-commits mailing list