[arch-commits] Commit in gutenprint/repos (10 files)

andyrtr at archlinux.org andyrtr at archlinux.org
Tue Nov 29 11:30:27 EST 2011


    Date: Tuesday, November 29, 2011 @ 11:30:26
  Author: andyrtr
Revision: 143830

archrelease: copy trunk to extra-i686, extra-x86_64

Added:
  gutenprint/repos/extra-i686/PKGBUILD
    (from rev 143829, gutenprint/trunk/PKGBUILD)
  gutenprint/repos/extra-i686/buildfix.patch
    (from rev 143829, gutenprint/trunk/buildfix.patch)
  gutenprint/repos/extra-i686/gutenprint.install
    (from rev 143829, gutenprint/trunk/gutenprint.install)
  gutenprint/repos/extra-x86_64/PKGBUILD
    (from rev 143829, gutenprint/trunk/PKGBUILD)
  gutenprint/repos/extra-x86_64/buildfix.patch
    (from rev 143829, gutenprint/trunk/buildfix.patch)
  gutenprint/repos/extra-x86_64/gutenprint.install
    (from rev 143829, gutenprint/trunk/gutenprint.install)
Deleted:
  gutenprint/repos/extra-i686/PKGBUILD
  gutenprint/repos/extra-i686/gutenprint.install
  gutenprint/repos/extra-x86_64/PKGBUILD
  gutenprint/repos/extra-x86_64/gutenprint.install

---------------------------------+
 extra-i686/PKGBUILD             |   80 +++++++++++++++++++-------------------
 extra-i686/buildfix.patch       |   22 ++++++++++
 extra-i686/gutenprint.install   |   18 ++++----
 extra-x86_64/PKGBUILD           |   80 +++++++++++++++++++-------------------
 extra-x86_64/buildfix.patch     |   22 ++++++++++
 extra-x86_64/gutenprint.install |   18 ++++----
 6 files changed, 144 insertions(+), 96 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2011-11-29 16:29:42 UTC (rev 143829)
+++ extra-i686/PKGBUILD	2011-11-29 16:30:26 UTC (rev 143830)
@@ -1,39 +0,0 @@
-# $Id$
-# Maintainer: Andreas Radke <andyrtr at archlinux.org>
-
-pkgname=gutenprint
-pkgver=5.2.7
-pkgrel=2
-pkgdesc="Top quality printer drivers for POSIX systems"
-arch=('i686' 'x86_64')
-license=('GPL')
-install=gutenprint.install
-depends=('readline' 'gnutls>=2.12.3') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
-makedepends=('gimp>=2.6.11' 'gtk2>=2.24.4' 'cups>=1.4.6' 'foomatic-db-engine' 'ghostscript>=9.02')
-optdepends=('cups:		to use cups printer spooler(recommended)'
-            'foomatic-db-engine:	to use foomatic spooler'
-            'ghostscript:	adds postscript support for ijsgutenprint'
-            'gimp:		adds gutenprint plugin to gimp')
-source=(http://downloads.sourceforge.net/gimp-print/$pkgname-$pkgver.tar.bz2)
-url="http://gimp-print.sourceforge.net/"
-replaces=('gimp-print')
-options=('!libtool' '!emptydirs')
-md5sums=('b19029972bf28f6efd693270daf8f5de')
-
-build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr --disable-samples --with-cups --with-gimp2 \
-	--disable-translated-cups-ppds --with-gimp2-as-gutenprint \
-	--disable-libgutenprintui  --enable-libgutenprintui2 --disable-gtktest \
-	--enable-cups-ppds --enable-cups-ppds-at-top-level \
-	--with-foomatic --with-foomatic3 --with-ghostscript \
-	--disable-static --disable-static-genppd --with-ijs \
-	--disable-globalized-cups-ppds
-  make
-}
-
-package() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  make DESTDIR=${pkgdir} install
-}
-

Copied: gutenprint/repos/extra-i686/PKGBUILD (from rev 143829, gutenprint/trunk/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Andreas Radke <andyrtr at archlinux.org>
+
+pkgname=gutenprint
+pkgver=5.2.7
+pkgrel=3
+pkgdesc="Top quality printer drivers for POSIX systems"
+arch=('i686' 'x86_64')
+license=('GPL')
+install=gutenprint.install
+depends=('readline' 'gnutls>=2.12.3') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
+makedepends=('gimp>=2.6.11' 'gtk2>=2.24.4' 'cups>=1.4.6' 'foomatic-db-engine' 'ghostscript>=9.02')
+optdepends=('cups:		to use cups printer spooler(recommended)'
+            'foomatic-db-engine:	to use foomatic spooler'
+            'ghostscript:	adds postscript support for ijsgutenprint'
+            'gimp:		adds gutenprint plugin to gimp')
+source=(http://downloads.sourceforge.net/gimp-print/$pkgname-$pkgver.tar.bz2 buildfix.patch)
+url="http://gimp-print.sourceforge.net/"
+replaces=('gimp-print')
+options=('!libtool' '!emptydirs')
+md5sums=('b19029972bf28f6efd693270daf8f5de'
+         '2354cdecf1fbab32eca84266c8c72e7d')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  patch -Np1 -i ${srcdir}/buildfix.patch
+  ./configure --prefix=/usr --disable-samples --with-cups --with-gimp2 \
+	--disable-translated-cups-ppds --with-gimp2-as-gutenprint \
+	--disable-libgutenprintui  --enable-libgutenprintui2 --disable-gtktest \
+	--enable-cups-ppds --enable-cups-ppds-at-top-level \
+	--with-foomatic --with-foomatic3 --with-ghostscript \
+	--disable-static --disable-static-genppd --with-ijs \
+	--disable-globalized-cups-ppds
+  make
+}
+
+package() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  make DESTDIR=${pkgdir} install
+}
+

Copied: gutenprint/repos/extra-i686/buildfix.patch (from rev 143829, gutenprint/trunk/buildfix.patch)
===================================================================
--- extra-i686/buildfix.patch	                        (rev 0)
+++ extra-i686/buildfix.patch	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,22 @@
+diff -up gutenprint-5.2.7/src/cups/commandtocanon.c.build gutenprint-5.2.7/src/cups/commandtocanon.c
+--- gutenprint-5.2.7/src/cups/commandtocanon.c.build	2011-06-07 13:32:37.372042304 +0100
++++ gutenprint-5.2.7/src/cups/commandtocanon.c	2011-06-07 13:32:41.270970750 +0100
+@@ -13,6 +13,7 @@
+ 
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ 
+ 
+diff -up gutenprint-5.2.7/src/cups/commandtoepson.c.build gutenprint-5.2.7/src/cups/commandtoepson.c
+--- gutenprint-5.2.7/src/cups/commandtoepson.c.build	2007-12-24 17:19:20.000000000 +0000
++++ gutenprint-5.2.7/src/cups/commandtoepson.c	2011-06-07 13:32:35.656073794 +0100
+@@ -30,6 +30,7 @@
+ 
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ 

Deleted: extra-i686/gutenprint.install
===================================================================
--- extra-i686/gutenprint.install	2011-11-29 16:29:42 UTC (rev 143829)
+++ extra-i686/gutenprint.install	2011-11-29 16:30:26 UTC (rev 143830)
@@ -1,9 +0,0 @@
-post_install() {
- echo ">>please run /usr/sbin/cups-genppdupdate"
- echo ">>and restart cups deamon"
-}
-
-post_upgrade() {
-   post_install
-}
-

Copied: gutenprint/repos/extra-i686/gutenprint.install (from rev 143829, gutenprint/trunk/gutenprint.install)
===================================================================
--- extra-i686/gutenprint.install	                        (rev 0)
+++ extra-i686/gutenprint.install	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,9 @@
+post_install() {
+ echo ">>please run /usr/sbin/cups-genppdupdate"
+ echo ">>and restart cups deamon"
+}
+
+post_upgrade() {
+   post_install
+}
+

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2011-11-29 16:29:42 UTC (rev 143829)
+++ extra-x86_64/PKGBUILD	2011-11-29 16:30:26 UTC (rev 143830)
@@ -1,39 +0,0 @@
-# $Id$
-# Maintainer: Andreas Radke <andyrtr at archlinux.org>
-
-pkgname=gutenprint
-pkgver=5.2.7
-pkgrel=2
-pkgdesc="Top quality printer drivers for POSIX systems"
-arch=('i686' 'x86_64')
-license=('GPL')
-install=gutenprint.install
-depends=('readline' 'gnutls>=2.12.3') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
-makedepends=('gimp>=2.6.11' 'gtk2>=2.24.4' 'cups>=1.4.6' 'foomatic-db-engine' 'ghostscript>=9.02')
-optdepends=('cups:		to use cups printer spooler(recommended)'
-            'foomatic-db-engine:	to use foomatic spooler'
-            'ghostscript:	adds postscript support for ijsgutenprint'
-            'gimp:		adds gutenprint plugin to gimp')
-source=(http://downloads.sourceforge.net/gimp-print/$pkgname-$pkgver.tar.bz2)
-url="http://gimp-print.sourceforge.net/"
-replaces=('gimp-print')
-options=('!libtool' '!emptydirs')
-md5sums=('b19029972bf28f6efd693270daf8f5de')
-
-build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr --disable-samples --with-cups --with-gimp2 \
-	--disable-translated-cups-ppds --with-gimp2-as-gutenprint \
-	--disable-libgutenprintui  --enable-libgutenprintui2 --disable-gtktest \
-	--enable-cups-ppds --enable-cups-ppds-at-top-level \
-	--with-foomatic --with-foomatic3 --with-ghostscript \
-	--disable-static --disable-static-genppd --with-ijs \
-	--disable-globalized-cups-ppds
-  make
-}
-
-package() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  make DESTDIR=${pkgdir} install
-}
-

Copied: gutenprint/repos/extra-x86_64/PKGBUILD (from rev 143829, gutenprint/trunk/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Andreas Radke <andyrtr at archlinux.org>
+
+pkgname=gutenprint
+pkgver=5.2.7
+pkgrel=3
+pkgdesc="Top quality printer drivers for POSIX systems"
+arch=('i686' 'x86_64')
+license=('GPL')
+install=gutenprint.install
+depends=('readline' 'gnutls>=2.12.3') # needs to be checked. build log says -Lgnutls but namcap doesn't detect it
+makedepends=('gimp>=2.6.11' 'gtk2>=2.24.4' 'cups>=1.4.6' 'foomatic-db-engine' 'ghostscript>=9.02')
+optdepends=('cups:		to use cups printer spooler(recommended)'
+            'foomatic-db-engine:	to use foomatic spooler'
+            'ghostscript:	adds postscript support for ijsgutenprint'
+            'gimp:		adds gutenprint plugin to gimp')
+source=(http://downloads.sourceforge.net/gimp-print/$pkgname-$pkgver.tar.bz2 buildfix.patch)
+url="http://gimp-print.sourceforge.net/"
+replaces=('gimp-print')
+options=('!libtool' '!emptydirs')
+md5sums=('b19029972bf28f6efd693270daf8f5de'
+         '2354cdecf1fbab32eca84266c8c72e7d')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  patch -Np1 -i ${srcdir}/buildfix.patch
+  ./configure --prefix=/usr --disable-samples --with-cups --with-gimp2 \
+	--disable-translated-cups-ppds --with-gimp2-as-gutenprint \
+	--disable-libgutenprintui  --enable-libgutenprintui2 --disable-gtktest \
+	--enable-cups-ppds --enable-cups-ppds-at-top-level \
+	--with-foomatic --with-foomatic3 --with-ghostscript \
+	--disable-static --disable-static-genppd --with-ijs \
+	--disable-globalized-cups-ppds
+  make
+}
+
+package() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  make DESTDIR=${pkgdir} install
+}
+

Copied: gutenprint/repos/extra-x86_64/buildfix.patch (from rev 143829, gutenprint/trunk/buildfix.patch)
===================================================================
--- extra-x86_64/buildfix.patch	                        (rev 0)
+++ extra-x86_64/buildfix.patch	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,22 @@
+diff -up gutenprint-5.2.7/src/cups/commandtocanon.c.build gutenprint-5.2.7/src/cups/commandtocanon.c
+--- gutenprint-5.2.7/src/cups/commandtocanon.c.build	2011-06-07 13:32:37.372042304 +0100
++++ gutenprint-5.2.7/src/cups/commandtocanon.c	2011-06-07 13:32:41.270970750 +0100
+@@ -13,6 +13,7 @@
+ 
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ 
+ 
+diff -up gutenprint-5.2.7/src/cups/commandtoepson.c.build gutenprint-5.2.7/src/cups/commandtoepson.c
+--- gutenprint-5.2.7/src/cups/commandtoepson.c.build	2007-12-24 17:19:20.000000000 +0000
++++ gutenprint-5.2.7/src/cups/commandtoepson.c	2011-06-07 13:32:35.656073794 +0100
+@@ -30,6 +30,7 @@
+ 
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ 

Deleted: extra-x86_64/gutenprint.install
===================================================================
--- extra-x86_64/gutenprint.install	2011-11-29 16:29:42 UTC (rev 143829)
+++ extra-x86_64/gutenprint.install	2011-11-29 16:30:26 UTC (rev 143830)
@@ -1,9 +0,0 @@
-post_install() {
- echo ">>please run /usr/sbin/cups-genppdupdate"
- echo ">>and restart cups deamon"
-}
-
-post_upgrade() {
-   post_install
-}
-

Copied: gutenprint/repos/extra-x86_64/gutenprint.install (from rev 143829, gutenprint/trunk/gutenprint.install)
===================================================================
--- extra-x86_64/gutenprint.install	                        (rev 0)
+++ extra-x86_64/gutenprint.install	2011-11-29 16:30:26 UTC (rev 143830)
@@ -0,0 +1,9 @@
+post_install() {
+ echo ">>please run /usr/sbin/cups-genppdupdate"
+ echo ">>and restart cups deamon"
+}
+
+post_upgrade() {
+   post_install
+}
+



More information about the arch-commits mailing list