[arch-commits] Commit in empathy/repos (5 files)

Ionut Biru ibiru at archlinux.org
Sat Oct 1 14:56:30 EDT 2011


    Date: Saturday, October 1, 2011 @ 14:56:30
  Author: ibiru
Revision: 139245

db-move: moved empathy from [testing] to [extra] (x86_64)

Added:
  empathy/repos/extra-x86_64/PKGBUILD
    (from rev 139207, empathy/repos/testing-x86_64/PKGBUILD)
  empathy/repos/extra-x86_64/empathy.install
    (from rev 139207, empathy/repos/testing-x86_64/empathy.install)
Deleted:
  empathy/repos/extra-x86_64/PKGBUILD
  empathy/repos/extra-x86_64/empathy.install
  empathy/repos/testing-x86_64/

-----------------+
 PKGBUILD        |   79 +++++++++++++++++++++++++++---------------------------
 empathy.install |   34 ++++++++++++-----------
 2 files changed, 58 insertions(+), 55 deletions(-)

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2011-10-01 18:56:29 UTC (rev 139244)
+++ extra-x86_64/PKGBUILD	2011-10-01 18:56:30 UTC (rev 139245)
@@ -1,39 +0,0 @@
-# $Id$
-# Maintainer: Ionut Biru <ibiru at archlinux.org>
-pkgname=empathy
-pkgver=3.0.2
-pkgrel=2
-pkgdesc="A GNOME instant messaging client using the Telepathy framework."
-arch=('i686' 'x86_64')
-url="http://live.gnome.org/Empathy"
-license=('GPL2')
-depends=('telepathy-glib' 'telepathy-mission-control' 'folks' 'telepathy-logger' 'telepathy-farsight' 'gnome-keyring' 'gnutls' 'evolution-data-server'
-         'libcanberra' 'libnotify' 'enchant' 'iso-codes' 'libwebkit3' 'dconf' 'ca-certificates')
-makedepends=('intltool' 'gnome-doc-utils' 'nautilus-sendto' 'gnome-control-center')
-optdepends=('telepathy-gabble: XMPP/Jabber support'
-            'telepathy-butterfly: MSN support'
-            'telepathy-idle: IRC support'
-            'telepathy-salut: Link-local XMPP support'
-            'telepathy-sofiasip: SIP support'
-            'telepathy-haze: libpurple support')
-options=('!libtool')
-groups=('gnome-extra')
-install=empathy.install
-source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/3.0/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('8074f6ce951fb95b1e13c546497e22d487bca9a87d88f1ebb903cdd2fd48bdc2')
-
-build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
-      --sysconfdir=/etc  \
-      --libexecdir=/usr/lib/empathy \
-      --disable-static \
-      --disable-scrollkeeper \
-      --disable-schemas-compile
-  make
-}
-
-package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  make DESTDIR="${pkgdir}" install
-}

Copied: empathy/repos/extra-x86_64/PKGBUILD (from rev 139207, empathy/repos/testing-x86_64/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2011-10-01 18:56:30 UTC (rev 139245)
@@ -0,0 +1,40 @@
+# $Id$
+# Maintainer: Ionut Biru <ibiru at archlinux.org>
+
+pkgname=empathy
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="A GNOME instant messaging client using the Telepathy framework."
+arch=('i686' 'x86_64')
+url="http://live.gnome.org/Empathy"
+license=('GPL2')
+depends=('libpulse' 'clutter-gtk' 'clutter-gst' 'telepathy-mission-control' 'telepathy-logger' 'telepathy-farsight' 'telepathy-farstream' 'folks' 'gnome-keyring' 'libcanberra' 'iso-codes' 'networkmanager')
+makedepends=('intltool' 'gnome-doc-utils' 'nautilus-sendto')
+optdepends=('telepathy-gabble: XMPP/Jabber support'
+            'telepathy-butterfly: MSN support'
+            'telepathy-idle: IRC support'
+            'telepathy-salut: Link-local XMPP support'
+            'telepathy-sofiasip: SIP support'
+            'telepathy-haze: libpurple support')
+options=('!libtool')
+groups=('gnome-extra')
+install=empathy.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/3.2/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('0c55d8603ab2f1a4e998dc06bf8a6e48bdb6b02e373ac0d009b3f218fdec9633')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+      --sysconfdir=/etc  \
+      --libexecdir=/usr/lib/empathy \
+      --disable-static \
+      --disable-scrollkeeper \
+      --disable-schemas-compile
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+}

Deleted: extra-x86_64/empathy.install
===================================================================
--- extra-x86_64/empathy.install	2011-10-01 18:56:29 UTC (rev 139244)
+++ extra-x86_64/empathy.install	2011-10-01 18:56:30 UTC (rev 139245)
@@ -1,16 +0,0 @@
-post_install() {
-    usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
-    update-desktop-database -q
-    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-    echo "To use Empathy you need to install at least one Telepathy connection manager."
-}
-
-post_upgrade() {
-    post_install $1
-}
-
-post_remove() {
-    usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
-    update-desktop-database -q
-    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}

Copied: empathy/repos/extra-x86_64/empathy.install (from rev 139207, empathy/repos/testing-x86_64/empathy.install)
===================================================================
--- extra-x86_64/empathy.install	                        (rev 0)
+++ extra-x86_64/empathy.install	2011-10-01 18:56:30 UTC (rev 139245)
@@ -0,0 +1,18 @@
+post_install() {
+    usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+    update-desktop-database -q
+    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+    echo "To use Empathy you need to install at least one Telepathy connection manager."
+}
+
+post_upgrade() {
+    usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+    update-desktop-database -q
+    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+    usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas
+    update-desktop-database -q
+    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}



More information about the arch-commits mailing list