[arch-commits] Commit in pulseaudio/repos (18 files)

Jan Steffens heftig at archlinux.org
Sun Oct 16 04:44:24 EDT 2011


    Date: Sunday, October 16, 2011 @ 04:44:24
  Author: heftig
Revision: 140517

archrelease: copy trunk to extra-i686, extra-x86_64

Added:
  pulseaudio/repos/extra-i686/PKGBUILD
    (from rev 140516, pulseaudio/trunk/PKGBUILD)
  pulseaudio/repos/extra-i686/dont-require-dbus.patch
    (from rev 140516, pulseaudio/trunk/dont-require-dbus.patch)
  pulseaudio/repos/extra-i686/pulseaudio.install
    (from rev 140516, pulseaudio/trunk/pulseaudio.install)
  pulseaudio/repos/extra-i686/pulseaudio.xinit
    (from rev 140516, pulseaudio/trunk/pulseaudio.xinit)
  pulseaudio/repos/extra-i686/version-number.patch
    (from rev 140516, pulseaudio/trunk/version-number.patch)
  pulseaudio/repos/extra-x86_64/PKGBUILD
    (from rev 140516, pulseaudio/trunk/PKGBUILD)
  pulseaudio/repos/extra-x86_64/dont-require-dbus.patch
    (from rev 140516, pulseaudio/trunk/dont-require-dbus.patch)
  pulseaudio/repos/extra-x86_64/pulseaudio.install
    (from rev 140516, pulseaudio/trunk/pulseaudio.install)
  pulseaudio/repos/extra-x86_64/pulseaudio.xinit
    (from rev 140516, pulseaudio/trunk/pulseaudio.xinit)
  pulseaudio/repos/extra-x86_64/version-number.patch
    (from rev 140516, pulseaudio/trunk/version-number.patch)
Deleted:
  pulseaudio/repos/extra-i686/PKGBUILD
  pulseaudio/repos/extra-i686/pulseaudio.install
  pulseaudio/repos/extra-i686/pulseaudio.xinit
  pulseaudio/repos/extra-i686/version-number.patch
  pulseaudio/repos/extra-x86_64/PKGBUILD
  pulseaudio/repos/extra-x86_64/pulseaudio.install
  pulseaudio/repos/extra-x86_64/pulseaudio.xinit
  pulseaudio/repos/extra-x86_64/version-number.patch

--------------------------------------+
 extra-i686/PKGBUILD                  |  206 ++++++++++++++++-----------------
 extra-i686/dont-require-dbus.patch   |   46 +++++++
 extra-i686/pulseaudio.install        |   46 +++----
 extra-i686/pulseaudio.xinit          |   24 +--
 extra-i686/version-number.patch      |   80 ++++++------
 extra-x86_64/PKGBUILD                |  206 ++++++++++++++++-----------------
 extra-x86_64/dont-require-dbus.patch |   46 +++++++
 extra-x86_64/pulseaudio.install      |   46 +++----
 extra-x86_64/pulseaudio.xinit        |   24 +--
 extra-x86_64/version-number.patch    |   80 ++++++------
 10 files changed, 450 insertions(+), 354 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-i686/PKGBUILD	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,102 +0,0 @@
-# $Id$
-# Maintainer: Jan "heftig" Steffens <jan.steffens at gmail.com>
-# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
-# Contributor: Corrado Primier <bardo at aur.archlinux.org>
-# Contributor: William Rea <sillywilly at gmail.com>
-
-pkgbase=pulseaudio
-pkgname=(pulseaudio libpulse)
-pkgdesc="A featureful, general-purpose sound server"
-pkgver=1.0
-pkgrel=3
-arch=(i686 x86_64)
-url="http://pulseaudio.org/"
-license=(GPL LGPL)
-makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
-             speex tdb udev dbus-core xcb-util avahi bluez gconf intltool jack
-             lirc-utils openssl fftw orc json-c)
-options=(!emptydirs !libtool !makeflags)
-source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz
-        $pkgbase.xinit version-number.patch)
-sha256sums=('e63464f8a0975446e2b4cfe768b615a66735c8d092b2366d2bdc7a2a04a249be'
-            'a0db6cdc74fbf0ca10e2343c08e1e228f109221c6c0ff91b0bfade5c4bdf03cf'
-            '6b067ae9e8da703510fb24eae8ee53f3a7b6a90bcf88941ee50997ad679a4530')
-
-build() {
-  cd "$srcdir/$pkgbase-$pkgver"
-
-  patch -Np1 -i "$srcdir/version-number.patch"
-
-  ./configure --prefix=/usr \
-    --sysconfdir=/etc \
-    --libexecdir=/usr/lib \
-    --localstatedir=/var \
-    --with-database=tdb \
-    --disable-hal \
-    --disable-tcpwrap \
-    --disable-rpath \
-    --disable-default-build-tests
-
-  make
-}
-
-package_pulseaudio() {
-  depends=("libpulse=$pkgver-$pkgrel" rtkit libtool speex tdb udev fftw orc)
-  optdepends=('avahi: zeroconf support'
-              'bluez: bluetooth support'
-              'gconf: configuration through gconf (paprefs)'
-              'jack: jack support'
-              'lirc-utils: infra-red support'
-              'openssl: RAOP support'
-              'python2-pyqt: Equalizer GUI (qpaeq)')
-  backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
-  install=pulseaudio.install
-  cd "$srcdir/$pkgbase-$pkgver"
-  make DESTDIR="$pkgdir" install
-
-  # Lower resample quality, saves CPU
-  sed -e '/resample-method/iresample-method=speex-float-0' \
-      -i "$pkgdir/etc/pulse/daemon.conf"
-
-  # Disable cork-request module, can result in e.g. media players unpausing
-  # when there's a Skype call incoming
-  sed -e 's|/usr/bin/pactl load-module module-x11-cork-request|#&|' \
-      -i "$pkgdir/usr/bin/start-pulseaudio-x11"
-
-  # Make some modules optional
-  sed -e $'/load-module module-console-kit/{i.nofail\n;a.fail\n;}' \
-      -e '/load-module module-jackdbus-detect/s/^/#/' \
-      -i "$pkgdir/etc/pulse/default.pa"
-
-  # Python fix
-  sed -i '1s:python$:&2:' "$pkgdir/usr/bin/qpaeq"
-
-  install -Dm755 "$srcdir/pulseaudio.xinit" "$pkgdir/etc/X11/xinit/xinitrc.d/pulseaudio"
-
-  rm "$pkgdir/etc/dbus-1/system.d/pulseaudio-system.conf"
-
-### Split libpulse
-
-  mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{lib,share/man/man5}}
-
-  mv {"$pkgdir","$srcdir/libpulse"}/etc/pulse/client.conf
-
-  mv "$pkgdir"/usr/lib/libpulse{,dsp,-simple,-mainloop-glib}.so* \
-     "$pkgdir"/usr/lib/libpulsecommon-*.so \
-     "$srcdir/libpulse/usr/lib"
-
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/lib/pkgconfig
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/include
-
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/man/man5/pulse-client.conf.5
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/vala
-}
-
-package_libpulse() {
-  pkgdesc="$pkgdesc (client library)"
-  depends=(dbus-core xcb-util libasyncns libcap libxtst libsm libsamplerate json-c)
-  optdepends=('alsa-plugins: ALSA support'
-              'avahi: zeroconf support')
-  backup=(etc/pulse/client.conf)
-  mv "$srcdir"/libpulse/* "$pkgdir"
-}

Copied: pulseaudio/repos/extra-i686/PKGBUILD (from rev 140516, pulseaudio/trunk/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,104 @@
+# $Id$
+# Maintainer: Jan "heftig" Steffens <jan.steffens at gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
+# Contributor: Corrado Primier <bardo at aur.archlinux.org>
+# Contributor: William Rea <sillywilly at gmail.com>
+
+pkgbase=pulseaudio
+pkgname=(pulseaudio libpulse)
+pkgdesc="A featureful, general-purpose sound server"
+pkgver=1.0
+pkgrel=4
+arch=(i686 x86_64)
+url="http://pulseaudio.org/"
+license=(GPL LGPL)
+makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
+             speex tdb udev dbus-core xcb-util avahi bluez gconf intltool jack
+             lirc-utils openssl fftw orc json-c)
+options=(!emptydirs !libtool !makeflags)
+source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz
+        $pkgbase.xinit version-number.patch dont-require-dbus.patch)
+sha256sums=('e63464f8a0975446e2b4cfe768b615a66735c8d092b2366d2bdc7a2a04a249be'
+            'a0db6cdc74fbf0ca10e2343c08e1e228f109221c6c0ff91b0bfade5c4bdf03cf'
+            '6b067ae9e8da703510fb24eae8ee53f3a7b6a90bcf88941ee50997ad679a4530'
+            '68c8ddf7ddb4035405ec61e7aa72e88f1430a30f75a36f31761fbfffa8f7dad4')
+
+build() {
+  cd "$srcdir/$pkgbase-$pkgver"
+
+  patch -Np1 -i "$srcdir/version-number.patch"
+  patch -Np1 -i "$srcdir/dont-require-dbus.patch"
+
+  ./configure --prefix=/usr \
+    --sysconfdir=/etc \
+    --libexecdir=/usr/lib \
+    --localstatedir=/var \
+    --with-database=tdb \
+    --disable-hal \
+    --disable-tcpwrap \
+    --disable-rpath \
+    --disable-default-build-tests
+
+  make
+}
+
+package_pulseaudio() {
+  depends=("libpulse=$pkgver-$pkgrel" rtkit libtool speex tdb udev fftw orc)
+  optdepends=('avahi: zeroconf support'
+              'bluez: bluetooth support'
+              'gconf: configuration through gconf (paprefs)'
+              'jack: jack support'
+              'lirc-utils: infra-red support'
+              'openssl: RAOP support'
+              'python2-pyqt: Equalizer GUI (qpaeq)')
+  backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
+  install=pulseaudio.install
+  cd "$srcdir/$pkgbase-$pkgver"
+  make DESTDIR="$pkgdir" install
+
+  # Lower resample quality, saves CPU
+  sed -e '/resample-method/iresample-method=speex-float-0' \
+      -i "$pkgdir/etc/pulse/daemon.conf"
+
+  # Disable cork-request module, can result in e.g. media players unpausing
+  # when there's a Skype call incoming
+  sed -e 's|/usr/bin/pactl load-module module-x11-cork-request|#&|' \
+      -i "$pkgdir/usr/bin/start-pulseaudio-x11"
+
+  # Make some modules optional
+  sed -e $'/load-module module-console-kit/{i.nofail\n;a.fail\n;}' \
+      -e '/load-module module-jackdbus-detect/s/^/#/' \
+      -i "$pkgdir/etc/pulse/default.pa"
+
+  # Python fix
+  sed -i '1s:python$:&2:' "$pkgdir/usr/bin/qpaeq"
+
+  install -Dm755 "$srcdir/pulseaudio.xinit" "$pkgdir/etc/X11/xinit/xinitrc.d/pulseaudio"
+
+  rm "$pkgdir/etc/dbus-1/system.d/pulseaudio-system.conf"
+
+### Split libpulse
+
+  mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{lib,share/man/man5}}
+
+  mv {"$pkgdir","$srcdir/libpulse"}/etc/pulse/client.conf
+
+  mv "$pkgdir"/usr/lib/libpulse{,dsp,-simple,-mainloop-glib}.so* \
+     "$pkgdir"/usr/lib/libpulsecommon-*.so \
+     "$srcdir/libpulse/usr/lib"
+
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/lib/pkgconfig
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/include
+
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/man/man5/pulse-client.conf.5
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/vala
+}
+
+package_libpulse() {
+  pkgdesc="$pkgdesc (client library)"
+  depends=(dbus-core xcb-util libasyncns libcap libxtst libsm libsamplerate json-c)
+  optdepends=('alsa-plugins: ALSA support'
+              'avahi: zeroconf support')
+  backup=(etc/pulse/client.conf)
+  mv "$srcdir"/libpulse/* "$pkgdir"
+}

Copied: pulseaudio/repos/extra-i686/dont-require-dbus.patch (from rev 140516, pulseaudio/trunk/dont-require-dbus.patch)
===================================================================
--- extra-i686/dont-require-dbus.patch	                        (rev 0)
+++ extra-i686/dont-require-dbus.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,46 @@
+commit 6d58497dd1d68231af201cf2a07bb9881c4efd2f
+Author: Tanu Kaskinen <tanuk at iki.fi>
+Date:   Thu Oct 6 23:28:37 2011 +0300
+
+    daemon: Don't treat it as a fatal error if we can't connect to the session bus
+    
+    http://lists.freedesktop.org/archives/pulseaudio-discuss/2011-June/010276.html
+
+diff --git a/src/daemon/main.c b/src/daemon/main.c
+index e2e4a81..c32f7c7 100644
+--- a/src/daemon/main.c
++++ b/src/daemon/main.c
+@@ -1107,14 +1107,14 @@ int main(int argc, char *argv[]) {
+ 
+ #ifdef HAVE_DBUS
+     if (!conf->system_instance) {
+-        if (!(server_lookup = pa_dbusobj_server_lookup_new(c)))
+-            goto finish;
+-        if (!(lookup_service_bus = register_dbus_name(c, DBUS_BUS_SESSION, "org.PulseAudio1")))
+-            goto finish;
++        if ((server_lookup = pa_dbusobj_server_lookup_new(c))) {
++            if (!(lookup_service_bus = register_dbus_name(c, DBUS_BUS_SESSION, "org.PulseAudio1")))
++                goto finish;
++        }
+     }
+ 
+-    if (start_server && !(server_bus = register_dbus_name(c, conf->system_instance ? DBUS_BUS_SYSTEM : DBUS_BUS_SESSION, "org.pulseaudio.Server")))
+-        goto finish;
++    if (start_server)
++        server_bus = register_dbus_name(c, conf->system_instance ? DBUS_BUS_SYSTEM : DBUS_BUS_SESSION, "org.pulseaudio.Server");
+ #endif
+ 
+ #ifdef HAVE_FORK
+diff --git a/src/daemon/server-lookup.c b/src/daemon/server-lookup.c
+index 45796e7..9bdc699 100644
+--- a/src/daemon/server-lookup.c
++++ b/src/daemon/server-lookup.c
+@@ -485,7 +485,7 @@ pa_dbusobj_server_lookup *pa_dbusobj_server_lookup_new(pa_core *c) {
+     sl->path_registered = FALSE;
+ 
+     if (!(sl->conn = pa_dbus_bus_get(c, DBUS_BUS_SESSION, &error)) || dbus_error_is_set(&error)) {
+-        pa_log("Unable to contact D-Bus: %s: %s", error.name, error.message);
++        pa_log_warn("Unable to contact D-Bus: %s: %s", error.name, error.message);
+         goto fail;
+     }
+ 

Deleted: extra-i686/pulseaudio.install
===================================================================
--- extra-i686/pulseaudio.install	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-i686/pulseaudio.install	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,23 +0,0 @@
-post_install() {
-  cat << MES
->>> See the wiki at http://wiki.archlinux.org/index.php/PulseAudio for details
-    on configuring your system for PulseAudio.
-
->>> Make sure to install pulseaudio-alsa to configure ALSA for PulseAudio.
-MES
-}
-
-post_upgrade() {
-  # Delete old users and groups
-  # System-wide daemon not supported anymore
-  if (( $(vercmp $2 0.9.22) < 0 )); then
-    getent passwd pulse &>/dev/null && usr/sbin/userdel -f pulse
-    getent group pulse-access &>/dev/null && usr/sbin/groupdel pulse-access
-    getent group pulse-rt &>/dev/null && usr/sbin/groupdel pulse-rt
-    getent group pulse &>/dev/null && usr/sbin/groupdel pulse
-  fi
-
-  true
-}
-
-# vim:set ts=2 sw=2 et:

Copied: pulseaudio/repos/extra-i686/pulseaudio.install (from rev 140516, pulseaudio/trunk/pulseaudio.install)
===================================================================
--- extra-i686/pulseaudio.install	                        (rev 0)
+++ extra-i686/pulseaudio.install	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,23 @@
+post_install() {
+  cat << MES
+>>> See the wiki at http://wiki.archlinux.org/index.php/PulseAudio for details
+    on configuring your system for PulseAudio.
+
+>>> Make sure to install pulseaudio-alsa to configure ALSA for PulseAudio.
+MES
+}
+
+post_upgrade() {
+  # Delete old users and groups
+  # System-wide daemon not supported anymore
+  if (( $(vercmp $2 0.9.22) < 0 )); then
+    getent passwd pulse &>/dev/null && usr/sbin/userdel -f pulse
+    getent group pulse-access &>/dev/null && usr/sbin/groupdel pulse-access
+    getent group pulse-rt &>/dev/null && usr/sbin/groupdel pulse-rt
+    getent group pulse &>/dev/null && usr/sbin/groupdel pulse
+  fi
+
+  true
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: extra-i686/pulseaudio.xinit
===================================================================
--- extra-i686/pulseaudio.xinit	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-i686/pulseaudio.xinit	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,12 +0,0 @@
-#!/bin/bash
-
-case "$DESKTOP_SESSION" in
-  gnome|kde*|xfce*) # PulseAudio is started via XDG Autostart
-  ;;
-  *)
-    # Extra checks in case DESKTOP_SESSION is not set correctly
-    if [[ -z $KDE_FULL_SESSION && -z $GNOME_DESKTOP_SESSION_ID ]]; then
-      /usr/bin/start-pulseaudio-x11
-    fi
-  ;;
-esac

Copied: pulseaudio/repos/extra-i686/pulseaudio.xinit (from rev 140516, pulseaudio/trunk/pulseaudio.xinit)
===================================================================
--- extra-i686/pulseaudio.xinit	                        (rev 0)
+++ extra-i686/pulseaudio.xinit	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+case "$DESKTOP_SESSION" in
+  gnome|kde*|xfce*) # PulseAudio is started via XDG Autostart
+  ;;
+  *)
+    # Extra checks in case DESKTOP_SESSION is not set correctly
+    if [[ -z $KDE_FULL_SESSION && -z $GNOME_DESKTOP_SESSION_ID ]]; then
+      /usr/bin/start-pulseaudio-x11
+    fi
+  ;;
+esac

Deleted: extra-i686/version-number.patch
===================================================================
--- extra-i686/version-number.patch	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-i686/version-number.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,40 +0,0 @@
-commit 7563e0bbb54fbac54e77f3a62d9761a70f3a559c
-Author: Colin Guthrie <colin at mageia.org>
-Date:   Sat Oct 1 12:03:44 2011 +0100
-
-    libpulse: Always return a three part version number in API calls.
-    
-    For both the headers and the library we should provide clean, three part
-    strings as this has been what we've previously done in the past
-    and some external systems apparently rely on this format. While it's not
-    something we've officially commented on before, there is no real advantage
-    to us to change it so let's not try to tidy things up too much
-    considering some third party apps (e.g. Skype) seem to dislike a two
-    part version string.
-
-diff --git a/src/pulse/context.c b/src/pulse/context.c
-index 25d04a1..af144aa 100644
---- a/src/pulse/context.c
-+++ b/src/pulse/context.c
-@@ -1281,7 +1281,7 @@ pa_operation* pa_context_set_name(pa_context *c, const char *name, pa_context_su
- }
- 
- const char* pa_get_library_version(void) {
--    return PACKAGE_VERSION;
-+    return pa_get_headers_version();
- }
- 
- const char* pa_context_get_server(pa_context *c) {
-diff --git a/src/pulse/version.h.in b/src/pulse/version.h.in
-index 7e00c5e..1be4c75 100644
---- a/src/pulse/version.h.in
-+++ b/src/pulse/version.h.in
-@@ -35,7 +35,7 @@ PA_C_DECL_BEGIN
- /** Return the version of the header files. Keep in mind that this is
- a macro and not a function, so it is impossible to get the pointer of
- it. */
--#define pa_get_headers_version() ("@PACKAGE_VERSION@")
-+#define pa_get_headers_version() ("@PA_MAJOR at .@PA_MINOR at .0")
- 
- /** Return the version of the library the current application is
-  * linked to. */

Copied: pulseaudio/repos/extra-i686/version-number.patch (from rev 140516, pulseaudio/trunk/version-number.patch)
===================================================================
--- extra-i686/version-number.patch	                        (rev 0)
+++ extra-i686/version-number.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,40 @@
+commit 7563e0bbb54fbac54e77f3a62d9761a70f3a559c
+Author: Colin Guthrie <colin at mageia.org>
+Date:   Sat Oct 1 12:03:44 2011 +0100
+
+    libpulse: Always return a three part version number in API calls.
+    
+    For both the headers and the library we should provide clean, three part
+    strings as this has been what we've previously done in the past
+    and some external systems apparently rely on this format. While it's not
+    something we've officially commented on before, there is no real advantage
+    to us to change it so let's not try to tidy things up too much
+    considering some third party apps (e.g. Skype) seem to dislike a two
+    part version string.
+
+diff --git a/src/pulse/context.c b/src/pulse/context.c
+index 25d04a1..af144aa 100644
+--- a/src/pulse/context.c
++++ b/src/pulse/context.c
+@@ -1281,7 +1281,7 @@ pa_operation* pa_context_set_name(pa_context *c, const char *name, pa_context_su
+ }
+ 
+ const char* pa_get_library_version(void) {
+-    return PACKAGE_VERSION;
++    return pa_get_headers_version();
+ }
+ 
+ const char* pa_context_get_server(pa_context *c) {
+diff --git a/src/pulse/version.h.in b/src/pulse/version.h.in
+index 7e00c5e..1be4c75 100644
+--- a/src/pulse/version.h.in
++++ b/src/pulse/version.h.in
+@@ -35,7 +35,7 @@ PA_C_DECL_BEGIN
+ /** Return the version of the header files. Keep in mind that this is
+ a macro and not a function, so it is impossible to get the pointer of
+ it. */
+-#define pa_get_headers_version() ("@PACKAGE_VERSION@")
++#define pa_get_headers_version() ("@PA_MAJOR at .@PA_MINOR at .0")
+ 
+ /** Return the version of the library the current application is
+  * linked to. */

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-x86_64/PKGBUILD	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,102 +0,0 @@
-# $Id$
-# Maintainer: Jan "heftig" Steffens <jan.steffens at gmail.com>
-# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
-# Contributor: Corrado Primier <bardo at aur.archlinux.org>
-# Contributor: William Rea <sillywilly at gmail.com>
-
-pkgbase=pulseaudio
-pkgname=(pulseaudio libpulse)
-pkgdesc="A featureful, general-purpose sound server"
-pkgver=1.0
-pkgrel=3
-arch=(i686 x86_64)
-url="http://pulseaudio.org/"
-license=(GPL LGPL)
-makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
-             speex tdb udev dbus-core xcb-util avahi bluez gconf intltool jack
-             lirc-utils openssl fftw orc json-c)
-options=(!emptydirs !libtool !makeflags)
-source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz
-        $pkgbase.xinit version-number.patch)
-sha256sums=('e63464f8a0975446e2b4cfe768b615a66735c8d092b2366d2bdc7a2a04a249be'
-            'a0db6cdc74fbf0ca10e2343c08e1e228f109221c6c0ff91b0bfade5c4bdf03cf'
-            '6b067ae9e8da703510fb24eae8ee53f3a7b6a90bcf88941ee50997ad679a4530')
-
-build() {
-  cd "$srcdir/$pkgbase-$pkgver"
-
-  patch -Np1 -i "$srcdir/version-number.patch"
-
-  ./configure --prefix=/usr \
-    --sysconfdir=/etc \
-    --libexecdir=/usr/lib \
-    --localstatedir=/var \
-    --with-database=tdb \
-    --disable-hal \
-    --disable-tcpwrap \
-    --disable-rpath \
-    --disable-default-build-tests
-
-  make
-}
-
-package_pulseaudio() {
-  depends=("libpulse=$pkgver-$pkgrel" rtkit libtool speex tdb udev fftw orc)
-  optdepends=('avahi: zeroconf support'
-              'bluez: bluetooth support'
-              'gconf: configuration through gconf (paprefs)'
-              'jack: jack support'
-              'lirc-utils: infra-red support'
-              'openssl: RAOP support'
-              'python2-pyqt: Equalizer GUI (qpaeq)')
-  backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
-  install=pulseaudio.install
-  cd "$srcdir/$pkgbase-$pkgver"
-  make DESTDIR="$pkgdir" install
-
-  # Lower resample quality, saves CPU
-  sed -e '/resample-method/iresample-method=speex-float-0' \
-      -i "$pkgdir/etc/pulse/daemon.conf"
-
-  # Disable cork-request module, can result in e.g. media players unpausing
-  # when there's a Skype call incoming
-  sed -e 's|/usr/bin/pactl load-module module-x11-cork-request|#&|' \
-      -i "$pkgdir/usr/bin/start-pulseaudio-x11"
-
-  # Make some modules optional
-  sed -e $'/load-module module-console-kit/{i.nofail\n;a.fail\n;}' \
-      -e '/load-module module-jackdbus-detect/s/^/#/' \
-      -i "$pkgdir/etc/pulse/default.pa"
-
-  # Python fix
-  sed -i '1s:python$:&2:' "$pkgdir/usr/bin/qpaeq"
-
-  install -Dm755 "$srcdir/pulseaudio.xinit" "$pkgdir/etc/X11/xinit/xinitrc.d/pulseaudio"
-
-  rm "$pkgdir/etc/dbus-1/system.d/pulseaudio-system.conf"
-
-### Split libpulse
-
-  mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{lib,share/man/man5}}
-
-  mv {"$pkgdir","$srcdir/libpulse"}/etc/pulse/client.conf
-
-  mv "$pkgdir"/usr/lib/libpulse{,dsp,-simple,-mainloop-glib}.so* \
-     "$pkgdir"/usr/lib/libpulsecommon-*.so \
-     "$srcdir/libpulse/usr/lib"
-
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/lib/pkgconfig
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/include
-
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/man/man5/pulse-client.conf.5
-  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/vala
-}
-
-package_libpulse() {
-  pkgdesc="$pkgdesc (client library)"
-  depends=(dbus-core xcb-util libasyncns libcap libxtst libsm libsamplerate json-c)
-  optdepends=('alsa-plugins: ALSA support'
-              'avahi: zeroconf support')
-  backup=(etc/pulse/client.conf)
-  mv "$srcdir"/libpulse/* "$pkgdir"
-}

Copied: pulseaudio/repos/extra-x86_64/PKGBUILD (from rev 140516, pulseaudio/trunk/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,104 @@
+# $Id$
+# Maintainer: Jan "heftig" Steffens <jan.steffens at gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
+# Contributor: Corrado Primier <bardo at aur.archlinux.org>
+# Contributor: William Rea <sillywilly at gmail.com>
+
+pkgbase=pulseaudio
+pkgname=(pulseaudio libpulse)
+pkgdesc="A featureful, general-purpose sound server"
+pkgver=1.0
+pkgrel=4
+arch=(i686 x86_64)
+url="http://pulseaudio.org/"
+license=(GPL LGPL)
+makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
+             speex tdb udev dbus-core xcb-util avahi bluez gconf intltool jack
+             lirc-utils openssl fftw orc json-c)
+options=(!emptydirs !libtool !makeflags)
+source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz
+        $pkgbase.xinit version-number.patch dont-require-dbus.patch)
+sha256sums=('e63464f8a0975446e2b4cfe768b615a66735c8d092b2366d2bdc7a2a04a249be'
+            'a0db6cdc74fbf0ca10e2343c08e1e228f109221c6c0ff91b0bfade5c4bdf03cf'
+            '6b067ae9e8da703510fb24eae8ee53f3a7b6a90bcf88941ee50997ad679a4530'
+            '68c8ddf7ddb4035405ec61e7aa72e88f1430a30f75a36f31761fbfffa8f7dad4')
+
+build() {
+  cd "$srcdir/$pkgbase-$pkgver"
+
+  patch -Np1 -i "$srcdir/version-number.patch"
+  patch -Np1 -i "$srcdir/dont-require-dbus.patch"
+
+  ./configure --prefix=/usr \
+    --sysconfdir=/etc \
+    --libexecdir=/usr/lib \
+    --localstatedir=/var \
+    --with-database=tdb \
+    --disable-hal \
+    --disable-tcpwrap \
+    --disable-rpath \
+    --disable-default-build-tests
+
+  make
+}
+
+package_pulseaudio() {
+  depends=("libpulse=$pkgver-$pkgrel" rtkit libtool speex tdb udev fftw orc)
+  optdepends=('avahi: zeroconf support'
+              'bluez: bluetooth support'
+              'gconf: configuration through gconf (paprefs)'
+              'jack: jack support'
+              'lirc-utils: infra-red support'
+              'openssl: RAOP support'
+              'python2-pyqt: Equalizer GUI (qpaeq)')
+  backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
+  install=pulseaudio.install
+  cd "$srcdir/$pkgbase-$pkgver"
+  make DESTDIR="$pkgdir" install
+
+  # Lower resample quality, saves CPU
+  sed -e '/resample-method/iresample-method=speex-float-0' \
+      -i "$pkgdir/etc/pulse/daemon.conf"
+
+  # Disable cork-request module, can result in e.g. media players unpausing
+  # when there's a Skype call incoming
+  sed -e 's|/usr/bin/pactl load-module module-x11-cork-request|#&|' \
+      -i "$pkgdir/usr/bin/start-pulseaudio-x11"
+
+  # Make some modules optional
+  sed -e $'/load-module module-console-kit/{i.nofail\n;a.fail\n;}' \
+      -e '/load-module module-jackdbus-detect/s/^/#/' \
+      -i "$pkgdir/etc/pulse/default.pa"
+
+  # Python fix
+  sed -i '1s:python$:&2:' "$pkgdir/usr/bin/qpaeq"
+
+  install -Dm755 "$srcdir/pulseaudio.xinit" "$pkgdir/etc/X11/xinit/xinitrc.d/pulseaudio"
+
+  rm "$pkgdir/etc/dbus-1/system.d/pulseaudio-system.conf"
+
+### Split libpulse
+
+  mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{lib,share/man/man5}}
+
+  mv {"$pkgdir","$srcdir/libpulse"}/etc/pulse/client.conf
+
+  mv "$pkgdir"/usr/lib/libpulse{,dsp,-simple,-mainloop-glib}.so* \
+     "$pkgdir"/usr/lib/libpulsecommon-*.so \
+     "$srcdir/libpulse/usr/lib"
+
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/lib/pkgconfig
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/include
+
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/man/man5/pulse-client.conf.5
+  mv {"$pkgdir","$srcdir/libpulse"}/usr/share/vala
+}
+
+package_libpulse() {
+  pkgdesc="$pkgdesc (client library)"
+  depends=(dbus-core xcb-util libasyncns libcap libxtst libsm libsamplerate json-c)
+  optdepends=('alsa-plugins: ALSA support'
+              'avahi: zeroconf support')
+  backup=(etc/pulse/client.conf)
+  mv "$srcdir"/libpulse/* "$pkgdir"
+}

Copied: pulseaudio/repos/extra-x86_64/dont-require-dbus.patch (from rev 140516, pulseaudio/trunk/dont-require-dbus.patch)
===================================================================
--- extra-x86_64/dont-require-dbus.patch	                        (rev 0)
+++ extra-x86_64/dont-require-dbus.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,46 @@
+commit 6d58497dd1d68231af201cf2a07bb9881c4efd2f
+Author: Tanu Kaskinen <tanuk at iki.fi>
+Date:   Thu Oct 6 23:28:37 2011 +0300
+
+    daemon: Don't treat it as a fatal error if we can't connect to the session bus
+    
+    http://lists.freedesktop.org/archives/pulseaudio-discuss/2011-June/010276.html
+
+diff --git a/src/daemon/main.c b/src/daemon/main.c
+index e2e4a81..c32f7c7 100644
+--- a/src/daemon/main.c
++++ b/src/daemon/main.c
+@@ -1107,14 +1107,14 @@ int main(int argc, char *argv[]) {
+ 
+ #ifdef HAVE_DBUS
+     if (!conf->system_instance) {
+-        if (!(server_lookup = pa_dbusobj_server_lookup_new(c)))
+-            goto finish;
+-        if (!(lookup_service_bus = register_dbus_name(c, DBUS_BUS_SESSION, "org.PulseAudio1")))
+-            goto finish;
++        if ((server_lookup = pa_dbusobj_server_lookup_new(c))) {
++            if (!(lookup_service_bus = register_dbus_name(c, DBUS_BUS_SESSION, "org.PulseAudio1")))
++                goto finish;
++        }
+     }
+ 
+-    if (start_server && !(server_bus = register_dbus_name(c, conf->system_instance ? DBUS_BUS_SYSTEM : DBUS_BUS_SESSION, "org.pulseaudio.Server")))
+-        goto finish;
++    if (start_server)
++        server_bus = register_dbus_name(c, conf->system_instance ? DBUS_BUS_SYSTEM : DBUS_BUS_SESSION, "org.pulseaudio.Server");
+ #endif
+ 
+ #ifdef HAVE_FORK
+diff --git a/src/daemon/server-lookup.c b/src/daemon/server-lookup.c
+index 45796e7..9bdc699 100644
+--- a/src/daemon/server-lookup.c
++++ b/src/daemon/server-lookup.c
+@@ -485,7 +485,7 @@ pa_dbusobj_server_lookup *pa_dbusobj_server_lookup_new(pa_core *c) {
+     sl->path_registered = FALSE;
+ 
+     if (!(sl->conn = pa_dbus_bus_get(c, DBUS_BUS_SESSION, &error)) || dbus_error_is_set(&error)) {
+-        pa_log("Unable to contact D-Bus: %s: %s", error.name, error.message);
++        pa_log_warn("Unable to contact D-Bus: %s: %s", error.name, error.message);
+         goto fail;
+     }
+ 

Deleted: extra-x86_64/pulseaudio.install
===================================================================
--- extra-x86_64/pulseaudio.install	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-x86_64/pulseaudio.install	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,23 +0,0 @@
-post_install() {
-  cat << MES
->>> See the wiki at http://wiki.archlinux.org/index.php/PulseAudio for details
-    on configuring your system for PulseAudio.
-
->>> Make sure to install pulseaudio-alsa to configure ALSA for PulseAudio.
-MES
-}
-
-post_upgrade() {
-  # Delete old users and groups
-  # System-wide daemon not supported anymore
-  if (( $(vercmp $2 0.9.22) < 0 )); then
-    getent passwd pulse &>/dev/null && usr/sbin/userdel -f pulse
-    getent group pulse-access &>/dev/null && usr/sbin/groupdel pulse-access
-    getent group pulse-rt &>/dev/null && usr/sbin/groupdel pulse-rt
-    getent group pulse &>/dev/null && usr/sbin/groupdel pulse
-  fi
-
-  true
-}
-
-# vim:set ts=2 sw=2 et:

Copied: pulseaudio/repos/extra-x86_64/pulseaudio.install (from rev 140516, pulseaudio/trunk/pulseaudio.install)
===================================================================
--- extra-x86_64/pulseaudio.install	                        (rev 0)
+++ extra-x86_64/pulseaudio.install	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,23 @@
+post_install() {
+  cat << MES
+>>> See the wiki at http://wiki.archlinux.org/index.php/PulseAudio for details
+    on configuring your system for PulseAudio.
+
+>>> Make sure to install pulseaudio-alsa to configure ALSA for PulseAudio.
+MES
+}
+
+post_upgrade() {
+  # Delete old users and groups
+  # System-wide daemon not supported anymore
+  if (( $(vercmp $2 0.9.22) < 0 )); then
+    getent passwd pulse &>/dev/null && usr/sbin/userdel -f pulse
+    getent group pulse-access &>/dev/null && usr/sbin/groupdel pulse-access
+    getent group pulse-rt &>/dev/null && usr/sbin/groupdel pulse-rt
+    getent group pulse &>/dev/null && usr/sbin/groupdel pulse
+  fi
+
+  true
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: extra-x86_64/pulseaudio.xinit
===================================================================
--- extra-x86_64/pulseaudio.xinit	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-x86_64/pulseaudio.xinit	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,12 +0,0 @@
-#!/bin/bash
-
-case "$DESKTOP_SESSION" in
-  gnome|kde*|xfce*) # PulseAudio is started via XDG Autostart
-  ;;
-  *)
-    # Extra checks in case DESKTOP_SESSION is not set correctly
-    if [[ -z $KDE_FULL_SESSION && -z $GNOME_DESKTOP_SESSION_ID ]]; then
-      /usr/bin/start-pulseaudio-x11
-    fi
-  ;;
-esac

Copied: pulseaudio/repos/extra-x86_64/pulseaudio.xinit (from rev 140516, pulseaudio/trunk/pulseaudio.xinit)
===================================================================
--- extra-x86_64/pulseaudio.xinit	                        (rev 0)
+++ extra-x86_64/pulseaudio.xinit	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+case "$DESKTOP_SESSION" in
+  gnome|kde*|xfce*) # PulseAudio is started via XDG Autostart
+  ;;
+  *)
+    # Extra checks in case DESKTOP_SESSION is not set correctly
+    if [[ -z $KDE_FULL_SESSION && -z $GNOME_DESKTOP_SESSION_ID ]]; then
+      /usr/bin/start-pulseaudio-x11
+    fi
+  ;;
+esac

Deleted: extra-x86_64/version-number.patch
===================================================================
--- extra-x86_64/version-number.patch	2011-10-16 08:38:53 UTC (rev 140516)
+++ extra-x86_64/version-number.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -1,40 +0,0 @@
-commit 7563e0bbb54fbac54e77f3a62d9761a70f3a559c
-Author: Colin Guthrie <colin at mageia.org>
-Date:   Sat Oct 1 12:03:44 2011 +0100
-
-    libpulse: Always return a three part version number in API calls.
-    
-    For both the headers and the library we should provide clean, three part
-    strings as this has been what we've previously done in the past
-    and some external systems apparently rely on this format. While it's not
-    something we've officially commented on before, there is no real advantage
-    to us to change it so let's not try to tidy things up too much
-    considering some third party apps (e.g. Skype) seem to dislike a two
-    part version string.
-
-diff --git a/src/pulse/context.c b/src/pulse/context.c
-index 25d04a1..af144aa 100644
---- a/src/pulse/context.c
-+++ b/src/pulse/context.c
-@@ -1281,7 +1281,7 @@ pa_operation* pa_context_set_name(pa_context *c, const char *name, pa_context_su
- }
- 
- const char* pa_get_library_version(void) {
--    return PACKAGE_VERSION;
-+    return pa_get_headers_version();
- }
- 
- const char* pa_context_get_server(pa_context *c) {
-diff --git a/src/pulse/version.h.in b/src/pulse/version.h.in
-index 7e00c5e..1be4c75 100644
---- a/src/pulse/version.h.in
-+++ b/src/pulse/version.h.in
-@@ -35,7 +35,7 @@ PA_C_DECL_BEGIN
- /** Return the version of the header files. Keep in mind that this is
- a macro and not a function, so it is impossible to get the pointer of
- it. */
--#define pa_get_headers_version() ("@PACKAGE_VERSION@")
-+#define pa_get_headers_version() ("@PA_MAJOR at .@PA_MINOR at .0")
- 
- /** Return the version of the library the current application is
-  * linked to. */

Copied: pulseaudio/repos/extra-x86_64/version-number.patch (from rev 140516, pulseaudio/trunk/version-number.patch)
===================================================================
--- extra-x86_64/version-number.patch	                        (rev 0)
+++ extra-x86_64/version-number.patch	2011-10-16 08:44:24 UTC (rev 140517)
@@ -0,0 +1,40 @@
+commit 7563e0bbb54fbac54e77f3a62d9761a70f3a559c
+Author: Colin Guthrie <colin at mageia.org>
+Date:   Sat Oct 1 12:03:44 2011 +0100
+
+    libpulse: Always return a three part version number in API calls.
+    
+    For both the headers and the library we should provide clean, three part
+    strings as this has been what we've previously done in the past
+    and some external systems apparently rely on this format. While it's not
+    something we've officially commented on before, there is no real advantage
+    to us to change it so let's not try to tidy things up too much
+    considering some third party apps (e.g. Skype) seem to dislike a two
+    part version string.
+
+diff --git a/src/pulse/context.c b/src/pulse/context.c
+index 25d04a1..af144aa 100644
+--- a/src/pulse/context.c
++++ b/src/pulse/context.c
+@@ -1281,7 +1281,7 @@ pa_operation* pa_context_set_name(pa_context *c, const char *name, pa_context_su
+ }
+ 
+ const char* pa_get_library_version(void) {
+-    return PACKAGE_VERSION;
++    return pa_get_headers_version();
+ }
+ 
+ const char* pa_context_get_server(pa_context *c) {
+diff --git a/src/pulse/version.h.in b/src/pulse/version.h.in
+index 7e00c5e..1be4c75 100644
+--- a/src/pulse/version.h.in
++++ b/src/pulse/version.h.in
+@@ -35,7 +35,7 @@ PA_C_DECL_BEGIN
+ /** Return the version of the header files. Keep in mind that this is
+ a macro and not a function, so it is impossible to get the pointer of
+ it. */
+-#define pa_get_headers_version() ("@PACKAGE_VERSION@")
++#define pa_get_headers_version() ("@PA_MAJOR at .@PA_MINOR at .0")
+ 
+ /** Return the version of the library the current application is
+  * linked to. */



More information about the arch-commits mailing list