[arch-commits] Commit in fcpci/trunk (PKGBUILD fcpci.install)

Thomas Bächler thomas at archlinux.org
Tue Oct 25 14:44:03 EDT 2011


    Date: Tuesday, October 25, 2011 @ 14:44:02
  Author: thomas
Revision: 141189

upgpkg: fcpci 31107-64

Fix depmod on update

Modified:
  fcpci/trunk/PKGBUILD
  fcpci/trunk/fcpci.install

---------------+
 PKGBUILD      |    4 ++--
 fcpci.install |    8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2011-10-25 18:43:18 UTC (rev 141188)
+++ PKGBUILD	2011-10-25 18:44:02 UTC (rev 141189)
@@ -3,7 +3,7 @@
 
 pkgname=fcpci
 pkgver=31107
-pkgrel=63
+pkgrel=64
 _extramodules=extramodules-3.1-ARCH
 _kernver="$(cat /lib/modules/${_extramodules}/version)"
 pkgdesc="AVM ISDN driver for FRITZ PCI isdn cards. For stock arch 2.6 kernel."
@@ -95,7 +95,7 @@
   cp $srcdir/fritz/src/fcpci.ko $pkgdir/lib/modules/${_extramodules}/ 
   rm -r $pkgdir/var/lib/fritz  
   # build module dependencies
-  sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" $startdir/fcpci.install
+  sed -i -e "s/EXTRAMODULES=.*/EXTRAMODULES=${_extramodules}/g" $startdir/fcpci.install
   # gzip -9 modules
   find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
 }

Modified: fcpci.install
===================================================================
--- fcpci.install	2011-10-25 18:43:18 UTC (rev 141188)
+++ fcpci.install	2011-10-25 18:44:02 UTC (rev 141189)
@@ -7,8 +7,8 @@
   sed -i -e 's/#fcpci		-	-	-	-	-	-/fcpci		-	-	-	-	-	-/g' /etc/capi.conf
   # updating module dependencies
   echo ">>> Updating module dependencies. Please wait ..."
-  KERNEL_VERSION=3.1.0-1-ARCH
-  depmod -v $KERNEL_VERSION > /dev/null 2>&1
+  EXTRAMODULES=extramodules-3.1-ARCH
+  depmod -v $(cat /lib/modules/$EXTRAMODULES/version) > /dev/null 2>&1
 }
 
 # arg 1:  the new package version
@@ -22,7 +22,7 @@
   sed -i -e 's/fcpci		-	-	-	-	-	-/#fcpci		-	-	-	-	-	-/g' /etc/capi.conf
     # updating module dependencies
   echo ">>> Updating module dependencies. Please wait ..."
-  KERNEL_VERSION=3.1.0-1-ARCH
-  depmod -v $KERNEL_VERSION > /dev/null 2>&1
+  EXTRAMODULES=extramodules-3.1-ARCH
+  depmod -v $(cat /lib/modules/$EXTRAMODULES/version) > /dev/null 2>&1
 }
 



More information about the arch-commits mailing list