[arch-commits] Commit in systemd/trunk (2 files)

Dave Reisner dreisner at archlinux.org
Mon Feb 6 22:51:36 EST 2012


    Date: Monday, February 6, 2012 @ 22:51:35
  Author: dreisner
Revision: 149353

upgpkg: systemd 40-1

Modified:
  systemd/trunk/PKGBUILD
Deleted:
  systemd/trunk/0001-mount-fix-automount-regression.patch

-------------------------------------------+
 0001-mount-fix-automount-regression.patch |   45 ----------------------------
 PKGBUILD                                  |   18 ++++-------
 2 files changed, 7 insertions(+), 56 deletions(-)

Deleted: 0001-mount-fix-automount-regression.patch
===================================================================
--- 0001-mount-fix-automount-regression.patch	2012-02-07 03:35:44 UTC (rev 149352)
+++ 0001-mount-fix-automount-regression.patch	2012-02-07 03:51:35 UTC (rev 149353)
@@ -1,45 +0,0 @@
-From da375869ff31f83938123dc0d2a8d5c0f0845a0c Mon Sep 17 00:00:00 2001
-From: Michal Schmidt <mschmidt at redhat.com>
-Date: Thu, 26 Jan 2012 01:19:19 +0100
-Subject: [PATCH] mount: fix automount regression
-
-Tom Gundersen noticed a regression where comment=systemd.automount in
-fstab no longer prevented the adding of the After=foo.mount dependency
-into local-fs.target. He bisected it to commit 9ddc4a26.
-
-It turns out that clearing the default_dependencies flag is necessary
-after all, in order to avoid complementing of Wants= with After= in the
-target unit. We still want to add the dependencies on quota units and
-umount.target though.
----
- src/mount.c |    7 ++++++-
- 1 files changed, 6 insertions(+), 1 deletions(-)
-
-diff --git a/src/mount.c b/src/mount.c
-index 6d0af4e..965f705 100644
---- a/src/mount.c
-+++ b/src/mount.c
-@@ -583,6 +583,11 @@ static int mount_load(Unit *u) {
- 
-                 if (UNIT(m)->fragment_path)
-                         m->from_fragment = true;
-+                else if (m->from_etc_fstab)
-+                        /* We always add several default dependencies to fstab mounts,
-+                         * but we do not want the implicit complementing of Wants= with After=
-+                         * in the target unit that this mount unit will be hooked into. */
-+                        UNIT(m)->default_dependencies = false;
- 
-                 if (!m->where)
-                         if (!(m->where = unit_name_to_path(u->id)))
-@@ -615,7 +620,7 @@ static int mount_load(Unit *u) {
-                 if ((r = mount_add_fstab_links(m)) < 0)
-                         return r;
- 
--                if (UNIT(m)->default_dependencies)
-+                if (UNIT(m)->default_dependencies || m->from_etc_fstab)
-                         if ((r = mount_add_default_dependencies(m)) < 0)
-                                 return r;
- 
--- 
-1.7.8.4
-

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2012-02-07 03:35:44 UTC (rev 149352)
+++ PKGBUILD	2012-02-07 03:51:35 UTC (rev 149353)
@@ -2,8 +2,8 @@
 # Maintainer: Dave Reisner <dreisner at archlinux.org>
 
 pkgname=systemd
-pkgver=39
-pkgrel=2
+pkgver=40
+pkgrel=1
 pkgdesc="Session and Startup manager"
 arch=('i686' 'x86_64')
 url="http://www.freedesktop.org/wiki/Software/systemd"
@@ -24,14 +24,13 @@
         etc/dbus-1/system.d/org.freedesktop.timedate1.conf
         etc/systemd/system.conf
         etc/systemd/user.conf
-        etc/systemd/systemd-logind.conf)
+        etc/systemd/systemd-logind.conf
+        etc/systemd/systemd-journald.conf)
 install=systemd.install
 source=("http://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
-        "os-release"
-        "0001-mount-fix-automount-regression.patch")
-md5sums=('7179b34f6f6553d2a36551ac1dec5f0d'
-         '752636def0db3c03f121f8b4f44a63cd'
-         '6e42637c1b1d4589909329dab777631b')
+        "os-release")
+md5sums=('8880180f54dac8618ef70c46492fd8d9'
+         '752636def0db3c03f121f8b4f44a63cd')
 
 build() {
   cd "$pkgname-$pkgver"
@@ -41,9 +40,6 @@
   sed -i -e '/^Environ.*LANG/s/^/#/' \
          -e '/^ExecStart/s/agetty/& -8/' units/getty at .service.m4
 
-  # fix default dependencies for automounts in /etc/fstab
-  patch -Np1 < "$srcdir/0001-mount-fix-automount-regression.patch"
-
   ./configure --sysconfdir=/etc \
               --libexecdir=/usr/lib \
               --libdir=/usr/lib \



More information about the arch-commits mailing list