[arch-commits] Commit in nvidia-lts/repos (6 files)

Ionut Biru ibiru at archlinux.org
Sun Feb 12 05:26:56 EST 2012


    Date: Sunday, February 12, 2012 @ 05:26:56
  Author: ibiru
Revision: 150101

archrelease: copy trunk to testing-i686, testing-x86_64

Added:
  nvidia-lts/repos/testing-i686/
  nvidia-lts/repos/testing-i686/PKGBUILD
    (from rev 150100, nvidia-lts/trunk/PKGBUILD)
  nvidia-lts/repos/testing-i686/nvidia-lts.install
    (from rev 150100, nvidia-lts/trunk/nvidia-lts.install)
  nvidia-lts/repos/testing-x86_64/
  nvidia-lts/repos/testing-x86_64/PKGBUILD
    (from rev 150100, nvidia-lts/trunk/PKGBUILD)
  nvidia-lts/repos/testing-x86_64/nvidia-lts.install
    (from rev 150100, nvidia-lts/trunk/nvidia-lts.install)

-----------------------------------+
 testing-i686/PKGBUILD             |   45 ++++++++++++++++++++++++++++++++++++
 testing-i686/nvidia-lts.install   |   15 ++++++++++++
 testing-x86_64/PKGBUILD           |   45 ++++++++++++++++++++++++++++++++++++
 testing-x86_64/nvidia-lts.install |   15 ++++++++++++
 4 files changed, 120 insertions(+)

Copied: nvidia-lts/repos/testing-i686/PKGBUILD (from rev 150100, nvidia-lts/trunk/PKGBUILD)
===================================================================
--- testing-i686/PKGBUILD	                        (rev 0)
+++ testing-i686/PKGBUILD	2012-02-12 10:26:56 UTC (rev 150101)
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-lts
+pkgver=295.17
+_extramodules=extramodules-3.0-lts
+pkgrel=1
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
+makedepends=('linux-lts-headers>=3.0.0')
+provides=('nvidia')
+license=('custom')
+install=nvidia-lts.install
+options=(!strip)
+if [ "$CARCH" = "i686" ]; then
+  _arch='x86'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('453d7585254cb2abb486135828278e43')
+elif [ "$CARCH" = "x86_64" ]; then
+  _arch='x86_64'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('784480587bb000df46065a853e370ef0')
+fi
+
+build() {
+  _kernver="$(cat /lib/modules/${_extramodules}/version)"
+  cd "${srcdir}"
+  sh ${_pkg}.run --extract-only
+  cd "${_pkg}/kernel"
+  make SYSSRC=/lib/modules/${_kernver}/build module
+}
+
+package() {
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  gzip "${pkgdir}/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -d -m755 "${pkgdir}/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Copied: nvidia-lts/repos/testing-i686/nvidia-lts.install (from rev 150100, nvidia-lts/trunk/nvidia-lts.install)
===================================================================
--- testing-i686/nvidia-lts.install	                        (rev 0)
+++ testing-i686/nvidia-lts.install	2012-02-12 10:26:56 UTC (rev 150101)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+}

Copied: nvidia-lts/repos/testing-x86_64/PKGBUILD (from rev 150100, nvidia-lts/trunk/PKGBUILD)
===================================================================
--- testing-x86_64/PKGBUILD	                        (rev 0)
+++ testing-x86_64/PKGBUILD	2012-02-12 10:26:56 UTC (rev 150101)
@@ -0,0 +1,45 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-lts
+pkgver=295.17
+_extramodules=extramodules-3.0-lts
+pkgrel=1
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
+makedepends=('linux-lts-headers>=3.0.0')
+provides=('nvidia')
+license=('custom')
+install=nvidia-lts.install
+options=(!strip)
+if [ "$CARCH" = "i686" ]; then
+  _arch='x86'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('453d7585254cb2abb486135828278e43')
+elif [ "$CARCH" = "x86_64" ]; then
+  _arch='x86_64'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('784480587bb000df46065a853e370ef0')
+fi
+
+build() {
+  _kernver="$(cat /lib/modules/${_extramodules}/version)"
+  cd "${srcdir}"
+  sh ${_pkg}.run --extract-only
+  cd "${_pkg}/kernel"
+  make SYSSRC=/lib/modules/${_kernver}/build module
+}
+
+package() {
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  gzip "${pkgdir}/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -d -m755 "${pkgdir}/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Copied: nvidia-lts/repos/testing-x86_64/nvidia-lts.install (from rev 150100, nvidia-lts/trunk/nvidia-lts.install)
===================================================================
--- testing-x86_64/nvidia-lts.install	                        (rev 0)
+++ testing-x86_64/nvidia-lts.install	2012-02-12 10:26:56 UTC (rev 150101)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /lib/modules/$EXTRAMODULES/version)
+}



More information about the arch-commits mailing list