[arch-commits] Commit in apitrace/repos (8 files)

Laurent Carlier lcarlier at nymeria.archlinux.org
Sun May 5 15:53:46 EDT 2013


    Date: Sunday, May 5, 2013 @ 21:53:46
  Author: lcarlier
Revision: 89930

archrelease: copy trunk to community-i686, community-x86_64

Added:
  apitrace/repos/community-i686/PKGBUILD
    (from rev 89929, apitrace/trunk/PKGBUILD)
  apitrace/repos/community-i686/gcc-4.7-fix.patch
    (from rev 89929, apitrace/trunk/gcc-4.7-fix.patch)
  apitrace/repos/community-x86_64/PKGBUILD
    (from rev 89929, apitrace/trunk/PKGBUILD)
  apitrace/repos/community-x86_64/gcc-4.7-fix.patch
    (from rev 89929, apitrace/trunk/gcc-4.7-fix.patch)
Deleted:
  apitrace/repos/community-i686/PKGBUILD
  apitrace/repos/community-i686/gcc-4.7-fix.patch
  apitrace/repos/community-x86_64/PKGBUILD
  apitrace/repos/community-x86_64/gcc-4.7-fix.patch

------------------------------------+
 /PKGBUILD                          |   66 +++++++++++++++++++++++++++++
 /gcc-4.7-fix.patch                 |   78 +++++++++++++++++++++++++++++++++++
 community-i686/PKGBUILD            |   38 -----------------
 community-i686/gcc-4.7-fix.patch   |   39 -----------------
 community-x86_64/PKGBUILD          |   38 -----------------
 community-x86_64/gcc-4.7-fix.patch |   39 -----------------
 6 files changed, 144 insertions(+), 154 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2013-05-05 19:53:36 UTC (rev 89929)
+++ community-i686/PKGBUILD	2013-05-05 19:53:46 UTC (rev 89930)
@@ -1,38 +0,0 @@
-# $Id$
-# Maintainer: Laurent Carlier <lordheavym at gmail.com>
-# Contributor: Luca Bennati <lucak3 AT gmail DOT com>
-# Contributor: Glaucous <glakke1 at gmail dot com>
-
-pkgname=apitrace
-pkgver=3.0
-pkgrel=1
-pkgdesc="Graphics API Tracing"
-arch=('i686' 'x86_64')
-url="https://github.com/apitrace/apitrace"
-license=('custom')
-makedepends=('cmake' 'mesa' 'libgl>=9.1' 'python2' 'qtwebkit' 'qjson')
-optdepends=('qtwebkit: GUI support' 'qjson: GUI support')
-source=("https://github.com/apitrace/$pkgname/zipball/$pkgver"
-	gcc-4.7-fix.patch)
-md5sums=('9ef70fa990f165e30a4408762fdb4a76'
-         '27a9a7aa14355b56fb48e2e17ff9911e')
-
-build() {
-  cd ${srcdir}/apitrace-*
-
-  # Merged upstream
-  patch -Np1 -i ${srcdir}/gcc-4.7-fix.patch
-
-  cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXECUTABLE='/usr/bin/python2'
-  make -C build
-}
-
-package() {
-depends=('python2' 'libgl')
-  cd ${srcdir}/apitrace-*
-
-  make -C build DESTDIR="${pkgdir}/" install
-
-  install -m755 -d "${pkgdir}/usr/share/licenses/apitrace"
-  install -m644 LICENSE "${pkgdir}/usr/share/licenses/apitrace/"
-}

Copied: apitrace/repos/community-i686/PKGBUILD (from rev 89929, apitrace/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2013-05-05 19:53:46 UTC (rev 89930)
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Laurent Carlier <lordheavym at gmail.com>
+# Contributor: Luca Bennati <lucak3 AT gmail DOT com>
+# Contributor: Glaucous <glakke1 at gmail dot com>
+
+pkgname=apitrace
+pkgver=4.0
+pkgrel=1
+pkgdesc="Graphics API Tracing"
+arch=('i686' 'x86_64')
+url="https://github.com/apitrace/apitrace"
+license=('custom')
+makedepends=('cmake' 'mesa' 'libgl' 'python2' 'qtwebkit' 'qjson')
+optdepends=('qtwebkit: GUI support' 'qjson: GUI support')
+source=("https://github.com/apitrace/apitrace/archive/${pkgver}.zip")
+md5sums=('5b2e212d91d2f184d8608c712eab69a0')
+
+build() {
+  cd ${srcdir}/apitrace-*
+
+  cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXECUTABLE='/usr/bin/python2'
+  make -C build
+}
+
+package() {
+  depends=('python2' 'libgl')
+  cd ${srcdir}/apitrace-*
+
+  make -C build DESTDIR="${pkgdir}/" install
+
+  install -m755 -d "${pkgdir}/usr/share/licenses/apitrace"
+  install -m644 LICENSE "${pkgdir}/usr/share/licenses/apitrace/"
+}

Deleted: community-i686/gcc-4.7-fix.patch
===================================================================
--- community-i686/gcc-4.7-fix.patch	2013-05-05 19:53:36 UTC (rev 89929)
+++ community-i686/gcc-4.7-fix.patch	2013-05-05 19:53:46 UTC (rev 89930)
@@ -1,39 +0,0 @@
-From 8159d6c1295da8c1b342bc77686e7ecfed1e5c01 Mon Sep 17 00:00:00 2001
-From: Martin Olsson <martin at minimum.se>
-Date: Mon, 26 Mar 2012 10:40:45 +0200
-Subject: [PATCH] Fix compile error "isatty was not declared"; missing
- unistd.h include
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-When I built apitrace on Fedora 16, using the usual:
-
-	cmake -H. -Bbuild
-	make -C build
-
-...then I got this compile error:
-
-	apitrace/cli/cli_dump.cpp: In function ‘int command(int, char**)’:
-	apitrace/cli/cli_dump.cpp:176:25: error: ‘isatty’ was not declared in this scope
----
- cli/cli_dump.cpp |    3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/cli/cli_dump.cpp b/cli/cli_dump.cpp
-index 28c91af..f52b83c 100644
---- a/cli/cli_dump.cpp
-+++ b/cli/cli_dump.cpp
-@@ -28,6 +28,9 @@
- #include <string.h>
- #include <limits.h> // for CHAR_MAX
- #include <getopt.h>
-+#ifndef _WIN32
-+#include <unistd.h> // for isatty()
-+#endif
- 
- #include "cli.hpp"
- #include "cli_pager.hpp"
--- 
-1.7.10
-

Copied: apitrace/repos/community-i686/gcc-4.7-fix.patch (from rev 89929, apitrace/trunk/gcc-4.7-fix.patch)
===================================================================
--- community-i686/gcc-4.7-fix.patch	                        (rev 0)
+++ community-i686/gcc-4.7-fix.patch	2013-05-05 19:53:46 UTC (rev 89930)
@@ -0,0 +1,39 @@
+From 8159d6c1295da8c1b342bc77686e7ecfed1e5c01 Mon Sep 17 00:00:00 2001
+From: Martin Olsson <martin at minimum.se>
+Date: Mon, 26 Mar 2012 10:40:45 +0200
+Subject: [PATCH] Fix compile error "isatty was not declared"; missing
+ unistd.h include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When I built apitrace on Fedora 16, using the usual:
+
+	cmake -H. -Bbuild
+	make -C build
+
+...then I got this compile error:
+
+	apitrace/cli/cli_dump.cpp: In function ‘int command(int, char**)’:
+	apitrace/cli/cli_dump.cpp:176:25: error: ‘isatty’ was not declared in this scope
+---
+ cli/cli_dump.cpp |    3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/cli/cli_dump.cpp b/cli/cli_dump.cpp
+index 28c91af..f52b83c 100644
+--- a/cli/cli_dump.cpp
++++ b/cli/cli_dump.cpp
+@@ -28,6 +28,9 @@
+ #include <string.h>
+ #include <limits.h> // for CHAR_MAX
+ #include <getopt.h>
++#ifndef _WIN32
++#include <unistd.h> // for isatty()
++#endif
+ 
+ #include "cli.hpp"
+ #include "cli_pager.hpp"
+-- 
+1.7.10
+

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2013-05-05 19:53:36 UTC (rev 89929)
+++ community-x86_64/PKGBUILD	2013-05-05 19:53:46 UTC (rev 89930)
@@ -1,38 +0,0 @@
-# $Id$
-# Maintainer: Laurent Carlier <lordheavym at gmail.com>
-# Contributor: Luca Bennati <lucak3 AT gmail DOT com>
-# Contributor: Glaucous <glakke1 at gmail dot com>
-
-pkgname=apitrace
-pkgver=3.0
-pkgrel=1
-pkgdesc="Graphics API Tracing"
-arch=('i686' 'x86_64')
-url="https://github.com/apitrace/apitrace"
-license=('custom')
-makedepends=('cmake' 'mesa' 'libgl>=9.1' 'python2' 'qtwebkit' 'qjson')
-optdepends=('qtwebkit: GUI support' 'qjson: GUI support')
-source=("https://github.com/apitrace/$pkgname/zipball/$pkgver"
-	gcc-4.7-fix.patch)
-md5sums=('9ef70fa990f165e30a4408762fdb4a76'
-         '27a9a7aa14355b56fb48e2e17ff9911e')
-
-build() {
-  cd ${srcdir}/apitrace-*
-
-  # Merged upstream
-  patch -Np1 -i ${srcdir}/gcc-4.7-fix.patch
-
-  cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXECUTABLE='/usr/bin/python2'
-  make -C build
-}
-
-package() {
-depends=('python2' 'libgl')
-  cd ${srcdir}/apitrace-*
-
-  make -C build DESTDIR="${pkgdir}/" install
-
-  install -m755 -d "${pkgdir}/usr/share/licenses/apitrace"
-  install -m644 LICENSE "${pkgdir}/usr/share/licenses/apitrace/"
-}

Copied: apitrace/repos/community-x86_64/PKGBUILD (from rev 89929, apitrace/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2013-05-05 19:53:46 UTC (rev 89930)
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Laurent Carlier <lordheavym at gmail.com>
+# Contributor: Luca Bennati <lucak3 AT gmail DOT com>
+# Contributor: Glaucous <glakke1 at gmail dot com>
+
+pkgname=apitrace
+pkgver=4.0
+pkgrel=1
+pkgdesc="Graphics API Tracing"
+arch=('i686' 'x86_64')
+url="https://github.com/apitrace/apitrace"
+license=('custom')
+makedepends=('cmake' 'mesa' 'libgl' 'python2' 'qtwebkit' 'qjson')
+optdepends=('qtwebkit: GUI support' 'qjson: GUI support')
+source=("https://github.com/apitrace/apitrace/archive/${pkgver}.zip")
+md5sums=('5b2e212d91d2f184d8608c712eab69a0')
+
+build() {
+  cd ${srcdir}/apitrace-*
+
+  cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON_EXECUTABLE='/usr/bin/python2'
+  make -C build
+}
+
+package() {
+  depends=('python2' 'libgl')
+  cd ${srcdir}/apitrace-*
+
+  make -C build DESTDIR="${pkgdir}/" install
+
+  install -m755 -d "${pkgdir}/usr/share/licenses/apitrace"
+  install -m644 LICENSE "${pkgdir}/usr/share/licenses/apitrace/"
+}

Deleted: community-x86_64/gcc-4.7-fix.patch
===================================================================
--- community-x86_64/gcc-4.7-fix.patch	2013-05-05 19:53:36 UTC (rev 89929)
+++ community-x86_64/gcc-4.7-fix.patch	2013-05-05 19:53:46 UTC (rev 89930)
@@ -1,39 +0,0 @@
-From 8159d6c1295da8c1b342bc77686e7ecfed1e5c01 Mon Sep 17 00:00:00 2001
-From: Martin Olsson <martin at minimum.se>
-Date: Mon, 26 Mar 2012 10:40:45 +0200
-Subject: [PATCH] Fix compile error "isatty was not declared"; missing
- unistd.h include
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-When I built apitrace on Fedora 16, using the usual:
-
-	cmake -H. -Bbuild
-	make -C build
-
-...then I got this compile error:
-
-	apitrace/cli/cli_dump.cpp: In function ‘int command(int, char**)’:
-	apitrace/cli/cli_dump.cpp:176:25: error: ‘isatty’ was not declared in this scope
----
- cli/cli_dump.cpp |    3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/cli/cli_dump.cpp b/cli/cli_dump.cpp
-index 28c91af..f52b83c 100644
---- a/cli/cli_dump.cpp
-+++ b/cli/cli_dump.cpp
-@@ -28,6 +28,9 @@
- #include <string.h>
- #include <limits.h> // for CHAR_MAX
- #include <getopt.h>
-+#ifndef _WIN32
-+#include <unistd.h> // for isatty()
-+#endif
- 
- #include "cli.hpp"
- #include "cli_pager.hpp"
--- 
-1.7.10
-

Copied: apitrace/repos/community-x86_64/gcc-4.7-fix.patch (from rev 89929, apitrace/trunk/gcc-4.7-fix.patch)
===================================================================
--- community-x86_64/gcc-4.7-fix.patch	                        (rev 0)
+++ community-x86_64/gcc-4.7-fix.patch	2013-05-05 19:53:46 UTC (rev 89930)
@@ -0,0 +1,39 @@
+From 8159d6c1295da8c1b342bc77686e7ecfed1e5c01 Mon Sep 17 00:00:00 2001
+From: Martin Olsson <martin at minimum.se>
+Date: Mon, 26 Mar 2012 10:40:45 +0200
+Subject: [PATCH] Fix compile error "isatty was not declared"; missing
+ unistd.h include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+When I built apitrace on Fedora 16, using the usual:
+
+	cmake -H. -Bbuild
+	make -C build
+
+...then I got this compile error:
+
+	apitrace/cli/cli_dump.cpp: In function ‘int command(int, char**)’:
+	apitrace/cli/cli_dump.cpp:176:25: error: ‘isatty’ was not declared in this scope
+---
+ cli/cli_dump.cpp |    3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/cli/cli_dump.cpp b/cli/cli_dump.cpp
+index 28c91af..f52b83c 100644
+--- a/cli/cli_dump.cpp
++++ b/cli/cli_dump.cpp
+@@ -28,6 +28,9 @@
+ #include <string.h>
+ #include <limits.h> // for CHAR_MAX
+ #include <getopt.h>
++#ifndef _WIN32
++#include <unistd.h> // for isatty()
++#endif
+ 
+ #include "cli.hpp"
+ #include "cli_pager.hpp"
+-- 
+1.7.10
+



More information about the arch-commits mailing list