[arch-commits] Commit in open-vm-tools-modules/repos (14 files)

Sergej Pupykin spupykin at nymeria.archlinux.org
Sun May 5 17:31:16 EDT 2013


    Date: Sunday, May 5, 2013 @ 23:31:15
  Author: spupykin
Revision: 89938

archrelease: copy trunk to community-i686, community-x86_64

Added:
  open-vm-tools-modules/repos/community-i686/PKGBUILD
    (from rev 89937, open-vm-tools-modules/trunk/PKGBUILD)
  open-vm-tools-modules/repos/community-i686/modprobe.conf
    (from rev 89937, open-vm-tools-modules/trunk/modprobe.conf)
  open-vm-tools-modules/repos/community-i686/open-vm-tools-modules.install
    (from rev 89937, open-vm-tools-modules/trunk/open-vm-tools-modules.install)
  open-vm-tools-modules/repos/community-x86_64/PKGBUILD
    (from rev 89937, open-vm-tools-modules/trunk/PKGBUILD)
  open-vm-tools-modules/repos/community-x86_64/modprobe.conf
    (from rev 89937, open-vm-tools-modules/trunk/modprobe.conf)
  open-vm-tools-modules/repos/community-x86_64/open-vm-tools-modules.install
    (from rev 89937, open-vm-tools-modules/trunk/open-vm-tools-modules.install)
Deleted:
  open-vm-tools-modules/repos/community-i686/PKGBUILD
  open-vm-tools-modules/repos/community-i686/linux-3.8.patch
  open-vm-tools-modules/repos/community-i686/modprobe.conf
  open-vm-tools-modules/repos/community-i686/open-vm-tools-modules.install
  open-vm-tools-modules/repos/community-x86_64/PKGBUILD
  open-vm-tools-modules/repos/community-x86_64/linux-3.8.patch
  open-vm-tools-modules/repos/community-x86_64/modprobe.conf
  open-vm-tools-modules/repos/community-x86_64/open-vm-tools-modules.install

------------------------------------------------+
 /PKGBUILD                                      |  112 +++++++++++++++++++++++
 /modprobe.conf                                 |    2 
 /open-vm-tools-modules.install                 |   46 +++++++++
 community-i686/PKGBUILD                        |   60 ------------
 community-i686/linux-3.8.patch                 |   53 ----------
 community-i686/modprobe.conf                   |    1 
 community-i686/open-vm-tools-modules.install   |   23 ----
 community-x86_64/PKGBUILD                      |   60 ------------
 community-x86_64/linux-3.8.patch               |   53 ----------
 community-x86_64/modprobe.conf                 |    1 
 community-x86_64/open-vm-tools-modules.install |   23 ----
 11 files changed, 160 insertions(+), 274 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-i686/PKGBUILD	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,60 +0,0 @@
-# $Id$
-# Maintainer: Sergej Pupykin <pupykin.s+arch at gmail.com>
-# Contributor: Krzysztof Raczkowski <raczkow at gmail.com>
-
-pkgname=open-vm-tools-modules
-epoch=1
-pkgver=9.2.2
-_pkgsubver=893683
-pkgrel=11
-pkgdesc="kernel modules for the open source implementation of VMware Tools"
-arch=('i686' 'x86_64')
-url="http://open-vm-tools.sourceforge.net/"
-license=('GPL')
-makedepends=('libdnet' 'procps' 'icu' 'uriparser' 'linux-headers')
-depends=('linux')
-install=$pkgname.install
-options=('!strip' '!makeflags')
-source=("http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-${_pkgsubver}.tar.gz"
-	"modprobe.conf"
-	"linux-3.8.patch")
-md5sums=('7af505681d736d4c9ee6493b1166689f'
-         'bc5518489077e91655489bd04b868584'
-         'ff757686649404db0c2c9761eb293174')
-
-build() {
-  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
-  KERNEL_RELEASE=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
-
-  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
-
-  patch -Np1 -i "${srcdir}/linux-3.8.patch"
-
-  sed -i 's|proc-3.2.8|procps|g' configure
-  sed -i 's|putname(name);|__putname(name);|' modules/linux/vmblock/linux/control.c
-
-  [ $NOEXTRACT -eq 1 ] || ./configure \
-      --prefix=/usr \
-      --without-x \
-      --with-linuxdir=/usr/lib/modules/$KERNEL_RELEASE
-
-  make -C modules modules
-}
-
-package() {
-  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
-  depends=("linux>=3.${_kernver}" "linux<3.$(expr ${_kernver} + 1)")
-  KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
-  msg "Kernel = $KERNEL_VERSION"
-
-  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
-  mkdir -p $pkgdir/usr/lib/modules/extramodules-3.${_kernver}-ARCH/
-
-  find -type f -name '*.ko' \
-    -exec install -t "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH" {} +
-
-  gzip "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH"/*.ko
-
-  install -D -m 644 ${srcdir}/modprobe.conf ${pkgdir}/usr/lib/modprobe.d/${pkgname}.conf
-  sed -i "s|extramodules-.*-ARCH|extramodules-3.${_kernver}-ARCH|" $startdir/$pkgname.install
-}

Copied: open-vm-tools-modules/repos/community-i686/PKGBUILD (from rev 89937, open-vm-tools-modules/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch at gmail.com>
+# Contributor: Krzysztof Raczkowski <raczkow at gmail.com>
+
+pkgname=open-vm-tools-modules
+epoch=1
+pkgver=9.2.3
+_pkgsubver=1031360
+pkgrel=1
+pkgdesc="kernel modules for the open source implementation of VMware Tools"
+arch=('i686' 'x86_64')
+url="http://open-vm-tools.sourceforge.net/"
+license=('GPL')
+makedepends=('libdnet' 'procps' 'icu' 'uriparser' 'linux-headers')
+depends=('linux')
+install=$pkgname.install
+options=('!strip' '!makeflags')
+source=("http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-${_pkgsubver}.tar.gz"
+	"modprobe.conf")
+md5sums=('71a1d8065b632692af2cdcc9d82f305e'
+         'bc5518489077e91655489bd04b868584')
+
+build() {
+  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
+  KERNEL_RELEASE=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
+
+  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
+
+  sed -i 's|proc-3.2.8|procps|g' configure
+  sed -i 's|putname(name);|__putname(name);|' modules/linux/vmblock/linux/control.c
+
+  [ $NOEXTRACT -eq 1 ] || ./configure \
+      --prefix=/usr \
+      --without-x \
+      --with-linuxdir=/usr/lib/modules/$KERNEL_RELEASE
+
+  make -C modules modules
+}
+
+package() {
+  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
+  depends=("linux>=3.${_kernver}" "linux<3.$(expr ${_kernver} + 1)")
+  KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
+  msg "Kernel = $KERNEL_VERSION"
+
+  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
+  mkdir -p $pkgdir/usr/lib/modules/extramodules-3.${_kernver}-ARCH/
+
+  find -type f -name '*.ko' \
+    -exec install -t "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH" {} +
+
+  gzip "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH"/*.ko
+
+  install -D -m 644 ${srcdir}/modprobe.conf ${pkgdir}/usr/lib/modprobe.d/${pkgname}.conf
+  sed -i "s|extramodules-.*-ARCH|extramodules-3.${_kernver}-ARCH|" $startdir/$pkgname.install
+}

Deleted: community-i686/linux-3.8.patch
===================================================================
--- community-i686/linux-3.8.patch	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-i686/linux-3.8.patch	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,53 +0,0 @@
-diff -upr open-vm-tools-9.2.2-893683.orig/modules/linux/shared/compat_mm.h open-vm-tools-9.2.2-893683/modules/linux/shared/compat_mm.h
---- open-vm-tools-9.2.2-893683.orig/modules/linux/shared/compat_mm.h	2013-02-21 03:02:46.000000000 +0200
-+++ open-vm-tools-9.2.2-893683/modules/linux/shared/compat_mm.h	2013-02-21 03:10:31.000000000 +0200
-@@ -99,8 +99,18 @@ static inline struct page * alloc_pages(
-    vmtruncate(inode, size);                                                   \
-    result;                                                                    \
- })
--#else
-+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 8, 0)
- #define compat_vmtruncate(inode, size) vmtruncate(inode, size)
-+#else
-+#define compat_vmtruncate(inode, size)                                        \
-+({                                                                            \
-+   result = inode_newsize_ok(inode, size);                                    \
-+   if (!result)                                                               \
-+   {                                                                          \
-+      truncate_setsize(inode, size);                                          \
-+   }                                                                          \
-+   result;                                                                    \
-+})
- #endif
- 
- 
-diff -upr open-vm-tools-9.2.2-893683.orig/modules/linux/vmci/linux/driver.c open-vm-tools-9.2.2-893683/modules/linux/vmci/linux/driver.c
---- open-vm-tools-9.2.2-893683.orig/modules/linux/vmci/linux/driver.c	2013-02-21 03:02:46.000000000 +0200
-+++ open-vm-tools-9.2.2-893683/modules/linux/vmci/linux/driver.c	2013-02-21 03:03:20.000000000 +0200
-@@ -124,7 +124,7 @@ static struct pci_driver vmci_driver = {
-    .name     = "vmci",
-    .id_table = vmci_ids,
-    .probe = vmci_probe_device,
--   .remove = __devexit_p(vmci_remove_device),
-+   .remove = vmci_remove_device,
- };
- 
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
-@@ -1750,7 +1750,7 @@ vmci_enable_msix(struct pci_dev *pdev) /
-  *-----------------------------------------------------------------------------
-  */
- 
--static int __devinit
-+static int
- vmci_probe_device(struct pci_dev *pdev,           // IN: vmci PCI device
-                   const struct pci_device_id *id) // IN: matching device ID
- {
-@@ -1978,7 +1978,7 @@ vmci_probe_device(struct pci_dev *pdev,
-  *-----------------------------------------------------------------------------
-  */
- 
--static void __devexit
-+static void
- vmci_remove_device(struct pci_dev* pdev)
- {
-    struct vmci_device *dev = pci_get_drvdata(pdev);

Deleted: community-i686/modprobe.conf
===================================================================
--- community-i686/modprobe.conf	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-i686/modprobe.conf	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1 +0,0 @@
-softdep pcnet32 pre: vmxnet

Copied: open-vm-tools-modules/repos/community-i686/modprobe.conf (from rev 89937, open-vm-tools-modules/trunk/modprobe.conf)
===================================================================
--- community-i686/modprobe.conf	                        (rev 0)
+++ community-i686/modprobe.conf	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1 @@
+softdep pcnet32 pre: vmxnet

Deleted: community-i686/open-vm-tools-modules.install
===================================================================
--- community-i686/open-vm-tools-modules.install	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-i686/open-vm-tools-modules.install	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,23 +0,0 @@
-post_install() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-  echo ">>> Enabling vmxnet driver in /usr/lib/modprobe.d/open-vm-tools-modules.conf"
-  echo ">>> (this will disable pcnet32 driver)"
-  echo ">>>"
-  echo ">>> If vmxnet driver doesn't handle your NIC, you have to manually"
-  echo ">>> disable loading of pcnet32 driver"
-  echo ">>>"
-}
-
-post_upgrade() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-  echo ">>>"
-  echo ">>> Remember to un-blacklist pcnet32 driver"
-  echo ">>>"
-}

Copied: open-vm-tools-modules/repos/community-i686/open-vm-tools-modules.install (from rev 89937, open-vm-tools-modules/trunk/open-vm-tools-modules.install)
===================================================================
--- community-i686/open-vm-tools-modules.install	                        (rev 0)
+++ community-i686/open-vm-tools-modules.install	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1,23 @@
+post_install() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+  echo ">>> Enabling vmxnet driver in /usr/lib/modprobe.d/open-vm-tools-modules.conf"
+  echo ">>> (this will disable pcnet32 driver)"
+  echo ">>>"
+  echo ">>> If vmxnet driver doesn't handle your NIC, you have to manually"
+  echo ">>> disable loading of pcnet32 driver"
+  echo ">>>"
+}
+
+post_upgrade() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+  echo ">>>"
+  echo ">>> Remember to un-blacklist pcnet32 driver"
+  echo ">>>"
+}

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-x86_64/PKGBUILD	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,60 +0,0 @@
-# $Id$
-# Maintainer: Sergej Pupykin <pupykin.s+arch at gmail.com>
-# Contributor: Krzysztof Raczkowski <raczkow at gmail.com>
-
-pkgname=open-vm-tools-modules
-epoch=1
-pkgver=9.2.2
-_pkgsubver=893683
-pkgrel=11
-pkgdesc="kernel modules for the open source implementation of VMware Tools"
-arch=('i686' 'x86_64')
-url="http://open-vm-tools.sourceforge.net/"
-license=('GPL')
-makedepends=('libdnet' 'procps' 'icu' 'uriparser' 'linux-headers')
-depends=('linux')
-install=$pkgname.install
-options=('!strip' '!makeflags')
-source=("http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-${_pkgsubver}.tar.gz"
-	"modprobe.conf"
-	"linux-3.8.patch")
-md5sums=('7af505681d736d4c9ee6493b1166689f'
-         'bc5518489077e91655489bd04b868584'
-         'ff757686649404db0c2c9761eb293174')
-
-build() {
-  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
-  KERNEL_RELEASE=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
-
-  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
-
-  patch -Np1 -i "${srcdir}/linux-3.8.patch"
-
-  sed -i 's|proc-3.2.8|procps|g' configure
-  sed -i 's|putname(name);|__putname(name);|' modules/linux/vmblock/linux/control.c
-
-  [ $NOEXTRACT -eq 1 ] || ./configure \
-      --prefix=/usr \
-      --without-x \
-      --with-linuxdir=/usr/lib/modules/$KERNEL_RELEASE
-
-  make -C modules modules
-}
-
-package() {
-  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
-  depends=("linux>=3.${_kernver}" "linux<3.$(expr ${_kernver} + 1)")
-  KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
-  msg "Kernel = $KERNEL_VERSION"
-
-  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
-  mkdir -p $pkgdir/usr/lib/modules/extramodules-3.${_kernver}-ARCH/
-
-  find -type f -name '*.ko' \
-    -exec install -t "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH" {} +
-
-  gzip "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH"/*.ko
-
-  install -D -m 644 ${srcdir}/modprobe.conf ${pkgdir}/usr/lib/modprobe.d/${pkgname}.conf
-  sed -i "s|extramodules-.*-ARCH|extramodules-3.${_kernver}-ARCH|" $startdir/$pkgname.install
-}

Copied: open-vm-tools-modules/repos/community-x86_64/PKGBUILD (from rev 89937, open-vm-tools-modules/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch at gmail.com>
+# Contributor: Krzysztof Raczkowski <raczkow at gmail.com>
+
+pkgname=open-vm-tools-modules
+epoch=1
+pkgver=9.2.3
+_pkgsubver=1031360
+pkgrel=1
+pkgdesc="kernel modules for the open source implementation of VMware Tools"
+arch=('i686' 'x86_64')
+url="http://open-vm-tools.sourceforge.net/"
+license=('GPL')
+makedepends=('libdnet' 'procps' 'icu' 'uriparser' 'linux-headers')
+depends=('linux')
+install=$pkgname.install
+options=('!strip' '!makeflags')
+source=("http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-${_pkgsubver}.tar.gz"
+	"modprobe.conf")
+md5sums=('71a1d8065b632692af2cdcc9d82f305e'
+         'bc5518489077e91655489bd04b868584')
+
+build() {
+  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
+  KERNEL_RELEASE=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
+
+  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
+
+  sed -i 's|proc-3.2.8|procps|g' configure
+  sed -i 's|putname(name);|__putname(name);|' modules/linux/vmblock/linux/control.c
+
+  [ $NOEXTRACT -eq 1 ] || ./configure \
+      --prefix=/usr \
+      --without-x \
+      --with-linuxdir=/usr/lib/modules/$KERNEL_RELEASE
+
+  make -C modules modules
+}
+
+package() {
+  _kernver=$(pacman -Q linux | cut -d . -f 2 | cut -f 1 -d -)
+  depends=("linux>=3.${_kernver}" "linux<3.$(expr ${_kernver} + 1)")
+  KERNEL_VERSION=$(cat /usr/lib/modules/extramodules-3.${_kernver}-ARCH/version)
+  msg "Kernel = $KERNEL_VERSION"
+
+  cd "$srcdir/open-vm-tools-${pkgver}-${_pkgsubver}"
+  mkdir -p $pkgdir/usr/lib/modules/extramodules-3.${_kernver}-ARCH/
+
+  find -type f -name '*.ko' \
+    -exec install -t "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH" {} +
+
+  gzip "$pkgdir/usr/lib/modules/extramodules-3.$_kernver-ARCH"/*.ko
+
+  install -D -m 644 ${srcdir}/modprobe.conf ${pkgdir}/usr/lib/modprobe.d/${pkgname}.conf
+  sed -i "s|extramodules-.*-ARCH|extramodules-3.${_kernver}-ARCH|" $startdir/$pkgname.install
+}

Deleted: community-x86_64/linux-3.8.patch
===================================================================
--- community-x86_64/linux-3.8.patch	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-x86_64/linux-3.8.patch	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,53 +0,0 @@
-diff -upr open-vm-tools-9.2.2-893683.orig/modules/linux/shared/compat_mm.h open-vm-tools-9.2.2-893683/modules/linux/shared/compat_mm.h
---- open-vm-tools-9.2.2-893683.orig/modules/linux/shared/compat_mm.h	2013-02-21 03:02:46.000000000 +0200
-+++ open-vm-tools-9.2.2-893683/modules/linux/shared/compat_mm.h	2013-02-21 03:10:31.000000000 +0200
-@@ -99,8 +99,18 @@ static inline struct page * alloc_pages(
-    vmtruncate(inode, size);                                                   \
-    result;                                                                    \
- })
--#else
-+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 8, 0)
- #define compat_vmtruncate(inode, size) vmtruncate(inode, size)
-+#else
-+#define compat_vmtruncate(inode, size)                                        \
-+({                                                                            \
-+   result = inode_newsize_ok(inode, size);                                    \
-+   if (!result)                                                               \
-+   {                                                                          \
-+      truncate_setsize(inode, size);                                          \
-+   }                                                                          \
-+   result;                                                                    \
-+})
- #endif
- 
- 
-diff -upr open-vm-tools-9.2.2-893683.orig/modules/linux/vmci/linux/driver.c open-vm-tools-9.2.2-893683/modules/linux/vmci/linux/driver.c
---- open-vm-tools-9.2.2-893683.orig/modules/linux/vmci/linux/driver.c	2013-02-21 03:02:46.000000000 +0200
-+++ open-vm-tools-9.2.2-893683/modules/linux/vmci/linux/driver.c	2013-02-21 03:03:20.000000000 +0200
-@@ -124,7 +124,7 @@ static struct pci_driver vmci_driver = {
-    .name     = "vmci",
-    .id_table = vmci_ids,
-    .probe = vmci_probe_device,
--   .remove = __devexit_p(vmci_remove_device),
-+   .remove = vmci_remove_device,
- };
- 
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 19)
-@@ -1750,7 +1750,7 @@ vmci_enable_msix(struct pci_dev *pdev) /
-  *-----------------------------------------------------------------------------
-  */
- 
--static int __devinit
-+static int
- vmci_probe_device(struct pci_dev *pdev,           // IN: vmci PCI device
-                   const struct pci_device_id *id) // IN: matching device ID
- {
-@@ -1978,7 +1978,7 @@ vmci_probe_device(struct pci_dev *pdev,
-  *-----------------------------------------------------------------------------
-  */
- 
--static void __devexit
-+static void
- vmci_remove_device(struct pci_dev* pdev)
- {
-    struct vmci_device *dev = pci_get_drvdata(pdev);

Deleted: community-x86_64/modprobe.conf
===================================================================
--- community-x86_64/modprobe.conf	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-x86_64/modprobe.conf	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1 +0,0 @@
-softdep pcnet32 pre: vmxnet

Copied: open-vm-tools-modules/repos/community-x86_64/modprobe.conf (from rev 89937, open-vm-tools-modules/trunk/modprobe.conf)
===================================================================
--- community-x86_64/modprobe.conf	                        (rev 0)
+++ community-x86_64/modprobe.conf	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1 @@
+softdep pcnet32 pre: vmxnet

Deleted: community-x86_64/open-vm-tools-modules.install
===================================================================
--- community-x86_64/open-vm-tools-modules.install	2013-05-05 21:30:55 UTC (rev 89937)
+++ community-x86_64/open-vm-tools-modules.install	2013-05-05 21:31:15 UTC (rev 89938)
@@ -1,23 +0,0 @@
-post_install() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-  echo ">>> Enabling vmxnet driver in /usr/lib/modprobe.d/open-vm-tools-modules.conf"
-  echo ">>> (this will disable pcnet32 driver)"
-  echo ">>>"
-  echo ">>> If vmxnet driver doesn't handle your NIC, you have to manually"
-  echo ">>> disable loading of pcnet32 driver"
-  echo ">>>"
-}
-
-post_upgrade() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-  EXTRAMODULES='extramodules-3.8-ARCH'
-  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-  echo ">>>"
-  echo ">>> Remember to un-blacklist pcnet32 driver"
-  echo ">>>"
-}

Copied: open-vm-tools-modules/repos/community-x86_64/open-vm-tools-modules.install (from rev 89937, open-vm-tools-modules/trunk/open-vm-tools-modules.install)
===================================================================
--- community-x86_64/open-vm-tools-modules.install	                        (rev 0)
+++ community-x86_64/open-vm-tools-modules.install	2013-05-05 21:31:15 UTC (rev 89938)
@@ -0,0 +1,23 @@
+post_install() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+  echo ">>> Enabling vmxnet driver in /usr/lib/modprobe.d/open-vm-tools-modules.conf"
+  echo ">>> (this will disable pcnet32 driver)"
+  echo ">>>"
+  echo ">>> If vmxnet driver doesn't handle your NIC, you have to manually"
+  echo ">>> disable loading of pcnet32 driver"
+  echo ">>>"
+}
+
+post_upgrade() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+  EXTRAMODULES='extramodules-3.8-ARCH'
+  depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+  echo ">>>"
+  echo ">>> Remember to un-blacklist pcnet32 driver"
+  echo ">>>"
+}



More information about the arch-commits mailing list