[arch-commits] Commit in claws-mail/trunk (PKGBUILD claws-mail.install)

Andreas Radke andyrtr at nymeria.archlinux.org
Fri May 10 05:22:57 EDT 2013


    Date: Friday, May 10, 2013 @ 11:22:57
  Author: andyrtr
Revision: 185019

upgpkg: claws-mail 3.9.1-1

upstream update 3.9.1; merge the claws-mail-extra-plugin pkg

Modified:
  claws-mail/trunk/PKGBUILD
  claws-mail/trunk/claws-mail.install

--------------------+
 PKGBUILD           |   40 +++++++++++++++++++++++++++++-----------
 claws-mail.install |    2 +-
 2 files changed, 30 insertions(+), 12 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2013-05-10 08:20:18 UTC (rev 185018)
+++ PKGBUILD	2013-05-10 09:22:57 UTC (rev 185019)
@@ -2,7 +2,7 @@
 # Maintainer: Andreas Radke <andyrtr at archlinux.org>
 
 pkgname=claws-mail
-pkgver=3.9.0
+pkgver=3.9.1
 pkgrel=1
 pkgdesc="A GTK+ based e-mail client."
 arch=('i686' 'x86_64')
@@ -10,34 +10,52 @@
 url="http://www.claws-mail.org"
 depends=('gtk2' 'gnutls' 'startup-notification' 'pilot-link' 'enchant'
          'gpgme' 'libetpan>=1.1' 'libsm' 'db' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('compface' 'spamassassin' 'bogofilter' 'valgrind')
-optdepends=('python2:           needed for some tools'
-            'perl:              needed for some tools'
+makedepends=('compface' 'spamassassin' 'bogofilter' 'valgrind' 
+             # dependencies for plugins
+             'libsoup' 'libgdata' 'webkitgtk2' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk') 
+             #'libchamplain' needed for geolocation plugin, disabled for now - most time it's not compatible with current gnome releases
+optdepends=('python2:           needed for some tools and python plugin'
+            'perl:              needed for some tools and perl plugin'
             'spamassassin:      adds support for spamfiltering'
-            'bogofilter:        adds support for spamfiltering')
-replaces=('sylpheed-claws')
+            'bogofilter:        adds support for spamfiltering'
+            'libnotify:         for notification plugin'
+            'libcanberra:       for notification plugin'
+            'dbus-core:         for notification plugin'
+            'libxml2:           for gtkhtml2_viewer and rssyl plugins'
+            'curl:              for gtkhtml2_viewer, vcalendar, rssyl and spamreport plugins'
+            'libarchive:        for archive plugin and various other plugins'
+            'libytnef:          for tnef_parse plugin'
+            'webkitgtk2:        for the fancy webkit html plugin'
+            'libsoup:           for the fancy webkit html plugin'
+	        'libgdata:          for gdata plugin'
+	        'poppler-glib:      for pdf viewer plugin'
+	        'ghostscript:       for pdf viewer plugin')    
+replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
+conflicts=('claws-mail-extra-plugins')
 provides=('claws')
 options=(!libtool)
 install=claws-mail.install
 source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('4c5ac7b21f0ed17d0f6404124c2229a4')
+md5sums=('8adc734912ff1b83545cb12850100473')
 
 build() {
   cd ${srcdir}/${pkgname}-${pkgver}
 
+  # fixes for python2
+  export PYTHON="/usr/bin/python2"
   sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
-
+  sed -i 's:python -c:python2 -c:g' configure
+  
   ./configure --prefix=/usr --disable-static \
     --enable-enchant \
     --enable-gnutls \
     --enable-ldap \
-    --disable-dillo-viewer-plugin \
     --enable-crash-dialog \
     --enable-pgpmime-plugin \
     --enable-spamassassin-plugin \
     --enable-bogofilter-plugin \
-    --enable-jpilot
-
+    --enable-jpilot \
+    #--help
   make
 }
 

Modified: claws-mail.install
===================================================================
--- claws-mail.install	2013-05-10 08:20:18 UTC (rev 185018)
+++ claws-mail.install	2013-05-10 09:22:57 UTC (rev 185019)
@@ -1,5 +1,5 @@
 post_install() {
-  echo "install \"html2ps\" from AUR to add support for printing html mails together with html plugins"
+  echo "install \"html2ps\" from AUR to add support for printing html mails with fancy plugin"
   gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
   update-desktop-database -q
 }



More information about the arch-commits mailing list