[arch-commits] Commit in libsasl/trunk (PKGBUILD)

Bartłomiej Piotrowski bpiotrowski at nymeria.archlinux.org
Fri May 10 13:33:51 EDT 2013


    Date: Friday, May 10, 2013 @ 19:33:51
  Author: bpiotrowski
Revision: 185052

upgpkg: libsasl 2.1.26-1

- upstream release
- disable not required patches

Modified:
  libsasl/trunk/PKGBUILD

----------+
 PKGBUILD |   35 +++++++++++++++++++----------------
 1 file changed, 19 insertions(+), 16 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2013-05-10 17:31:59 UTC (rev 185051)
+++ PKGBUILD	2013-05-10 17:33:51 UTC (rev 185052)
@@ -7,15 +7,15 @@
 #pkgbase=('cyrus-sasl')
 #pkgname=('cyrus-sasl' 'cyrus-sasl-gssapi' 'cyrus-sasl-ldap' 'cyrus-sasl-sql')
 pkgname=libsasl
-pkgver=2.1.23
-pkgrel=10
+pkgver=2.1.26
+pkgrel=1
 pkgdesc="Cyrus Simple Authentication Service Layer (SASL) library"
 arch=('i686' 'x86_64')
 url="http://cyrusimap.web.cmu.edu/"
 license=('custom')
 options=('!makeflags' '!libtool')
 makedepends=('postgresql-libs' 'libmariadbclient' 'libldap' 'krb5' 'openssl')
-source=(ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-${pkgver}.tar.gz
+source=(ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${pkgver}.tar.gz
         cyrus-sasl-2.1.19-checkpw.c.patch
         cyrus-sasl-2.1.22-crypt.patch
         cyrus-sasl-2.1.22-qa.patch
@@ -35,7 +35,7 @@
         0030-dont_use_la_files_for_opening_plugins.patch
         saslauthd.conf.d
         saslauthd)
-md5sums=('2eb0e48106f0e9cd8001e654f267ecbc'
+md5sums=('a7f4e5e559a0e37b3ffc438c9456e425'
          'e27ddff076342e7a3041c4759817d04b'
          'd7e6886e88af04d05f3dec7f0a59ccf7'
          '79b8a5e8689989e2afd4b7bda595a7b1'
@@ -57,25 +57,28 @@
          '75542f613185d5a90520ad0d7d926a20')
 
 build() {
+  export CFLAGS="$CFLAGS -fPIC"
+ 
   cd "${srcdir}/cyrus-sasl-${pkgver}"
-  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.19-checkpw.c.patch"
-  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.22-crypt.patch"
+#  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.19-checkpw.c.patch"
+#  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.22-crypt.patch"
   patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.22-qa.patch"
-  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.22-automake-1.10.patch"
-  patch -Np0 -i "${srcdir}/cyrus-sasl-2.1.23-authd-fix.patch"
-  patch -Np1 -i "${srcdir}/0003_saslauthd_mdoc.patch"
+#  patch -Np1 -i "${srcdir}/cyrus-sasl-2.1.22-automake-1.10.patch"
+#  patch -Np0 -i "${srcdir}/cyrus-sasl-2.1.23-authd-fix.patch"
+#  patch -Np1 -i "${srcdir}/0003_saslauthd_mdoc.patch"
   patch -Np1 -i "${srcdir}/0010_maintainer_mode.patch"
   patch -Np1 -i "${srcdir}/0011_saslauthd_ac_prog_libtool.patch"
-  patch -Np1 -i "${srcdir}/0012_xopen_crypt_prototype.patch"
-  patch -Np1 -i "${srcdir}/0016_pid_file_lock_creation_mask.patch"
-  patch -Np1 -i "${srcdir}/0018_auth_rimap_quotes.patch"
-  patch -Np1 -i "${srcdir}/0019_ldap_deprecated.patch"
-  patch -Np1 -i "${srcdir}/0022_gcc4.4_preprocessor_syntax.patch"
+#  patch -Np1 -i "${srcdir}/0012_xopen_crypt_prototype.patch"
+#  patch -Np1 -i "${srcdir}/0016_pid_file_lock_creation_mask.patch"
+#  patch -Np1 -i "${srcdir}/0018_auth_rimap_quotes.patch"
+#  patch -Np1 -i "${srcdir}/0019_ldap_deprecated.patch"
+#  patch -Np1 -i "${srcdir}/0022_gcc4.4_preprocessor_syntax.patch"
   patch -Np1 -i "${srcdir}/0025_ld_as_needed.patch"
   patch -Np1 -i "${srcdir}/0026_drop_krb5support_dependency.patch"
-  patch -Np1 -i "${srcdir}/0027_db5_support.patch"
+#  patch -Np1 -i "${srcdir}/0027_db5_support.patch"
   patch -Np1 -i "${srcdir}/0030-dont_use_la_files_for_opening_plugins.patch"
 
+  sed 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.in
   rm -f config/config.guess config/config.sub 
   rm -f config/ltconfig config/ltmain.sh config/libtool.m4
   rm -fr autom4te.cache
@@ -130,7 +133,7 @@
 
 package_libsasl() {
   pkgdesc="Cyrus Simple Authentication Service Layer (SASL) Library"
-  depends=('openssl')
+  depends=('openssl' 'krb5')
   conflicts=('cyrus-sasl-plugins')
 
   cd "${srcdir}/cyrus-sasl-${pkgver}"



More information about the arch-commits mailing list