[arch-commits] Commit in nvidia-lts/repos (8 files)

Ionuț Mircea Bîru ioni at nymeria.archlinux.org
Tue May 28 05:36:20 EDT 2013


    Date: Tuesday, May 28, 2013 @ 11:36:20
  Author: ioni
Revision: 186509

archrelease: copy trunk to extra-i686, extra-x86_64

Added:
  nvidia-lts/repos/extra-i686/PKGBUILD
    (from rev 186508, nvidia-lts/trunk/PKGBUILD)
  nvidia-lts/repos/extra-i686/nvidia-lts.install
    (from rev 186508, nvidia-lts/trunk/nvidia-lts.install)
  nvidia-lts/repos/extra-x86_64/PKGBUILD
    (from rev 186508, nvidia-lts/trunk/PKGBUILD)
  nvidia-lts/repos/extra-x86_64/nvidia-lts.install
    (from rev 186508, nvidia-lts/trunk/nvidia-lts.install)
Deleted:
  nvidia-lts/repos/extra-i686/PKGBUILD
  nvidia-lts/repos/extra-i686/nvidia-lts.install
  nvidia-lts/repos/extra-x86_64/PKGBUILD
  nvidia-lts/repos/extra-x86_64/nvidia-lts.install

---------------------------------+
 /PKGBUILD                       |   88 ++++++++++++++++++++++++++++++++++++++
 /nvidia-lts.install             |   30 ++++++++++++
 extra-i686/PKGBUILD             |   44 -------------------
 extra-i686/nvidia-lts.install   |   15 ------
 extra-x86_64/PKGBUILD           |   44 -------------------
 extra-x86_64/nvidia-lts.install |   15 ------
 6 files changed, 118 insertions(+), 118 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2013-05-28 09:35:12 UTC (rev 186508)
+++ extra-i686/PKGBUILD	2013-05-28 09:36:20 UTC (rev 186509)
@@ -1,44 +0,0 @@
-# $Id$
-# Maintainer: Eric Bélanger <eric at archlinux.org>
-
-pkgname=nvidia-lts
-pkgver=319.17
-_extramodules=extramodules-3.0-lts
-pkgrel=1
-pkgdesc="NVIDIA drivers for linux-lts"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
-makedepends=('linux-lts-headers>=3.0.0')
-provides=('nvidia')
-license=('custom')
-install=nvidia-lts.install
-options=(!strip)
-if [ "$CARCH" = "i686" ]; then
-  _arch='x86'
-  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
-  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-  md5sums=('993eee683aea53b7965a853ccde3d740')
-elif [ "$CARCH" = "x86_64" ]; then
-  _arch='x86_64'
-  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
-  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-  md5sums=('4dda9b3e5c24136bebfaad122715c202')
-fi
-
-build() {
-  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-  sh ${_pkg}.run --extract-only
-  cd "${_pkg}/kernel"
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-}
-
-package() {
-  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
-}

Copied: nvidia-lts/repos/extra-i686/PKGBUILD (from rev 186508, nvidia-lts/trunk/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2013-05-28 09:36:20 UTC (rev 186509)
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-lts
+pkgver=319.23
+_extramodules=extramodules-3.0-lts
+pkgrel=1
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
+makedepends=('linux-lts-headers>=3.0.0')
+provides=('nvidia')
+license=('custom')
+install=nvidia-lts.install
+options=(!strip)
+if [ "$CARCH" = "i686" ]; then
+  _arch='x86'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('cbdca80e11b643aa46bded82abe43754')
+elif [ "$CARCH" = "x86_64" ]; then
+  _arch='x86_64'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('74edd76b4bb9229f7d9c00a79f1e3860')
+fi
+
+build() {
+  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+  sh ${_pkg}.run --extract-only
+  cd "${_pkg}/kernel"
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+}
+
+package() {
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Deleted: extra-i686/nvidia-lts.install
===================================================================
--- extra-i686/nvidia-lts.install	2013-05-28 09:35:12 UTC (rev 186508)
+++ extra-i686/nvidia-lts.install	2013-05-28 09:36:20 UTC (rev 186509)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-lts/repos/extra-i686/nvidia-lts.install (from rev 186508, nvidia-lts/trunk/nvidia-lts.install)
===================================================================
--- extra-i686/nvidia-lts.install	                        (rev 0)
+++ extra-i686/nvidia-lts.install	2013-05-28 09:36:20 UTC (rev 186509)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2013-05-28 09:35:12 UTC (rev 186508)
+++ extra-x86_64/PKGBUILD	2013-05-28 09:36:20 UTC (rev 186509)
@@ -1,44 +0,0 @@
-# $Id$
-# Maintainer: Eric Bélanger <eric at archlinux.org>
-
-pkgname=nvidia-lts
-pkgver=319.17
-_extramodules=extramodules-3.0-lts
-pkgrel=1
-pkgdesc="NVIDIA drivers for linux-lts"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
-makedepends=('linux-lts-headers>=3.0.0')
-provides=('nvidia')
-license=('custom')
-install=nvidia-lts.install
-options=(!strip)
-if [ "$CARCH" = "i686" ]; then
-  _arch='x86'
-  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
-  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-  md5sums=('993eee683aea53b7965a853ccde3d740')
-elif [ "$CARCH" = "x86_64" ]; then
-  _arch='x86_64'
-  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
-  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-  md5sums=('4dda9b3e5c24136bebfaad122715c202')
-fi
-
-build() {
-  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-  sh ${_pkg}.run --extract-only
-  cd "${_pkg}/kernel"
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-}
-
-package() {
-  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
-}

Copied: nvidia-lts/repos/extra-x86_64/PKGBUILD (from rev 186508, nvidia-lts/trunk/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2013-05-28 09:36:20 UTC (rev 186509)
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-lts
+pkgver=319.23
+_extramodules=extramodules-3.0-lts
+pkgrel=1
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux-lts>=3.0.0' "nvidia-utils=$pkgver")
+makedepends=('linux-lts-headers>=3.0.0')
+provides=('nvidia')
+license=('custom')
+install=nvidia-lts.install
+options=(!strip)
+if [ "$CARCH" = "i686" ]; then
+  _arch='x86'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('cbdca80e11b643aa46bded82abe43754')
+elif [ "$CARCH" = "x86_64" ]; then
+  _arch='x86_64'
+  _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+  source=("ftp://download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+  md5sums=('74edd76b4bb9229f7d9c00a79f1e3860')
+fi
+
+build() {
+  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+  sh ${_pkg}.run --extract-only
+  cd "${_pkg}/kernel"
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+}
+
+package() {
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Deleted: extra-x86_64/nvidia-lts.install
===================================================================
--- extra-x86_64/nvidia-lts.install	2013-05-28 09:35:12 UTC (rev 186508)
+++ extra-x86_64/nvidia-lts.install	2013-05-28 09:36:20 UTC (rev 186509)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.0-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-lts/repos/extra-x86_64/nvidia-lts.install (from rev 186508, nvidia-lts/trunk/nvidia-lts.install)
===================================================================
--- extra-x86_64/nvidia-lts.install	                        (rev 0)
+++ extra-x86_64/nvidia-lts.install	2013-05-28 09:36:20 UTC (rev 186509)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.0-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}



More information about the arch-commits mailing list