[arch-commits] Commit in digikam/repos (14 files)

Ronald van Haren ronald at archlinux.org
Mon Nov 3 12:36:27 UTC 2014


    Date: Monday, November 3, 2014 @ 13:36:27
  Author: ronald
Revision: 225565

archrelease: copy trunk to extra-i686, extra-x86_64

Added:
  digikam/repos/extra-i686/PKGBUILD
    (from rev 225564, digikam/trunk/PKGBUILD)
  digikam/repos/extra-i686/digikam.install
    (from rev 225564, digikam/trunk/digikam.install)
  digikam/repos/extra-i686/digikam_libkexiv2.patch
    (from rev 225564, digikam/trunk/digikam_libkexiv2.patch)
  digikam/repos/extra-i686/kipi-plugins.install
    (from rev 225564, digikam/trunk/kipi-plugins.install)
  digikam/repos/extra-x86_64/PKGBUILD
    (from rev 225564, digikam/trunk/PKGBUILD)
  digikam/repos/extra-x86_64/digikam.install
    (from rev 225564, digikam/trunk/digikam.install)
  digikam/repos/extra-x86_64/digikam_libkexiv2.patch
    (from rev 225564, digikam/trunk/digikam_libkexiv2.patch)
  digikam/repos/extra-x86_64/kipi-plugins.install
    (from rev 225564, digikam/trunk/kipi-plugins.install)
Deleted:
  digikam/repos/extra-i686/PKGBUILD
  digikam/repos/extra-i686/digikam.install
  digikam/repos/extra-i686/kipi-plugins.install
  digikam/repos/extra-x86_64/PKGBUILD
  digikam/repos/extra-x86_64/digikam.install
  digikam/repos/extra-x86_64/kipi-plugins.install

--------------------------------------+
 /PKGBUILD                            |  244 +++++++++++++++++++++++++++++++++
 /digikam.install                     |   24 +++
 /kipi-plugins.install                |   24 +++
 extra-i686/PKGBUILD                  |  119 ----------------
 extra-i686/digikam.install           |   12 -
 extra-i686/digikam_libkexiv2.patch   |   53 +++++++
 extra-i686/kipi-plugins.install      |   12 -
 extra-x86_64/PKGBUILD                |  119 ----------------
 extra-x86_64/digikam.install         |   12 -
 extra-x86_64/digikam_libkexiv2.patch |   53 +++++++
 extra-x86_64/kipi-plugins.install    |   12 -
 11 files changed, 398 insertions(+), 286 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-i686/PKGBUILD	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,119 +0,0 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald at archlinux.org>
-# Contributor: Andrea Scarpino <andrea at archlinux.org>
-# Contributor: Tobias Powalowski <tpowa at archlinux.org>
-
-pkgbase=digikam
-pkgname=('digikam' 'kipi-plugins' 'libkface' 'libkgeomap' 'libkvkontakte' 'libmediawiki')
-pkgver=4.2.0
-pkgrel=3
-pkgdesc="Digital photo management application for KDE"
-arch=('i686' 'x86_64')
-license=('GPL')
-url="http://www.digikam.org/"
-makedepends=('kdepimlibs' 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane' 'liblqr'
-             'kdeedu-marble' 'opencv' 'boost' 'libgpod' 'qjson' 'hugin' 'libgphoto2'
-             'cmake' 'automoc4' 'doxygen' 'lensfun' 'qt-gstreamer' 'imagemagick' 'eigen')
-source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-sha1sums=('4a54136629bed3b30cf4e9355e8d5b498b0d4e54')
-
-prepare() {
-  mkdir build
-}
-
-build() {
-  cd build
-  cmake ../${pkgname}-${pkgver} \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DCMAKE_BUILD_TYPE=Release \
-    -DCMAKE_SKIP_RPATH=ON \
-    -DBUILD_tests=OFF \
-    -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF
-  make
-}
-
-package_digikam() {
-  pkgdesc="Digital photo management application for KDE"
-  depends=('kdebase-runtime' 'kdepimlibs' 'libgphoto2' 'opencv' 'liblqr'
-           'libkipi' 'libkexiv2' 'libkdcraw' 'libkface' 'libkgeomap' 'lensfun')
-  optdepends=('kipi-plugins: more tools and plugins' 'kdebase-workspace: Theme configuration dialog')
-  install=digikam.install
-
-  cd build/core
-  make DESTDIR="${pkgdir}" install
-  cd ../../build/doc
-  make DESTDIR="${pkgdir}" install
-  cd ../../build/po
-  make DESTDIR="${pkgdir}" install
-
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap*.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}
-
-package_libkface() {
-  pkgdesc="A Qt/C++ wrapper around LibFace library to perform face recognition and detection over pictures"
-  depends=('kdelibs' 'opencv')
-
-  cd build/extra/libkface
-  make DESTDIR="${pkgdir}" install
-}
-
-package_libkgeomap() {
-  pkgdesc="A wrapper around world map components for browsing and arranging photos on a map"
-  depends=('kdelibs' 'kdeedu-marble')
-
-  cd build/extra/libkgeomap
-  make DESTDIR="${pkgdir}" install
-
-  cd ../../../build/po
-  make DESTDIR="${pkgdir}" install
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}
-
-package_libkvkontakte() {
-  pkgdesc="KDE C++ library for asynchronous interaction with vkontakte.rusocial network"
-  depends=('kdelibs' 'qjson')
-
-  cd build/extra/libkvkontakte
-  make DESTDIR="${pkgdir}" install
-}
-
-package_libmediawiki() {
-  pkgdesc="A KDE C++ interface for MediaWiki based web service as wikipedia.org"
-  depends=('kdelibs')
-
-  cd build/extra/libmediawiki
-  make DESTDIR="${pkgdir}" install
-}
-
-package_kipi-plugins() {
-  pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
-  depends=('kdebase-runtime' 'kdepimlibs' 'libkdcraw' 'libkipi' 'libksane' 'libkexiv2')
-  optdepends=('libkgeomap: Geolocalize tool'
-              'libmediawiki: MediaWiki Export plugin'
-              'libkvkontakte: VKontakte.ru Exporter plugin'
-              'libgpod: iPodExport plugin'
-              'opencv: Remove Red Eyes plugin'
-              'imagemagick: Video SlideShow plugin'
-              'qt-gstreamer: Video SlideShow plugin')
-  options=('staticlibs')
-  install=kipi-plugins.install
-
-  cd build/extra/kipi-plugins
-  make DESTDIR="${pkgdir}" install
-
-  cd ../../../build/po
-  make DESTDIR="${pkgdir}" install
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}

Copied: digikam/repos/extra-i686/PKGBUILD (from rev 225564, digikam/trunk/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,122 @@
+# $Id$
+# Maintainer: Ronald van Haren <ronald at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Tobias Powalowski <tpowa at archlinux.org>
+
+pkgbase=digikam
+pkgname=('digikam' 'kipi-plugins' 'libkface' 'libkgeomap' 'libkvkontakte' 'libmediawiki')
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Digital photo management application for KDE"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.digikam.org/"
+makedepends=('kdepimlibs' 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane' 'liblqr'
+             'kdeedu-marble' 'opencv' 'boost' 'libgpod' 'qjson' 'hugin' 'libgphoto2'
+             'cmake' 'automoc4' 'doxygen' 'lensfun' 'qt-gstreamer' 'imagemagick' 'eigen')
+source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.bz2" "digikam_libkexiv2.patch")
+sha1sums=('1feb43120addda314e09761440ec2058e430171c'
+          '39a09a8e7de1612eb47f3ef0966c6fa02b7e3284')
+
+prepare() {
+  mkdir build
+  cd ${pkgname}-${pkgver}/core
+  patch -Np1 -i "${srcdir}/digikam_libkexiv2.patch"
+}
+
+build() {
+  cd build
+  cmake ../${pkgname}-${pkgver} \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_SKIP_RPATH=ON \
+    -DBUILD_tests=OFF \
+    -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF
+  make
+}
+
+package_digikam() {
+  pkgdesc="Digital photo management application for KDE"
+  depends=('kdebase-runtime' 'kdepimlibs' 'libgphoto2' 'opencv' 'liblqr'
+           'libkipi' 'libkexiv2' 'libkdcraw' 'libkface' 'libkgeomap' 'lensfun')
+  optdepends=('kipi-plugins: more tools and plugins' 'kdebase-workspace: Theme configuration dialog')
+  install=digikam.install
+
+  cd build/core
+  make DESTDIR="${pkgdir}" install
+  cd ../../build/doc
+  make DESTDIR="${pkgdir}" install
+  cd ../../build/po
+  make DESTDIR="${pkgdir}" install
+
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap*.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}
+
+package_libkface() {
+  pkgdesc="A Qt/C++ wrapper around LibFace library to perform face recognition and detection over pictures"
+  depends=('kdelibs' 'opencv')
+
+  cd build/extra/libkface
+  make DESTDIR="${pkgdir}" install
+}
+
+package_libkgeomap() {
+  pkgdesc="A wrapper around world map components for browsing and arranging photos on a map"
+  depends=('kdelibs' 'kdeedu-marble')
+
+  cd build/extra/libkgeomap
+  make DESTDIR="${pkgdir}" install
+
+  cd ../../../build/po
+  make DESTDIR="${pkgdir}" install
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}
+
+package_libkvkontakte() {
+  pkgdesc="KDE C++ library for asynchronous interaction with vkontakte.rusocial network"
+  depends=('kdelibs' 'qjson')
+
+  cd build/extra/libkvkontakte
+  make DESTDIR="${pkgdir}" install
+}
+
+package_libmediawiki() {
+  pkgdesc="A KDE C++ interface for MediaWiki based web service as wikipedia.org"
+  depends=('kdelibs')
+
+  cd build/extra/libmediawiki
+  make DESTDIR="${pkgdir}" install
+}
+
+package_kipi-plugins() {
+  pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
+  depends=('kdebase-runtime' 'kdepimlibs' 'libkdcraw' 'libkipi' 'libksane' 'libkexiv2')
+  optdepends=('libkgeomap: Geolocalize tool'
+              'libmediawiki: MediaWiki Export plugin'
+              'libkvkontakte: VKontakte.ru Exporter plugin'
+              'libgpod: iPodExport plugin'
+              'opencv: Remove Red Eyes plugin'
+              'imagemagick: Video SlideShow plugin'
+              'qt-gstreamer: Video SlideShow plugin')
+  options=('staticlibs')
+  install=kipi-plugins.install
+
+  cd build/extra/kipi-plugins
+  make DESTDIR="${pkgdir}" install
+
+  cd ../../../build/po
+  make DESTDIR="${pkgdir}" install
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}

Deleted: extra-i686/digikam.install
===================================================================
--- extra-i686/digikam.install	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-i686/digikam.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,12 +0,0 @@
-post_install() {
-	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
-    update-desktop-database -q
-}
-
-post_upgrade() {
-	post_install
-}
-
-post_remove() {
-	post_install
-}

Copied: digikam/repos/extra-i686/digikam.install (from rev 225564, digikam/trunk/digikam.install)
===================================================================
--- extra-i686/digikam.install	                        (rev 0)
+++ extra-i686/digikam.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,12 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}

Copied: digikam/repos/extra-i686/digikam_libkexiv2.patch (from rev 225564, digikam/trunk/digikam_libkexiv2.patch)
===================================================================
--- extra-i686/digikam_libkexiv2.patch	                        (rev 0)
+++ extra-i686/digikam_libkexiv2.patch	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,53 @@
+commit f6945f23e0ed1e11f26e2c7e62b02baa8cfa640e
+Author: Pino Toscano <pino at kde.org>
+Date:   Tue Oct 14 22:26:19 2014 +0200
+
+    fix libkexiv2 version for AltLangStrEdit::textEdit()
+    
+    it is part of current libkexiv2/master only (i.e. post 4.14.x, which
+    is 2.3.x)
+
+diff --git a/libs/imageproperties/captionedit.cpp b/libs/imageproperties/captionedit.cpp
+index 88413fc..70bdb6d 100644
+--- a/libs/imageproperties/captionedit.cpp
++++ b/libs/imageproperties/captionedit.cpp
+@@ -202,7 +202,7 @@ void CaptionEdit::slotAuthorChanged(const QString& text)
+ 
+ MsgTextEdit* CaptionEdit::textEdit() const
+ {
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     return d->altLangStrEdit->textEdit();
+ #else
+     return 0;
+diff --git a/libs/imageproperties/imagedescedittab.cpp b/libs/imageproperties/imagedescedittab.cpp
+index ebfbae1..3d12777 100644
+--- a/libs/imageproperties/imagedescedittab.cpp
++++ b/libs/imageproperties/imagedescedittab.cpp
+@@ -429,7 +429,7 @@ ImageDescEditTab::ImageDescEditTab(QWidget* const parent)
+ 
+     // Initialize ---------------------------------------------
+ 
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->titleEdit->textEdit()->installEventFilter(this);
+     d->captionsEdit->textEdit()->installEventFilter(this);
+ #endif
+@@ -532,7 +532,7 @@ void ImageDescEditTab::setFocusToNewTagEdit()
+ void ImageDescEditTab::setFocusToTitlesEdit()
+ {
+     d->tabWidget->setCurrentIndex(Private::DESCRIPTIONS);
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->titleEdit->textEdit()->setFocus();
+ #endif
+ }
+@@ -540,7 +540,7 @@ void ImageDescEditTab::setFocusToTitlesEdit()
+ void ImageDescEditTab::setFocusToCommentsEdit()
+ {
+     d->tabWidget->setCurrentIndex(Private::DESCRIPTIONS);
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->captionsEdit->textEdit()->setFocus();
+ #endif
+ }

Deleted: extra-i686/kipi-plugins.install
===================================================================
--- extra-i686/kipi-plugins.install	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-i686/kipi-plugins.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,12 +0,0 @@
-post_install() {
-	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
-    update-desktop-database -q
-}
-
-post_upgrade() {
-	post_install
-}
-
-post_remove() {
-	post_install
-}

Copied: digikam/repos/extra-i686/kipi-plugins.install (from rev 225564, digikam/trunk/kipi-plugins.install)
===================================================================
--- extra-i686/kipi-plugins.install	                        (rev 0)
+++ extra-i686/kipi-plugins.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,12 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-x86_64/PKGBUILD	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,119 +0,0 @@
-# $Id$
-# Maintainer: Ronald van Haren <ronald at archlinux.org>
-# Contributor: Andrea Scarpino <andrea at archlinux.org>
-# Contributor: Tobias Powalowski <tpowa at archlinux.org>
-
-pkgbase=digikam
-pkgname=('digikam' 'kipi-plugins' 'libkface' 'libkgeomap' 'libkvkontakte' 'libmediawiki')
-pkgver=4.2.0
-pkgrel=3
-pkgdesc="Digital photo management application for KDE"
-arch=('i686' 'x86_64')
-license=('GPL')
-url="http://www.digikam.org/"
-makedepends=('kdepimlibs' 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane' 'liblqr'
-             'kdeedu-marble' 'opencv' 'boost' 'libgpod' 'qjson' 'hugin' 'libgphoto2'
-             'cmake' 'automoc4' 'doxygen' 'lensfun' 'qt-gstreamer' 'imagemagick' 'eigen')
-source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
-sha1sums=('4a54136629bed3b30cf4e9355e8d5b498b0d4e54')
-
-prepare() {
-  mkdir build
-}
-
-build() {
-  cd build
-  cmake ../${pkgname}-${pkgver} \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DCMAKE_BUILD_TYPE=Release \
-    -DCMAKE_SKIP_RPATH=ON \
-    -DBUILD_tests=OFF \
-    -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF
-  make
-}
-
-package_digikam() {
-  pkgdesc="Digital photo management application for KDE"
-  depends=('kdebase-runtime' 'kdepimlibs' 'libgphoto2' 'opencv' 'liblqr'
-           'libkipi' 'libkexiv2' 'libkdcraw' 'libkface' 'libkgeomap' 'lensfun')
-  optdepends=('kipi-plugins: more tools and plugins' 'kdebase-workspace: Theme configuration dialog')
-  install=digikam.install
-
-  cd build/core
-  make DESTDIR="${pkgdir}" install
-  cd ../../build/doc
-  make DESTDIR="${pkgdir}" install
-  cd ../../build/po
-  make DESTDIR="${pkgdir}" install
-
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap*.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}
-
-package_libkface() {
-  pkgdesc="A Qt/C++ wrapper around LibFace library to perform face recognition and detection over pictures"
-  depends=('kdelibs' 'opencv')
-
-  cd build/extra/libkface
-  make DESTDIR="${pkgdir}" install
-}
-
-package_libkgeomap() {
-  pkgdesc="A wrapper around world map components for browsing and arranging photos on a map"
-  depends=('kdelibs' 'kdeedu-marble')
-
-  cd build/extra/libkgeomap
-  make DESTDIR="${pkgdir}" install
-
-  cd ../../../build/po
-  make DESTDIR="${pkgdir}" install
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}
-
-package_libkvkontakte() {
-  pkgdesc="KDE C++ library for asynchronous interaction with vkontakte.rusocial network"
-  depends=('kdelibs' 'qjson')
-
-  cd build/extra/libkvkontakte
-  make DESTDIR="${pkgdir}" install
-}
-
-package_libmediawiki() {
-  pkgdesc="A KDE C++ interface for MediaWiki based web service as wikipedia.org"
-  depends=('kdelibs')
-
-  cd build/extra/libmediawiki
-  make DESTDIR="${pkgdir}" install
-}
-
-package_kipi-plugins() {
-  pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
-  depends=('kdebase-runtime' 'kdepimlibs' 'libkdcraw' 'libkipi' 'libksane' 'libkexiv2')
-  optdepends=('libkgeomap: Geolocalize tool'
-              'libmediawiki: MediaWiki Export plugin'
-              'libkvkontakte: VKontakte.ru Exporter plugin'
-              'libgpod: iPodExport plugin'
-              'opencv: Remove Red Eyes plugin'
-              'imagemagick: Video SlideShow plugin'
-              'qt-gstreamer: Video SlideShow plugin')
-  options=('staticlibs')
-  install=kipi-plugins.install
-
-  cd build/extra/kipi-plugins
-  make DESTDIR="${pkgdir}" install
-
-  cd ../../../build/po
-  make DESTDIR="${pkgdir}" install
-  # Put these in the relevant splitted packages
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap.mo
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
-  # Fix conflicts with kde-l10n-* (FS#33762)
-  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
-}

Copied: digikam/repos/extra-x86_64/PKGBUILD (from rev 225564, digikam/trunk/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,122 @@
+# $Id$
+# Maintainer: Ronald van Haren <ronald at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Tobias Powalowski <tpowa at archlinux.org>
+
+pkgbase=digikam
+pkgname=('digikam' 'kipi-plugins' 'libkface' 'libkgeomap' 'libkvkontakte' 'libmediawiki')
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Digital photo management application for KDE"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.digikam.org/"
+makedepends=('kdepimlibs' 'libkexiv2' 'libkdcraw' 'libkipi' 'libksane' 'liblqr'
+             'kdeedu-marble' 'opencv' 'boost' 'libgpod' 'qjson' 'hugin' 'libgphoto2'
+             'cmake' 'automoc4' 'doxygen' 'lensfun' 'qt-gstreamer' 'imagemagick' 'eigen')
+source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.bz2" "digikam_libkexiv2.patch")
+sha1sums=('1feb43120addda314e09761440ec2058e430171c'
+          '39a09a8e7de1612eb47f3ef0966c6fa02b7e3284')
+
+prepare() {
+  mkdir build
+  cd ${pkgname}-${pkgver}/core
+  patch -Np1 -i "${srcdir}/digikam_libkexiv2.patch"
+}
+
+build() {
+  cd build
+  cmake ../${pkgname}-${pkgver} \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DCMAKE_BUILD_TYPE=Release \
+    -DCMAKE_SKIP_RPATH=ON \
+    -DBUILD_tests=OFF \
+    -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=OFF
+  make
+}
+
+package_digikam() {
+  pkgdesc="Digital photo management application for KDE"
+  depends=('kdebase-runtime' 'kdepimlibs' 'libgphoto2' 'opencv' 'liblqr'
+           'libkipi' 'libkexiv2' 'libkdcraw' 'libkface' 'libkgeomap' 'lensfun')
+  optdepends=('kipi-plugins: more tools and plugins' 'kdebase-workspace: Theme configuration dialog')
+  install=digikam.install
+
+  cd build/core
+  make DESTDIR="${pkgdir}" install
+  cd ../../build/doc
+  make DESTDIR="${pkgdir}" install
+  cd ../../build/po
+  make DESTDIR="${pkgdir}" install
+
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap*.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}
+
+package_libkface() {
+  pkgdesc="A Qt/C++ wrapper around LibFace library to perform face recognition and detection over pictures"
+  depends=('kdelibs' 'opencv')
+
+  cd build/extra/libkface
+  make DESTDIR="${pkgdir}" install
+}
+
+package_libkgeomap() {
+  pkgdesc="A wrapper around world map components for browsing and arranging photos on a map"
+  depends=('kdelibs' 'kdeedu-marble')
+
+  cd build/extra/libkgeomap
+  make DESTDIR="${pkgdir}" install
+
+  cd ../../../build/po
+  make DESTDIR="${pkgdir}" install
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/kipiplugin*.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}
+
+package_libkvkontakte() {
+  pkgdesc="KDE C++ library for asynchronous interaction with vkontakte.rusocial network"
+  depends=('kdelibs' 'qjson')
+
+  cd build/extra/libkvkontakte
+  make DESTDIR="${pkgdir}" install
+}
+
+package_libmediawiki() {
+  pkgdesc="A KDE C++ interface for MediaWiki based web service as wikipedia.org"
+  depends=('kdelibs')
+
+  cd build/extra/libmediawiki
+  make DESTDIR="${pkgdir}" install
+}
+
+package_kipi-plugins() {
+  pkgdesc="A collection of plugins extending the KDE graphics and image applications as digiKam"
+  depends=('kdebase-runtime' 'kdepimlibs' 'libkdcraw' 'libkipi' 'libksane' 'libkexiv2')
+  optdepends=('libkgeomap: Geolocalize tool'
+              'libmediawiki: MediaWiki Export plugin'
+              'libkvkontakte: VKontakte.ru Exporter plugin'
+              'libgpod: iPodExport plugin'
+              'opencv: Remove Red Eyes plugin'
+              'imagemagick: Video SlideShow plugin'
+              'qt-gstreamer: Video SlideShow plugin')
+  options=('staticlibs')
+  install=kipi-plugins.install
+
+  cd build/extra/kipi-plugins
+  make DESTDIR="${pkgdir}" install
+
+  cd ../../../build/po
+  make DESTDIR="${pkgdir}" install
+  # Put these in the relevant splitted packages
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkgeomap.mo
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/digikam.mo
+  # Fix conflicts with kde-l10n-* (FS#33762)
+  rm "${pkgdir}"/usr/share/locale/kde4/*/LC_MESSAGES/libkipi.mo
+}

Deleted: extra-x86_64/digikam.install
===================================================================
--- extra-x86_64/digikam.install	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-x86_64/digikam.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,12 +0,0 @@
-post_install() {
-	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
-    update-desktop-database -q
-}
-
-post_upgrade() {
-	post_install
-}
-
-post_remove() {
-	post_install
-}

Copied: digikam/repos/extra-x86_64/digikam.install (from rev 225564, digikam/trunk/digikam.install)
===================================================================
--- extra-x86_64/digikam.install	                        (rev 0)
+++ extra-x86_64/digikam.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,12 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}

Copied: digikam/repos/extra-x86_64/digikam_libkexiv2.patch (from rev 225564, digikam/trunk/digikam_libkexiv2.patch)
===================================================================
--- extra-x86_64/digikam_libkexiv2.patch	                        (rev 0)
+++ extra-x86_64/digikam_libkexiv2.patch	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,53 @@
+commit f6945f23e0ed1e11f26e2c7e62b02baa8cfa640e
+Author: Pino Toscano <pino at kde.org>
+Date:   Tue Oct 14 22:26:19 2014 +0200
+
+    fix libkexiv2 version for AltLangStrEdit::textEdit()
+    
+    it is part of current libkexiv2/master only (i.e. post 4.14.x, which
+    is 2.3.x)
+
+diff --git a/libs/imageproperties/captionedit.cpp b/libs/imageproperties/captionedit.cpp
+index 88413fc..70bdb6d 100644
+--- a/libs/imageproperties/captionedit.cpp
++++ b/libs/imageproperties/captionedit.cpp
+@@ -202,7 +202,7 @@ void CaptionEdit::slotAuthorChanged(const QString& text)
+ 
+ MsgTextEdit* CaptionEdit::textEdit() const
+ {
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     return d->altLangStrEdit->textEdit();
+ #else
+     return 0;
+diff --git a/libs/imageproperties/imagedescedittab.cpp b/libs/imageproperties/imagedescedittab.cpp
+index ebfbae1..3d12777 100644
+--- a/libs/imageproperties/imagedescedittab.cpp
++++ b/libs/imageproperties/imagedescedittab.cpp
+@@ -429,7 +429,7 @@ ImageDescEditTab::ImageDescEditTab(QWidget* const parent)
+ 
+     // Initialize ---------------------------------------------
+ 
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->titleEdit->textEdit()->installEventFilter(this);
+     d->captionsEdit->textEdit()->installEventFilter(this);
+ #endif
+@@ -532,7 +532,7 @@ void ImageDescEditTab::setFocusToNewTagEdit()
+ void ImageDescEditTab::setFocusToTitlesEdit()
+ {
+     d->tabWidget->setCurrentIndex(Private::DESCRIPTIONS);
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->titleEdit->textEdit()->setFocus();
+ #endif
+ }
+@@ -540,7 +540,7 @@ void ImageDescEditTab::setFocusToTitlesEdit()
+ void ImageDescEditTab::setFocusToCommentsEdit()
+ {
+     d->tabWidget->setCurrentIndex(Private::DESCRIPTIONS);
+-#if KEXIV2_VERSION >= 0x020302
++#if KEXIV2_VERSION >= 0x020400
+     d->captionsEdit->textEdit()->setFocus();
+ #endif
+ }

Deleted: extra-x86_64/kipi-plugins.install
===================================================================
--- extra-x86_64/kipi-plugins.install	2014-11-03 12:36:10 UTC (rev 225564)
+++ extra-x86_64/kipi-plugins.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -1,12 +0,0 @@
-post_install() {
-	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
-    update-desktop-database -q
-}
-
-post_upgrade() {
-	post_install
-}
-
-post_remove() {
-	post_install
-}

Copied: digikam/repos/extra-x86_64/kipi-plugins.install (from rev 225564, digikam/trunk/kipi-plugins.install)
===================================================================
--- extra-x86_64/kipi-plugins.install	                        (rev 0)
+++ extra-x86_64/kipi-plugins.install	2014-11-03 12:36:27 UTC (rev 225565)
@@ -0,0 +1,12 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}


More information about the arch-commits mailing list