[arch-commits] Commit in thrift/repos (4 files)

Anatol Pomozov anatolik at archlinux.org
Wed Nov 5 17:04:44 UTC 2014


    Date: Wednesday, November 5, 2014 @ 18:04:44
  Author: anatolik
Revision: 121969

archrelease: copy trunk to community-i686, community-x86_64

Added:
  thrift/repos/community-i686/PKGBUILD
    (from rev 121968, thrift/trunk/PKGBUILD)
  thrift/repos/community-x86_64/PKGBUILD
    (from rev 121968, thrift/trunk/PKGBUILD)
Deleted:
  thrift/repos/community-i686/PKGBUILD
  thrift/repos/community-x86_64/PKGBUILD

---------------------------+
 /PKGBUILD                 |  120 ++++++++++++++++++++++++++++++++++++++++++++
 community-i686/PKGBUILD   |   55 --------------------
 community-x86_64/PKGBUILD |   55 --------------------
 3 files changed, 120 insertions(+), 110 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2014-11-05 17:03:58 UTC (rev 121968)
+++ community-i686/PKGBUILD	2014-11-05 17:04:44 UTC (rev 121969)
@@ -1,55 +0,0 @@
-# $Id$
-# Maintainer: Anatol Pomozov
-# Contributor: Byron Clark <byron at theclarkfamily.name>
-
-# This package contains only thrift compiler and C/C++ libraries
-# for all the language binding one should use corresponding language-specific package manager:
-# CPAN for perl, gem for ruby, pip for python etc... Or better to create arch packages that install
-# the binding from the language specific managers python2-thrift, perl-thrift, ruby-thrift, ...
-
-pkgname=thrift
-pkgver=0.9.1
-pkgrel=2
-pkgdesc='Scalable cross-language services framework for IPC/RPC'
-arch=(i686 x86_64)
-url='http://thrift.apache.org/'
-license=(APACHE)
-depends=(gcc-libs openssl)
-makedepends=(boost libevent emacs-nox)
-source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz)
-sha1sums=('dc54a54f8dc706ffddcd3e8c6cd5301c931af1cc')
-
-build() {
-  cd thrift-$pkgver
-
-  export CPPFLAGS="$CPPFLAGS -O2 -fno-strict-aliasing"
-  # tests compilation is broken https://issues.apache.org/jira/browse/THRIFT-2545 enable tess with 0.9.2
-  ./configure --prefix=/usr \
-              --with-cpp \
-              --with-c_glib \
-              --without-haskell \
-              --without-php \
-              --without-ruby \
-              --without-python \
-              --without-erlang \
-              --without-perl \
-              --without-java \
-              --without-c_sharp \
-              --without-d \
-              --without-php \
-              --without-go \
-              --without-tests
-              
-  make
-
-  emacs -Q --batch -f batch-byte-compile contrib/thrift.el
-}
-
-package() {
-  cd thrift-$pkgver
-  make DESTDIR="$pkgdir" install
-
-  install -m0644 -D contrib/thrift.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/thrift.vim
-  install -m0644 -D contrib/thrift.el "$pkgdir"/usr/share/emacs/site-lisp/thrift.el
-  install -m0644 -D contrib/thrift.elc "$pkgdir"/usr/share/emacs/site-lisp/thrift.elc
-}

Copied: thrift/repos/community-i686/PKGBUILD (from rev 121968, thrift/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2014-11-05 17:04:44 UTC (rev 121969)
@@ -0,0 +1,60 @@
+# $Id$
+# Maintainer: Anatol Pomozov
+# Contributor: Byron Clark <byron at theclarkfamily.name>
+
+# This package contains only thrift compiler and C/C++ libraries
+# for all the language binding one should use corresponding language-specific package manager:
+# CPAN for perl, gem for ruby, pip for python etc... Or better to create arch packages that install
+# the binding from the language specific managers python2-thrift, perl-thrift, ruby-thrift, ...
+
+pkgname=thrift
+pkgver=0.9.1
+pkgrel=3
+pkgdesc='Scalable cross-language services framework for IPC/RPC'
+arch=(i686 x86_64)
+url='http://thrift.apache.org/'
+license=(APACHE)
+depends=(gcc-libs openssl)
+makedepends=(qt4 boost libevent emacs-nox)
+optdepends=(
+  'qt4: TQTcpServer support'
+)
+source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz)
+sha1sums=('dc54a54f8dc706ffddcd3e8c6cd5301c931af1cc')
+
+build() {
+  cd thrift-$pkgver
+
+  export CPPFLAGS="$CPPFLAGS -O2 -fno-strict-aliasing"
+  # tests compilation is broken https://issues.apache.org/jira/browse/THRIFT-2545 enable tess with 0.9.2
+  ./configure --prefix=/usr \
+              --with-cpp \
+              --with-c_glib \
+              --with-qt4 \
+              --with-libevent \
+              --without-haskell \
+              --without-php \
+              --without-ruby \
+              --without-python \
+              --without-erlang \
+              --without-perl \
+              --without-java \
+              --without-c_sharp \
+              --without-d \
+              --without-php \
+              --without-go \
+              --without-tests
+              
+  make
+
+  emacs -Q --batch -f batch-byte-compile contrib/thrift.el
+}
+
+package() {
+  cd thrift-$pkgver
+  make DESTDIR="$pkgdir" install
+
+  install -m0644 -D contrib/thrift.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/thrift.vim
+  install -m0644 -D contrib/thrift.el "$pkgdir"/usr/share/emacs/site-lisp/thrift.el
+  install -m0644 -D contrib/thrift.elc "$pkgdir"/usr/share/emacs/site-lisp/thrift.elc
+}

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2014-11-05 17:03:58 UTC (rev 121968)
+++ community-x86_64/PKGBUILD	2014-11-05 17:04:44 UTC (rev 121969)
@@ -1,55 +0,0 @@
-# $Id$
-# Maintainer: Anatol Pomozov
-# Contributor: Byron Clark <byron at theclarkfamily.name>
-
-# This package contains only thrift compiler and C/C++ libraries
-# for all the language binding one should use corresponding language-specific package manager:
-# CPAN for perl, gem for ruby, pip for python etc... Or better to create arch packages that install
-# the binding from the language specific managers python2-thrift, perl-thrift, ruby-thrift, ...
-
-pkgname=thrift
-pkgver=0.9.1
-pkgrel=2
-pkgdesc='Scalable cross-language services framework for IPC/RPC'
-arch=(i686 x86_64)
-url='http://thrift.apache.org/'
-license=(APACHE)
-depends=(gcc-libs openssl)
-makedepends=(boost libevent emacs-nox)
-source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz)
-sha1sums=('dc54a54f8dc706ffddcd3e8c6cd5301c931af1cc')
-
-build() {
-  cd thrift-$pkgver
-
-  export CPPFLAGS="$CPPFLAGS -O2 -fno-strict-aliasing"
-  # tests compilation is broken https://issues.apache.org/jira/browse/THRIFT-2545 enable tess with 0.9.2
-  ./configure --prefix=/usr \
-              --with-cpp \
-              --with-c_glib \
-              --without-haskell \
-              --without-php \
-              --without-ruby \
-              --without-python \
-              --without-erlang \
-              --without-perl \
-              --without-java \
-              --without-c_sharp \
-              --without-d \
-              --without-php \
-              --without-go \
-              --without-tests
-              
-  make
-
-  emacs -Q --batch -f batch-byte-compile contrib/thrift.el
-}
-
-package() {
-  cd thrift-$pkgver
-  make DESTDIR="$pkgdir" install
-
-  install -m0644 -D contrib/thrift.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/thrift.vim
-  install -m0644 -D contrib/thrift.el "$pkgdir"/usr/share/emacs/site-lisp/thrift.el
-  install -m0644 -D contrib/thrift.elc "$pkgdir"/usr/share/emacs/site-lisp/thrift.elc
-}

Copied: thrift/repos/community-x86_64/PKGBUILD (from rev 121968, thrift/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2014-11-05 17:04:44 UTC (rev 121969)
@@ -0,0 +1,60 @@
+# $Id$
+# Maintainer: Anatol Pomozov
+# Contributor: Byron Clark <byron at theclarkfamily.name>
+
+# This package contains only thrift compiler and C/C++ libraries
+# for all the language binding one should use corresponding language-specific package manager:
+# CPAN for perl, gem for ruby, pip for python etc... Or better to create arch packages that install
+# the binding from the language specific managers python2-thrift, perl-thrift, ruby-thrift, ...
+
+pkgname=thrift
+pkgver=0.9.1
+pkgrel=3
+pkgdesc='Scalable cross-language services framework for IPC/RPC'
+arch=(i686 x86_64)
+url='http://thrift.apache.org/'
+license=(APACHE)
+depends=(gcc-libs openssl)
+makedepends=(qt4 boost libevent emacs-nox)
+optdepends=(
+  'qt4: TQTcpServer support'
+)
+source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz)
+sha1sums=('dc54a54f8dc706ffddcd3e8c6cd5301c931af1cc')
+
+build() {
+  cd thrift-$pkgver
+
+  export CPPFLAGS="$CPPFLAGS -O2 -fno-strict-aliasing"
+  # tests compilation is broken https://issues.apache.org/jira/browse/THRIFT-2545 enable tess with 0.9.2
+  ./configure --prefix=/usr \
+              --with-cpp \
+              --with-c_glib \
+              --with-qt4 \
+              --with-libevent \
+              --without-haskell \
+              --without-php \
+              --without-ruby \
+              --without-python \
+              --without-erlang \
+              --without-perl \
+              --without-java \
+              --without-c_sharp \
+              --without-d \
+              --without-php \
+              --without-go \
+              --without-tests
+              
+  make
+
+  emacs -Q --batch -f batch-byte-compile contrib/thrift.el
+}
+
+package() {
+  cd thrift-$pkgver
+  make DESTDIR="$pkgdir" install
+
+  install -m0644 -D contrib/thrift.vim "$pkgdir"/usr/share/vim/vimfiles/syntax/thrift.vim
+  install -m0644 -D contrib/thrift.el "$pkgdir"/usr/share/emacs/site-lisp/thrift.el
+  install -m0644 -D contrib/thrift.elc "$pkgdir"/usr/share/emacs/site-lisp/thrift.elc
+}


More information about the arch-commits mailing list