[arch-commits] Commit in qupzilla/repos (8 files)

speps speps at archlinux.org
Thu Nov 6 00:37:25 UTC 2014


    Date: Thursday, November 6, 2014 @ 01:37:25
  Author: speps
Revision: 121993

archrelease: copy trunk to community-i686, community-x86_64

Added:
  qupzilla/repos/community-i686/PKGBUILD
    (from rev 121992, qupzilla/trunk/PKGBUILD)
  qupzilla/repos/community-i686/qupzilla.install
    (from rev 121992, qupzilla/trunk/qupzilla.install)
  qupzilla/repos/community-x86_64/PKGBUILD
    (from rev 121992, qupzilla/trunk/PKGBUILD)
  qupzilla/repos/community-x86_64/qupzilla.install
    (from rev 121992, qupzilla/trunk/qupzilla.install)
Deleted:
  qupzilla/repos/community-i686/PKGBUILD
  qupzilla/repos/community-i686/qupzilla.install
  qupzilla/repos/community-x86_64/PKGBUILD
  qupzilla/repos/community-x86_64/qupzilla.install

-----------------------------------+
 /PKGBUILD                         |  150 ++++++++++++++++++++++++++++++++++++
 /qupzilla.install                 |   24 +++++
 community-i686/PKGBUILD           |   75 ------------------
 community-i686/qupzilla.install   |   12 --
 community-x86_64/PKGBUILD         |   75 ------------------
 community-x86_64/qupzilla.install |   12 --
 6 files changed, 174 insertions(+), 174 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2014-11-06 00:37:07 UTC (rev 121992)
+++ community-i686/PKGBUILD	2014-11-06 00:37:25 UTC (rev 121993)
@@ -1,75 +0,0 @@
-# $Id$
-# Maintainer: speps <speps at aur dot archlinux dot org>
-
-pkgbase=qupzilla
-pkgname=(qupzilla qupzilla-qt4)
-pkgver=1.8.3
-pkgrel=1
-pkgdesc="Cross-platform QtWebKit browser"
-arch=(i686 x86_64)
-url="http://www.qupzilla.com/"
-license=('GPL3')
-makedepends=('qtwebkit' 'qt5-webkit' 'qt5-script' 'qt5-tools' 'hunspell' 'kdelibs' 'kwallet' 'libgnome-keyring')
-optdepends=('bash-completion: bash completion support')
-install="$pkgbase.install"
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/QupZilla/qupzilla/archive/v$pkgver.tar.gz")
-noextract=("$pkgbase-$pkgver.tar.gz")
-md5sums=('800f943279ab7269ea66765490a3a33a')
-
-prepare() {
-  # extract
-  mkdir -p qt{4,5}
-  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt4
-  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt5
-
-  # configure
-  export USE_WEBGL=true \
-         QUPZILLA_PREFIX=/usr/ \
-         KDE_INTEGRATION=true \
-         GNOME_INTEGRATION=true
-}
-
-build() {
-  cd qt4
-  qmake-qt4
-  make
-
-  cd ../qt5
-  qmake
-  make
-}
-
-package_qupzilla() {
-  pkgdesc+=" (Qt5)"
-  depends=('qt5-webkit' 'qt5-script' 'hunspell' 'desktop-file-utils' 'hicolor-icon-theme')
-  optdepends=('kwallet: kf5 kwallet integration'
-              'libgnome-keyring: gnome keyring integration')
-  provides=('qupzilla-qt5')
-  conflicts=('qupzilla-qt5')
-  replaces=('qupzilla-qt5')
-
-  cd qt5
-  make INSTALL_ROOT="$pkgdir/" install
-
-  # zsh completion
-  install -Dm644 linux/completion/_$pkgbase \
-    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
-}
-
-package_qupzilla-qt4() {
-  pkgdesc+=" (Qt4)"
-  depends=('qtwebkit' 'hunspell')
-  optdepends=('kdelibs: kwallet integration'
-              'libgnome-keyring: gnome keyring integration')
-  provides=('qupzilla')
-  conflicts=('qupzilla')
-
-  cd qt4
-  make INSTALL_ROOT="$pkgdir/" install
-
-  # zsh completion
-  install -Dm644 linux/completion/_$pkgbase \
-    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
-}
-
-# vim:set ts=2 sw=2 et:

Copied: qupzilla/repos/community-i686/PKGBUILD (from rev 121992, qupzilla/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2014-11-06 00:37:25 UTC (rev 121993)
@@ -0,0 +1,75 @@
+# $Id$
+# Maintainer: speps <speps at aur dot archlinux dot org>
+
+pkgbase=qupzilla
+pkgname=(qupzilla qupzilla-qt4)
+pkgver=1.8.4
+pkgrel=1
+pkgdesc="Cross-platform QtWebKit browser"
+arch=(i686 x86_64)
+url="http://www.qupzilla.com/"
+license=('GPL3')
+makedepends=('qtwebkit' 'qt5-webkit' 'qt5-script' 'qt5-tools' 'hunspell' 'kdelibs' 'kwallet' 'libgnome-keyring')
+optdepends=('bash-completion: bash completion support')
+install="$pkgbase.install"
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/QupZilla/qupzilla/archive/v$pkgver.tar.gz")
+noextract=("$pkgbase-$pkgver.tar.gz")
+md5sums=('88a679eb26a2071ac34c19ca0074a305')
+
+prepare() {
+  # extract
+  mkdir -p qt{4,5}
+  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt4
+  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt5
+
+  # configure
+  export USE_WEBGL=true \
+         QUPZILLA_PREFIX=/usr/ \
+         KDE_INTEGRATION=true \
+         GNOME_INTEGRATION=true
+}
+
+build() {
+  cd qt4
+  qmake-qt4
+  make
+
+  cd ../qt5
+  qmake
+  make
+}
+
+package_qupzilla() {
+  pkgdesc+=" (Qt5)"
+  depends=('qt5-webkit' 'qt5-script' 'hunspell' 'desktop-file-utils' 'hicolor-icon-theme')
+  optdepends=('kwallet: kf5 kwallet integration'
+              'libgnome-keyring: gnome keyring integration')
+  provides=('qupzilla-qt5')
+  conflicts=('qupzilla-qt5')
+  replaces=('qupzilla-qt5')
+
+  cd qt5
+  make INSTALL_ROOT="$pkgdir/" install
+
+  # zsh completion
+  install -Dm644 linux/completion/_$pkgbase \
+    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
+}
+
+package_qupzilla-qt4() {
+  pkgdesc+=" (Qt4)"
+  depends=('qtwebkit' 'hunspell')
+  optdepends=('kdelibs: kwallet integration'
+              'libgnome-keyring: gnome keyring integration')
+  provides=('qupzilla')
+  conflicts=('qupzilla')
+
+  cd qt4
+  make INSTALL_ROOT="$pkgdir/" install
+
+  # zsh completion
+  install -Dm644 linux/completion/_$pkgbase \
+    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: community-i686/qupzilla.install
===================================================================
--- community-i686/qupzilla.install	2014-11-06 00:37:07 UTC (rev 121992)
+++ community-i686/qupzilla.install	2014-11-06 00:37:25 UTC (rev 121993)
@@ -1,12 +0,0 @@
-post_install() {
-  xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
-  update-desktop-database -q
-}
-
-post_upgrade() {
-  post_install
-}
-
-post_remove() {
-  post_install
-}

Copied: qupzilla/repos/community-i686/qupzilla.install (from rev 121992, qupzilla/trunk/qupzilla.install)
===================================================================
--- community-i686/qupzilla.install	                        (rev 0)
+++ community-i686/qupzilla.install	2014-11-06 00:37:25 UTC (rev 121993)
@@ -0,0 +1,12 @@
+post_install() {
+  xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+  update-desktop-database -q
+}
+
+post_upgrade() {
+  post_install
+}
+
+post_remove() {
+  post_install
+}

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2014-11-06 00:37:07 UTC (rev 121992)
+++ community-x86_64/PKGBUILD	2014-11-06 00:37:25 UTC (rev 121993)
@@ -1,75 +0,0 @@
-# $Id$
-# Maintainer: speps <speps at aur dot archlinux dot org>
-
-pkgbase=qupzilla
-pkgname=(qupzilla qupzilla-qt4)
-pkgver=1.8.3
-pkgrel=1
-pkgdesc="Cross-platform QtWebKit browser"
-arch=(i686 x86_64)
-url="http://www.qupzilla.com/"
-license=('GPL3')
-makedepends=('qtwebkit' 'qt5-webkit' 'qt5-script' 'qt5-tools' 'hunspell' 'kdelibs' 'kwallet' 'libgnome-keyring')
-optdepends=('bash-completion: bash completion support')
-install="$pkgbase.install"
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/QupZilla/qupzilla/archive/v$pkgver.tar.gz")
-noextract=("$pkgbase-$pkgver.tar.gz")
-md5sums=('800f943279ab7269ea66765490a3a33a')
-
-prepare() {
-  # extract
-  mkdir -p qt{4,5}
-  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt4
-  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt5
-
-  # configure
-  export USE_WEBGL=true \
-         QUPZILLA_PREFIX=/usr/ \
-         KDE_INTEGRATION=true \
-         GNOME_INTEGRATION=true
-}
-
-build() {
-  cd qt4
-  qmake-qt4
-  make
-
-  cd ../qt5
-  qmake
-  make
-}
-
-package_qupzilla() {
-  pkgdesc+=" (Qt5)"
-  depends=('qt5-webkit' 'qt5-script' 'hunspell' 'desktop-file-utils' 'hicolor-icon-theme')
-  optdepends=('kwallet: kf5 kwallet integration'
-              'libgnome-keyring: gnome keyring integration')
-  provides=('qupzilla-qt5')
-  conflicts=('qupzilla-qt5')
-  replaces=('qupzilla-qt5')
-
-  cd qt5
-  make INSTALL_ROOT="$pkgdir/" install
-
-  # zsh completion
-  install -Dm644 linux/completion/_$pkgbase \
-    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
-}
-
-package_qupzilla-qt4() {
-  pkgdesc+=" (Qt4)"
-  depends=('qtwebkit' 'hunspell')
-  optdepends=('kdelibs: kwallet integration'
-              'libgnome-keyring: gnome keyring integration')
-  provides=('qupzilla')
-  conflicts=('qupzilla')
-
-  cd qt4
-  make INSTALL_ROOT="$pkgdir/" install
-
-  # zsh completion
-  install -Dm644 linux/completion/_$pkgbase \
-    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
-}
-
-# vim:set ts=2 sw=2 et:

Copied: qupzilla/repos/community-x86_64/PKGBUILD (from rev 121992, qupzilla/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2014-11-06 00:37:25 UTC (rev 121993)
@@ -0,0 +1,75 @@
+# $Id$
+# Maintainer: speps <speps at aur dot archlinux dot org>
+
+pkgbase=qupzilla
+pkgname=(qupzilla qupzilla-qt4)
+pkgver=1.8.4
+pkgrel=1
+pkgdesc="Cross-platform QtWebKit browser"
+arch=(i686 x86_64)
+url="http://www.qupzilla.com/"
+license=('GPL3')
+makedepends=('qtwebkit' 'qt5-webkit' 'qt5-script' 'qt5-tools' 'hunspell' 'kdelibs' 'kwallet' 'libgnome-keyring')
+optdepends=('bash-completion: bash completion support')
+install="$pkgbase.install"
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/QupZilla/qupzilla/archive/v$pkgver.tar.gz")
+noextract=("$pkgbase-$pkgver.tar.gz")
+md5sums=('88a679eb26a2071ac34c19ca0074a305')
+
+prepare() {
+  # extract
+  mkdir -p qt{4,5}
+  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt4
+  bsdtar --strip-components 1 -zxf $pkgbase-$pkgver.tar.gz -C qt5
+
+  # configure
+  export USE_WEBGL=true \
+         QUPZILLA_PREFIX=/usr/ \
+         KDE_INTEGRATION=true \
+         GNOME_INTEGRATION=true
+}
+
+build() {
+  cd qt4
+  qmake-qt4
+  make
+
+  cd ../qt5
+  qmake
+  make
+}
+
+package_qupzilla() {
+  pkgdesc+=" (Qt5)"
+  depends=('qt5-webkit' 'qt5-script' 'hunspell' 'desktop-file-utils' 'hicolor-icon-theme')
+  optdepends=('kwallet: kf5 kwallet integration'
+              'libgnome-keyring: gnome keyring integration')
+  provides=('qupzilla-qt5')
+  conflicts=('qupzilla-qt5')
+  replaces=('qupzilla-qt5')
+
+  cd qt5
+  make INSTALL_ROOT="$pkgdir/" install
+
+  # zsh completion
+  install -Dm644 linux/completion/_$pkgbase \
+    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
+}
+
+package_qupzilla-qt4() {
+  pkgdesc+=" (Qt4)"
+  depends=('qtwebkit' 'hunspell')
+  optdepends=('kdelibs: kwallet integration'
+              'libgnome-keyring: gnome keyring integration')
+  provides=('qupzilla')
+  conflicts=('qupzilla')
+
+  cd qt4
+  make INSTALL_ROOT="$pkgdir/" install
+
+  # zsh completion
+  install -Dm644 linux/completion/_$pkgbase \
+    "$pkgdir/usr/share/zsh/site-functions/_$pkgbase"
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: community-x86_64/qupzilla.install
===================================================================
--- community-x86_64/qupzilla.install	2014-11-06 00:37:07 UTC (rev 121992)
+++ community-x86_64/qupzilla.install	2014-11-06 00:37:25 UTC (rev 121993)
@@ -1,12 +0,0 @@
-post_install() {
-  xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
-  update-desktop-database -q
-}
-
-post_upgrade() {
-  post_install
-}
-
-post_remove() {
-  post_install
-}

Copied: qupzilla/repos/community-x86_64/qupzilla.install (from rev 121992, qupzilla/trunk/qupzilla.install)
===================================================================
--- community-x86_64/qupzilla.install	                        (rev 0)
+++ community-x86_64/qupzilla.install	2014-11-06 00:37:25 UTC (rev 121993)
@@ -0,0 +1,12 @@
+post_install() {
+  xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+  update-desktop-database -q
+}
+
+post_upgrade() {
+  post_install
+}
+
+post_remove() {
+  post_install
+}


More information about the arch-commits mailing list