[arch-commits] Commit in python-pygments/repos/community-any (4 files)

Evangelos Foutras foutrelis at archlinux.org
Tue Nov 11 04:16:15 UTC 2014


    Date: Tuesday, November 11, 2014 @ 05:16:15
  Author: foutrelis
Revision: 122337

archrelease: copy trunk to community-any

Added:
  python-pygments/repos/community-any/PKGBUILD
    (from rev 122336, python-pygments/trunk/PKGBUILD)
  python-pygments/repos/community-any/python-pygments.install
    (from rev 122336, python-pygments/trunk/python-pygments.install)
Deleted:
  python-pygments/repos/community-any/PKGBUILD
  python-pygments/repos/community-any/python-pygments.install

-------------------------+
 PKGBUILD                |   88 +++++++++++++++++++++++-----------------------
 python-pygments.install |   14 +++----
 2 files changed, 51 insertions(+), 51 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2014-11-11 04:15:30 UTC (rev 122336)
+++ PKGBUILD	2014-11-11 04:16:15 UTC (rev 122337)
@@ -1,44 +0,0 @@
-# $Id$
-# Maintainer: Evangelos Foutras <evangelos at foutrelis.com>
-# Contributor: Timm Preetz <timm at preetz.us>
-
-pkgname=('python-pygments' 'python2-pygments')
-pkgver=2.0
-pkgrel=1
-pkgdesc="Python syntax highlighter"
-arch=('any')
-url="http://pygments.org/"
-license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools')
-options=('!emptydirs')
-source=(https://pypi.python.org/packages/source/P/Pygments/Pygments-$pkgver.tar.gz)
-sha256sums=('4de23e88eeb7570e0425270d1013deff6343d78776dd38aeaf26c98ec3552421')
-
-package_python-pygments() {
-  depends=('python-setuptools')
-  install=python-pygments.install
-
-  cd "$srcdir/Pygments-$pkgver"
-
-  python3 setup.py install --root="$pkgdir" -O1
-
-  # pygmentize has been moved to the python2-pygments package
-  rm "$pkgdir/usr/bin/pygmentize"
-
-  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-package_python2-pygments() {
-  depends=('python2-setuptools')
-
-  cd "$srcdir/Pygments-$pkgver"
-
-  python2 setup.py install --root="$pkgdir" -O1
-
-  install -Dm644 external/pygments.bashcomp \
-    "$pkgdir/usr/share/bash-completion/completions/pygmentize"
-
-  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-# vim:set ts=2 sw=2 et:

Copied: python-pygments/repos/community-any/PKGBUILD (from rev 122336, python-pygments/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2014-11-11 04:16:15 UTC (rev 122337)
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Evangelos Foutras <evangelos at foutrelis.com>
+# Contributor: Timm Preetz <timm at preetz.us>
+
+pkgname=('python-pygments' 'python2-pygments')
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Python syntax highlighter"
+arch=('any')
+url="http://pygments.org/"
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+options=('!emptydirs')
+source=(https://pypi.python.org/packages/source/P/Pygments/Pygments-$pkgver.tar.gz)
+sha256sums=('5e039e1d40d232981ed58914b6d1ac2e453a7e83ddea22ef9f3eeadd01de45cb')
+
+package_python-pygments() {
+  depends=('python-setuptools')
+  install=python-pygments.install
+
+  cd "$srcdir/Pygments-$pkgver"
+
+  python3 setup.py install --root="$pkgdir" -O1
+
+  # pygmentize has been moved to the python2-pygments package
+  rm "$pkgdir/usr/bin/pygmentize"
+
+  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pygments() {
+  depends=('python2-setuptools')
+
+  cd "$srcdir/Pygments-$pkgver"
+
+  python2 setup.py install --root="$pkgdir" -O1
+
+  install -Dm644 external/pygments.bashcomp \
+    "$pkgdir/usr/share/bash-completion/completions/pygmentize"
+
+  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: python-pygments.install
===================================================================
--- python-pygments.install	2014-11-11 04:15:30 UTC (rev 122336)
+++ python-pygments.install	2014-11-11 04:16:15 UTC (rev 122337)
@@ -1,7 +0,0 @@
-post_upgrade() {
-  if (($(vercmp $2 1.4-5) < 0)); then
-    echo '/usr/bin/pygmentize has been moved to the python2-pygments package'
-  fi
-}
-
-# vim:set ts=2 sw=2 et:

Copied: python-pygments/repos/community-any/python-pygments.install (from rev 122336, python-pygments/trunk/python-pygments.install)
===================================================================
--- python-pygments.install	                        (rev 0)
+++ python-pygments.install	2014-11-11 04:16:15 UTC (rev 122337)
@@ -0,0 +1,7 @@
+post_upgrade() {
+  if (($(vercmp $2 1.4-5) < 0)); then
+    echo '/usr/bin/pygmentize has been moved to the python2-pygments package'
+  fi
+}
+
+# vim:set ts=2 sw=2 et:


More information about the arch-commits mailing list