[arch-commits] Commit in kdelibs/repos (16 files)

Felix Yan fyan at archlinux.org
Wed Nov 19 15:12:45 UTC 2014


    Date: Wednesday, November 19, 2014 @ 16:12:45
  Author: fyan
Revision: 226390

archrelease: copy trunk to testing-i686, testing-x86_64

Added:
  kdelibs/repos/testing-i686/
  kdelibs/repos/testing-i686/PKGBUILD
    (from rev 226389, kdelibs/trunk/PKGBUILD)
  kdelibs/repos/testing-i686/archlinux-menu.patch
    (from rev 226389, kdelibs/trunk/archlinux-menu.patch)
  kdelibs/repos/testing-i686/kde-applications-menu.patch
    (from rev 226389, kdelibs/trunk/kde-applications-menu.patch)
  kdelibs/repos/testing-i686/kdelibs-cve-2014-5033.patch
    (from rev 226389, kdelibs/trunk/kdelibs-cve-2014-5033.patch)
  kdelibs/repos/testing-i686/kdelibs.install
    (from rev 226389, kdelibs/trunk/kdelibs.install)
  kdelibs/repos/testing-i686/pyqt.patch
    (from rev 226389, kdelibs/trunk/pyqt.patch)
  kdelibs/repos/testing-i686/qt4.patch
    (from rev 226389, kdelibs/trunk/qt4.patch)
  kdelibs/repos/testing-x86_64/
  kdelibs/repos/testing-x86_64/PKGBUILD
    (from rev 226389, kdelibs/trunk/PKGBUILD)
  kdelibs/repos/testing-x86_64/archlinux-menu.patch
    (from rev 226389, kdelibs/trunk/archlinux-menu.patch)
  kdelibs/repos/testing-x86_64/kde-applications-menu.patch
    (from rev 226389, kdelibs/trunk/kde-applications-menu.patch)
  kdelibs/repos/testing-x86_64/kdelibs-cve-2014-5033.patch
    (from rev 226389, kdelibs/trunk/kdelibs-cve-2014-5033.patch)
  kdelibs/repos/testing-x86_64/kdelibs.install
    (from rev 226389, kdelibs/trunk/kdelibs.install)
  kdelibs/repos/testing-x86_64/pyqt.patch
    (from rev 226389, kdelibs/trunk/pyqt.patch)
  kdelibs/repos/testing-x86_64/qt4.patch
    (from rev 226389, kdelibs/trunk/qt4.patch)

--------------------------------------------+
 testing-i686/PKGBUILD                      |   61 ++++++
 testing-i686/archlinux-menu.patch          |   22 ++
 testing-i686/kde-applications-menu.patch   |   22 ++
 testing-i686/kdelibs-cve-2014-5033.patch   |   36 +++
 testing-i686/kdelibs.install               |   13 +
 testing-i686/pyqt.patch                    |  247 +++++++++++++++++++++++++++
 testing-i686/qt4.patch                     |   11 +
 testing-x86_64/PKGBUILD                    |   61 ++++++
 testing-x86_64/archlinux-menu.patch        |   22 ++
 testing-x86_64/kde-applications-menu.patch |   22 ++
 testing-x86_64/kdelibs-cve-2014-5033.patch |   36 +++
 testing-x86_64/kdelibs.install             |   13 +
 testing-x86_64/pyqt.patch                  |  247 +++++++++++++++++++++++++++
 testing-x86_64/qt4.patch                   |   11 +
 14 files changed, 824 insertions(+)

Copied: kdelibs/repos/testing-i686/PKGBUILD (from rev 226389, kdelibs/trunk/PKGBUILD)
===================================================================
--- testing-i686/PKGBUILD	                        (rev 0)
+++ testing-i686/PKGBUILD	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,61 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea at archlinux.org
+# Contributor: Pierre Schmitz <pierre at archlinux.de>
+
+pkgname=kdelibs
+pkgver=4.14.3
+pkgrel=1
+pkgdesc="KDE Core Libraries"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/kdelibs'
+license=('GPL' 'LGPL' 'FDL')
+depends=('attica-qt4' 'libxss' 'krb5' 'grantlee-qt4' 'qca' 'libdbusmenu-qt' 'polkit-qt4'
+        'shared-mime-info' 'enchant' 'giflib' 'jasper' 'openexr' 'strigi'
+        'docbook-xsl' 'upower' 'udisks2' 'libxcursor' 'phonon-qt4'
+        'media-player-info' 'libxtst' 'libutempter' 'qtwebkit' 'icu')
+makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'hspell' 'mesa')
+install=${pkgname}.install
+source=("http://download.kde.org/stable/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
+        'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch')
+sha1sums=('a61beafbd7ff0f5c6be54e685d197c135ba36865'
+          '86ee8c8660f19de8141ac99cd6943964d97a1ed7'
+          '63a850ab4196b9d06934f2b4a13acd9f7739bc67'
+          'ed1f57ee661e5c7440efcaba7e51d2554709701c')
+
+prepare() {
+       mkdir build
+       cd ${pkgname}-${pkgver}
+       # avoid file conflict with gnome-menus
+       patch -p1 -i "${srcdir}"/kde-applications-menu.patch
+       # add Archlinux menu entry
+       patch -p1 -i "${srcdir}"/archlinux-menu.patch
+       # qmake refers to Qt5
+       patch -p1 -i "${srcdir}"/qt4.patch
+}
+
+build() {
+       cd build
+       cmake ../${pkgname}-${pkgver} \
+               -DCMAKE_BUILD_TYPE=Release \
+               -DKDE4_BUILD_TESTS=OFF \
+               -DCMAKE_SKIP_RPATH=ON \
+               -DKDE_DISTRIBUTION_TEXT='Arch Linux' \
+               -DCMAKE_INSTALL_PREFIX=/usr \
+               -DSYSCONF_INSTALL_DIR=/etc \
+               -DHTML_INSTALL_DIR=/usr/share/doc/kde/html \
+               -DLOCALE_INSTALL_DIR=/usr/share/locale/kde4 \
+               -DKDE_DEFAULT_HOME='.kde4' \
+               -DWITH_FAM=OFF \
+               -DWITH_SOLID_UDISKS2=ON
+       make
+}
+
+package() {
+       cd "${srcdir}"/build
+       make DESTDIR="${pkgdir}" install
+
+       # cert bundle seems to be hardcoded
+       # link it to the one from ca-certificates
+       rm -f "${pkgdir}"/usr/share/apps/kssl/ca-bundle.crt
+       ln -sf /etc/ssl/certs/ca-certificates.crt "${pkgdir}"/usr/share/apps/kssl/ca-bundle.crt
+}

Copied: kdelibs/repos/testing-i686/archlinux-menu.patch (from rev 226389, kdelibs/trunk/archlinux-menu.patch)
===================================================================
--- testing-i686/archlinux-menu.patch	                        (rev 0)
+++ testing-i686/archlinux-menu.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,22 @@
+--- kdelibs-4.3.98/kded/applications.menu	2010-01-31 19:28:11.000000000 +0000
++++ kdelibs-4.3.98/kded/applications.menu	2010-01-31 22:25:53.556043077 +0000
+@@ -16,11 +16,19 @@
+ 	</DefaultLayout>
+ 	<Layout>
+ 		<Merge type="menus"/>
++		<Menuname>Arch Linux</Menuname>
+ 		<Menuname>Applications</Menuname>
+ 		<Merge type="files"/>
+ 	</Layout>
+ 
+ 	<Menu>
++		<Name>Arch Linux</Name>                                                                                                   
++		<Directory>Archlinux.directory</Directory>                                                                               
++		<Include>                                                                                                                
++			<Category>Archlinux</Category>                                                                                           
++		</Include>
++	</Menu>
++	<Menu>
+ 		<Name>Applications</Name>
+ 		<Directory>kde-unknown.directory</Directory>
+ 		<OnlyUnallocated/>

Copied: kdelibs/repos/testing-i686/kde-applications-menu.patch (from rev 226389, kdelibs/trunk/kde-applications-menu.patch)
===================================================================
--- testing-i686/kde-applications-menu.patch	                        (rev 0)
+++ testing-i686/kde-applications-menu.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,22 @@
+--- kdelibs-4.3.98/kded/CMakeLists.txt	2009-10-02 14:55:17.000000000 +0000
++++ kdelibs-4.3.98/kded/CMakeLists.txt	2010-01-31 22:16:13.946933892 +0000
+@@ -69,7 +69,7 @@
+ if (WIN32)
+ install( FILES applications.menu  DESTINATION  ${SHARE_INSTALL_PREFIX}/xdg/menus )
+ else (WIN32)
+-install( FILES applications.menu  DESTINATION  ${SYSCONF_INSTALL_DIR}/xdg/menus )
++install( FILES applications.menu  DESTINATION  ${SYSCONF_INSTALL_DIR}/xdg/menus RENAME kde-applications.menu )
+ endif (WIN32)
+ install( FILES kdedmodule.desktop DESTINATION  ${SERVICETYPES_INSTALL_DIR} )
+ install( FILES kded.upd           DESTINATION  ${DATA_INSTALL_DIR}/kconf_update )
+--- kdelibs-4.3.98/kded/kbuildsycoca.cpp	2009-12-04 23:10:18.000000000 +0000
++++ kdelibs-4.3.98/kded/kbuildsycoca.cpp	2010-01-31 22:16:13.962766572 +0000
+@@ -302,7 +302,7 @@
+      if (!m_trackId.isEmpty())
+         g_vfolder->setTrackId(m_trackId);
+ 
+-     VFolderMenu::SubMenu *kdeMenu = g_vfolder->parseMenu("applications.menu", true);
++     VFolderMenu::SubMenu *kdeMenu = g_vfolder->parseMenu("kde-applications.menu", true);
+ 
+      KServiceGroup::Ptr entry = g_bsgf->addNew("/", kdeMenu->directoryFile, KServiceGroup::Ptr(), false);
+      entry->setLayoutInfo(kdeMenu->layoutList);

Copied: kdelibs/repos/testing-i686/kdelibs-cve-2014-5033.patch (from rev 226389, kdelibs/trunk/kdelibs-cve-2014-5033.patch)
===================================================================
--- testing-i686/kdelibs-cve-2014-5033.patch	                        (rev 0)
+++ testing-i686/kdelibs-cve-2014-5033.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,36 @@
+--- a/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp
++++ b/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp
+@@ -144,7 +144,7 @@
+ 
+ Action::AuthStatus Polkit1Backend::actionStatus(const QString &action)
+ {
+-    PolkitQt1::UnixProcessSubject subject(QCoreApplication::applicationPid());
++    PolkitQt1::SystemBusNameSubject subject(QString::fromUtf8(callerID()));
+     PolkitQt1::Authority::Result r = PolkitQt1::Authority::instance()->checkAuthorizationSync(action, subject,
+                                                                                               PolkitQt1::Authority::None);
+     switch (r) {
+@@ -160,21 +160,12 @@
+ 
+ QByteArray Polkit1Backend::callerID() const
+ {
+-    QByteArray a;
+-    QDataStream s(&a, QIODevice::WriteOnly);
+-    s << QCoreApplication::applicationPid();
+-
+-    return a;
++    return QDBusConnection::systemBus().baseService().toUtf8();
+ }
+ 
+ bool Polkit1Backend::isCallerAuthorized(const QString &action, QByteArray callerID)
+ {
+-    QDataStream s(&callerID, QIODevice::ReadOnly);
+-    qint64 pid;
+-
+-    s >> pid;
+-
+-    PolkitQt1::UnixProcessSubject subject(pid);
++    PolkitQt1::SystemBusNameSubject subject(QString::fromUtf8(callerID));
+     PolkitQt1::Authority *authority = PolkitQt1::Authority::instance();
+ 
+     PolkitResultEventLoop e;
+

Copied: kdelibs/repos/testing-i686/kdelibs.install (from rev 226389, kdelibs/trunk/kdelibs.install)
===================================================================
--- testing-i686/kdelibs.install	                        (rev 0)
+++ testing-i686/kdelibs.install	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,13 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+	update-mime-database usr/share/mime &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}

Copied: kdelibs/repos/testing-i686/pyqt.patch (from rev 226389, kdelibs/trunk/pyqt.patch)
===================================================================
--- testing-i686/pyqt.patch	                        (rev 0)
+++ testing-i686/pyqt.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,247 @@
+Make FindPyKDE4 work with PyQt's new build system.
+Make FindPyQt4 work with PyQt's new build system.
+
+Since PyQt 4.10, PyQt.pyqtconfig is deprecated and not available unless
+PyQt is built using the old configure script.
+
+PyKDE4 itself has recently been adjusted to mimic PyQt itself and only
+install its pykdeconfig module if pyqtconfig is present. Additionally,
+information such as SIP flags and the directory where PyKDE's SIP files
+are installed are now also provided in the
+PyKDE4.kdecore.PYKDE_CONFIGURATION dict.
+
+This commit completely rewrites FindPyKDE4.py to make it look like
+FindPyQt.cmake after commit a7e4743: most of the information used by
+FindPyKDE4.cmake is fetched from PyKDE4.kdecore, and we first try to
+obtain the SIP flags and directory from pykdeconfig and, if it fails, we
+use PYKDE_CONFIGURATION.
+
+Furthermore, FindPyKDE4.py now only prints the variables that are
+actually consumed by FindPyKDE4.cmake -- it is not possible to obtain
+all the data provided by pykdeconfig in PYKDE_CONFIGURATION. We've also
+stopped reading and setting PYKDE4_VERSION_TAG, since PyKDE4 stopped
+setting a KDE tag in 2008 (and its value was 3_92_0 at the time).
+
+CCBUG: 327633
+REVIEW: 119454
+
+BUG: 337462
+FIXED-IN: 4.14.0
+REVIEW: 119302
+--- kdelibs-4.13.3/cmake/modules/FindPyKDE4.cmake~	2014-08-06 21:54:27.564432282 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyKDE4.cmake	2014-08-06 21:54:43.417702615 +0000
+@@ -25,7 +25,6 @@
+     STRING(REGEX REPLACE ".*\npykde_version_str:([^\n]+).*$" "\\1" PYKDE4_VERSION_STR ${pykde_config})
+     STRING(REGEX REPLACE ".*\npykde_kde_sip_flags:([^\n]+).*$" "\\1" PYKDE4_SIP_FLAGS ${pykde_config})
+     STRING(REGEX REPLACE ".*\npykde_sip_dir:([^\n]+).*$" "\\1" PYKDE4_SIP_DIR ${pykde_config})
+-    STRING(REGEX REPLACE ".*\npykde_version_tag:([^\n]+).*$" "\\1" PYKDE4_VERSION_TAG ${pykde_config})
+     MESSAGE(STATUS "Found PyKDE4 version ${PYKDE4_VERSION_STR} ${PYKDE4_SIP_DIR}")
+ 
+     SET(PYKDE4_FOUND TRUE)
+@@ -183,3 +182,4 @@
+     endif(WIN32)
+ ENDMACRO(PYKDE4_ADD_EXECUTABLE)
+ 
++
+--- kdelibs-4.13.3/cmake/modules/FindPyKDE4.py~	2014-08-06 21:54:56.427650960 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyKDE4.py	2014-08-06 21:55:04.400952596 +0000
+@@ -1,46 +1,23 @@
+-# By Simon Edwards <simon at simonzone.com>
+-# modified by Paul Giannaros <paul at giannaros.org> to add better PyKDE4
+-# sip directory finding
+-# This file is in the public domain.
++# Copyright (c) 2014, Raphael Kubo da Costa <rakuco at FreeBSD.org>
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+ 
+-import sys
+-import os
+-import PyKDE4.pykdeconfig
+-import PyQt4.pyqtconfig
++import PyKDE4.kdecore
+ 
+-if "_pkg_config" in dir(PyKDE4.pykdeconfig):
+-    _pkg_config = PyKDE4.pykdeconfig._pkg_config
++if __name__ == '__main__':
++    try:
++        import PyKDE4.pykdeconfig
++        pykdecfg = PyKDE4.pykdeconfig.Configuration()
++        sip_dir = pykdecfg.pykde_sip_dir
++        sip_flags = pykdecfg.pykde_kde_sip_flags
++    except ImportError:
++        # PyQt4 >= 4.10.0 was built with configure-ng.py instead of
++        # configure.py, so pyqtconfig.py and pykdeconfig.py are not installed.
++        sip_dir = PyKDE4.kdecore.PYKDE_CONFIGURATION['sip_dir']
++        sip_flags = PyKDE4.kdecore.PYKDE_CONFIGURATION['sip_flags']
+ 
+-    for varname in [
+-            'kde_version',
+-            'kde_version_extra',
+-            'kdebasedir',
+-            'kdeincdir',
+-            'kdelibdir',
+-            'libdir',
+-            'pykde_kde_sip_flags', 
+-            'pykde_mod_dir',
+-            'pykde_modules', 
+-            'pykde_sip_dir',
+-            'pykde_version',
+-            'pykde_version_str']:
+-        varvalue = _pkg_config[varname]
+-        if varname == 'pykde_sip_dir':
+-            d = os.path.join(_pkg_config[varname], 'PyKDE4')
+-            if os.path.exists(d):
+-                varvalue = d
+-        print("%s:%s\n" % (varname, varvalue))
+-    pykde_version_tag = ''
+-    in_t = False
+-    for item in _pkg_config['pykde_kde_sip_flags'].split():
+-        if item == "-t":
+-            in_t = True
+-        elif in_t:
+-            if item.startswith("KDE_"):
+-                pykde_version_tag = item
+-        else:
+-            in_t = False
+-    print("pykde_version_tag:%s" % pykde_version_tag)
++    print('pykde_version:%06.x' % PyKDE4.kdecore.version())
++    print('pykde_version_str:%s' % PyKDE4.kdecore.versionString())
++    print('pykde_sip_dir:%s' % sip_dir)
++    print('pykde_sip_flags:%s' % sip_flags)
+ 
+-else:
+-    sys.exit(1)
+--- kdelibs-4.13.3/cmake/modules/FindPyQt.py~	2014-08-06 21:55:55.874081319 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyQt.py	2014-08-06 21:56:06.250706848 +0000
+@@ -1,24 +1,49 @@
+ # Copyright (c) 2007, Simon Edwards <simon at simonzone.com>
++# Copyright (c) 2014, Raphael Kubo da Costa <rakuco at FreeBSD.org>
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+ 
+-import PyQt4.pyqtconfig
++import PyQt4.QtCore
++import os
++import sys
+ 
+-pyqtcfg = PyQt4.pyqtconfig.Configuration()
+-print("pyqt_version:%06.0x" % pyqtcfg.pyqt_version)
+-print("pyqt_version_str:%s" % pyqtcfg.pyqt_version_str)
+-
+-pyqt_version_tag = ""
+-in_t = False
+-for item in pyqtcfg.pyqt_sip_flags.split(' '):
+-    if item=="-t":
+-        in_t = True
+-    elif in_t:
+-        if item.startswith("Qt_4"):
+-            pyqt_version_tag = item
++def get_default_sip_dir():
++    # This is based on QScintilla's configure.py, and only works for the
++    # default case where installation paths have not been changed in PyQt's
++    # configuration process.
++    if sys.platform == 'win32':
++        pyqt_sip_dir = os.path.join(sys.prefix, 'sip', 'PyQt4')
+     else:
+-        in_t = False
+-print("pyqt_version_tag:%s" % pyqt_version_tag)
++        pyqt_sip_dir = os.path.join(sys.prefix, 'share', 'sip', 'PyQt4')
++    return pyqt_sip_dir
++
++def get_qt4_tag(sip_flags):
++    in_t = False
++    for item in sip_flags.split(' '):
++        if item == '-t':
++            in_t = True
++        elif in_t:
++            if item.startswith('Qt_4'):
++                return item
++        else:
++            in_t = False
++    raise ValueError('Cannot find Qt\'s tag in PyQt4\'s SIP flags.')
++
++if __name__ == '__main__':
++    try:
++        import PyQt4.pyqtconfig
++        pyqtcfg = PyQt4.pyqtconfig.Configuration()
++        sip_dir = pyqtcfg.pyqt_sip_dir
++        sip_flags = pyqtcfg.pyqt_sip_flags
++    except ImportError:
++        # PyQt4 >= 4.10.0 was built with configure-ng.py instead of
++        # configure.py, so pyqtconfig.py is not installed.
++        sip_dir = get_default_sip_dir()
++        sip_flags = PyQt4.QtCore.PYQT_CONFIGURATION['sip_flags']
++
++    print('pyqt_version:%06.x' % PyQt4.QtCore.PYQT_VERSION)
++    print('pyqt_version_str:%s' % PyQt4.QtCore.PYQT_VERSION_STR)
++    print('pyqt_version_tag:%s' % get_qt4_tag(sip_flags))
++    print('pyqt_sip_dir:%s' % sip_dir)
++    print('pyqt_sip_flags:%s' % sip_flags)
+ 
+-print("pyqt_sip_dir:%s" % pyqtcfg.pyqt_sip_dir)
+-print("pyqt_sip_flags:%s" % pyqtcfg.pyqt_sip_flags)
+--- kdelibs-4.13.3/cmake/modules/FindPyQt4.cmake~	2014-08-06 21:55:16.697570407 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyQt4.cmake	2014-08-06 21:55:38.597483393 +0000
+@@ -9,16 +9,20 @@
+ # Find the installed version of PyQt4. FindPyQt4 should only be called after
+ # Python has been found.
+ #
+-# This file defines the following variables:
++# This file defines the following variables, which can also be overriden by
++# users:
+ #
+ # PYQT4_VERSION - The version of PyQt4 found expressed as a 6 digit hex number
+ #     suitable for comparison as a string
+ #
+ # PYQT4_VERSION_STR - The version of PyQt4 as a human readable string.
+ #
+-# PYQT4_VERSION_TAG - The PyQt version tag using by PyQt's sip files.
++# PYQT4_VERSION_TAG - The Qt4 version tag used by PyQt's sip files.
+ #
+-# PYQT4_SIP_DIR - The directory holding the PyQt4 .sip files.
++# PYQT4_SIP_DIR - The directory holding the PyQt4 .sip files. This can be unset
++# if PyQt4 was built using its new build system and pyqtconfig.py is not
++# present on the system, as in this case its value cannot be determined
++# automatically.
+ #
+ # PYQT4_SIP_FLAGS - The SIP flags used to build PyQt.
+ 
+@@ -31,13 +35,27 @@
+ 
+   EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} ${_find_pyqt_py} OUTPUT_VARIABLE pyqt_config)
+   IF(pyqt_config)
+-    STRING(REGEX REPLACE "^pyqt_version:([^\n]+).*$" "\\1" PYQT4_VERSION ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_version_str:([^\n]+).*$" "\\1" PYQT4_VERSION_STR ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_version_tag:([^\n]+).*$" "\\1" PYQT4_VERSION_TAG ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_sip_dir:([^\n]+).*$" "\\1" PYQT4_SIP_DIR ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_sip_flags:([^\n]+).*$" "\\1" PYQT4_SIP_FLAGS ${pyqt_config})
++    STRING(REGEX MATCH "^pyqt_version:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION "${CMAKE_MATCH_1}" CACHE STRING "PyQt4's version as a 6-digit hexadecimal number")
+ 
+-    SET(PYQT4_FOUND TRUE)
++    STRING(REGEX MATCH ".*\npyqt_version_str:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION_STR "${CMAKE_MATCH_1}" CACHE STRING "PyQt4's version as a human-readable string")
++
++    STRING(REGEX MATCH ".*\npyqt_version_tag:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION_TAG "${CMAKE_MATCH_1}" CACHE STRING "The Qt4 version tag used by PyQt4's .sip files")
++
++    STRING(REGEX MATCH ".*\npyqt_sip_dir:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_SIP_DIR "${CMAKE_MATCH_1}" CACHE PATH "The base directory where PyQt4's .sip files are installed")
++
++    STRING(REGEX MATCH ".*\npyqt_sip_flags:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_SIP_FLAGS "${CMAKE_MATCH_1}" CACHE STRING "The SIP flags used to build PyQt4")
++
++    IF(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
++      MESSAGE(WARNING "The base directory where PyQt4's SIP files are installed could not be determined. This usually means PyQt4 was built with its new build system and pyqtconfig.py is not present.\n"
++                      "Please set the PYQT4_SIP_DIR variable manually.")
++    ELSE(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
++      SET(PYQT4_FOUND TRUE)
++    ENDIF(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
+   ENDIF(pyqt_config)
+ 
+   IF(PYQT4_FOUND)
+@@ -51,3 +69,4 @@
+   ENDIF(PYQT4_FOUND)
+ 
+ ENDIF(EXISTS PYQT4_VERSION)
++

Copied: kdelibs/repos/testing-i686/qt4.patch (from rev 226389, kdelibs/trunk/qt4.patch)
===================================================================
--- testing-i686/qt4.patch	                        (rev 0)
+++ testing-i686/qt4.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,11 @@
+--- kdelibs-4.10.1/cmake/modules/FindQt4.cmake~	2013-03-07 16:57:29.735552097 +0000
++++ kdelibs-4.10.1/cmake/modules/FindQt4.cmake	2013-03-07 16:57:52.038725421 +0000
+@@ -446,7 +446,7 @@
+ # check for qmake
+ # Debian uses qmake-qt4
+ # macports' Qt uses qmake-mac
+-FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake qmake4 qmake-qt4 qmake-mac PATHS
++FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake4 qmake-qt4 qmake-mac PATHS
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Qt3Versions\\4.0.0;InstallDir]/bin"
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\4.0.0;InstallDir]/bin"
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\${qt_install_version};InstallDir]/bin"

Copied: kdelibs/repos/testing-x86_64/PKGBUILD (from rev 226389, kdelibs/trunk/PKGBUILD)
===================================================================
--- testing-x86_64/PKGBUILD	                        (rev 0)
+++ testing-x86_64/PKGBUILD	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,61 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea at archlinux.org
+# Contributor: Pierre Schmitz <pierre at archlinux.de>
+
+pkgname=kdelibs
+pkgver=4.14.3
+pkgrel=1
+pkgdesc="KDE Core Libraries"
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/kdelibs'
+license=('GPL' 'LGPL' 'FDL')
+depends=('attica-qt4' 'libxss' 'krb5' 'grantlee-qt4' 'qca' 'libdbusmenu-qt' 'polkit-qt4'
+        'shared-mime-info' 'enchant' 'giflib' 'jasper' 'openexr' 'strigi'
+        'docbook-xsl' 'upower' 'udisks2' 'libxcursor' 'phonon-qt4'
+        'media-player-info' 'libxtst' 'libutempter' 'qtwebkit' 'icu')
+makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'hspell' 'mesa')
+install=${pkgname}.install
+source=("http://download.kde.org/stable/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
+        'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch')
+sha1sums=('a61beafbd7ff0f5c6be54e685d197c135ba36865'
+          '86ee8c8660f19de8141ac99cd6943964d97a1ed7'
+          '63a850ab4196b9d06934f2b4a13acd9f7739bc67'
+          'ed1f57ee661e5c7440efcaba7e51d2554709701c')
+
+prepare() {
+       mkdir build
+       cd ${pkgname}-${pkgver}
+       # avoid file conflict with gnome-menus
+       patch -p1 -i "${srcdir}"/kde-applications-menu.patch
+       # add Archlinux menu entry
+       patch -p1 -i "${srcdir}"/archlinux-menu.patch
+       # qmake refers to Qt5
+       patch -p1 -i "${srcdir}"/qt4.patch
+}
+
+build() {
+       cd build
+       cmake ../${pkgname}-${pkgver} \
+               -DCMAKE_BUILD_TYPE=Release \
+               -DKDE4_BUILD_TESTS=OFF \
+               -DCMAKE_SKIP_RPATH=ON \
+               -DKDE_DISTRIBUTION_TEXT='Arch Linux' \
+               -DCMAKE_INSTALL_PREFIX=/usr \
+               -DSYSCONF_INSTALL_DIR=/etc \
+               -DHTML_INSTALL_DIR=/usr/share/doc/kde/html \
+               -DLOCALE_INSTALL_DIR=/usr/share/locale/kde4 \
+               -DKDE_DEFAULT_HOME='.kde4' \
+               -DWITH_FAM=OFF \
+               -DWITH_SOLID_UDISKS2=ON
+       make
+}
+
+package() {
+       cd "${srcdir}"/build
+       make DESTDIR="${pkgdir}" install
+
+       # cert bundle seems to be hardcoded
+       # link it to the one from ca-certificates
+       rm -f "${pkgdir}"/usr/share/apps/kssl/ca-bundle.crt
+       ln -sf /etc/ssl/certs/ca-certificates.crt "${pkgdir}"/usr/share/apps/kssl/ca-bundle.crt
+}

Copied: kdelibs/repos/testing-x86_64/archlinux-menu.patch (from rev 226389, kdelibs/trunk/archlinux-menu.patch)
===================================================================
--- testing-x86_64/archlinux-menu.patch	                        (rev 0)
+++ testing-x86_64/archlinux-menu.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,22 @@
+--- kdelibs-4.3.98/kded/applications.menu	2010-01-31 19:28:11.000000000 +0000
++++ kdelibs-4.3.98/kded/applications.menu	2010-01-31 22:25:53.556043077 +0000
+@@ -16,11 +16,19 @@
+ 	</DefaultLayout>
+ 	<Layout>
+ 		<Merge type="menus"/>
++		<Menuname>Arch Linux</Menuname>
+ 		<Menuname>Applications</Menuname>
+ 		<Merge type="files"/>
+ 	</Layout>
+ 
+ 	<Menu>
++		<Name>Arch Linux</Name>                                                                                                   
++		<Directory>Archlinux.directory</Directory>                                                                               
++		<Include>                                                                                                                
++			<Category>Archlinux</Category>                                                                                           
++		</Include>
++	</Menu>
++	<Menu>
+ 		<Name>Applications</Name>
+ 		<Directory>kde-unknown.directory</Directory>
+ 		<OnlyUnallocated/>

Copied: kdelibs/repos/testing-x86_64/kde-applications-menu.patch (from rev 226389, kdelibs/trunk/kde-applications-menu.patch)
===================================================================
--- testing-x86_64/kde-applications-menu.patch	                        (rev 0)
+++ testing-x86_64/kde-applications-menu.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,22 @@
+--- kdelibs-4.3.98/kded/CMakeLists.txt	2009-10-02 14:55:17.000000000 +0000
++++ kdelibs-4.3.98/kded/CMakeLists.txt	2010-01-31 22:16:13.946933892 +0000
+@@ -69,7 +69,7 @@
+ if (WIN32)
+ install( FILES applications.menu  DESTINATION  ${SHARE_INSTALL_PREFIX}/xdg/menus )
+ else (WIN32)
+-install( FILES applications.menu  DESTINATION  ${SYSCONF_INSTALL_DIR}/xdg/menus )
++install( FILES applications.menu  DESTINATION  ${SYSCONF_INSTALL_DIR}/xdg/menus RENAME kde-applications.menu )
+ endif (WIN32)
+ install( FILES kdedmodule.desktop DESTINATION  ${SERVICETYPES_INSTALL_DIR} )
+ install( FILES kded.upd           DESTINATION  ${DATA_INSTALL_DIR}/kconf_update )
+--- kdelibs-4.3.98/kded/kbuildsycoca.cpp	2009-12-04 23:10:18.000000000 +0000
++++ kdelibs-4.3.98/kded/kbuildsycoca.cpp	2010-01-31 22:16:13.962766572 +0000
+@@ -302,7 +302,7 @@
+      if (!m_trackId.isEmpty())
+         g_vfolder->setTrackId(m_trackId);
+ 
+-     VFolderMenu::SubMenu *kdeMenu = g_vfolder->parseMenu("applications.menu", true);
++     VFolderMenu::SubMenu *kdeMenu = g_vfolder->parseMenu("kde-applications.menu", true);
+ 
+      KServiceGroup::Ptr entry = g_bsgf->addNew("/", kdeMenu->directoryFile, KServiceGroup::Ptr(), false);
+      entry->setLayoutInfo(kdeMenu->layoutList);

Copied: kdelibs/repos/testing-x86_64/kdelibs-cve-2014-5033.patch (from rev 226389, kdelibs/trunk/kdelibs-cve-2014-5033.patch)
===================================================================
--- testing-x86_64/kdelibs-cve-2014-5033.patch	                        (rev 0)
+++ testing-x86_64/kdelibs-cve-2014-5033.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,36 @@
+--- a/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp
++++ b/kdecore/auth/backends/polkit-1/Polkit1Backend.cpp
+@@ -144,7 +144,7 @@
+ 
+ Action::AuthStatus Polkit1Backend::actionStatus(const QString &action)
+ {
+-    PolkitQt1::UnixProcessSubject subject(QCoreApplication::applicationPid());
++    PolkitQt1::SystemBusNameSubject subject(QString::fromUtf8(callerID()));
+     PolkitQt1::Authority::Result r = PolkitQt1::Authority::instance()->checkAuthorizationSync(action, subject,
+                                                                                               PolkitQt1::Authority::None);
+     switch (r) {
+@@ -160,21 +160,12 @@
+ 
+ QByteArray Polkit1Backend::callerID() const
+ {
+-    QByteArray a;
+-    QDataStream s(&a, QIODevice::WriteOnly);
+-    s << QCoreApplication::applicationPid();
+-
+-    return a;
++    return QDBusConnection::systemBus().baseService().toUtf8();
+ }
+ 
+ bool Polkit1Backend::isCallerAuthorized(const QString &action, QByteArray callerID)
+ {
+-    QDataStream s(&callerID, QIODevice::ReadOnly);
+-    qint64 pid;
+-
+-    s >> pid;
+-
+-    PolkitQt1::UnixProcessSubject subject(pid);
++    PolkitQt1::SystemBusNameSubject subject(QString::fromUtf8(callerID));
+     PolkitQt1::Authority *authority = PolkitQt1::Authority::instance();
+ 
+     PolkitResultEventLoop e;
+

Copied: kdelibs/repos/testing-x86_64/kdelibs.install (from rev 226389, kdelibs/trunk/kdelibs.install)
===================================================================
--- testing-x86_64/kdelibs.install	                        (rev 0)
+++ testing-x86_64/kdelibs.install	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,13 @@
+post_install() {
+	xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+	update-mime-database usr/share/mime &> /dev/null
+    update-desktop-database -q
+}
+
+post_upgrade() {
+	post_install
+}
+
+post_remove() {
+	post_install
+}

Copied: kdelibs/repos/testing-x86_64/pyqt.patch (from rev 226389, kdelibs/trunk/pyqt.patch)
===================================================================
--- testing-x86_64/pyqt.patch	                        (rev 0)
+++ testing-x86_64/pyqt.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,247 @@
+Make FindPyKDE4 work with PyQt's new build system.
+Make FindPyQt4 work with PyQt's new build system.
+
+Since PyQt 4.10, PyQt.pyqtconfig is deprecated and not available unless
+PyQt is built using the old configure script.
+
+PyKDE4 itself has recently been adjusted to mimic PyQt itself and only
+install its pykdeconfig module if pyqtconfig is present. Additionally,
+information such as SIP flags and the directory where PyKDE's SIP files
+are installed are now also provided in the
+PyKDE4.kdecore.PYKDE_CONFIGURATION dict.
+
+This commit completely rewrites FindPyKDE4.py to make it look like
+FindPyQt.cmake after commit a7e4743: most of the information used by
+FindPyKDE4.cmake is fetched from PyKDE4.kdecore, and we first try to
+obtain the SIP flags and directory from pykdeconfig and, if it fails, we
+use PYKDE_CONFIGURATION.
+
+Furthermore, FindPyKDE4.py now only prints the variables that are
+actually consumed by FindPyKDE4.cmake -- it is not possible to obtain
+all the data provided by pykdeconfig in PYKDE_CONFIGURATION. We've also
+stopped reading and setting PYKDE4_VERSION_TAG, since PyKDE4 stopped
+setting a KDE tag in 2008 (and its value was 3_92_0 at the time).
+
+CCBUG: 327633
+REVIEW: 119454
+
+BUG: 337462
+FIXED-IN: 4.14.0
+REVIEW: 119302
+--- kdelibs-4.13.3/cmake/modules/FindPyKDE4.cmake~	2014-08-06 21:54:27.564432282 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyKDE4.cmake	2014-08-06 21:54:43.417702615 +0000
+@@ -25,7 +25,6 @@
+     STRING(REGEX REPLACE ".*\npykde_version_str:([^\n]+).*$" "\\1" PYKDE4_VERSION_STR ${pykde_config})
+     STRING(REGEX REPLACE ".*\npykde_kde_sip_flags:([^\n]+).*$" "\\1" PYKDE4_SIP_FLAGS ${pykde_config})
+     STRING(REGEX REPLACE ".*\npykde_sip_dir:([^\n]+).*$" "\\1" PYKDE4_SIP_DIR ${pykde_config})
+-    STRING(REGEX REPLACE ".*\npykde_version_tag:([^\n]+).*$" "\\1" PYKDE4_VERSION_TAG ${pykde_config})
+     MESSAGE(STATUS "Found PyKDE4 version ${PYKDE4_VERSION_STR} ${PYKDE4_SIP_DIR}")
+ 
+     SET(PYKDE4_FOUND TRUE)
+@@ -183,3 +182,4 @@
+     endif(WIN32)
+ ENDMACRO(PYKDE4_ADD_EXECUTABLE)
+ 
++
+--- kdelibs-4.13.3/cmake/modules/FindPyKDE4.py~	2014-08-06 21:54:56.427650960 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyKDE4.py	2014-08-06 21:55:04.400952596 +0000
+@@ -1,46 +1,23 @@
+-# By Simon Edwards <simon at simonzone.com>
+-# modified by Paul Giannaros <paul at giannaros.org> to add better PyKDE4
+-# sip directory finding
+-# This file is in the public domain.
++# Copyright (c) 2014, Raphael Kubo da Costa <rakuco at FreeBSD.org>
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+ 
+-import sys
+-import os
+-import PyKDE4.pykdeconfig
+-import PyQt4.pyqtconfig
++import PyKDE4.kdecore
+ 
+-if "_pkg_config" in dir(PyKDE4.pykdeconfig):
+-    _pkg_config = PyKDE4.pykdeconfig._pkg_config
++if __name__ == '__main__':
++    try:
++        import PyKDE4.pykdeconfig
++        pykdecfg = PyKDE4.pykdeconfig.Configuration()
++        sip_dir = pykdecfg.pykde_sip_dir
++        sip_flags = pykdecfg.pykde_kde_sip_flags
++    except ImportError:
++        # PyQt4 >= 4.10.0 was built with configure-ng.py instead of
++        # configure.py, so pyqtconfig.py and pykdeconfig.py are not installed.
++        sip_dir = PyKDE4.kdecore.PYKDE_CONFIGURATION['sip_dir']
++        sip_flags = PyKDE4.kdecore.PYKDE_CONFIGURATION['sip_flags']
+ 
+-    for varname in [
+-            'kde_version',
+-            'kde_version_extra',
+-            'kdebasedir',
+-            'kdeincdir',
+-            'kdelibdir',
+-            'libdir',
+-            'pykde_kde_sip_flags', 
+-            'pykde_mod_dir',
+-            'pykde_modules', 
+-            'pykde_sip_dir',
+-            'pykde_version',
+-            'pykde_version_str']:
+-        varvalue = _pkg_config[varname]
+-        if varname == 'pykde_sip_dir':
+-            d = os.path.join(_pkg_config[varname], 'PyKDE4')
+-            if os.path.exists(d):
+-                varvalue = d
+-        print("%s:%s\n" % (varname, varvalue))
+-    pykde_version_tag = ''
+-    in_t = False
+-    for item in _pkg_config['pykde_kde_sip_flags'].split():
+-        if item == "-t":
+-            in_t = True
+-        elif in_t:
+-            if item.startswith("KDE_"):
+-                pykde_version_tag = item
+-        else:
+-            in_t = False
+-    print("pykde_version_tag:%s" % pykde_version_tag)
++    print('pykde_version:%06.x' % PyKDE4.kdecore.version())
++    print('pykde_version_str:%s' % PyKDE4.kdecore.versionString())
++    print('pykde_sip_dir:%s' % sip_dir)
++    print('pykde_sip_flags:%s' % sip_flags)
+ 
+-else:
+-    sys.exit(1)
+--- kdelibs-4.13.3/cmake/modules/FindPyQt.py~	2014-08-06 21:55:55.874081319 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyQt.py	2014-08-06 21:56:06.250706848 +0000
+@@ -1,24 +1,49 @@
+ # Copyright (c) 2007, Simon Edwards <simon at simonzone.com>
++# Copyright (c) 2014, Raphael Kubo da Costa <rakuco at FreeBSD.org>
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+ 
+-import PyQt4.pyqtconfig
++import PyQt4.QtCore
++import os
++import sys
+ 
+-pyqtcfg = PyQt4.pyqtconfig.Configuration()
+-print("pyqt_version:%06.0x" % pyqtcfg.pyqt_version)
+-print("pyqt_version_str:%s" % pyqtcfg.pyqt_version_str)
+-
+-pyqt_version_tag = ""
+-in_t = False
+-for item in pyqtcfg.pyqt_sip_flags.split(' '):
+-    if item=="-t":
+-        in_t = True
+-    elif in_t:
+-        if item.startswith("Qt_4"):
+-            pyqt_version_tag = item
++def get_default_sip_dir():
++    # This is based on QScintilla's configure.py, and only works for the
++    # default case where installation paths have not been changed in PyQt's
++    # configuration process.
++    if sys.platform == 'win32':
++        pyqt_sip_dir = os.path.join(sys.prefix, 'sip', 'PyQt4')
+     else:
+-        in_t = False
+-print("pyqt_version_tag:%s" % pyqt_version_tag)
++        pyqt_sip_dir = os.path.join(sys.prefix, 'share', 'sip', 'PyQt4')
++    return pyqt_sip_dir
++
++def get_qt4_tag(sip_flags):
++    in_t = False
++    for item in sip_flags.split(' '):
++        if item == '-t':
++            in_t = True
++        elif in_t:
++            if item.startswith('Qt_4'):
++                return item
++        else:
++            in_t = False
++    raise ValueError('Cannot find Qt\'s tag in PyQt4\'s SIP flags.')
++
++if __name__ == '__main__':
++    try:
++        import PyQt4.pyqtconfig
++        pyqtcfg = PyQt4.pyqtconfig.Configuration()
++        sip_dir = pyqtcfg.pyqt_sip_dir
++        sip_flags = pyqtcfg.pyqt_sip_flags
++    except ImportError:
++        # PyQt4 >= 4.10.0 was built with configure-ng.py instead of
++        # configure.py, so pyqtconfig.py is not installed.
++        sip_dir = get_default_sip_dir()
++        sip_flags = PyQt4.QtCore.PYQT_CONFIGURATION['sip_flags']
++
++    print('pyqt_version:%06.x' % PyQt4.QtCore.PYQT_VERSION)
++    print('pyqt_version_str:%s' % PyQt4.QtCore.PYQT_VERSION_STR)
++    print('pyqt_version_tag:%s' % get_qt4_tag(sip_flags))
++    print('pyqt_sip_dir:%s' % sip_dir)
++    print('pyqt_sip_flags:%s' % sip_flags)
+ 
+-print("pyqt_sip_dir:%s" % pyqtcfg.pyqt_sip_dir)
+-print("pyqt_sip_flags:%s" % pyqtcfg.pyqt_sip_flags)
+--- kdelibs-4.13.3/cmake/modules/FindPyQt4.cmake~	2014-08-06 21:55:16.697570407 +0000
++++ kdelibs-4.13.3/cmake/modules/FindPyQt4.cmake	2014-08-06 21:55:38.597483393 +0000
+@@ -9,16 +9,20 @@
+ # Find the installed version of PyQt4. FindPyQt4 should only be called after
+ # Python has been found.
+ #
+-# This file defines the following variables:
++# This file defines the following variables, which can also be overriden by
++# users:
+ #
+ # PYQT4_VERSION - The version of PyQt4 found expressed as a 6 digit hex number
+ #     suitable for comparison as a string
+ #
+ # PYQT4_VERSION_STR - The version of PyQt4 as a human readable string.
+ #
+-# PYQT4_VERSION_TAG - The PyQt version tag using by PyQt's sip files.
++# PYQT4_VERSION_TAG - The Qt4 version tag used by PyQt's sip files.
+ #
+-# PYQT4_SIP_DIR - The directory holding the PyQt4 .sip files.
++# PYQT4_SIP_DIR - The directory holding the PyQt4 .sip files. This can be unset
++# if PyQt4 was built using its new build system and pyqtconfig.py is not
++# present on the system, as in this case its value cannot be determined
++# automatically.
+ #
+ # PYQT4_SIP_FLAGS - The SIP flags used to build PyQt.
+ 
+@@ -31,13 +35,27 @@
+ 
+   EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} ${_find_pyqt_py} OUTPUT_VARIABLE pyqt_config)
+   IF(pyqt_config)
+-    STRING(REGEX REPLACE "^pyqt_version:([^\n]+).*$" "\\1" PYQT4_VERSION ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_version_str:([^\n]+).*$" "\\1" PYQT4_VERSION_STR ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_version_tag:([^\n]+).*$" "\\1" PYQT4_VERSION_TAG ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_sip_dir:([^\n]+).*$" "\\1" PYQT4_SIP_DIR ${pyqt_config})
+-    STRING(REGEX REPLACE ".*\npyqt_sip_flags:([^\n]+).*$" "\\1" PYQT4_SIP_FLAGS ${pyqt_config})
++    STRING(REGEX MATCH "^pyqt_version:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION "${CMAKE_MATCH_1}" CACHE STRING "PyQt4's version as a 6-digit hexadecimal number")
+ 
+-    SET(PYQT4_FOUND TRUE)
++    STRING(REGEX MATCH ".*\npyqt_version_str:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION_STR "${CMAKE_MATCH_1}" CACHE STRING "PyQt4's version as a human-readable string")
++
++    STRING(REGEX MATCH ".*\npyqt_version_tag:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_VERSION_TAG "${CMAKE_MATCH_1}" CACHE STRING "The Qt4 version tag used by PyQt4's .sip files")
++
++    STRING(REGEX MATCH ".*\npyqt_sip_dir:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_SIP_DIR "${CMAKE_MATCH_1}" CACHE PATH "The base directory where PyQt4's .sip files are installed")
++
++    STRING(REGEX MATCH ".*\npyqt_sip_flags:([^\n]+).*$" _dummy ${pyqt_config})
++    SET(PYQT4_SIP_FLAGS "${CMAKE_MATCH_1}" CACHE STRING "The SIP flags used to build PyQt4")
++
++    IF(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
++      MESSAGE(WARNING "The base directory where PyQt4's SIP files are installed could not be determined. This usually means PyQt4 was built with its new build system and pyqtconfig.py is not present.\n"
++                      "Please set the PYQT4_SIP_DIR variable manually.")
++    ELSE(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
++      SET(PYQT4_FOUND TRUE)
++    ENDIF(NOT IS_DIRECTORY "${PYQT4_SIP_DIR}")
+   ENDIF(pyqt_config)
+ 
+   IF(PYQT4_FOUND)
+@@ -51,3 +69,4 @@
+   ENDIF(PYQT4_FOUND)
+ 
+ ENDIF(EXISTS PYQT4_VERSION)
++

Copied: kdelibs/repos/testing-x86_64/qt4.patch (from rev 226389, kdelibs/trunk/qt4.patch)
===================================================================
--- testing-x86_64/qt4.patch	                        (rev 0)
+++ testing-x86_64/qt4.patch	2014-11-19 15:12:45 UTC (rev 226390)
@@ -0,0 +1,11 @@
+--- kdelibs-4.10.1/cmake/modules/FindQt4.cmake~	2013-03-07 16:57:29.735552097 +0000
++++ kdelibs-4.10.1/cmake/modules/FindQt4.cmake	2013-03-07 16:57:52.038725421 +0000
+@@ -446,7 +446,7 @@
+ # check for qmake
+ # Debian uses qmake-qt4
+ # macports' Qt uses qmake-mac
+-FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake qmake4 qmake-qt4 qmake-mac PATHS
++FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake4 qmake-qt4 qmake-mac PATHS
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Qt3Versions\\4.0.0;InstallDir]/bin"
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\4.0.0;InstallDir]/bin"
+   "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\${qt_install_version};InstallDir]/bin"


More information about the arch-commits mailing list