[arch-commits] Commit in docker/repos/community-x86_64 (4 files)

Sébastien Luttringer seblu at archlinux.org
Tue Nov 25 22:35:12 UTC 2014


    Date: Tuesday, November 25, 2014 @ 23:35:11
  Author: seblu
Revision: 123115

archrelease: copy trunk to community-x86_64

Added:
  docker/repos/community-x86_64/PKGBUILD
    (from rev 123114, docker/trunk/PKGBUILD)
  docker/repos/community-x86_64/docker.install
    (from rev 123114, docker/trunk/docker.install)
Deleted:
  docker/repos/community-x86_64/PKGBUILD
  docker/repos/community-x86_64/docker.install

----------------+
 PKGBUILD       |  108 +++++++++++++++++++++++++++----------------------------
 docker.install |   36 +++++++++---------
 2 files changed, 72 insertions(+), 72 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2014-11-25 22:35:01 UTC (rev 123114)
+++ PKGBUILD	2014-11-25 22:35:11 UTC (rev 123115)
@@ -1,54 +0,0 @@
-# $Id$
-# Maintainer: Sébastien "Seblu" Luttringer
-
-pkgname=docker
-pkgver=1.3.1
-pkgrel=1
-epoch=1
-pkgdesc='Pack, ship and run any application as a lightweight container'
-arch=('x86_64')
-url='http://www.docker.io/'
-license=('Apache')
-depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd')
-makedepends=('git' 'go' 'btrfs-progs')
-optdepends=('btrfs-progs: btrfs backend support'
-            'lxc: lxc backend support')
-# don't strip binaries! A sha1 is used to check binary consistency.
-options=('!strip')
-install=$pkgname.install
-source=("git+https://github.com/docker/docker.git#tag=v$pkgver")
-md5sums=('SKIP')
-
-build() {
-  cd docker
-  export AUTO_GOPATH=1
-  ./hack/make.sh dynbinary
-}
-
-#check() {
-#  cd "$_magic/docker"
-#  # Will be added upstream soon
-#  ./hack/make.sh dyntest
-#}
-
-package() {
-  cd docker
-  install -Dm755 "bundles/$pkgver/dynbinary/docker-$pkgver" "$pkgdir/usr/bin/docker"
-  install -Dm755 "bundles/$pkgver/dynbinary/dockerinit-$pkgver" "$pkgdir/usr/lib/docker/dockerinit"
-  # completion
-  install -Dm644 'contrib/completion/bash/docker' "$pkgdir/usr/share/bash-completion/completions/docker"
-  install -Dm644 'contrib/completion/zsh/_docker' "$pkgdir/usr/share/zsh/site-functions/_docker"
-  install -Dm644 'contrib/completion/fish/docker.fish' "$pkgdir/usr/share/fish/completions/docker.fish"
-  # systemd
-  install -Dm644 'contrib/init/systemd/docker.service' \
-    "$pkgdir/usr/lib/systemd/system/docker.service"
-  install -Dm644 'contrib/init/systemd/docker.socket' \
-    "$pkgdir/usr/lib/systemd/system/docker.socket"
-  # vim syntax
-  install -Dm644 'contrib/syntax/vim/syntax/dockerfile.vim' \
-    "$pkgdir/usr/share/vim/vimfiles/syntax/dockerfile.vim"
-  install -Dm644 'contrib/syntax/vim/ftdetect/dockerfile.vim' \
-    "$pkgdir/usr/share/vim/vimfiles/ftdetect/dockerfile.vim"
-}
-
-# vim:set ts=2 sw=2 et:

Copied: docker/repos/community-x86_64/PKGBUILD (from rev 123114, docker/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2014-11-25 22:35:11 UTC (rev 123115)
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Sébastien "Seblu" Luttringer
+
+pkgname=docker
+pkgver=1.3.2
+pkgrel=1
+epoch=1
+pkgdesc='Pack, ship and run any application as a lightweight container'
+arch=('x86_64')
+url='http://www.docker.io/'
+license=('Apache')
+depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd')
+makedepends=('git' 'go' 'btrfs-progs')
+optdepends=('btrfs-progs: btrfs backend support'
+            'lxc: lxc backend support')
+# don't strip binaries! A sha1 is used to check binary consistency.
+options=('!strip')
+install=$pkgname.install
+source=("git+https://github.com/docker/docker.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+  cd docker
+  export AUTO_GOPATH=1
+  ./hack/make.sh dynbinary
+}
+
+#check() {
+#  cd "$_magic/docker"
+#  # Will be added upstream soon
+#  ./hack/make.sh dyntest
+#}
+
+package() {
+  cd docker
+  install -Dm755 "bundles/$pkgver/dynbinary/docker-$pkgver" "$pkgdir/usr/bin/docker"
+  install -Dm755 "bundles/$pkgver/dynbinary/dockerinit-$pkgver" "$pkgdir/usr/lib/docker/dockerinit"
+  # completion
+  install -Dm644 'contrib/completion/bash/docker' "$pkgdir/usr/share/bash-completion/completions/docker"
+  install -Dm644 'contrib/completion/zsh/_docker' "$pkgdir/usr/share/zsh/site-functions/_docker"
+  install -Dm644 'contrib/completion/fish/docker.fish' "$pkgdir/usr/share/fish/completions/docker.fish"
+  # systemd
+  install -Dm644 'contrib/init/systemd/docker.service' \
+    "$pkgdir/usr/lib/systemd/system/docker.service"
+  install -Dm644 'contrib/init/systemd/docker.socket' \
+    "$pkgdir/usr/lib/systemd/system/docker.socket"
+  # vim syntax
+  install -Dm644 'contrib/syntax/vim/syntax/dockerfile.vim' \
+    "$pkgdir/usr/share/vim/vimfiles/syntax/dockerfile.vim"
+  install -Dm644 'contrib/syntax/vim/ftdetect/dockerfile.vim' \
+    "$pkgdir/usr/share/vim/vimfiles/ftdetect/dockerfile.vim"
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: docker.install
===================================================================
--- docker.install	2014-11-25 22:35:01 UTC (rev 123114)
+++ docker.install	2014-11-25 22:35:11 UTC (rev 123115)
@@ -1,18 +0,0 @@
-# arg 1:  the new package version
-post_install() {
-  # create docker group (FS#38029)
-  getent group docker >/dev/null || groupadd -g 142 docker
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-  (( $(vercmp $2 '1:0.7.1-1') < 0 )) &&  post_install "$1" || true
-}
-
-# arg 1:  the old package version
-post_remove() {
-  groupdel docker >/dev/null 2>&1 || true
-}
-
-# vim:set ts=2 sw=2 et:

Copied: docker/repos/community-x86_64/docker.install (from rev 123114, docker/trunk/docker.install)
===================================================================
--- docker.install	                        (rev 0)
+++ docker.install	2014-11-25 22:35:11 UTC (rev 123115)
@@ -0,0 +1,18 @@
+# arg 1:  the new package version
+post_install() {
+  # create docker group (FS#38029)
+  getent group docker >/dev/null || groupadd -g 142 docker
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  (( $(vercmp $2 '1:0.7.1-1') < 0 )) &&  post_install "$1" || true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  groupdel docker >/dev/null 2>&1 || true
+}
+
+# vim:set ts=2 sw=2 et:


More information about the arch-commits mailing list