[arch-commits] Commit in vim/repos (12 files)

Anatol Pomozov anatolik at archlinux.org
Sat Nov 29 18:26:24 UTC 2014


    Date: Saturday, November 29, 2014 @ 19:26:23
  Author: anatolik
Revision: 227187

archrelease: copy trunk to testing-i686, testing-x86_64

Added:
  vim/repos/testing-i686/
  vim/repos/testing-i686/PKGBUILD
    (from rev 227186, vim/trunk/PKGBUILD)
  vim/repos/testing-i686/archlinux.vim
    (from rev 227186, vim/trunk/archlinux.vim)
  vim/repos/testing-i686/gvim.desktop
    (from rev 227186, vim/trunk/gvim.desktop)
  vim/repos/testing-i686/gvim.install
    (from rev 227186, vim/trunk/gvim.install)
  vim/repos/testing-i686/vimrc
    (from rev 227186, vim/trunk/vimrc)
  vim/repos/testing-x86_64/
  vim/repos/testing-x86_64/PKGBUILD
    (from rev 227186, vim/trunk/PKGBUILD)
  vim/repos/testing-x86_64/archlinux.vim
    (from rev 227186, vim/trunk/archlinux.vim)
  vim/repos/testing-x86_64/gvim.desktop
    (from rev 227186, vim/trunk/gvim.desktop)
  vim/repos/testing-x86_64/gvim.install
    (from rev 227186, vim/trunk/gvim.install)
  vim/repos/testing-x86_64/vimrc
    (from rev 227186, vim/trunk/vimrc)

------------------------------+
 testing-i686/PKGBUILD        |  392 +++++++++++++++++++++++++++++++++++++++++
 testing-i686/archlinux.vim   |   25 ++
 testing-i686/gvim.desktop    |   63 ++++++
 testing-i686/gvim.install    |   15 +
 testing-i686/vimrc           |   16 +
 testing-x86_64/PKGBUILD      |  392 +++++++++++++++++++++++++++++++++++++++++
 testing-x86_64/archlinux.vim |   25 ++
 testing-x86_64/gvim.desktop  |   63 ++++++
 testing-x86_64/gvim.install  |   15 +
 testing-x86_64/vimrc         |   16 +
 10 files changed, 1022 insertions(+)

Copied: vim/repos/testing-i686/PKGBUILD (from rev 227186, vim/trunk/PKGBUILD)
===================================================================
--- testing-i686/PKGBUILD	                        (rev 0)
+++ testing-i686/PKGBUILD	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,392 @@
+# Maintainer: Thomas Dziedzic <gostrc at gmail.com>
+# Contributor: Jan "heftig" Steffens <jan.steffens at gmail.com>
+# Contributor: tobias [ tobias at archlinux org ]
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
+
+pkgbase=vim
+pkgname=('vim-minimal' 'vim' 'vim-python3' 'gvim' 'gvim-python3' 'vim-runtime')
+# list of tags can be found at https://code.google.com/p/vim/source/list
+_topver=7.4
+_patchlevel=537
+_tag=v${_topver/./-}-${_patchlevel}
+_versiondir="vim${_topver//./}"
+pkgver=${_topver}.${_patchlevel}
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('custom:vim')
+url="http://www.vim.org"
+makedepends=('gpm' 'python2' 'python' 'ruby' 'libxt' 'desktop-file-utils' 'gtk2' 'lua' 'mercurial')
+# It would be great to use downloadable archives https://vim.googlecode.com/archive/$tag.tar.gz
+# unfortunately its content changes each time you download one (files modification date is different)
+source=("${pkgbase}-repo::hg+https://vim.googlecode.com/hg#tag=${_tag}"
+        'vimrc'
+        'archlinux.vim'
+        'gvim.desktop')
+sha1sums=('SKIP'
+          '15ebf3f48693f1f219fe2d8edb7643683139eb6b'
+          '94f7bb87b5d06bace86bc4b3ef1372813b4eedf2'
+          '4a579cf66590d711f49c5dfb4a25e5df116ff7ba')
+
+prepare() {
+  cd ${pkgbase}-repo
+
+  _latesttag=$(hg parents --template '{latesttag}' -r default)
+  if (( $_tag != $_latesttag )); then
+    printf 'You are not building the latest revision!\n'
+    printf "Consider updating to tag $_latesttag.\n"
+  fi
+
+  # define the place for the global (g)vimrc file (set to /etc/vimrc)
+  sed -i 's|^.*\(#define SYS_.*VIMRC_FILE.*"\) .*$|\1|' \
+    src/feature.h
+  sed -i 's|^.*\(#define VIMRC_FILE.*"\) .*$|\1|' \
+    src/feature.h
+
+  (cd src && autoconf)
+
+  cd ..
+  for pkg in ${pkgname[@]}
+  do
+    cp -a ${pkgbase}-repo ${pkg}-build
+  done
+}
+
+build() {
+  cd "${srcdir}"/vim-runtime-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --disable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --disable-python3interp \
+    --disable-rubyinterp \
+    --disable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-minimal-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --disable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --disable-python3interp \
+    --disable-rubyinterp \
+    --disable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --enable-pythoninterp \
+    --disable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-python3-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --enable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/gvim-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=yes \
+    --enable-gui=gtk2 \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --enable-pythoninterp \
+    --disable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/gvim-python3-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=yes \
+    --enable-gui=gtk2 \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --enable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+}
+
+check() {
+  # disable tests because they seem to freeze
+
+  cd "${srcdir}"/vim-build
+
+  #make test
+
+  cd "${srcdir}"/gvim-build
+
+  #make test
+}
+
+package_vim-minimal() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with a minimal set of dependencies)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'acl')
+  conflicts=('vim' 'vim-python3' 'gvim' 'gvim-python3')
+  provides=("vim=${pkgver}-${pkgrel}")
+
+  cd "${srcdir}"/vim-minimal-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with support for additional scripting languages)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'lua' 'python2' 'acl')
+  conflicts=('vim-minimal' 'vim-python3' 'gvim' 'gvim-python3')
+
+  cd "${srcdir}"/vim-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim-python3() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with support for additional scripting languages)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'lua' 'python' 'acl')
+  conflicts=('vim-minimal' 'vim' 'gvim' 'gvim-python3')
+  provides=("vim=${pkgver}-${pkgrel}")
+
+  cd "${srcdir}"/vim-python3-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_gvim() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with advanced features, such as a GUI)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'libxt'
+           'desktop-file-utils' 'gtk2' 'lua' 'python2')
+  provides=("vim=${pkgver}-${pkgrel}")
+  conflicts=('vim-minimal' 'vim' 'vim-python3' 'gvim-python3')
+  install=gvim.install
+
+  cd "${srcdir}"/gvim-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+  done
+
+  # need to remove since this is provided by vim-runtime
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # freedesktop links
+  install -Dm644 "${srcdir}"/gvim.desktop \
+    "${pkgdir}"/usr/share/applications/gvim.desktop
+  install -Dm644 runtime/vim48x48.png "${pkgdir}"/usr/share/pixmaps/gvim.png
+
+  # license
+   install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_gvim-python3() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with advanced features, such as a GUI) with python 3 support'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'libxt'
+           'desktop-file-utils' 'gtk2' 'lua' 'python')
+  provides=("vim=${pkgver}-${pkgrel}"
+            "gvim=${pkgver}-${pkgrel}")
+  conflicts=('vim-minimal' 'vim' 'vim-python3' 'gvim')
+  install=gvim.install
+
+  cd "${srcdir}"/gvim-python3-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+  done
+
+  # need to remove since this is provided by vim-runtime
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # freedesktop links
+  install -Dm644 "${srcdir}"/gvim.desktop \
+    "${pkgdir}"/usr/share/applications/gvim.desktop
+  install -Dm644 runtime/vim48x48.png "${pkgdir}"/usr/share/pixmaps/gvim.png
+
+  # license
+   install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim-runtime() {
+  pkgdesc='Runtime for vim and gvim'
+  depends=('perl' 'gawk')
+  backup=('etc/vimrc')
+
+  cd "${srcdir}"/vim-runtime-build
+
+  (cd src && make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" installruntime install-languages installtools)
+  # man and bin files belong to 'vim'
+  rm -r "${pkgdir}"/usr/share/man/ "${pkgdir}"/usr/bin/
+
+  # Don't forget logtalk.dict
+  install -Dm644 runtime/ftplugin/logtalk.dict \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/ftplugin/logtalk.dict
+
+  # fix FS#17216
+  sed -i 's|messages,/var|messages,/var/log/messages.log,/var|' \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/filetype.vim
+
+  # patch filetype.vim for better handling of pacman related files
+  sed -i "s/rpmsave/pacsave/;s/rpmnew/pacnew/;s/,\*\.ebuild/\0,PKGBUILD*,*.install/" \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/filetype.vim
+  sed -i "/find the end/,+3{s/changelog_date_entry_search/changelog_date_end_entry_search/}" \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/ftplugin/changelog.vim
+
+  # rc files
+  install -Dm644 "${srcdir}"/vimrc "${pkgdir}"/etc/vimrc
+  install -Dm644 "${srcdir}"/archlinux.vim \
+    "${pkgdir}"/usr/share/vim/vimfiles/archlinux.vim
+
+  # rgb.txt file
+  install -Dm644 runtime/rgb.txt \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/rgb.txt
+
+  # license
+  install -dm755 "${pkgdir}"/usr/share/licenses/vim-runtime
+  ln -s /usr/share/vim/${_versiondir}/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/vim-runtime/license.txt
+}
+
+# vim:set sw=2 sts=2 et:

Copied: vim/repos/testing-i686/archlinux.vim (from rev 227186, vim/trunk/archlinux.vim)
===================================================================
--- testing-i686/archlinux.vim	                        (rev 0)
+++ testing-i686/archlinux.vim	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,25 @@
+" The ArchLinux global vimrc - setting only a few sane defaults
+"
+" Maintainer:      Thomas Dziedzic [gostrc at gmail.com]
+"
+" NEVER EDIT THIS FILE, IT'S OVERWRITTEN UPON UPGRADES, GLOBAL CONFIGURATION
+" SHALL BE DONE IN /etc/vimrc, USER SPECIFIC CONFIGURATION IN ~/.vimrc
+
+" Normally we use vim-extensions. If you want true vi-compatibility
+" remove change the following statements
+set nocompatible                " Use Vim defaults instead of 100% vi compatibility
+set backspace=indent,eol,start  " more powerful backspacing
+
+" Now we set some defaults for the editor
+set history=50                  " keep 50 lines of command line history
+set ruler                       " show the cursor position all the time
+
+" Suffixes that get lower priority when doing tab completion for filenames.
+" These are files we are not likely to want to edit or read.
+set suffixes=.bak,~,.swp,.o,.info,.aux,.log,.dvi,.bbl,.blg,.brf,.cb,.ind,.idx,.ilg,.inx,.out,.toc,.png,.jpg
+
+if has('gui_running')
+  " Make shift-insert work like in Xterm
+  map <S-Insert> <MiddleMouse>
+  map! <S-Insert> <MiddleMouse>
+endif

Copied: vim/repos/testing-i686/gvim.desktop (from rev 227186, vim/trunk/gvim.desktop)
===================================================================
--- testing-i686/gvim.desktop	                        (rev 0)
+++ testing-i686/gvim.desktop	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,63 @@
+[Desktop Entry]
+Name=Vi IMproved
+Name[bg]=Vi Ðåäàêòîð
+Name[ca]=Vi Millorat
+Name[da]=Vi forbedret
+Name[eo]=VIM
+Name[et]=Täiustatud Vi (vim)
+Name[fr]=Vi étendu (VIM)
+Name[he]=רפושמ Vi
+Name[hu]=Vi
+Name[is]=Vi IMproved ritillinn
+Name[it]=Vi iMproved
+Name[no]=Vi IMproved (forbedret VI)
+Name[pl]=Poprawiony VI (vim)
+Name[ro]=VIM
+Name[ru]=Улучшенный VI
+Name[sk]=Vi IMpreved
+Name[sl]=Izboljšani vi (vim)
+Name[sv]=Förbättrad Vi
+Name[zh_CN.GB2312]=改进的 Vi
+Comment=Powerful text editor with scripting functions and macro recorder
+Comment[bg]=Ðåäàêòîð ñ ìíîãî âúçìîæíîñòè
+Comment[ca]=Editor vi potent
+Comment[cs]=Mocný textový editor vi
+Comment[da]=En kraftig vi tekstbehandler
+Comment[de]=Ein leistungsfähiger vi-Editor
+Comment[el]=Πανίσχυρος διορθωτής vi
+Comment[eo]=VIM similas al redaktilo "vi", sed havas aldonajn ecojn
+Comment[es]=Una versión mejorada del editor vi
+Comment[et]=Võimas tekstiredaktor vi
+Comment[fi]=Tehokas vi-tekstieditori
+Comment[fr]=Éditeur vi puissant
+Comment[gl]=Potente editor vi
+Comment[he]=Vi המצועה בר ךרועה
+Comment[hr]=Napredni vi uređivač
+Comment[hu]=Vi szövegszerkesztő
+Comment[is]=Öflug útgáfa vi ritilsins
+Comment[it]=Un editor vi potenziato
+Comment[ja]=強力なViエディタ
+Comment[lt]=Galingas vi redaktorius
+Comment[mk]=Моќен VI уредувач
+Comment[nl]=Krachtige vi-editor
+Comment[no]=En kraftig vi-redigerer
+Comment[no_NY]=Kraftig vi-tekstredigeringsprogram
+Comment[pl]=Edytor vi
+Comment[pt]=Um poderoso editor de texto
+Comment[ro]=Un editor de texte VI, puternic
+Comment[ru]=Мощный текстовый редактор vi
+Comment[sk]=Silný textový procesor vi
+Comment[sl]=Zmogljivi urejevalnik vi
+Comment[sr]=Moćni vi editor
+Comment[sv]=En kraftfull texteditor
+Comment[ta]=ºì¾¢Å¡öó¾ vi ¦¾¡ÌôÀ¡Ç÷
+Comment[tr]=Güçlü vi düzenleyicisi
+Comment[uk]=Потужний редактор vi
+Comment[zh_CN.GB2312]=功能强大的 vi 编辑器
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+Exec=gvim -f %F
+Icon=gvim
+Type=Application
+Terminal=false
+X-XClassHintResName=VIM
+Categories=Utility;TextEditor;

Copied: vim/repos/testing-i686/gvim.install (from rev 227186, vim/trunk/gvim.install)
===================================================================
--- testing-i686/gvim.install	                        (rev 0)
+++ testing-i686/gvim.install	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,15 @@
+update_desktop_database() {
+  update-desktop-database --quiet
+}
+
+post_install() {
+  update_desktop_database
+}
+
+post_upgrade() {
+  update_desktop_database
+}
+
+post_remove() {
+  update_desktop_database
+}

Copied: vim/repos/testing-i686/vimrc (from rev 227186, vim/trunk/vimrc)
===================================================================
--- testing-i686/vimrc	                        (rev 0)
+++ testing-i686/vimrc	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,16 @@
+" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
+" you can find below.  If you wish to change any of those settings, you should
+" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
+" everytime an upgrade of the vim packages is performed.  It is recommended to
+" make changes after sourcing archlinux.vim since it alters the value of the
+" 'compatible' option.
+
+" This line should not be removed as it ensures that various options are
+" properly set to work with the Vim-related packages.
+runtime! archlinux.vim
+
+" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
+" Or better yet, read /usr/share/vim/vim74/vimrc_example.vim or the vim manual
+" and configure vim to your own liking!
+

Copied: vim/repos/testing-x86_64/PKGBUILD (from rev 227186, vim/trunk/PKGBUILD)
===================================================================
--- testing-x86_64/PKGBUILD	                        (rev 0)
+++ testing-x86_64/PKGBUILD	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,392 @@
+# Maintainer: Thomas Dziedzic <gostrc at gmail.com>
+# Contributor: Jan "heftig" Steffens <jan.steffens at gmail.com>
+# Contributor: tobias [ tobias at archlinux org ]
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux.us>
+
+pkgbase=vim
+pkgname=('vim-minimal' 'vim' 'vim-python3' 'gvim' 'gvim-python3' 'vim-runtime')
+# list of tags can be found at https://code.google.com/p/vim/source/list
+_topver=7.4
+_patchlevel=537
+_tag=v${_topver/./-}-${_patchlevel}
+_versiondir="vim${_topver//./}"
+pkgver=${_topver}.${_patchlevel}
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('custom:vim')
+url="http://www.vim.org"
+makedepends=('gpm' 'python2' 'python' 'ruby' 'libxt' 'desktop-file-utils' 'gtk2' 'lua' 'mercurial')
+# It would be great to use downloadable archives https://vim.googlecode.com/archive/$tag.tar.gz
+# unfortunately its content changes each time you download one (files modification date is different)
+source=("${pkgbase}-repo::hg+https://vim.googlecode.com/hg#tag=${_tag}"
+        'vimrc'
+        'archlinux.vim'
+        'gvim.desktop')
+sha1sums=('SKIP'
+          '15ebf3f48693f1f219fe2d8edb7643683139eb6b'
+          '94f7bb87b5d06bace86bc4b3ef1372813b4eedf2'
+          '4a579cf66590d711f49c5dfb4a25e5df116ff7ba')
+
+prepare() {
+  cd ${pkgbase}-repo
+
+  _latesttag=$(hg parents --template '{latesttag}' -r default)
+  if (( $_tag != $_latesttag )); then
+    printf 'You are not building the latest revision!\n'
+    printf "Consider updating to tag $_latesttag.\n"
+  fi
+
+  # define the place for the global (g)vimrc file (set to /etc/vimrc)
+  sed -i 's|^.*\(#define SYS_.*VIMRC_FILE.*"\) .*$|\1|' \
+    src/feature.h
+  sed -i 's|^.*\(#define VIMRC_FILE.*"\) .*$|\1|' \
+    src/feature.h
+
+  (cd src && autoconf)
+
+  cd ..
+  for pkg in ${pkgname[@]}
+  do
+    cp -a ${pkgbase}-repo ${pkg}-build
+  done
+}
+
+build() {
+  cd "${srcdir}"/vim-runtime-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --disable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --disable-python3interp \
+    --disable-rubyinterp \
+    --disable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-minimal-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --disable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --disable-python3interp \
+    --disable-rubyinterp \
+    --disable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --enable-pythoninterp \
+    --disable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/vim-python3-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=no \
+    --disable-gui \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --enable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/gvim-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=yes \
+    --enable-gui=gtk2 \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --enable-pythoninterp \
+    --disable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+
+  cd "${srcdir}"/gvim-python3-build
+
+  ./configure \
+    --prefix=/usr \
+    --localstatedir=/var/lib/vim \
+    --with-features=huge \
+    --with-compiledby='Arch Linux' \
+    --enable-gpm \
+    --enable-acl \
+    --with-x=yes \
+    --enable-gui=gtk2 \
+    --enable-multibyte \
+    --enable-cscope \
+    --enable-netbeans \
+    --enable-perlinterp \
+    --disable-pythoninterp \
+    --enable-python3interp \
+    --enable-rubyinterp \
+    --enable-luainterp
+
+  make
+}
+
+check() {
+  # disable tests because they seem to freeze
+
+  cd "${srcdir}"/vim-build
+
+  #make test
+
+  cd "${srcdir}"/gvim-build
+
+  #make test
+}
+
+package_vim-minimal() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with a minimal set of dependencies)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'acl')
+  conflicts=('vim' 'vim-python3' 'gvim' 'gvim-python3')
+  provides=("vim=${pkgver}-${pkgrel}")
+
+  cd "${srcdir}"/vim-minimal-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with support for additional scripting languages)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'lua' 'python2' 'acl')
+  conflicts=('vim-minimal' 'vim-python3' 'gvim' 'gvim-python3')
+
+  cd "${srcdir}"/vim-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim-python3() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with support for additional scripting languages)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'lua' 'python' 'acl')
+  conflicts=('vim-minimal' 'vim' 'gvim' 'gvim-python3')
+  provides=("vim=${pkgver}-${pkgrel}")
+
+  cd "${srcdir}"/vim-python3-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+    rm -f evim.1    # this does not make sense if we have no GUI
+  done
+
+  # Runtime provided by runtime package
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # license
+  install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_gvim() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with advanced features, such as a GUI)'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'libxt'
+           'desktop-file-utils' 'gtk2' 'lua' 'python2')
+  provides=("vim=${pkgver}-${pkgrel}")
+  conflicts=('vim-minimal' 'vim' 'vim-python3' 'gvim-python3')
+  install=gvim.install
+
+  cd "${srcdir}"/gvim-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+  done
+
+  # need to remove since this is provided by vim-runtime
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # freedesktop links
+  install -Dm644 "${srcdir}"/gvim.desktop \
+    "${pkgdir}"/usr/share/applications/gvim.desktop
+  install -Dm644 runtime/vim48x48.png "${pkgdir}"/usr/share/pixmaps/gvim.png
+
+  # license
+   install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_gvim-python3() {
+  pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor (with advanced features, such as a GUI) with python 3 support'
+  depends=("vim-runtime=${pkgver}-${pkgrel}" 'gpm' 'ruby' 'libxt'
+           'desktop-file-utils' 'gtk2' 'lua' 'python')
+  provides=("vim=${pkgver}-${pkgrel}"
+            "gvim=${pkgver}-${pkgrel}")
+  conflicts=('vim-minimal' 'vim' 'vim-python3' 'gvim')
+  install=gvim.install
+
+  cd "${srcdir}"/gvim-python3-build
+  make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
+
+  # provided by (n)vi in core
+  rm "${pkgdir}"/usr/bin/{ex,view}
+
+  # delete some manpages
+  find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
+    while read _mandir; do
+    cd ${_mandir}
+    rm -f ex.1 view.1 # provided by (n)vi
+  done
+
+  # need to remove since this is provided by vim-runtime
+  rm -r "${pkgdir}"/usr/share/vim
+
+  # freedesktop links
+  install -Dm644 "${srcdir}"/gvim.desktop \
+    "${pkgdir}"/usr/share/applications/gvim.desktop
+  install -Dm644 runtime/vim48x48.png "${pkgdir}"/usr/share/pixmaps/gvim.png
+
+  # license
+   install -Dm644 runtime/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
+
+package_vim-runtime() {
+  pkgdesc='Runtime for vim and gvim'
+  depends=('perl' 'gawk')
+  backup=('etc/vimrc')
+
+  cd "${srcdir}"/vim-runtime-build
+
+  (cd src && make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" installruntime install-languages installtools)
+  # man and bin files belong to 'vim'
+  rm -r "${pkgdir}"/usr/share/man/ "${pkgdir}"/usr/bin/
+
+  # Don't forget logtalk.dict
+  install -Dm644 runtime/ftplugin/logtalk.dict \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/ftplugin/logtalk.dict
+
+  # fix FS#17216
+  sed -i 's|messages,/var|messages,/var/log/messages.log,/var|' \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/filetype.vim
+
+  # patch filetype.vim for better handling of pacman related files
+  sed -i "s/rpmsave/pacsave/;s/rpmnew/pacnew/;s/,\*\.ebuild/\0,PKGBUILD*,*.install/" \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/filetype.vim
+  sed -i "/find the end/,+3{s/changelog_date_entry_search/changelog_date_end_entry_search/}" \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/ftplugin/changelog.vim
+
+  # rc files
+  install -Dm644 "${srcdir}"/vimrc "${pkgdir}"/etc/vimrc
+  install -Dm644 "${srcdir}"/archlinux.vim \
+    "${pkgdir}"/usr/share/vim/vimfiles/archlinux.vim
+
+  # rgb.txt file
+  install -Dm644 runtime/rgb.txt \
+    "${pkgdir}"/usr/share/vim/${_versiondir}/rgb.txt
+
+  # license
+  install -dm755 "${pkgdir}"/usr/share/licenses/vim-runtime
+  ln -s /usr/share/vim/${_versiondir}/doc/uganda.txt \
+    "${pkgdir}"/usr/share/licenses/vim-runtime/license.txt
+}
+
+# vim:set sw=2 sts=2 et:

Copied: vim/repos/testing-x86_64/archlinux.vim (from rev 227186, vim/trunk/archlinux.vim)
===================================================================
--- testing-x86_64/archlinux.vim	                        (rev 0)
+++ testing-x86_64/archlinux.vim	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,25 @@
+" The ArchLinux global vimrc - setting only a few sane defaults
+"
+" Maintainer:      Thomas Dziedzic [gostrc at gmail.com]
+"
+" NEVER EDIT THIS FILE, IT'S OVERWRITTEN UPON UPGRADES, GLOBAL CONFIGURATION
+" SHALL BE DONE IN /etc/vimrc, USER SPECIFIC CONFIGURATION IN ~/.vimrc
+
+" Normally we use vim-extensions. If you want true vi-compatibility
+" remove change the following statements
+set nocompatible                " Use Vim defaults instead of 100% vi compatibility
+set backspace=indent,eol,start  " more powerful backspacing
+
+" Now we set some defaults for the editor
+set history=50                  " keep 50 lines of command line history
+set ruler                       " show the cursor position all the time
+
+" Suffixes that get lower priority when doing tab completion for filenames.
+" These are files we are not likely to want to edit or read.
+set suffixes=.bak,~,.swp,.o,.info,.aux,.log,.dvi,.bbl,.blg,.brf,.cb,.ind,.idx,.ilg,.inx,.out,.toc,.png,.jpg
+
+if has('gui_running')
+  " Make shift-insert work like in Xterm
+  map <S-Insert> <MiddleMouse>
+  map! <S-Insert> <MiddleMouse>
+endif

Copied: vim/repos/testing-x86_64/gvim.desktop (from rev 227186, vim/trunk/gvim.desktop)
===================================================================
--- testing-x86_64/gvim.desktop	                        (rev 0)
+++ testing-x86_64/gvim.desktop	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,63 @@
+[Desktop Entry]
+Name=Vi IMproved
+Name[bg]=Vi Ðåäàêòîð
+Name[ca]=Vi Millorat
+Name[da]=Vi forbedret
+Name[eo]=VIM
+Name[et]=Täiustatud Vi (vim)
+Name[fr]=Vi étendu (VIM)
+Name[he]=רפושמ Vi
+Name[hu]=Vi
+Name[is]=Vi IMproved ritillinn
+Name[it]=Vi iMproved
+Name[no]=Vi IMproved (forbedret VI)
+Name[pl]=Poprawiony VI (vim)
+Name[ro]=VIM
+Name[ru]=Улучшенный VI
+Name[sk]=Vi IMpreved
+Name[sl]=Izboljšani vi (vim)
+Name[sv]=Förbättrad Vi
+Name[zh_CN.GB2312]=改进的 Vi
+Comment=Powerful text editor with scripting functions and macro recorder
+Comment[bg]=Ðåäàêòîð ñ ìíîãî âúçìîæíîñòè
+Comment[ca]=Editor vi potent
+Comment[cs]=Mocný textový editor vi
+Comment[da]=En kraftig vi tekstbehandler
+Comment[de]=Ein leistungsfähiger vi-Editor
+Comment[el]=Πανίσχυρος διορθωτής vi
+Comment[eo]=VIM similas al redaktilo "vi", sed havas aldonajn ecojn
+Comment[es]=Una versión mejorada del editor vi
+Comment[et]=Võimas tekstiredaktor vi
+Comment[fi]=Tehokas vi-tekstieditori
+Comment[fr]=Éditeur vi puissant
+Comment[gl]=Potente editor vi
+Comment[he]=Vi המצועה בר ךרועה
+Comment[hr]=Napredni vi uređivač
+Comment[hu]=Vi szövegszerkesztő
+Comment[is]=Öflug útgáfa vi ritilsins
+Comment[it]=Un editor vi potenziato
+Comment[ja]=強力なViエディタ
+Comment[lt]=Galingas vi redaktorius
+Comment[mk]=Моќен VI уредувач
+Comment[nl]=Krachtige vi-editor
+Comment[no]=En kraftig vi-redigerer
+Comment[no_NY]=Kraftig vi-tekstredigeringsprogram
+Comment[pl]=Edytor vi
+Comment[pt]=Um poderoso editor de texto
+Comment[ro]=Un editor de texte VI, puternic
+Comment[ru]=Мощный текстовый редактор vi
+Comment[sk]=Silný textový procesor vi
+Comment[sl]=Zmogljivi urejevalnik vi
+Comment[sr]=Moćni vi editor
+Comment[sv]=En kraftfull texteditor
+Comment[ta]=ºì¾¢Å¡öó¾ vi ¦¾¡ÌôÀ¡Ç÷
+Comment[tr]=Güçlü vi düzenleyicisi
+Comment[uk]=Потужний редактор vi
+Comment[zh_CN.GB2312]=功能强大的 vi 编辑器
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
+Exec=gvim -f %F
+Icon=gvim
+Type=Application
+Terminal=false
+X-XClassHintResName=VIM
+Categories=Utility;TextEditor;

Copied: vim/repos/testing-x86_64/gvim.install (from rev 227186, vim/trunk/gvim.install)
===================================================================
--- testing-x86_64/gvim.install	                        (rev 0)
+++ testing-x86_64/gvim.install	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,15 @@
+update_desktop_database() {
+  update-desktop-database --quiet
+}
+
+post_install() {
+  update_desktop_database
+}
+
+post_upgrade() {
+  update_desktop_database
+}
+
+post_remove() {
+  update_desktop_database
+}

Copied: vim/repos/testing-x86_64/vimrc (from rev 227186, vim/trunk/vimrc)
===================================================================
--- testing-x86_64/vimrc	                        (rev 0)
+++ testing-x86_64/vimrc	2014-11-29 18:26:23 UTC (rev 227187)
@@ -0,0 +1,16 @@
+" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
+" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
+" you can find below.  If you wish to change any of those settings, you should
+" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
+" everytime an upgrade of the vim packages is performed.  It is recommended to
+" make changes after sourcing archlinux.vim since it alters the value of the
+" 'compatible' option.
+
+" This line should not be removed as it ensures that various options are
+" properly set to work with the Vim-related packages.
+runtime! archlinux.vim
+
+" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
+" Or better yet, read /usr/share/vim/vim74/vimrc_example.vim or the vim manual
+" and configure vim to your own liking!
+


More information about the arch-commits mailing list