[arch-commits] Commit in nvidia-340xx-lts/repos (10 files)

Laurent Carlier lcarlier at archlinux.org
Mon Mar 6 19:18:27 UTC 2017


    Date: Monday, March 6, 2017 @ 19:18:27
  Author: lcarlier
Revision: 290058

archrelease: copy trunk to extra-i686, extra-x86_64

Added:
  nvidia-340xx-lts/repos/extra-i686/PKGBUILD
    (from rev 290057, nvidia-340xx-lts/trunk/PKGBUILD)
  nvidia-340xx-lts/repos/extra-i686/fs52243.patch
    (from rev 290057, nvidia-340xx-lts/trunk/fs52243.patch)
  nvidia-340xx-lts/repos/extra-i686/nvidia-340xx-lts.install
    (from rev 290057, nvidia-340xx-lts/trunk/nvidia-340xx-lts.install)
  nvidia-340xx-lts/repos/extra-x86_64/PKGBUILD
    (from rev 290057, nvidia-340xx-lts/trunk/PKGBUILD)
  nvidia-340xx-lts/repos/extra-x86_64/fs52243.patch
    (from rev 290057, nvidia-340xx-lts/trunk/fs52243.patch)
  nvidia-340xx-lts/repos/extra-x86_64/nvidia-340xx-lts.install
    (from rev 290057, nvidia-340xx-lts/trunk/nvidia-340xx-lts.install)
Deleted:
  nvidia-340xx-lts/repos/extra-i686/PKGBUILD
  nvidia-340xx-lts/repos/extra-i686/nvidia-340xx-lts.install
  nvidia-340xx-lts/repos/extra-x86_64/PKGBUILD
  nvidia-340xx-lts/repos/extra-x86_64/nvidia-340xx-lts.install

---------------------------------------+
 /PKGBUILD                             |  112 ++++++++++++++++++++++++++++++++
 /nvidia-340xx-lts.install             |   30 ++++++++
 extra-i686/PKGBUILD                   |   50 --------------
 extra-i686/fs52243.patch              |   14 ++++
 extra-i686/nvidia-340xx-lts.install   |   15 ----
 extra-x86_64/PKGBUILD                 |   50 --------------
 extra-x86_64/fs52243.patch            |   14 ++++
 extra-x86_64/nvidia-340xx-lts.install |   15 ----
 8 files changed, 170 insertions(+), 130 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2017-03-06 19:18:16 UTC (rev 290057)
+++ extra-i686/PKGBUILD	2017-03-06 19:18:27 UTC (rev 290058)
@@ -1,50 +0,0 @@
-# $Id$
-# Maintainer: Eric Bélanger <eric at archlinux.org>
-
-pkgname=nvidia-340xx-lts
-pkgver=340.102
-_extramodules=extramodules-4.9-lts
-pkgrel=3
-pkgdesc="NVIDIA drivers for linux-lts"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-makedepends=('linux-lts>=4.9.13' 'linux-lts-headers>=4.9.13' "nvidia-340xx-utils=$pkgver")
-provides=('nvidia-340xx')
-conflicts=('nvidia-lts')
-license=('custom')
-install=${pkgname}.install
-options=(!strip)
-source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums_i686=('bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca')
-sha512sums_x86_64=('2a29e6418244ea384e4237d74057bd8e56247b1c503cf623dea34a3b1065d8783879aa7e6a802dd31f0a10cf81cfcab2a1b1a8269b97996f15fa1838c0a3a44b')
-
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
-
-prepare() {
-    sh ${_pkg}.run --extract-only
-}
-
-build() {
-  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-  cd "${_pkg}/kernel"
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-
-  cd uvm
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-}
-
-package() {
-  depends=('linux-lts>=4.4.40' "nvidia-340xx-utils=$pkgver" 'libgl')
-
-  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia-uvm.ko"
-  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/"*.ko
-  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
-}

Copied: nvidia-340xx-lts/repos/extra-i686/PKGBUILD (from rev 290057, nvidia-340xx-lts/trunk/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-340xx-lts
+pkgver=340.102
+_extramodules=extramodules-4.9-lts
+pkgrel=4
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+makedepends=('linux-lts>=4.9.13' 'linux-lts-headers>=4.9.13' "nvidia-340xx-utils=$pkgver")
+provides=('nvidia-340xx')
+conflicts=('nvidia-lts')
+license=('custom')
+install=${pkgname}.install
+options=(!strip)
+source=('fs52243.patch')
+source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('4b9b61bbcaaea4a99a6abe4a13309016')
+md5sums_i686=('61aad6a98238bc61466e6a9e392cfd08')
+md5sums_x86_64=('81e720487caa2823586b32659da9acc1')
+
+[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
+[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+
+prepare() {
+    sh ${_pkg}.run --extract-only
+    cd "${_pkg}"
+    # patches here
+
+    patch -Np0 < "${srcdir}"/fs52243.patch
+}
+
+build() {
+  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+  cd "${_pkg}/kernel"
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+
+  cd uvm
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+}
+
+package() {
+  depends=('linux-lts>=4.4.40' "nvidia-340xx-utils=$pkgver" 'libgl')
+
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia-uvm.ko"
+  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/"*.ko
+  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Copied: nvidia-340xx-lts/repos/extra-i686/fs52243.patch (from rev 290057, nvidia-340xx-lts/trunk/fs52243.patch)
===================================================================
--- extra-i686/fs52243.patch	                        (rev 0)
+++ extra-i686/fs52243.patch	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,14 @@
+--- kernel/nv-drm.c	2016-12-15 12:41:26.000000000 +0100
++++ kernel/nv-drm.c	2016-12-15 12:58:48.000000000 +0100
+@@ -115,7 +115,11 @@
+ };
+ 
+ static struct drm_driver nv_drm_driver = {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++    .driver_features = DRIVER_GEM | DRIVER_PRIME | DRIVER_LEGACY,
++#else
+     .driver_features = DRIVER_GEM | DRIVER_PRIME,
++#endif
+     .load = nv_drm_load,
+     .unload = nv_drm_unload,
+     .fops = &nv_drm_fops,

Deleted: extra-i686/nvidia-340xx-lts.install
===================================================================
--- extra-i686/nvidia-340xx-lts.install	2017-03-06 19:18:16 UTC (rev 290057)
+++ extra-i686/nvidia-340xx-lts.install	2017-03-06 19:18:27 UTC (rev 290058)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-340xx-lts/repos/extra-i686/nvidia-340xx-lts.install (from rev 290057, nvidia-340xx-lts/trunk/nvidia-340xx-lts.install)
===================================================================
--- extra-i686/nvidia-340xx-lts.install	                        (rev 0)
+++ extra-i686/nvidia-340xx-lts.install	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2017-03-06 19:18:16 UTC (rev 290057)
+++ extra-x86_64/PKGBUILD	2017-03-06 19:18:27 UTC (rev 290058)
@@ -1,50 +0,0 @@
-# $Id$
-# Maintainer: Eric Bélanger <eric at archlinux.org>
-
-pkgname=nvidia-340xx-lts
-pkgver=340.102
-_extramodules=extramodules-4.9-lts
-pkgrel=3
-pkgdesc="NVIDIA drivers for linux-lts"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-makedepends=('linux-lts>=4.9.13' 'linux-lts-headers>=4.9.13' "nvidia-340xx-utils=$pkgver")
-provides=('nvidia-340xx')
-conflicts=('nvidia-lts')
-license=('custom')
-install=${pkgname}.install
-options=(!strip)
-source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums_i686=('bea700c925a6044fcded40324bb389c5fa1aadc40831f685a76e7b0ded11161f492960950c201467e564d157dcbe0c330d13a2014f51d0073002c5a262a6f0ca')
-sha512sums_x86_64=('2a29e6418244ea384e4237d74057bd8e56247b1c503cf623dea34a3b1065d8783879aa7e6a802dd31f0a10cf81cfcab2a1b1a8269b97996f15fa1838c0a3a44b')
-
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
-
-prepare() {
-    sh ${_pkg}.run --extract-only
-}
-
-build() {
-  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-  cd "${_pkg}/kernel"
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-
-  cd uvm
-  make SYSSRC=/usr/lib/modules/${_kernver}/build module
-}
-
-package() {
-  depends=('linux-lts>=4.4.40' "nvidia-340xx-utils=$pkgver" 'libgl')
-
-  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
-  install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
-    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia-uvm.ko"
-  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/"*.ko
-  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
-  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
-}

Copied: nvidia-340xx-lts/repos/extra-x86_64/PKGBUILD (from rev 290057, nvidia-340xx-lts/trunk/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Eric Bélanger <eric at archlinux.org>
+
+pkgname=nvidia-340xx-lts
+pkgver=340.102
+_extramodules=extramodules-4.9-lts
+pkgrel=4
+pkgdesc="NVIDIA drivers for linux-lts"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+makedepends=('linux-lts>=4.9.13' 'linux-lts-headers>=4.9.13' "nvidia-340xx-utils=$pkgver")
+provides=('nvidia-340xx')
+conflicts=('nvidia-lts')
+license=('custom')
+install=${pkgname}.install
+options=(!strip)
+source=('fs52243.patch')
+source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('4b9b61bbcaaea4a99a6abe4a13309016')
+md5sums_i686=('61aad6a98238bc61466e6a9e392cfd08')
+md5sums_x86_64=('81e720487caa2823586b32659da9acc1')
+
+[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
+[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+
+prepare() {
+    sh ${_pkg}.run --extract-only
+    cd "${_pkg}"
+    # patches here
+
+    patch -Np0 < "${srcdir}"/fs52243.patch
+}
+
+build() {
+  _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+  cd "${_pkg}/kernel"
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+
+  cd uvm
+  make SYSSRC=/usr/lib/modules/${_kernver}/build module
+}
+
+package() {
+  depends=('linux-lts>=4.4.40' "nvidia-340xx-utils=$pkgver" 'libgl')
+
+  install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia.ko"
+  install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
+    "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/nvidia-uvm.ko"
+  gzip "${pkgdir}/usr/lib/modules/${_extramodules}/kernel/drivers/video/"*.ko
+  install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+  echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  echo "blacklist nvidiafb" >> "${pkgdir}/usr/lib/modprobe.d/nvidia-lts.conf"
+  install -D -m644 "${srcdir}/${_pkg}/LICENSE" "${pkgdir}/usr/share/licenses/nvidia-lts/LICENSE"
+}

Copied: nvidia-340xx-lts/repos/extra-x86_64/fs52243.patch (from rev 290057, nvidia-340xx-lts/trunk/fs52243.patch)
===================================================================
--- extra-x86_64/fs52243.patch	                        (rev 0)
+++ extra-x86_64/fs52243.patch	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,14 @@
+--- kernel/nv-drm.c	2016-12-15 12:41:26.000000000 +0100
++++ kernel/nv-drm.c	2016-12-15 12:58:48.000000000 +0100
+@@ -115,7 +115,11 @@
+ };
+ 
+ static struct drm_driver nv_drm_driver = {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++    .driver_features = DRIVER_GEM | DRIVER_PRIME | DRIVER_LEGACY,
++#else
+     .driver_features = DRIVER_GEM | DRIVER_PRIME,
++#endif
+     .load = nv_drm_load,
+     .unload = nv_drm_unload,
+     .fops = &nv_drm_fops,

Deleted: extra-x86_64/nvidia-340xx-lts.install
===================================================================
--- extra-x86_64/nvidia-340xx-lts.install	2017-03-06 19:18:16 UTC (rev 290057)
+++ extra-x86_64/nvidia-340xx-lts.install	2017-03-06 19:18:27 UTC (rev 290058)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-4.9-lts'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-340xx-lts/repos/extra-x86_64/nvidia-340xx-lts.install (from rev 290057, nvidia-340xx-lts/trunk/nvidia-340xx-lts.install)
===================================================================
--- extra-x86_64/nvidia-340xx-lts.install	                        (rev 0)
+++ extra-x86_64/nvidia-340xx-lts.install	2017-03-06 19:18:27 UTC (rev 290058)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-4.9-lts'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}


More information about the arch-commits mailing list