[arch-commits] Commit in leatherman/repos (8 files)

Jonathan Steel jsteel at archlinux.org
Tue Mar 14 14:30:57 UTC 2017


    Date: Tuesday, March 14, 2017 @ 14:30:56
  Author: jsteel
Revision: 216275

archrelease: copy trunk to community-i686, community-x86_64

Added:
  leatherman/repos/community-i686/PKGBUILD
    (from rev 216274, leatherman/trunk/PKGBUILD)
  leatherman/repos/community-i686/ruby-2.4.patch
    (from rev 216274, leatherman/trunk/ruby-2.4.patch)
  leatherman/repos/community-x86_64/PKGBUILD
    (from rev 216274, leatherman/trunk/PKGBUILD)
  leatherman/repos/community-x86_64/ruby-2.4.patch
    (from rev 216274, leatherman/trunk/ruby-2.4.patch)
Deleted:
  leatherman/repos/community-i686/PKGBUILD
  leatherman/repos/community-i686/ruby-2.4.patch
  leatherman/repos/community-x86_64/PKGBUILD
  leatherman/repos/community-x86_64/ruby-2.4.patch

---------------------------------+
 /PKGBUILD                       |   96 ++++++++++++++++++++++++++++
 /ruby-2.4.patch                 |  126 ++++++++++++++++++++++++++++++++++++++
 community-i686/PKGBUILD         |   48 --------------
 community-i686/ruby-2.4.patch   |   63 -------------------
 community-x86_64/PKGBUILD       |   48 --------------
 community-x86_64/ruby-2.4.patch |   63 -------------------
 6 files changed, 222 insertions(+), 222 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2017-03-14 14:30:43 UTC (rev 216274)
+++ community-i686/PKGBUILD	2017-03-14 14:30:56 UTC (rev 216275)
@@ -1,48 +0,0 @@
-# Maintainer: Jonathan Steel <jsteel at archlinux.org>
-
-pkgname=leatherman
-pkgver=0.11.0
-pkgrel=1
-pkgdesc="Collection of C++ and CMake utility libraries"
-arch=('i686' 'x86_64')
-url="https://github.com/puppetlabs/leatherman"
-license=('APACHE')
-makedepends=('boost' 'cmake' 'rapidjson')
-checkdepends=('ruby')
-source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz
-        ruby-2.4.patch)
-md5sums=('8ea6260b8138ee9b1210cf46673d308a'
-         'eb63e7694bd15e779ddc7b146adaad90')
-
-prepare() {
-  cd $pkgname-$pkgver
-
-  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
-  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
-    $( grep -rl rb_data_object_alloc ruby )
-
-  # (LTH-124) Fix for ruby-2.4 related API changes
-  patch -p1 -i ../ruby-2.4.patch
-}
-
-build() {
-  cd $pkgname-$pkgver
-
-  cmake -DCMAKE_INSTALL_PREFIX=/usr
-
-  make
-}
-
-check() {
-  cd $pkgname-$pkgver
-
-  make test
-}
-
-package() {
-  cd $pkgname-$pkgver
-
-  make install DESTDIR="$pkgdir"
-
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: leatherman/repos/community-i686/PKGBUILD (from rev 216274, leatherman/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2017-03-14 14:30:56 UTC (rev 216275)
@@ -0,0 +1,48 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+
+pkgname=leatherman
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="Collection of C++ and CMake utility libraries"
+arch=('i686' 'x86_64')
+url="https://github.com/puppetlabs/leatherman"
+license=('APACHE')
+makedepends=('boost' 'cmake' 'rapidjson')
+checkdepends=('ruby')
+source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz
+        ruby-2.4.patch)
+md5sums=('d4533726589e89f3aae20df027cd1ea3'
+         'eb63e7694bd15e779ddc7b146adaad90')
+
+prepare() {
+  cd $pkgname-$pkgver
+
+  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
+  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
+    $( grep -rl rb_data_object_alloc ruby )
+
+  # (LTH-124) Fix for ruby-2.4 related API changes
+  patch -p1 -i ../ruby-2.4.patch
+}
+
+build() {
+  cd $pkgname-$pkgver
+
+  cmake -DCMAKE_INSTALL_PREFIX=/usr
+
+  make
+}
+
+check() {
+  cd $pkgname-$pkgver
+
+  make test
+}
+
+package() {
+  cd $pkgname-$pkgver
+
+  make install DESTDIR="$pkgdir"
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}

Deleted: community-i686/ruby-2.4.patch
===================================================================
--- community-i686/ruby-2.4.patch	2017-03-14 14:30:43 UTC (rev 216274)
+++ community-i686/ruby-2.4.patch	2017-03-14 14:30:56 UTC (rev 216275)
@@ -1,63 +0,0 @@
-diff --git a/ruby/inc/leatherman/ruby/api.hpp b/ruby/inc/leatherman/ruby/api.hpp
-index 32117c6..4f6c0ba 100644
---- a/ruby/inc/leatherman/ruby/api.hpp
-+++ b/ruby/inc/leatherman/ruby/api.hpp
-@@ -412,15 +412,11 @@ namespace leatherman {  namespace ruby {
-         /**
-          * See MRI documentation.
-          */
--        VALUE* const rb_cFixnum;
-+        VALUE* const rb_cInteger;
-         /**
-          * See MRI documentation.
-          */
-         VALUE* const rb_cFloat;
--        /**
--         * See MRI documentation.
--         */
--        VALUE* const rb_cBignum;
- 
-         /**
-          * See MRI documentation.
-diff --git a/ruby/src/api.cc b/ruby/src/api.cc
-index 434f691..9e96e05 100644
---- a/ruby/src/api.cc
-+++ b/ruby/src/api.cc
-@@ -100,9 +100,8 @@ namespace leatherman { namespace ruby {
-         LOAD_SYMBOL(rb_cHash),
-         LOAD_SYMBOL(rb_cString),
-         LOAD_SYMBOL(rb_cSymbol),
--        LOAD_SYMBOL(rb_cFixnum),
-+        LOAD_SYMBOL(rb_cInteger),
-         LOAD_SYMBOL(rb_cFloat),
--        LOAD_SYMBOL(rb_cBignum),
-         LOAD_SYMBOL(rb_eException),
-         LOAD_SYMBOL(rb_eArgError),
-         LOAD_SYMBOL(rb_eTypeError),
-@@ -396,12 +395,12 @@ namespace leatherman { namespace ruby {
- 
-     bool api::is_fixednum(VALUE value) const
-     {
--        return is_a(value, *rb_cFixnum);
-+        return is_a(value, *rb_cInteger);
-     }
- 
-     bool api::is_bignum(VALUE value) const
-     {
--        return is_a(value, *rb_cBignum);
-+        return is_a(value, *rb_cInteger);
-     }
- 
-     bool api::is_float(VALUE value) const
-diff --git a/ruby/tests/api-test.cc b/ruby/tests/api-test.cc
-index 20bcec7..1d2cafb 100644
---- a/ruby/tests/api-test.cc
-+++ b/ruby/tests/api-test.cc
-@@ -52,7 +52,7 @@ TEST_CASE("api::is_*", "[ruby-api]") {
-         REQUIRE_FALSE(ruby.is_fixednum(ruby.eval("1.5")));
- 
-         REQUIRE(ruby.is_bignum(ruby.eval(to_string(numeric_limits<int64_t>::max()))));
--        REQUIRE_FALSE(ruby.is_bignum(ruby.eval("2")));
-+        REQUIRE(ruby.is_bignum(ruby.eval("2")));
-         REQUIRE_FALSE(ruby.is_bignum(ruby.eval("1.5")));
-     }

Copied: leatherman/repos/community-i686/ruby-2.4.patch (from rev 216274, leatherman/trunk/ruby-2.4.patch)
===================================================================
--- community-i686/ruby-2.4.patch	                        (rev 0)
+++ community-i686/ruby-2.4.patch	2017-03-14 14:30:56 UTC (rev 216275)
@@ -0,0 +1,63 @@
+diff --git a/ruby/inc/leatherman/ruby/api.hpp b/ruby/inc/leatherman/ruby/api.hpp
+index 32117c6..4f6c0ba 100644
+--- a/ruby/inc/leatherman/ruby/api.hpp
++++ b/ruby/inc/leatherman/ruby/api.hpp
+@@ -412,15 +412,11 @@ namespace leatherman {  namespace ruby {
+         /**
+          * See MRI documentation.
+          */
+-        VALUE* const rb_cFixnum;
++        VALUE* const rb_cInteger;
+         /**
+          * See MRI documentation.
+          */
+         VALUE* const rb_cFloat;
+-        /**
+-         * See MRI documentation.
+-         */
+-        VALUE* const rb_cBignum;
+ 
+         /**
+          * See MRI documentation.
+diff --git a/ruby/src/api.cc b/ruby/src/api.cc
+index 434f691..9e96e05 100644
+--- a/ruby/src/api.cc
++++ b/ruby/src/api.cc
+@@ -100,9 +100,8 @@ namespace leatherman { namespace ruby {
+         LOAD_SYMBOL(rb_cHash),
+         LOAD_SYMBOL(rb_cString),
+         LOAD_SYMBOL(rb_cSymbol),
+-        LOAD_SYMBOL(rb_cFixnum),
++        LOAD_SYMBOL(rb_cInteger),
+         LOAD_SYMBOL(rb_cFloat),
+-        LOAD_SYMBOL(rb_cBignum),
+         LOAD_SYMBOL(rb_eException),
+         LOAD_SYMBOL(rb_eArgError),
+         LOAD_SYMBOL(rb_eTypeError),
+@@ -396,12 +395,12 @@ namespace leatherman { namespace ruby {
+ 
+     bool api::is_fixednum(VALUE value) const
+     {
+-        return is_a(value, *rb_cFixnum);
++        return is_a(value, *rb_cInteger);
+     }
+ 
+     bool api::is_bignum(VALUE value) const
+     {
+-        return is_a(value, *rb_cBignum);
++        return is_a(value, *rb_cInteger);
+     }
+ 
+     bool api::is_float(VALUE value) const
+diff --git a/ruby/tests/api-test.cc b/ruby/tests/api-test.cc
+index 20bcec7..1d2cafb 100644
+--- a/ruby/tests/api-test.cc
++++ b/ruby/tests/api-test.cc
+@@ -52,7 +52,7 @@ TEST_CASE("api::is_*", "[ruby-api]") {
+         REQUIRE_FALSE(ruby.is_fixednum(ruby.eval("1.5")));
+ 
+         REQUIRE(ruby.is_bignum(ruby.eval(to_string(numeric_limits<int64_t>::max()))));
+-        REQUIRE_FALSE(ruby.is_bignum(ruby.eval("2")));
++        REQUIRE(ruby.is_bignum(ruby.eval("2")));
+         REQUIRE_FALSE(ruby.is_bignum(ruby.eval("1.5")));
+     }

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2017-03-14 14:30:43 UTC (rev 216274)
+++ community-x86_64/PKGBUILD	2017-03-14 14:30:56 UTC (rev 216275)
@@ -1,48 +0,0 @@
-# Maintainer: Jonathan Steel <jsteel at archlinux.org>
-
-pkgname=leatherman
-pkgver=0.11.0
-pkgrel=1
-pkgdesc="Collection of C++ and CMake utility libraries"
-arch=('i686' 'x86_64')
-url="https://github.com/puppetlabs/leatherman"
-license=('APACHE')
-makedepends=('boost' 'cmake' 'rapidjson')
-checkdepends=('ruby')
-source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz
-        ruby-2.4.patch)
-md5sums=('8ea6260b8138ee9b1210cf46673d308a'
-         'eb63e7694bd15e779ddc7b146adaad90')
-
-prepare() {
-  cd $pkgname-$pkgver
-
-  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
-  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
-    $( grep -rl rb_data_object_alloc ruby )
-
-  # (LTH-124) Fix for ruby-2.4 related API changes
-  patch -p1 -i ../ruby-2.4.patch
-}
-
-build() {
-  cd $pkgname-$pkgver
-
-  cmake -DCMAKE_INSTALL_PREFIX=/usr
-
-  make
-}
-
-check() {
-  cd $pkgname-$pkgver
-
-  make test
-}
-
-package() {
-  cd $pkgname-$pkgver
-
-  make install DESTDIR="$pkgdir"
-
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: leatherman/repos/community-x86_64/PKGBUILD (from rev 216274, leatherman/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2017-03-14 14:30:56 UTC (rev 216275)
@@ -0,0 +1,48 @@
+# Maintainer: Jonathan Steel <jsteel at archlinux.org>
+
+pkgname=leatherman
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="Collection of C++ and CMake utility libraries"
+arch=('i686' 'x86_64')
+url="https://github.com/puppetlabs/leatherman"
+license=('APACHE')
+makedepends=('boost' 'cmake' 'rapidjson')
+checkdepends=('ruby')
+source=($pkgname-$pkgver.tar.gz::https://github.com/puppetlabs/leatherman/archive/$pkgver.tar.gz
+        ruby-2.4.patch)
+md5sums=('d4533726589e89f3aae20df027cd1ea3'
+         'eb63e7694bd15e779ddc7b146adaad90')
+
+prepare() {
+  cd $pkgname-$pkgver
+
+  # Ruby 2.3 fix: replace rb_data_object_alloc symbol with rb_data_object_wrap
+  sed -i 's/rb_data_object_alloc/rb_data_object_wrap/g' \
+    $( grep -rl rb_data_object_alloc ruby )
+
+  # (LTH-124) Fix for ruby-2.4 related API changes
+  patch -p1 -i ../ruby-2.4.patch
+}
+
+build() {
+  cd $pkgname-$pkgver
+
+  cmake -DCMAKE_INSTALL_PREFIX=/usr
+
+  make
+}
+
+check() {
+  cd $pkgname-$pkgver
+
+  make test
+}
+
+package() {
+  cd $pkgname-$pkgver
+
+  make install DESTDIR="$pkgdir"
+
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}

Deleted: community-x86_64/ruby-2.4.patch
===================================================================
--- community-x86_64/ruby-2.4.patch	2017-03-14 14:30:43 UTC (rev 216274)
+++ community-x86_64/ruby-2.4.patch	2017-03-14 14:30:56 UTC (rev 216275)
@@ -1,63 +0,0 @@
-diff --git a/ruby/inc/leatherman/ruby/api.hpp b/ruby/inc/leatherman/ruby/api.hpp
-index 32117c6..4f6c0ba 100644
---- a/ruby/inc/leatherman/ruby/api.hpp
-+++ b/ruby/inc/leatherman/ruby/api.hpp
-@@ -412,15 +412,11 @@ namespace leatherman {  namespace ruby {
-         /**
-          * See MRI documentation.
-          */
--        VALUE* const rb_cFixnum;
-+        VALUE* const rb_cInteger;
-         /**
-          * See MRI documentation.
-          */
-         VALUE* const rb_cFloat;
--        /**
--         * See MRI documentation.
--         */
--        VALUE* const rb_cBignum;
- 
-         /**
-          * See MRI documentation.
-diff --git a/ruby/src/api.cc b/ruby/src/api.cc
-index 434f691..9e96e05 100644
---- a/ruby/src/api.cc
-+++ b/ruby/src/api.cc
-@@ -100,9 +100,8 @@ namespace leatherman { namespace ruby {
-         LOAD_SYMBOL(rb_cHash),
-         LOAD_SYMBOL(rb_cString),
-         LOAD_SYMBOL(rb_cSymbol),
--        LOAD_SYMBOL(rb_cFixnum),
-+        LOAD_SYMBOL(rb_cInteger),
-         LOAD_SYMBOL(rb_cFloat),
--        LOAD_SYMBOL(rb_cBignum),
-         LOAD_SYMBOL(rb_eException),
-         LOAD_SYMBOL(rb_eArgError),
-         LOAD_SYMBOL(rb_eTypeError),
-@@ -396,12 +395,12 @@ namespace leatherman { namespace ruby {
- 
-     bool api::is_fixednum(VALUE value) const
-     {
--        return is_a(value, *rb_cFixnum);
-+        return is_a(value, *rb_cInteger);
-     }
- 
-     bool api::is_bignum(VALUE value) const
-     {
--        return is_a(value, *rb_cBignum);
-+        return is_a(value, *rb_cInteger);
-     }
- 
-     bool api::is_float(VALUE value) const
-diff --git a/ruby/tests/api-test.cc b/ruby/tests/api-test.cc
-index 20bcec7..1d2cafb 100644
---- a/ruby/tests/api-test.cc
-+++ b/ruby/tests/api-test.cc
-@@ -52,7 +52,7 @@ TEST_CASE("api::is_*", "[ruby-api]") {
-         REQUIRE_FALSE(ruby.is_fixednum(ruby.eval("1.5")));
- 
-         REQUIRE(ruby.is_bignum(ruby.eval(to_string(numeric_limits<int64_t>::max()))));
--        REQUIRE_FALSE(ruby.is_bignum(ruby.eval("2")));
-+        REQUIRE(ruby.is_bignum(ruby.eval("2")));
-         REQUIRE_FALSE(ruby.is_bignum(ruby.eval("1.5")));
-     }

Copied: leatherman/repos/community-x86_64/ruby-2.4.patch (from rev 216274, leatherman/trunk/ruby-2.4.patch)
===================================================================
--- community-x86_64/ruby-2.4.patch	                        (rev 0)
+++ community-x86_64/ruby-2.4.patch	2017-03-14 14:30:56 UTC (rev 216275)
@@ -0,0 +1,63 @@
+diff --git a/ruby/inc/leatherman/ruby/api.hpp b/ruby/inc/leatherman/ruby/api.hpp
+index 32117c6..4f6c0ba 100644
+--- a/ruby/inc/leatherman/ruby/api.hpp
++++ b/ruby/inc/leatherman/ruby/api.hpp
+@@ -412,15 +412,11 @@ namespace leatherman {  namespace ruby {
+         /**
+          * See MRI documentation.
+          */
+-        VALUE* const rb_cFixnum;
++        VALUE* const rb_cInteger;
+         /**
+          * See MRI documentation.
+          */
+         VALUE* const rb_cFloat;
+-        /**
+-         * See MRI documentation.
+-         */
+-        VALUE* const rb_cBignum;
+ 
+         /**
+          * See MRI documentation.
+diff --git a/ruby/src/api.cc b/ruby/src/api.cc
+index 434f691..9e96e05 100644
+--- a/ruby/src/api.cc
++++ b/ruby/src/api.cc
+@@ -100,9 +100,8 @@ namespace leatherman { namespace ruby {
+         LOAD_SYMBOL(rb_cHash),
+         LOAD_SYMBOL(rb_cString),
+         LOAD_SYMBOL(rb_cSymbol),
+-        LOAD_SYMBOL(rb_cFixnum),
++        LOAD_SYMBOL(rb_cInteger),
+         LOAD_SYMBOL(rb_cFloat),
+-        LOAD_SYMBOL(rb_cBignum),
+         LOAD_SYMBOL(rb_eException),
+         LOAD_SYMBOL(rb_eArgError),
+         LOAD_SYMBOL(rb_eTypeError),
+@@ -396,12 +395,12 @@ namespace leatherman { namespace ruby {
+ 
+     bool api::is_fixednum(VALUE value) const
+     {
+-        return is_a(value, *rb_cFixnum);
++        return is_a(value, *rb_cInteger);
+     }
+ 
+     bool api::is_bignum(VALUE value) const
+     {
+-        return is_a(value, *rb_cBignum);
++        return is_a(value, *rb_cInteger);
+     }
+ 
+     bool api::is_float(VALUE value) const
+diff --git a/ruby/tests/api-test.cc b/ruby/tests/api-test.cc
+index 20bcec7..1d2cafb 100644
+--- a/ruby/tests/api-test.cc
++++ b/ruby/tests/api-test.cc
+@@ -52,7 +52,7 @@ TEST_CASE("api::is_*", "[ruby-api]") {
+         REQUIRE_FALSE(ruby.is_fixednum(ruby.eval("1.5")));
+ 
+         REQUIRE(ruby.is_bignum(ruby.eval(to_string(numeric_limits<int64_t>::max()))));
+-        REQUIRE_FALSE(ruby.is_bignum(ruby.eval("2")));
++        REQUIRE(ruby.is_bignum(ruby.eval("2")));
+         REQUIRE_FALSE(ruby.is_bignum(ruby.eval("1.5")));
+     }


More information about the arch-commits mailing list