[arch-commits] Commit in libdbi-drivers/repos (6 files)

Jelle van der Waa jelle at archlinux.org
Thu Mar 16 20:46:13 UTC 2017


    Date: Thursday, March 16, 2017 @ 20:46:13
  Author: jelle
Revision: 216815

archrelease: copy trunk to community-staging-i686, community-staging-x86_64

Added:
  libdbi-drivers/repos/community-staging-i686/
  libdbi-drivers/repos/community-staging-i686/PKGBUILD
    (from rev 216814, libdbi-drivers/trunk/PKGBUILD)
  libdbi-drivers/repos/community-staging-i686/libdbi-drivers.install
    (from rev 216814, libdbi-drivers/trunk/libdbi-drivers.install)
  libdbi-drivers/repos/community-staging-x86_64/
  libdbi-drivers/repos/community-staging-x86_64/PKGBUILD
    (from rev 216814, libdbi-drivers/trunk/PKGBUILD)
  libdbi-drivers/repos/community-staging-x86_64/libdbi-drivers.install
    (from rev 216814, libdbi-drivers/trunk/libdbi-drivers.install)

-------------------------------------------------+
 community-staging-i686/PKGBUILD                 |   39 ++++++++++++++++++++++
 community-staging-i686/libdbi-drivers.install   |   19 ++++++++++
 community-staging-x86_64/PKGBUILD               |   39 ++++++++++++++++++++++
 community-staging-x86_64/libdbi-drivers.install |   19 ++++++++++
 4 files changed, 116 insertions(+)

Copied: libdbi-drivers/repos/community-staging-i686/PKGBUILD (from rev 216814, libdbi-drivers/trunk/PKGBUILD)
===================================================================
--- community-staging-i686/PKGBUILD	                        (rev 0)
+++ community-staging-i686/PKGBUILD	2017-03-16 20:46:13 UTC (rev 216815)
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Thorsten Töpper <atsutane-tu at freethoughts.de>
+# Contributor: Olivier Médoc <o_medoc at yahoo.fr>
+# Contributor: Ashok `ScriptDevil` Gautham <ScriptDevil.Arch at gmail.com>
+
+pkgname=libdbi-drivers
+pkgver=0.9.0
+pkgrel=4
+pkgdesc="Database drivers for libdbi (MySQL, PostgreSQL, and SQLite)"
+url="http://libdbi-drivers.sourceforge.net/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('libdbi')
+makedepends=('postgresql-libs' 'libmariadbclient' 'sqlite2' 'sqlite')
+optdepends=("postgresql-libs: To work with postgresql using libdbdpgsql "
+			"sqlite3: To work with sqlite3 using libdbdsqlite3"
+			"libmariadbclient: To work with mysql using libdbdmysql"
+			"sqlite2: To work with sqlite2 using libdbdsqlite")
+options=(!libtool)
+install=libdbi-drivers.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('8472875d30c216540d48d591b442e40ba4f7df5d')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr \
+  	--disable-docs \
+	--with-mysql \
+	--with-pgsql \
+	--with-sqlite \
+	--with-sqlite3
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR=${pkgdir} localstatedir=/var install
+}
+

Copied: libdbi-drivers/repos/community-staging-i686/libdbi-drivers.install (from rev 216814, libdbi-drivers/trunk/libdbi-drivers.install)
===================================================================
--- community-staging-i686/libdbi-drivers.install	                        (rev 0)
+++ community-staging-i686/libdbi-drivers.install	2017-03-16 20:46:13 UTC (rev 216815)
@@ -0,0 +1,19 @@
+# arg 1:  the new package version
+post_install() {
+  ldconfig
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  ldconfig
+}
+
+# arg 1:  the old package version
+post_remove() {
+  ldconfig
+}
+
+op=$1
+shift
+$op $*

Copied: libdbi-drivers/repos/community-staging-x86_64/PKGBUILD (from rev 216814, libdbi-drivers/trunk/PKGBUILD)
===================================================================
--- community-staging-x86_64/PKGBUILD	                        (rev 0)
+++ community-staging-x86_64/PKGBUILD	2017-03-16 20:46:13 UTC (rev 216815)
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Thorsten Töpper <atsutane-tu at freethoughts.de>
+# Contributor: Olivier Médoc <o_medoc at yahoo.fr>
+# Contributor: Ashok `ScriptDevil` Gautham <ScriptDevil.Arch at gmail.com>
+
+pkgname=libdbi-drivers
+pkgver=0.9.0
+pkgrel=4
+pkgdesc="Database drivers for libdbi (MySQL, PostgreSQL, and SQLite)"
+url="http://libdbi-drivers.sourceforge.net/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('libdbi')
+makedepends=('postgresql-libs' 'libmariadbclient' 'sqlite2' 'sqlite')
+optdepends=("postgresql-libs: To work with postgresql using libdbdpgsql "
+			"sqlite3: To work with sqlite3 using libdbdsqlite3"
+			"libmariadbclient: To work with mysql using libdbdmysql"
+			"sqlite2: To work with sqlite2 using libdbdsqlite")
+options=(!libtool)
+install=libdbi-drivers.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('8472875d30c216540d48d591b442e40ba4f7df5d')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr \
+  	--disable-docs \
+	--with-mysql \
+	--with-pgsql \
+	--with-sqlite \
+	--with-sqlite3
+  make
+}
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR=${pkgdir} localstatedir=/var install
+}
+

Copied: libdbi-drivers/repos/community-staging-x86_64/libdbi-drivers.install (from rev 216814, libdbi-drivers/trunk/libdbi-drivers.install)
===================================================================
--- community-staging-x86_64/libdbi-drivers.install	                        (rev 0)
+++ community-staging-x86_64/libdbi-drivers.install	2017-03-16 20:46:13 UTC (rev 216815)
@@ -0,0 +1,19 @@
+# arg 1:  the new package version
+post_install() {
+  ldconfig
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  ldconfig
+}
+
+# arg 1:  the old package version
+post_remove() {
+  ldconfig
+}
+
+op=$1
+shift
+$op $*


More information about the arch-commits mailing list