[arch-commits] Commit in kbibtex/repos (8 files)

Antonio Rojas arojas at archlinux.org
Sun Mar 19 22:01:36 UTC 2017


    Date: Sunday, March 19, 2017 @ 22:01:35
  Author: arojas
Revision: 217378

archrelease: copy trunk to community-i686, community-x86_64

Added:
  kbibtex/repos/community-i686/PKGBUILD
    (from rev 217377, kbibtex/trunk/PKGBUILD)
  kbibtex/repos/community-i686/kbibtex-no-qtwebkit.patch
    (from rev 217377, kbibtex/trunk/kbibtex-no-qtwebkit.patch)
  kbibtex/repos/community-x86_64/PKGBUILD
    (from rev 217377, kbibtex/trunk/PKGBUILD)
  kbibtex/repos/community-x86_64/kbibtex-no-qtwebkit.patch
    (from rev 217377, kbibtex/trunk/kbibtex-no-qtwebkit.patch)
Deleted:
  kbibtex/repos/community-i686/PKGBUILD
  kbibtex/repos/community-i686/kbibtex-no-qtwebkit.patch
  kbibtex/repos/community-x86_64/PKGBUILD
  kbibtex/repos/community-x86_64/kbibtex-no-qtwebkit.patch

--------------------------------------------+
 /PKGBUILD                                  |   82 +++++++++++++++++++++++++++
 /kbibtex-no-qtwebkit.patch                 |   68 ++++++++++++++++++++++
 community-i686/PKGBUILD                    |   41 -------------
 community-i686/kbibtex-no-qtwebkit.patch   |   34 -----------
 community-x86_64/PKGBUILD                  |   41 -------------
 community-x86_64/kbibtex-no-qtwebkit.patch |   34 -----------
 6 files changed, 150 insertions(+), 150 deletions(-)

Deleted: community-i686/PKGBUILD
===================================================================
--- community-i686/PKGBUILD	2017-03-19 22:00:51 UTC (rev 217377)
+++ community-i686/PKGBUILD	2017-03-19 22:01:35 UTC (rev 217378)
@@ -1,41 +0,0 @@
-# $Id$
-# Maintainer: Ray Rashif <schiv at archlinux.org>
-# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
-# Contributor: cmorlok <christianmorlok at web.de>
-
-pkgname=kbibtex
-pkgver=0.6
-_branch=0.6
-pkgrel=5
-pkgdesc="A BibTeX editor for KDE"
-arch=('i686' 'x86_64')
-url='http://home.gna.org/kbibtex/'
-license=('GPL')
-depends=('kdebase-runtime' 'poppler-qt4')
-optdepends=('okular: Document preview')
-makedepends=('cmake' 'automoc4')
-source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch)
-md5sums=('f1a9c1867d94c36fe88cfa0470b85dac'
-         '73a6be6e48e0e9106f60b65ad07d73e6')
-
-prepare() {
-  cd $pkgname-$pkgver
-
-# Disable insecure qtwebkit
-  patch -p1 -i ../kbibtex-no-qtwebkit.patch
-}
-
-build() {
-  cd "$pkgname-$pkgver"
-
-  cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
-  make
-}
-
-package() {
-  cd "$pkgname-$pkgver"
-
-  make DESTDIR="$pkgdir" install
-}
-
-# vim:set ts=2 sw=2 et:

Copied: kbibtex/repos/community-i686/PKGBUILD (from rev 217377, kbibtex/trunk/PKGBUILD)
===================================================================
--- community-i686/PKGBUILD	                        (rev 0)
+++ community-i686/PKGBUILD	2017-03-19 22:01:35 UTC (rev 217378)
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Ray Rashif <schiv at archlinux.org>
+# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
+# Contributor: cmorlok <christianmorlok at web.de>
+
+pkgname=kbibtex
+pkgver=0.6.2
+_branch=0.6
+pkgrel=1
+pkgdesc="A BibTeX editor for KDE"
+arch=('i686' 'x86_64')
+url='http://home.gna.org/kbibtex/'
+license=('GPL')
+depends=('kdebase-runtime' 'poppler-qt4')
+optdepends=('okular: Document preview')
+makedepends=('cmake' 'automoc4')
+source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch)
+md5sums=('5372f79e4ce0ee498e48aabdc377b114'
+         '73a6be6e48e0e9106f60b65ad07d73e6')
+
+prepare() {
+  cd $pkgname-$pkgver
+
+# Disable insecure qtwebkit
+  patch -p1 -i ../kbibtex-no-qtwebkit.patch
+}
+
+build() {
+  cd "$pkgname-$pkgver"
+
+  cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+  make
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+
+  make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: community-i686/kbibtex-no-qtwebkit.patch
===================================================================
--- community-i686/kbibtex-no-qtwebkit.patch	2017-03-19 22:00:51 UTC (rev 217377)
+++ community-i686/kbibtex-no-qtwebkit.patch	2017-03-19 22:01:35 UTC (rev 217378)
@@ -1,34 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 04222a74..1485acc1 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -34,29 +34,6 @@ include(
- ##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
- ##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
- 
--# check if QtWebKit is available, which seems to be not available
--# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
--if(
--    QT_QTWEBKIT_FOUND
--)
--    message(
--        STATUS
--        "Found QtWebKit, enabling WebKit support"
--    )
--    add_definitions(
--        -DHAVE_QTWEBKIT
--    )
--else(
--    QT_QTWEBKIT_FOUND
--)
--    message(
--        STATUS
--        "QtWebKit not found, disabling WebKit support"
--    )
--endif(
--    QT_QTWEBKIT_FOUND
--)
--
- add_definitions(
-     ${QT_DEFINITIONS}
-     ${KDE4_DEFINITIONS}

Copied: kbibtex/repos/community-i686/kbibtex-no-qtwebkit.patch (from rev 217377, kbibtex/trunk/kbibtex-no-qtwebkit.patch)
===================================================================
--- community-i686/kbibtex-no-qtwebkit.patch	                        (rev 0)
+++ community-i686/kbibtex-no-qtwebkit.patch	2017-03-19 22:01:35 UTC (rev 217378)
@@ -0,0 +1,34 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 04222a74..1485acc1 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -34,29 +34,6 @@ include(
+ ##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
+ ##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
+ 
+-# check if QtWebKit is available, which seems to be not available
+-# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
+-if(
+-    QT_QTWEBKIT_FOUND
+-)
+-    message(
+-        STATUS
+-        "Found QtWebKit, enabling WebKit support"
+-    )
+-    add_definitions(
+-        -DHAVE_QTWEBKIT
+-    )
+-else(
+-    QT_QTWEBKIT_FOUND
+-)
+-    message(
+-        STATUS
+-        "QtWebKit not found, disabling WebKit support"
+-    )
+-endif(
+-    QT_QTWEBKIT_FOUND
+-)
+-
+ add_definitions(
+     ${QT_DEFINITIONS}
+     ${KDE4_DEFINITIONS}

Deleted: community-x86_64/PKGBUILD
===================================================================
--- community-x86_64/PKGBUILD	2017-03-19 22:00:51 UTC (rev 217377)
+++ community-x86_64/PKGBUILD	2017-03-19 22:01:35 UTC (rev 217378)
@@ -1,41 +0,0 @@
-# $Id$
-# Maintainer: Ray Rashif <schiv at archlinux.org>
-# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
-# Contributor: cmorlok <christianmorlok at web.de>
-
-pkgname=kbibtex
-pkgver=0.6
-_branch=0.6
-pkgrel=5
-pkgdesc="A BibTeX editor for KDE"
-arch=('i686' 'x86_64')
-url='http://home.gna.org/kbibtex/'
-license=('GPL')
-depends=('kdebase-runtime' 'poppler-qt4')
-optdepends=('okular: Document preview')
-makedepends=('cmake' 'automoc4')
-source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch)
-md5sums=('f1a9c1867d94c36fe88cfa0470b85dac'
-         '73a6be6e48e0e9106f60b65ad07d73e6')
-
-prepare() {
-  cd $pkgname-$pkgver
-
-# Disable insecure qtwebkit
-  patch -p1 -i ../kbibtex-no-qtwebkit.patch
-}
-
-build() {
-  cd "$pkgname-$pkgver"
-
-  cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
-  make
-}
-
-package() {
-  cd "$pkgname-$pkgver"
-
-  make DESTDIR="$pkgdir" install
-}
-
-# vim:set ts=2 sw=2 et:

Copied: kbibtex/repos/community-x86_64/PKGBUILD (from rev 217377, kbibtex/trunk/PKGBUILD)
===================================================================
--- community-x86_64/PKGBUILD	                        (rev 0)
+++ community-x86_64/PKGBUILD	2017-03-19 22:01:35 UTC (rev 217378)
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Ray Rashif <schiv at archlinux.org>
+# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
+# Contributor: cmorlok <christianmorlok at web.de>
+
+pkgname=kbibtex
+pkgver=0.6.2
+_branch=0.6
+pkgrel=1
+pkgdesc="A BibTeX editor for KDE"
+arch=('i686' 'x86_64')
+url='http://home.gna.org/kbibtex/'
+license=('GPL')
+depends=('kdebase-runtime' 'poppler-qt4')
+optdepends=('okular: Document preview')
+makedepends=('cmake' 'automoc4')
+source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz" kbibtex-no-qtwebkit.patch)
+md5sums=('5372f79e4ce0ee498e48aabdc377b114'
+         '73a6be6e48e0e9106f60b65ad07d73e6')
+
+prepare() {
+  cd $pkgname-$pkgver
+
+# Disable insecure qtwebkit
+  patch -p1 -i ../kbibtex-no-qtwebkit.patch
+}
+
+build() {
+  cd "$pkgname-$pkgver"
+
+  cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+  make
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+
+  make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: community-x86_64/kbibtex-no-qtwebkit.patch
===================================================================
--- community-x86_64/kbibtex-no-qtwebkit.patch	2017-03-19 22:00:51 UTC (rev 217377)
+++ community-x86_64/kbibtex-no-qtwebkit.patch	2017-03-19 22:01:35 UTC (rev 217378)
@@ -1,34 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 04222a74..1485acc1 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -34,29 +34,6 @@ include(
- ##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
- ##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
- 
--# check if QtWebKit is available, which seems to be not available
--# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
--if(
--    QT_QTWEBKIT_FOUND
--)
--    message(
--        STATUS
--        "Found QtWebKit, enabling WebKit support"
--    )
--    add_definitions(
--        -DHAVE_QTWEBKIT
--    )
--else(
--    QT_QTWEBKIT_FOUND
--)
--    message(
--        STATUS
--        "QtWebKit not found, disabling WebKit support"
--    )
--endif(
--    QT_QTWEBKIT_FOUND
--)
--
- add_definitions(
-     ${QT_DEFINITIONS}
-     ${KDE4_DEFINITIONS}

Copied: kbibtex/repos/community-x86_64/kbibtex-no-qtwebkit.patch (from rev 217377, kbibtex/trunk/kbibtex-no-qtwebkit.patch)
===================================================================
--- community-x86_64/kbibtex-no-qtwebkit.patch	                        (rev 0)
+++ community-x86_64/kbibtex-no-qtwebkit.patch	2017-03-19 22:01:35 UTC (rev 217378)
@@ -0,0 +1,34 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 04222a74..1485acc1 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -34,29 +34,6 @@ include(
+ ##SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -pg")
+ ##SET(CMAKE_CXX_FLAGS_DISTRIBUTION "${CMAKE_CXX_FLAGS_DISTRIBUTION} -pg")
+ 
+-# check if QtWebKit is available, which seems to be not available
+-# on e.g. RedHat Enterprise Linux 6 or Scientific Linux 6
+-if(
+-    QT_QTWEBKIT_FOUND
+-)
+-    message(
+-        STATUS
+-        "Found QtWebKit, enabling WebKit support"
+-    )
+-    add_definitions(
+-        -DHAVE_QTWEBKIT
+-    )
+-else(
+-    QT_QTWEBKIT_FOUND
+-)
+-    message(
+-        STATUS
+-        "QtWebKit not found, disabling WebKit support"
+-    )
+-endif(
+-    QT_QTWEBKIT_FOUND
+-)
+-
+ add_definitions(
+     ${QT_DEFINITIONS}
+     ${KDE4_DEFINITIONS}


More information about the arch-commits mailing list