[arch-commits] Commit in python-ipywidgets/trunk (PKGBUILD)

Kyle Keen kkeen at archlinux.org
Sat Mar 25 18:41:52 UTC 2017


    Date: Saturday, March 25, 2017 @ 18:41:51
  Author: kkeen
Revision: 218982

upgpkg: python-ipywidgets 6.0.0-1

Modified:
  python-ipywidgets/trunk/PKGBUILD

----------+
 PKGBUILD |   16 +++-------------
 1 file changed, 3 insertions(+), 13 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2017-03-25 18:31:08 UTC (rev 218981)
+++ PKGBUILD	2017-03-25 18:41:51 UTC (rev 218982)
@@ -3,8 +3,8 @@
 
 pkgbase=python-ipywidgets
 pkgname=(python-ipywidgets python2-ipywidgets)
-pkgver=5.2.2
-pkgrel=3
+pkgver=6.0.0
+pkgrel=1
 pkgdesc="IPython widgets for the Jupyter Notebook"
 arch=('any')
 url="https://github.com/ipython/ipywidgets"
@@ -12,13 +12,8 @@
 depends=('python' 'jupyter-widgetsnbextension')
 makedepends=('python-setuptools' 'python2-setuptools' 'npm' 'git')
 
-# Ipywidgets 5.2.X may be a joke, based on speed of releases
-# and it seems to be because it doesn't do npm correctly?
-# It doesn't work for me but it does for arojas
-# but let's update it anyway, it doesn't seem to break anything else.
-
 source=("$pkgname-$pkgver.tgz::https://github.com/ipython/ipywidgets/archive/$pkgver.tar.gz")
-md5sums=('112f3daa4aa0f42f8dda831cea3649c8')
+md5sums=('3082b6760be8c566d88bdf1c9fd94063')
 
 prepare() {
   cp -r "ipywidgets-$pkgver" "py2-ipywidgets-$pkgver"
@@ -28,11 +23,6 @@
   cd "$srcdir/ipywidgets-$pkgver"
   # needs node, downloads a lot of stuff
   python3 setup.py build
-  # as of 5.something it doesn't automatically npm?
-  # npm install seems very broken for tarball builds
-  #cd jupyter-js-widgets
-  #npm install
-  #cd ..
   #cd widgetsnbextension
   #python3 setup.py build
   #cd ..


More information about the arch-commits mailing list