[arch-commits] Commit in pyqt5/trunk (PKGBUILD pyqt-5.8-segfault.patch)

Felix Yan felixonmars at archlinux.org
Wed Mar 29 07:47:31 UTC 2017


    Date: Wednesday, March 29, 2017 @ 07:47:30
  Author: felixonmars
Revision: 291774

upgpkg: pyqt5 5.8.1-1

Modified:
  pyqt5/trunk/PKGBUILD
Deleted:
  pyqt5/trunk/pyqt-5.8-segfault.patch

-------------------------+
 PKGBUILD                |   64 +++++++++++++++++++++++-----------------------
 pyqt-5.8-segfault.patch |   62 --------------------------------------------
 2 files changed, 33 insertions(+), 93 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2017-03-29 07:35:36 UTC (rev 291773)
+++ PKGBUILD	2017-03-29 07:47:30 UTC (rev 291774)
@@ -7,9 +7,8 @@
 
 pkgbase=pyqt5
 pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
-pkgver=5.8
-_pkgver=$pkgver
-pkgrel=2
+pkgver=5.8.1
+pkgrel=1
 arch=('i686' 'x86_64')
 url="http://riverbankcomputing.co.uk/software/pyqt/intro"
 license=('GPL')
@@ -17,26 +16,21 @@
              'python2-dbus' 'python-dbus' 'qt5-connectivity'
              'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
              'qt5-webengine' 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
-source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" "pyqt-5.8-segfault.patch")
-md5sums=('ac04c0bfc1f05f5a1c2a1edd2640235c'
-         'de7b2781874ff0c7c0d710f718cfa01a')
+source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz")
+sha512sums=('56607263f6782409a2088b986954e973fdeea681fe3d6e3708b4946477da1431c33814454ad14e758de7c46b1dac660f3204aae2e1087249d13be6d80ddd6458')
 
 prepare() {
-  pushd PyQt5_gpl-${_pkgver}
-  patch -Np1 -i "${srcdir}/pyqt-5.8-segfault.patch"
-  popd
-
   # Support new versions of Qt - don't remove, needs to be reapplied after every new Qt release
   # patch -p1 -i ../pyqt-support-new-qt.patch
 
   # The additional include path was removed due to this line, I don't really know why they are doing this...
-  sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-${_pkgver}/configure.py
+  sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-$pkgver/configure.py
 
-  cp -a PyQt5_gpl-${_pkgver}{,-py2}
+  cp -a PyQt5_gpl-$pkgver{,-py2}
 }
 
 build() {
-  cd "$srcdir"/PyQt5_gpl-${_pkgver}
+  cd "$srcdir"/PyQt5_gpl-$pkgver
   python configure.py \
     --confirm-license \
     --no-sip-files \
@@ -48,7 +42,7 @@
 
   make
 
-  cd "$srcdir"/PyQt5_gpl-${_pkgver}-py2
+  cd "$srcdir"/PyQt5_gpl-$pkgver-py2
   python2 configure.py \
     --confirm-license \
     --no-sip-files \
@@ -65,11 +59,11 @@
   pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5"
   depends=('qt5-base')
 
-  cd PyQt5_gpl-${_pkgver}
-  install -Dm644 PyQt5.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
+  cd PyQt5_gpl-$pkgver
+  install -Dm644 PyQt5.api "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
 
-  install -d "${pkgdir}"/usr/share/sip/PyQt5
-  cp -a sip/* "${pkgdir}"/usr/share/sip/PyQt5
+  install -d "$pkgdir"/usr/share/sip/PyQt5
+  cp -a sip/* "$pkgdir"/usr/share/sip/PyQt5
 }
 
 package_python-pyqt5(){
@@ -83,14 +77,18 @@
               'qt5-webkit: QtWebKit, QtWebKitWidgets'
               'qt5-xmlpatterns: QtXmlPatterns'
               'qt5-declarative: QtQml, qmlplugin'
-              'qt5-serialport: QtSerialPort')
+              'qt5-serialport: QtSerialPort'
+              'qt5-websockets: QtWebSockets'
+              'qt5-connectivity: QtNfc, QtBluetooth'
+              'qt5-webengine: QtWebEngine, QtWebEngineCore, QtWebEngineWidgets'
+              'qt5-x11extras: QtX11Extras')
 
-  cd PyQt5_gpl-${_pkgver}
+  cd PyQt5_gpl-$pkgver
   # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
-  make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+  make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
 
   # Provided by pyqt-common
-  rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
+  rm "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
 }
 
 package_python2-pyqt5(){
@@ -104,18 +102,22 @@
               'qt5-webkit: QtWebKit, QtWebKitWidgets'
               'qt5-xmlpatterns: QtXmlPatterns'
               'qt5-declarative: QtQml, qmlplugin'
-              'qt5-serialport: QtSerialPort')
+              'qt5-serialport: QtSerialPort'
+              'qt5-websockets: QtWebSockets'
+              'qt5-connectivity: QtNfc, QtBluetooth'
+              'qt5-webengine: QtWebEngine, QtWebEngineCore, QtWebEngineWidgets'
+              'qt5-x11extras: QtX11Extras')
 
-  cd PyQt5_gpl-${_pkgver}-py2
+  cd PyQt5_gpl-$pkgver-py2
   # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
-  make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+  make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
 
   # Fix conflicts with python-pyqt5
-  mv "${pkgdir}"/usr/bin/{,python2-}pyuic5
-  mv "${pkgdir}"/usr/bin/{,python2-}pylupdate5
-  mv "${pkgdir}"/usr/bin/{,python2-}pyrcc5
+  mv "$pkgdir"/usr/bin/{,python2-}pyuic5
+  mv "$pkgdir"/usr/bin/{,python2-}pylupdate5
+  mv "$pkgdir"/usr/bin/{,python2-}pyrcc5
 
-  rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpyqt5.so
-  rm "${pkgdir}"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
-  rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
+  rm "$pkgdir"/usr/lib/qt/plugins/designer/libpyqt5.so
+  rm "$pkgdir"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
+  rm "$pkgdir"/usr/share/qt/qsci/api/python/PyQt5.api
 }

Deleted: pyqt-5.8-segfault.patch
===================================================================
--- pyqt-5.8-segfault.patch	2017-03-29 07:35:36 UTC (rev 291773)
+++ pyqt-5.8-segfault.patch	2017-03-29 07:47:30 UTC (rev 291774)
@@ -1,62 +0,0 @@
---- a/qpy/QtQml/qpyqml_register_type.cpp    2017-02-23 03:32:51.000000000 +0100
-+++ b/qpy/QtQml/qpyqml_register_type.cpp    2017-02-25 03:32:58.000000000 +0100
-@@ -124,13 +124,13 @@
- 
- #define QPYQML_TYPE_INIT(n) \
-     case n##U: \
--        QPyQmlObject##n::staticMetaObject = *mo; \
-+        QPyQmlObject##n::staticMetaObject = static_mo; \
-         QPyQmlObject##n::attachedPyType = attached; \
-         rt->typeId = qRegisterNormalizedMetaType<QPyQmlObject##n *>(ptr_name); \
-         rt->listId = qRegisterNormalizedMetaType<QQmlListProperty<QPyQmlObject##n> >(list_name); \
-         rt->objectSize = ctor ? sizeof(QPyQmlObject##n) : 0; \
-         if (ctor) rt->create = QQmlPrivate::createInto<QPyQmlObject##n>; else rt->create = 0; \
--        rt->metaObject = mo; \
-+        rt->metaObject = &QPyQmlObject##n::staticMetaObject; \
-         rt->attachedPropertiesFunction = attached_mo ? QPyQmlObject##n::attachedProperties : 0; \
-         rt->attachedPropertiesMetaObject = attached_mo; \
-         rt->parserStatusCast = is_parser_status ? QQmlPrivate::StaticCastSelector<QPyQmlObject##n,QQmlParserStatus>::cast() : -1; \
-@@ -219,7 +219,33 @@
-         return 0;
-     }
- 
--    const QMetaObject *mo = pyqt5_qtqml_get_qmetaobject(py_type);
-+    const QMetaObject *orig_mo = pyqt5_qtqml_get_qmetaobject(py_type);
-+    QMetaObject static_mo = *orig_mo;
-+
-+#if QT_VERSION >= 0x050800
-+    // Qt v5.8.0 changed the way properties are handled by directly calling a
-+    // class's static meta-call (if there was one) directly.  This bypasses the
-+    // proxy and calls the static meta-call with a pointer to the proxy rather
-+    // than a pointer to the real object.  To work round this we clone the
-+    // QMetaObject chain and remove the references to the static meta-call
-+    // forcing the earlier behaviour.  This approach may also work with earlier
-+    // versions of Qt - but if it ain't broke...
-+    static_mo.d.static_metacall = 0;
-+
-+    QMetaObject *sub_mo = &static_mo;
-+
-+    // By retaining the QObject static meta-object we don't appear to be a
-+    // gadget.
-+    for (const QMetaObject *mo = sub_mo->d.superdata; mo != &QObject::staticMetaObject; mo = mo->d.superdata)
-+    {
-+        QMetaObject *new_mo = new QMetaObject;
-+        *new_mo = *mo;
-+        new_mo->d.static_metacall = 0;
-+
-+        sub_mo->d.superdata = new_mo;
-+        sub_mo = new_mo;
-+    }
-+#endif
- 
-     // See if the type is a parser status.
-     bool is_parser_status = PyType_IsSubtype(py_type,
-@@ -272,7 +298,7 @@
- 
-     if (qquickitem_register)
-     {
--        sipErrorState estate = qquickitem_register(py_type, mo, ptr_name,
-+        sipErrorState estate = qquickitem_register(py_type, orig_mo, ptr_name,
-                 list_name, &rt);
- 
-         if (estate == sipErrorFail)


More information about the arch-commits mailing list