[arch-commits] Commit in deepin-qt5integration/trunk (PKGBUILD)

Felix Yan felixonmars at archlinux.org
Thu Nov 2 15:20:03 UTC 2017


    Date: Thursday, November 2, 2017 @ 15:20:02
  Author: felixonmars
Revision: 265160

upgpkg: deepin-qt5integration 0.2.8.1-1

Modified:
  deepin-qt5integration/trunk/PKGBUILD

----------+
 PKGBUILD |   14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2017-11-02 15:19:25 UTC (rev 265159)
+++ PKGBUILD	2017-11-02 15:20:02 UTC (rev 265160)
@@ -2,26 +2,22 @@
 # Maintainer: Felix Yan <felixonmars at archlinux.org>
 
 pkgname=deepin-qt5integration
-pkgver=0.2.7
+pkgver=0.2.8.1
 pkgrel=1
-pkgdesc='Deepin Qt5 platform plugin'
+pkgdesc='Qt platform theme integration plugins for DDE'
 arch=('i686' 'x86_64')
 url="https://github.com/linuxdeepin/qt5integration"
 license=('GPL3')
-depends=('dtkwidget' 'libqtxdg' 'qt5-styleplugins')
-makedepends=('xcb-util-renderutil' 'deepin-file-manager' 'qt5-xcb-private-headers')
+depends=('dtkwidget' 'libqtxdg' 'qt5-styleplugins' 'deepin-qt5dxcb-plugin')
+makedepends=('xcb-util-renderutil' 'deepin-file-manager')
 replaces=('qt5dxcb-plugin')
 conflicts=('qt5dxcb-plugin')
 groups=('deepin')
 source=("$pkgname-$pkgver.tar.gz::https://github.com/linuxdeepin/qt5integration/archive/$pkgver.tar.gz")
-sha512sums=('167a454818a547bc8cbfb3ab2caed435d8590473f1b3a9408012d5fd644f82f3a0ebf63450163441a58f9fe0ce7958a7fbdd424c644cdcbe6f08c5feec7fdaaa')
+sha512sums=('871fb2f424823cc97ac5bd13af18540228e9b10e911c6c5a6ed19a9ba0e0d21223182fde5dbb1e4b8830b4e0993f51c9f40c5a145ea458fb811b106df2e3c3cd')
 
 prepare() {
   cd qt5integration-$pkgver
-
-  rm -r platformplugin/libqt5xcbqpa-dev
-  sed -i 's|error(Not support Qt Version: .*)|INCLUDEPATH += /usr/include/qtxcb-private|' platformplugin/linux.pri
-
   sed -i 's|qt5xdgiconloader/2.0.0|qt5xdgiconloader/3.1.0|' platformthemeplugin/main.cpp
 }
 


More information about the arch-commits mailing list