[arch-commits] Commit in metasploit/trunk (2 files)

Levente Polyak anthraxx at archlinux.org
Sun Nov 5 20:46:29 UTC 2017


    Date: Sunday, November 5, 2017 @ 20:46:28
  Author: anthraxx
Revision: 265449

upgpkg: metasploit 4.16.15-1

Added:
  metasploit/trunk/metasploit-dont-restrict-aggregator.patch
Modified:
  metasploit/trunk/PKGBUILD

-------------------------------------------+
 PKGBUILD                                  |   12 ++++++++----
 metasploit-dont-restrict-aggregator.patch |   25 +++++++++++++++++++++++++
 2 files changed, 33 insertions(+), 4 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2017-11-05 20:28:21 UTC (rev 265448)
+++ PKGBUILD	2017-11-05 20:46:28 UTC (rev 265449)
@@ -3,7 +3,7 @@
 # Contributor: Tobias Veit - nIcE <m.on.key.tobi[at]gmail[dot]com>
 
 pkgname=metasploit
-pkgver=4.16.11
+pkgver=4.16.15
 pkgrel=1
 pkgdesc='Advanced open-source platform for developing, testing, and using exploit code'
 url='https://www.metasploit.com/'
@@ -12,14 +12,18 @@
 depends=('ruby' 'libpcap' 'postgresql-libs' 'ruby-bundler' 'sqlite' 'libxslt' 'git')
 optdepends=('ruby-pg: database support')
 options=('!strip' '!emptydirs')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/rapid7/metasploit-framework/archive/${pkgver}.tar.gz)
-sha256sums=('13ce7794bec989bcab6868c1f2d2c5f054b5ea0c167a9baf82fb3ed006a053d8')
-sha512sums=('5913962b85e3234fe1e75603b4075f9034c317224619b13f898b1fe5197ce1c7c0161344c9323a092be45184d0faa7a31c3da772c316c5a69b44f7ea90f81846')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/rapid7/metasploit-framework/archive/${pkgver}.tar.gz
+        metasploit-dont-restrict-aggregator.patch)
+sha256sums=('441c07274f936fbea8f859157048dec4890ee6e80920c49d6c4306129ee00384'
+            'f1a6d0369f24eb622d23dd0fed428cf6404f74cfb0a8001af5d1e18df026d9f6')
+sha512sums=('e8e612ceb80f8edec2cff745be9bfc57032770e24179b4613ef8331a2b48ebcd8eb8fea6f5beda0af98a8ceff62c89a63d5107b37738b2dc724dfe277f8a443f'
+            '71611dd350a3f74b6ba61d1508b57d357de221bb676d25d96d5bbcd898e5cabb978ffb9c6c3b37559055fb886c11fe4fed64d8b701d1d94dfff057a32ed53b00')
 
 prepare() {
   cd ${pkgname}-framework-${pkgver}
   bundle config build.nokogiri --use-system-libraries
   sed 's|git ls-files|find -type f|' -i metasploit-framework.gemspec
+  patch -R -p1 < "${srcdir}/metasploit-dont-restrict-aggregator.patch"
 }
 
 build() {

Added: metasploit-dont-restrict-aggregator.patch
===================================================================
--- metasploit-dont-restrict-aggregator.patch	                        (rev 0)
+++ metasploit-dont-restrict-aggregator.patch	2017-11-05 20:46:28 UTC (rev 265449)
@@ -0,0 +1,25 @@
+From 5458b58a74a035e141a939dff0a85eff1330bdae Mon Sep 17 00:00:00 2001
+From: Jeffrey Martin <Jeffrey_Martin at rapid7.com>
+Date: Wed, 18 Oct 2017 13:21:02 -0500
+Subject: [PATCH] restrict aggregator on arm for now
+
+---
+ Gemfile      | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/Gemfile b/Gemfile
+index 12b6341b41c..012578df9fc 100755
+--- a/Gemfile
++++ b/Gemfile
+@@ -19,7 +19,10 @@ group :development do
+   # module documentation
+   gem 'octokit'
+   # Metasploit::Aggregator external session proxy
+-  gem 'metasploit-aggregator'
++  gem 'metasploit-aggregator' if [
++    'x86-mingw32', 'x64-mingw32',
++    'x86_64-linux', 'x86-linux',
++    'darwin'].include?(RUBY_PLATFORM.gsub(/.*darwin.*/, 'darwin'))
+ end
+ 
+ group :development, :test do


More information about the arch-commits mailing list