[arch-commits] Commit in nvidia/trunk (PKGBUILD nvidia.install)

Sven-Hendrik Haase svenstaro at archlinux.org
Sun Nov 26 09:19:34 UTC 2017


    Date: Sunday, November 26, 2017 @ 09:19:33
  Author: svenstaro
Revision: 310941

upgpkg: nvidia 387.34-6

Modified:
  nvidia/trunk/PKGBUILD
Deleted:
  nvidia/trunk/nvidia.install

----------------+
 PKGBUILD       |   43 +++++++++++++++++--------------------------
 nvidia.install |   13 -------------
 2 files changed, 17 insertions(+), 39 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2017-11-26 09:12:04 UTC (rev 310940)
+++ PKGBUILD	2017-11-26 09:19:33 UTC (rev 310941)
@@ -6,20 +6,18 @@
 pkgbase=nvidia
 pkgname=(nvidia nvidia-dkms)
 pkgver=387.34
-_extramodules=extramodules-4.13-ARCH
-pkgrel=5
+_extramodules=extramodules-4.14-ARCH
+pkgrel=6
 pkgdesc="NVIDIA drivers for linux"
 arch=('x86_64')
 url="http://www.nvidia.com/"
-makedepends=('nvidia-libgl' "nvidia-utils=${pkgver}" 'linux' 'linux-headers>=4.13' 'linux-headers<4.14')
+makedepends=('nvidia-libgl' "nvidia-utils=${pkgver}" 'linux' 'linux-headers>=4.14' 'linux-headers<4.15')
 license=('custom')
 options=('!strip')
-source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums_x86_64=('a009bbc502c30e4b483d71be9fa51790')
+source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+sha256sums=('d540908e76aeecb1f4a2812acf5ad37346934a6b7c8043c8b3ce230a48ceb440')
 
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
 
 prepare() {
     sh "${_pkg}.run" --extract-only
@@ -51,25 +49,15 @@
 
 package_nvidia() {
     pkgdesc="NVIDIA drivers for linux"
-    depends=('linux>=4.13' 'linux<4.14' "nvidia-utils=${pkgver}" 'libgl')
-    install=nvidia.install
+    depends=('linux>=4.14' 'linux<4.15' "nvidia-utils=${pkgver}" 'libgl')
 
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-modeset.ko" \
-         "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-modeset.ko"
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-drm.ko" \
-         "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-drm.ko"
+    install -Dt "${pkgdir}/usr/lib/modules/${_extramodules}" -m644 \
+      "${srcdir}/${_pkg}/kernel"/nvidia{,-modeset,-drm,-uvm}.ko
 
-    if [[ "$CARCH" = "x86_64" ]]; then
-        install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia-uvm.ko" \
-            "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
-    fi
+    find "${pkgdir}" -name '*.ko' -exec gzip -n {} +
 
-    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
-    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-
-    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+    echo "blacklist nouveau" |
+      install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
 }
 
 package_nvidia-dkms() {
@@ -80,7 +68,10 @@
     conflicts+=('nvidia')
 
     cd ${_pkg}
-    install -dm 755 "${pkgdir}"/usr/{lib/modprobe.d,src}
+
+    install -dm 755 "${pkgdir}"/usr/src
     cp -dr --no-preserve='ownership' kernel-dkms "${pkgdir}/usr/src/nvidia-${pkgver}"
-    echo 'blacklist nouveau' > "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+
+    echo "blacklist nouveau" |
+      install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
 }

Deleted: nvidia.install
===================================================================
--- nvidia.install	2017-11-26 09:12:04 UTC (rev 310940)
+++ nvidia.install	2017-11-26 09:19:33 UTC (rev 310941)
@@ -1,13 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-4.13-ARCH'
-    depmod $(cat /usr/lib/modules/${EXTRAMODULES}/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    post_install
-}
-
-post_remove() {
-    post_install
-}


More information about the arch-commits mailing list