[arch-commits] Commit in logstash/trunk (PKGBUILD)

Levente Polyak anthraxx at archlinux.org
Sun Nov 11 13:05:21 UTC 2018


    Date: Sunday, November 11, 2018 @ 13:05:20
  Author: anthraxx
Revision: 406356

upgpkg: logstash 6.4.3-1

- remove strict makedepends on 8, builds fine now
- remove obsolete JVM options erroring on >=11

Modified:
  logstash/trunk/PKGBUILD

----------+
 PKGBUILD |   13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2018-11-11 13:01:36 UTC (rev 406355)
+++ PKGBUILD	2018-11-11 13:05:20 UTC (rev 406356)
@@ -2,7 +2,7 @@
 # Maintainer: Massimiliano Torromeo <massimiliano.torromeo at gmail.com>
 
 pkgname=logstash
-pkgver=6.4.2
+pkgver=6.4.3
 _jrubyver=9.1.13.0
 pkgrel=1
 pkgdesc='Tool for managing events and logs'
@@ -10,7 +10,7 @@
 arch=('x86_64')
 license=('Apache')
 depends=('java-runtime-headless>=8' 'ruby' 'ruby-bundler' 'coreutils' 'awk')
-makedepends=('java-environment=8' 'gradle' 'git')
+makedepends=('java-environment>=8' 'gradle' 'git')
 backup=('etc/conf.d/logstash'
         'etc/logstash/jvm.options'
         'etc/logstash/log4j2.properties'
@@ -26,7 +26,7 @@
         logstash-tmpfile.conf
         bundle.config)
 noextract=(${_jrubydist})
-sha256sums=('476c112f87ab9a83436bfc637a451b4b947fc9586a27faaa4011110840014d02'
+sha256sums=('2600cca021b321cf94869c1b012036ac995a96bbb32a1ba9ffa4d8703a3b733e'
             '9d156646623ac2f27174721035b52572a4b05690db7c1293295aa2c04aad3908'
             '640f1c81e6c68f9d1256875db89f5439992e2b8188fb7e6e3ddcdae1c33a3af8'
             '2b8b29297202334c784fdd7f2eb8d7e776c24c783b3c9f8387b500ab0039335c'
@@ -34,7 +34,7 @@
             '18a68a59ddb0ce19778e83b65e68dd568d65b7180bf45b4cf298fb332d69eb26'
             '346b630484f8a35b1a549e94e53e3e151527852a29c72cc6e529221215a7f533'
             'fe05315345e4489458c3eecac43726800109c1e390e74a14584096f6c041fee1')
-sha512sums=('b2ea2ad52bcc9ee819eb0b349d273fb6a8c26a81de5cc93c1b9483c654d0cafc55c30a2aba9d7e2eb39bc51cdc2cb59b665aa207eee2ea467841466805cb7cc2'
+sha512sums=('5d25037f4e493b6f7c07006fe1112cf28ada4393e075f81bb4cc2d96831b78a7279158a5e4dc193afd18cb15b8927e4ac31485b80aa679075d72f55c5e9c36ff'
             'ef88f613ada2665d4f63b2e2f15594739de8ba501406e76de417821f44847b0e258524687b0ae0cf5b737520aa4dd9bb59d80a4b89a81408cda638f28bebbead'
             '21adfc88d980cabb3a45ac029b5dddf8c4b4bc96ac95999ae85fa655101ff58b139bceb613c0e91c108f3f78dcb21ba6f997ee2884c58c3a55eaa7938b6959c4'
             '817097565519dc7c5eac7521339947c74c6148683ca594356dd2ceb3274a1e94f8e7318ce310e0fe5789d7ab0d4c23404f814bef31036a11ddfec08d16814c69'
@@ -49,6 +49,10 @@
 	sed -e 's|LS_SETTINGS_DIR=.*|LS_SETTINGS_DIR="/etc/logstash"|' -i config/startup.options
   sed -e '1i [ -f /etc/profile.d/jre.sh ] && . /etc/profile.d/jre.sh' -i bin/logstash.lib.sh
 
+  # remove deprecated JVM options
+  sed 's|"-XX:+UseParNewGC", ||g' -i logstash-core/benchmarks/build.gradle
+  sed 's|-XX:+UseParNewGC||g' -i config/jvm.options
+
   patch -p1 -i "$srcdir"/build.patch
 
   # Use system gradle
@@ -65,7 +69,6 @@
 build() {
   cd ${pkgname}-${pkgver}
 
-  export JAVA_HOME=/usr/lib/jvm/java-8-openjdk
   msg2 "Install vendored JRuby..."
   gradle downloadAndInstallJRuby
 


More information about the arch-commits mailing list