[arch-commits] Commit in python-apispec/repos/community-any (PKGBUILD PKGBUILD)

Felix Yan felixonmars at archlinux.org
Tue Apr 9 09:21:23 UTC 2019


    Date: Tuesday, April 9, 2019 @ 09:21:22
  Author: felixonmars
Revision: 450511

archrelease: copy trunk to community-any

Added:
  python-apispec/repos/community-any/PKGBUILD
    (from rev 450510, python-apispec/trunk/PKGBUILD)
Deleted:
  python-apispec/repos/community-any/PKGBUILD

----------+
 PKGBUILD |  120 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 60 insertions(+), 60 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-04-09 09:21:07 UTC (rev 450510)
+++ PKGBUILD	2019-04-09 09:21:22 UTC (rev 450511)
@@ -1,60 +0,0 @@
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-
-pkgbase=python-apispec
-pkgname=(python-apispec python2-apispec)
-pkgver=1.1.1
-pkgrel=1
-pkgdesc="A pluggable API specification generator. Currently supports the OpenAPI Specification."
-url="https://github.com/marshmallow-code/apispec"
-license=('MIT')
-arch=('any')
-makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-tornado' 'python2-tornado'
-              'python-bottle' 'python2-bottle' 'python-marshmallow' 'python2-marshmallow'
-              'python-flask' 'python2-flask' 'python-prance' 'python2-prance' 'python-yaml'
-              'python2-yaml' 'python-mock' 'python2-mock' 'python-openapi-spec-validator'
-              'python2-openapi-spec-validator')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/marshmallow-code/apispec/archive/$pkgver.tar.gz")
-sha512sums=('aff78d663803e73be4504ab6dfff7c794fea844d07a5f47263dfc11c3286c78ef68fab7a1d340770f58f49028a490c37d6104b47867b5f63f8a62fcd06aaf530')
-
-prepare() {
-  cp -a apispec-$pkgver{,-py2}
-}
-
-build() {
-  cd "$srcdir"/apispec-$pkgver
-  python setup.py build
-
-  cd "$srcdir"/apispec-$pkgver-py2
-  python2 setup.py build
-}
-
-check() {
-  cd "$srcdir"/apispec-$pkgver
-  python setup.py pytest
-
-  cd "$srcdir"/apispec-$pkgver-py2
-  python2 setup.py pytest
-}
-
-package_python-apispec() {
-  depends=('python')
-  optdepends=('python-yaml: for yaml support'
-              'python-prance: for validation'
-              'python-openapi-spec-validator: for validation')
-
-  cd apispec-$pkgver
-  python setup.py install --root="$pkgdir" --optimize=1
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
-package_python2-apispec() {
-  depends=('python2')
-  optdepends=('python2-yaml: for yaml support'
-              'python2-prance: for validation'
-              'python2-openapi-spec-validator: for validation')
-
-  cd apispec-$pkgver-py2
-  python2 setup.py install --root="$pkgdir" --optimize=1
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: python-apispec/repos/community-any/PKGBUILD (from rev 450510, python-apispec/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-04-09 09:21:22 UTC (rev 450511)
@@ -0,0 +1,60 @@
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+
+pkgbase=python-apispec
+pkgname=(python-apispec python2-apispec)
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A pluggable API specification generator. Currently supports the OpenAPI Specification."
+url="https://github.com/marshmallow-code/apispec"
+license=('MIT')
+arch=('any')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-tornado' 'python2-tornado'
+              'python-bottle' 'python2-bottle' 'python-marshmallow' 'python2-marshmallow'
+              'python-flask' 'python2-flask' 'python-prance' 'python2-prance' 'python-yaml'
+              'python2-yaml' 'python-mock' 'python2-mock' 'python-openapi-spec-validator'
+              'python2-openapi-spec-validator')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/marshmallow-code/apispec/archive/$pkgver.tar.gz")
+sha512sums=('a7cf58add8f381d0ff599873dd44fe66aaa80723ef808ab339e8ab467d814c14ffcac51d17cfc5ba52af026436bd216417b0ade624b7657e8a811a69da7bb121')
+
+prepare() {
+  cp -a apispec-$pkgver{,-py2}
+}
+
+build() {
+  cd "$srcdir"/apispec-$pkgver
+  python setup.py build
+
+  cd "$srcdir"/apispec-$pkgver-py2
+  python2 setup.py build
+}
+
+check() {
+  cd "$srcdir"/apispec-$pkgver
+  python setup.py pytest
+
+  cd "$srcdir"/apispec-$pkgver-py2
+  python2 setup.py pytest
+}
+
+package_python-apispec() {
+  depends=('python')
+  optdepends=('python-yaml: for yaml support'
+              'python-prance: for validation'
+              'python-openapi-spec-validator: for validation')
+
+  cd apispec-$pkgver
+  python setup.py install --root="$pkgdir" --optimize=1
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-apispec() {
+  depends=('python2')
+  optdepends=('python2-yaml: for yaml support'
+              'python2-prance: for validation'
+              'python2-openapi-spec-validator: for validation')
+
+  cd apispec-$pkgver-py2
+  python2 setup.py install --root="$pkgdir" --optimize=1
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}


More information about the arch-commits mailing list