[arch-commits] Commit in qtcurve/repos/community-x86_64 (PKGBUILD PKGBUILD)

Antonio Rojas arojas at archlinux.org
Mon Apr 29 20:05:52 UTC 2019


    Date: Monday, April 29, 2019 @ 20:05:51
  Author: arojas
Revision: 456458

archrelease: copy trunk to community-x86_64

Added:
  qtcurve/repos/community-x86_64/PKGBUILD
    (from rev 456457, qtcurve/trunk/PKGBUILD)
Deleted:
  qtcurve/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |  160 ++++++++++++++++++++++++++++---------------------------------
 1 file changed, 76 insertions(+), 84 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-04-29 20:05:32 UTC (rev 456457)
+++ PKGBUILD	2019-04-29 20:05:51 UTC (rev 456458)
@@ -1,84 +0,0 @@
-# Maintainer: Antonio Rojas <arojas at archlinux.org>
-# Contributor: speps <speps at aur dot archlinux dot org>
-# Contributor: Sven-Hendrik Haase <sh at lutzhaase.com>
-# Contributor: Andrea Scarpino <andrea at archlinux.org>
-# Contributor: Pierre Schmitz <pierre at archlinux.de>
-
-pkgbase=qtcurve
-pkgname=(qtcurve-utils qtcurve-gtk2 qtcurve-qt4 qtcurve-qt5 qtcurve-kde)
-epoch=1
-pkgver=1.9
-pkgrel=1
-pkgdesc='A configurable set of widget styles for KDE and Gtk'
-arch=(x86_64)
-url='https://github.com/KDE/qtcurve/'
-license=(LGPL)
-groups=(qtcurve)
-makedepends=(extra-cmake-modules gtk2 qt4 kdelibs4support kdoctools frameworkintegration kdesignerplugin git)
-source=(https://download.kde.org/stable/$pkgbase/$pkgbase-$pkgver.tar.xz{,.sig})
-sha256sums=('281f5e3d13b0c1c0aeea6f5c7e895aedcb8f4ce91bdbd12d068d3616bc6d2f99'
-            'SKIP')
-validpgpkeys=(D88390B2991F8242FABD2A3C07F45E2A1937DD32) # Yichao Yu <yyc1992 at gmail.com>
-
-prepare() {
-  mkdir -p build{,-kde}
-}
-
-build() {
-  cd build
-  cmake ../$pkgbase-$pkgver \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DQTC_QT4_ENABLE_KDE=false \
-    -DQTC_QT5_ENABLE_KDE=false
-  make
-
-  cd ../build-kde
-  cmake ../$pkgbase-$pkgver \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DENABLE_QT4=false \
-    -DENABLE_GTK2=false
-  make
-}
-
-package_qtcurve-utils() {
-  pkgdesc='A configurable set of widget styles for KDE and Gtk (shared libraries)'
-  depends=(libx11 gcc-libs)
-  cd build/lib/utils
-  make DESTDIR="$pkgdir" install
-
-# Install translations
-  mkdir "$pkgdir"/usr/share
-  cp -r ../../locale "$pkgdir"/usr/share 
-}
-
-package_qtcurve-gtk2() {
-  pkgdesk='A configurable set of widget styles for Gtk2'
-  depends=(qtcurve-utils gtk2)
-  cd build/gtk2
-  make DESTDIR="$pkgdir" install
-  cd ../lib/cairo
-  make DESTDIR="$pkgdir" install
-}
-
-package_qtcurve-qt4() {
-  pkgdesc='A configurable set of widget styles for Qt4'
-  depends=(qtcurve-utils qt4)
-  cd build/qt4
-  make DESTDIR="$pkgdir" install
-}
-
-package_qtcurve-qt5() {
-  pkgdesc='A configurable set of widget styles for Qt5'
-  depends=(qtcurve-utils qt5-svg qt5-x11extras)
-  groups=()
-  cd build/qt5
-  make DESTDIR="$pkgdir" install
-}
-
-package_qtcurve-kde() {
-  pkgdesc='A configurable set of widget styles for Qt5 (with KDE integration)'
-  depends=(qtcurve-utils kdelibs4support frameworkintegration)
-  conflicts=(qtcurve-qt5)
-  cd build-kde/qt5
-  make DESTDIR="$pkgdir" install
-}

Copied: qtcurve/repos/community-x86_64/PKGBUILD (from rev 456457, qtcurve/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-04-29 20:05:51 UTC (rev 456458)
@@ -0,0 +1,76 @@
+# Maintainer: Antonio Rojas <arojas at archlinux.org>
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: Sven-Hendrik Haase <sh at lutzhaase.com>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Pierre Schmitz <pierre at archlinux.de>
+
+pkgbase=qtcurve
+pkgname=(qtcurve-utils qtcurve-gtk2 qtcurve-qt5 qtcurve-kde)
+epoch=1
+pkgver=1.9
+pkgrel=2
+pkgdesc='A configurable set of widget styles for KDE and Gtk'
+arch=(x86_64)
+url='https://github.com/KDE/qtcurve/'
+license=(LGPL)
+groups=(qtcurve)
+makedepends=(extra-cmake-modules gtk2 kdelibs4support kdoctools frameworkintegration kdesignerplugin git)
+source=(https://download.kde.org/stable/$pkgbase/$pkgbase-$pkgver.tar.xz{,.sig})
+sha256sums=('281f5e3d13b0c1c0aeea6f5c7e895aedcb8f4ce91bdbd12d068d3616bc6d2f99'
+            'SKIP')
+validpgpkeys=(D88390B2991F8242FABD2A3C07F45E2A1937DD32) # Yichao Yu <yyc1992 at gmail.com>
+
+prepare() {
+  mkdir -p build{,-kde}
+}
+
+build() {
+  cd build
+  cmake ../$pkgbase-$pkgver \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DQTC_QT5_ENABLE_KDE=false
+  make
+
+  cd ../build-kde
+  cmake ../$pkgbase-$pkgver \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DENABLE_QT4=false \
+    -DENABLE_GTK2=false
+  make
+}
+
+package_qtcurve-utils() {
+  pkgdesc='A configurable set of widget styles for KDE and Gtk (shared libraries)'
+  depends=(libx11 gcc-libs)
+  cd build/lib/utils
+  make DESTDIR="$pkgdir" install
+
+# Install translations
+  mkdir "$pkgdir"/usr/share
+  cp -r ../../locale "$pkgdir"/usr/share 
+}
+
+package_qtcurve-gtk2() {
+  pkgdesk='A configurable set of widget styles for Gtk2'
+  depends=(qtcurve-utils gtk2)
+  cd build/gtk2
+  make DESTDIR="$pkgdir" install
+  cd ../lib/cairo
+  make DESTDIR="$pkgdir" install
+}
+
+package_qtcurve-qt5() {
+  pkgdesc='A configurable set of widget styles for Qt5'
+  depends=(qtcurve-utils qt5-svg qt5-x11extras)
+  groups=()
+  cd build/qt5
+  make DESTDIR="$pkgdir" install
+}
+
+package_qtcurve-kde() {
+  pkgdesc='A configurable set of widget styles for Qt5 (with KDE integration)'
+  depends=(qtcurve-utils kdelibs4support frameworkintegration)
+  conflicts=(qtcurve-qt5)
+  cd build-kde/qt5
+  make DESTDIR="$pkgdir" install
+}


More information about the arch-commits mailing list