[arch-commits] Commit in cargo-outdated/repos/community-x86_64 (PKGBUILD PKGBUILD)

Kpcyrd kpcyrd at archlinux.org
Mon Dec 9 02:40:35 UTC 2019


    Date: Monday, December 9, 2019 @ 02:40:34
  Author: kpcyrd
Revision: 536377

archrelease: copy trunk to community-x86_64

Added:
  cargo-outdated/repos/community-x86_64/PKGBUILD
    (from rev 536376, cargo-outdated/trunk/PKGBUILD)
Deleted:
  cargo-outdated/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |   58 +++++++++++++++++++++++++++++-----------------------------
 1 file changed, 29 insertions(+), 29 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-12-09 02:40:14 UTC (rev 536376)
+++ PKGBUILD	2019-12-09 02:40:34 UTC (rev 536377)
@@ -1,29 +0,0 @@
-# Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
-# Contributor: Jian Zeng <anonymousknight96+aur AT gmail.com>
-# Contributor: Alexandre Bury <alexandre.bury+aur AT gmail.com>
-# Contributor: Vlad M. <vlad at archlinux.net>
-
-pkgname=cargo-outdated
-pkgver=0.8.0
-pkgrel=2
-pkgdesc="A cargo subcommand for displaying when Rust dependencies are out of date"
-url="https://github.com/kbknapp/cargo-outdated"
-arch=('x86_64')
-license=('MIT')
-depends=('cargo')
-source=("https://github.com/kbknapp/${pkgname}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6e07552706cdebceaf5b03bcd022082cdafca70e8e095a74ace95c767e39d509')
-
-build() {
-  cd "${pkgname}-${pkgver}"
-  # --locked is broken https://github.com/kbknapp/cargo-outdated/issues/177
-  cargo build --release
-}
-
-package() {
-  cd "${pkgname}-${pkgver}"
-  install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
-  install -Dm644 LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
-}
-
-# vim: ts=2 sw=2 et:

Copied: cargo-outdated/repos/community-x86_64/PKGBUILD (from rev 536376, cargo-outdated/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-12-09 02:40:34 UTC (rev 536377)
@@ -0,0 +1,29 @@
+# Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
+# Contributor: Jian Zeng <anonymousknight96+aur AT gmail.com>
+# Contributor: Alexandre Bury <alexandre.bury+aur AT gmail.com>
+# Contributor: Vlad M. <vlad at archlinux.net>
+
+pkgname=cargo-outdated
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="A cargo subcommand for displaying when Rust dependencies are out of date"
+url="https://github.com/kbknapp/cargo-outdated"
+arch=('x86_64')
+license=('MIT')
+depends=('cargo')
+source=("${pkgname}-${pkgver}.tar.gz::https://crates.io/api/v1/crates/${pkgname}/${pkgver}/download")
+sha256sums=('83bebbd0985ed1edfbb18a6bf161d1f4e73e6a3ed2a8ca92a83a1756650877bd')
+b2sums=('1204413e21746e8119da81522fbcb99cf1d49487359e645696787fc76f0436044c040569fbdc9d961496f0a1e46f6520fb024352f8acc74b6c74ed9a814fe22b')
+
+build() {
+  cd "${pkgname}-${pkgver}"
+  cargo build --release --locked
+}
+
+package() {
+  cd "${pkgname}-${pkgver}"
+  install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+  install -Dm644 LICENSE-MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et:


More information about the arch-commits mailing list