[arch-commits] Commit in terraform/trunk (CHANGELOG.md PKGBUILD)

Christian Rebischke shibumi at archlinux.org
Sat Dec 14 18:07:01 UTC 2019


    Date: Saturday, December 14, 2019 @ 18:07:00
  Author: shibumi
Revision: 537675

upgpkg: terraform 0.12.18-1

Modified:
  terraform/trunk/CHANGELOG.md
  terraform/trunk/PKGBUILD

--------------+
 CHANGELOG.md |   56 ++++++++++++++++++++++++++++++++++++++++++++++++++++++--
 PKGBUILD     |    4 ++--
 2 files changed, 56 insertions(+), 4 deletions(-)

Modified: CHANGELOG.md
===================================================================
--- CHANGELOG.md	2019-12-14 18:06:14 UTC (rev 537674)
+++ CHANGELOG.md	2019-12-14 18:07:00 UTC (rev 537675)
@@ -1,12 +1,64 @@
-## 0.12.17 (Unreleased)
-## 0.12.16 (November 18, 2019)
+## 0.12.19 (Unreleased)
+## 0.12.18 (December 11, 2019)
 
+NOTES:
+
+* cli: Our darwin releases for this version and up will be signed and notarized according to Apple's requirements.
+
+    Prior to this release, MacOS 10.15+ users attemping to run our software [reported](https://github.com/hashicorp/terraform/issues/23033) seeing the error: "'terraform' cannot be opened because the developer cannot be verified." This error affected all MacOS 10.15+ users who downloaded our software directly via web browsers, and was caused by [changes to Apple's third-party software requirements](https://developer.apple.com/news/?id=04102019a).
+
+    [Our recommended approach to install and interact with the Terraform CLI can be found here](https://learn.hashicorp.com/terraform/getting-started/install).
+
+    MacOS 10.15+ users should plan to upgrade to 0.12.18+.
+
+UPGRADE NOTES:
+
+* Inside `provisioner` blocks that have `when = destroy` set, and inside any `connection` blocks that are used by such provisioner blocks, it is now deprecated to refer to any objects other than `self`, `count`, and `each`.
+
+    Terraform has historically allowed this but doing so tends to cause downstream problems with dependency cycles or incorrect destroy ordering because it causes the destroy phase of one resource to depend on the existing state of another. Although this is currently only a warning, we strongly suggest seeking alternative approaches for existing configurations that are hitting this warning in order to avoid the risk of later problems should you need to replace or destroy the related resources.
+    
+    This deprecation warning will be promoted to an error in a future release.
+
+ENHANCEMENTS:
+
+* provisioners: Warn about the deprecation of non-self references in destroy-time provisioners, both to allow preparation for this later becoming an error and also as an extra hint for the "Cycle" errors that commonly arise when such references are used. ([#23559](https://github.com/hashicorp/terraform/issues/23559))
+* cli: The `terraform plan` and `terraform apply` commands (and some others) now accept the additional option `-compact-warnings`. If set, and if Terraform produces warnings that are not also accompanied by errors, then the warnings will be presented in the output in a compact form that includes only the summary information, thus providing a compromise to avoid warnings overwhelming the output if you are not yet ready to resolve them. ([#23632](https://github.com/hashicorp/terraform/issues/23632))
+
+BUG FIXES:
+
+* backend/s3: Fix for users with >1000 workspaces ([#22963](https://github.com/hashicorp/terraform/issues/22963))
+* cli: Allow moving indexed resource instances to new addresses that that don't yet exist in state ([#23582](https://github.com/hashicorp/terraform/issues/23582))
+* cli: Improved heuristics for log level filtering with the `TF_LOG` environment variable, although it is still not 100% reliable for levels other than `TRACE` due to limitations of Terraform's internal logging infrastructure. Because of that, levels other than `TRACE` will now cause the logs to begin with a warning about potential filtering inaccuracy. ([#23577](https://github.com/hashicorp/terraform/issues/23577))
+* command/show: Fix panic on show plan ([#23581](https://github.com/hashicorp/terraform/issues/23581))
+* config: Fixed referencing errors generally involving `for_each` ([#23475](https://github.com/hashicorp/terraform/issues/23475))
+* provisioners: The built-in provisioners (`local-exec`, `remote-exec`, `file`, etc) will no longer fail when the `TF_CLI_ARGS` environment variable is set. ([#17400](https://github.com/hashicorp/terraform/issues/17400))
+
+## 0.12.17 (December 02, 2019)
+
+SECURITY NOTES:
+
+* If you are using the Azure remote state backend and you are using a SAS Token for authentication, please refer to [the Azure remote state backend security advisory](https://github.com/hashicorp/terraform/security/advisories/GHSA-4rvg-555h-r626).
+
+    Prior versions of the backend may have transmitted your state to the storage service using cleartext HTTP unless you specifically requested HTTPS when generating your SAS Token. This does not affect any other backends, and does not affect the Azure backend when using other authentication mechanisms.
+
 NEW FEATURES:
 
 *  lang/funcs: Add `trim*` functions
 
+ENHANCEMENTS:
+
+* cli: Terraform will now consolidate many warnings with the same summary text into fewer warning items, in order to avoid excessive amounts of warnings making it hard to read other output from Terraform commands. ([#23425](https://github.com/hashicorp/terraform/issues/23425))
+* core: The upgrade logic for moving from the Terraform 0.11 to the Terraform 0.12 state snapshot format (internally, format version 3 to version 4) will now tolerate and ignore dependencies with invalid addresses, which tend to be left behind when following the `terraform 0.11checklist` directive to rename resources whose names start with digits prior to upgrading to Terraform 0.12. This should allow upgrading the state for a configuration that in the past had digit-prefixed resource names, once those names have been fixed in the configuration and state using the instructions given by `terraform 0.11checklist` in Terraform 0.11.14. ([#23443](https://github.com/hashicorp/terraform/issues/23443))
+
 BUG FIXES:
 
+* command/jsonplan, command/jsonstate: fix panic with null values ([#23492](https://github.com/hashicorp/terraform/issues/23492))
+* backend/azure: Use HTTPS to talk to the storage API, even if using a SAS token that does not require it. ([#23496](https://github.com/hashicorp/terraform/issues/23496))
+
+## 0.12.16 (November 18, 2019)
+
+BUG FIXES:
+
 * command/0.12upgrade: fix panic when int value is out of range ([#23394](https://github.com/hashicorp/terraform/issues/23394))
 * core: fix cycle between dependencies with create_before_destroy ([#23399](https://github.com/hashicorp/terraform/issues/23399))
 * backend/remote: default .terraformignore paths will now work on Windows ([#23311](https://github.com/hashicorp/terraform/issues/23311))

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2019-12-14 18:06:14 UTC (rev 537674)
+++ PKGBUILD	2019-12-14 18:07:00 UTC (rev 537675)
@@ -2,7 +2,7 @@
 # Maintainer: Christian Rebischke <chris.rebischke at archlinux.org>
 
 pkgname=terraform
-pkgver=0.12.17
+pkgver=0.12.18
 pkgrel=1
 pkgdesc="HashiCorp tool for building and updating infrastructure as code idempotently"
 url="https://www.terraform.io/"
@@ -10,7 +10,7 @@
 license=("MPL")
 makedepends=("go-pie")
 source=("$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/terraform/archive/v$pkgver.tar.gz")
-sha512sums=('6311fdbf6764e585126a1e177dc498634a799ba1a68ba98682e2be29d14b40c09d0a780555f10bbde0587445d31a1e0d9810226f9e6bd3fcb248428ceb864c87')
+sha512sums=('b75b9318a10285b445e97ab3b6a4b8b166d60a0036098e1e46421b6c67f87c0bc8c3a91d781b015264f6b6265f233396ac7735a758648e5f721229c5de172472')
 changelog="CHANGELOG.md"
 
 build() {


More information about the arch-commits mailing list